Subject: [I2nsf] I-D Action: draft-ietf-i2nsf-problem-and-use-cases-07.txt

From: [email-masked]
Date: Sat, 28 Jan 2017 16:38:05 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Interface to Network Security Functions of the IETF.

        Title           : I2NSF Problem Statement and Use cases
        Authors         : Susan Hares
                          Diego R. Lopex
                          Myo Zarny
                          Christian Jacquenet
                          Rakesh Kumar
                          Jaehoon Paul Jeong
	Filename        : draft-ietf-i2nsf-problem-and-use-cases-07.txt
	Pages           : 27
	Date            : 2017-01-28

Abstract:
   This document describes the problem statement for Interface to
   Network Security Functions (I2NSF) as well as some companion use
   cases.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-problem-and-use-cases/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-i2nsf-problem-and-use-cases-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-i2nsf-problem-and-use-cases-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Susan Hares" <[email-masked]>
Date: Sat, 28 Jan 2017 19:40:01 -0500

Linda and Adrian: 

I believe captures all the edits and fixes all IDNITS in the draft.    One
warning exists on line 872 for a tab that turns to 8 characters.  I cannot
find the tab in the xml it is complaining about.   I've sent an email to
Adrian that indicates the resolution of all comments (Adrian's,  David Qi,
and Paul Jeong's).  I appreciate the detailed review by each of these
people.  Since these are public comments to accept or not-to accept, I have
published the edited version.  I rejected a few of Adrian's and Paul Jeong's
edits - so I would like to ask Adrian, Paul, and my co-authors to verify you
are good with all differences.    

I do need Adrian to respond on 2 requested changes.   Therefore, there will
be a version-08 on Monday. 

Cheers, 
Sue 

-----Original Message-----
From: I2nsf [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Saturday, January 28, 2017 7:38 PM
To: [email-masked]
Cc: [email-masked]
Subject: [I2nsf] I-D Action: draft-ietf-i2nsf-problem-and-use-cases-07.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Interface to Network Security Functions of
the IETF.

Abstract:

_______________________________________________
I2nsf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2nsf

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 29 Jan 2017 15:48:17 -0000

Thanks for the work, Sue.

I'll take a look as time allows, but you're usually pretty reasonable so I doubt
there will be any issues.

Will also respond to your specific questions.

Adrian

> From: Susan Hares [mailto:[email-masked]]
> Sent: 29 January 2017 00:40
> To: [email-masked]
> Cc: 'Linda Dunbar'; [email-masked]; [email-masked]
> Subject: FW: [I2nsf] I-D Action: draft-ietf-i2nsf-problem-and-use-cases-07.txt
> 
> Linda and Adrian:
>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Mon, 30 Jan 2017 12:00:11 +0900

Hi Sue,
I will double-check this version this week.

Thanks for your work.

Best Regards,
Paul

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Rakesh Kumar <[email-masked]>
Date: Mon, 30 Jan 2017 06:34:01 +0000

Hi Susan,

Xiaobo Long had requested earlier that her name be removed from all publications since she did not get permission from her organization. I hope we can honor her request in the next edit you plan to do. The changes look good to me.

I really appreciate your hard work in making all these edits.

Regards,
Rakesh

On 1/28/17, 4:40 PM, "I2nsf on behalf of Susan Hares" <[email-masked] on behalf of [email-masked]> wrote:

    Linda and Adrian: 

    
    Cheers, 
    Sue 
    
    -----Original Message-----
    From: I2nsf [mailto:[email-masked]] On Behalf Of
    [email-masked]
    Sent: Saturday, January 28, 2017 7:38 PM
    To: [email-masked]
    Cc: [email-masked]
    Subject: [I2nsf] I-D Action: draft-ietf-i2nsf-problem-and-use-cases-07.txt

    
    Abstract:

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 1 Feb 2017 10:32:25 +0900

Sue,
I checked the revision 07 with the suggested changes as follows:

------------------------------------------------------------------------------------------------------------
[page 4]
OLD: I2NSF: Interface to Network Security Functions.
NEW: I2NSF: Interface to Network Security Functions
//delete a period '.'

OLD: SDN: Software Defined Networks
NEW: SDN: Software-Defined Networking
//replace "Networks" with "Networking"

[page 8]
OLD: Distributed Denial of services
NEW: Distributed Denial of Service
//replace "services" with "Service". 'S' of "Service" is capital.

[page 9]
OLD: e.g. encryption algorithms, key deriation
NEW: e.g., encryption algorithms, key derivation
//add a comma ',' after "e.g." and replace "deriation" with "derivation"

[page 15]
OLD: e.g. enact/revoke
NEW: e.g., enact/revoke
//add a comma ',' after "e.g."

[page 16]
OLD: mobile user,and
NEW: mobile user, and
//insert a blank between ',' and "and"

OLD: use cases #7
NEW: use case #7
//replace "cases" with "case"

OLD: (B2B)communications.
NEW: (B2B) communications.
//insert a blank between "(B2B)" and "communications"

[page 17]
OLD: access to (or isolation from) to
NEW: access to (or isolation from)
//delete the second redundant "to"

[page 19]
OLD: a set timeframes
NEW: a set of timeframes
//insert "of" between "set" and "timeframes"

OLD: virtual machines (VMs)
NEW: VMs
//delete "virtual machines" because "VMs" is defined in Section 3.1.3

[page 22]
OLD: Industry(PCI)
NEW: Industry (PCI)
//insert a blank between "Industry" and "(PCI)"

OLD: [HIPPA]
NEW: [HIPAA]

[page 24]
OLD: [HIPPA]
NEW: [HIPAA]

[page 25]
OLD: [NFVUC] ETSI GS NFV 002 V1.1.1, , "ETSI NFV Group Specification,
Network Functions Virtualization (NFV) Use Cases", June 2014.
NEW: [NFVUC] ETSI GS NFV 001 V1.1.1, , "ETSI NFV Group Specification,
Network Functions Virtualisation (NFV) Use Cases", October 2013.
//replace "002" with "001", replace "Virtualization" with "Virtualisation",
and replace "June 2014" with "October 2013"

[page 26]
OLD: Diego R. Lopex
NEW: Diego R. Lopez
//replace "Lopex" with "Lopez"
------------------------------------------------------------------------------------------------------------

Also, I attach a PDF file to have the changes.

Thanks for your hard work.

Best Regards,
Paul