Subject: [i2rs] comments on draft-atlas-i2rs-problem-statement?

From: Alia Atlas <[email-masked]>
Date: Thu, 20 Jun 2013 00:51:51 -0400

(WG chair hat off)  I am actively revising
draft-atlas-i2rs-problem-statement and would welcome any and all reasonable
comments on it this week.  I think it is a good base for a WG draft.

Thanks,
Alia

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 20 Jun 2013 11:09:48 +0200

Hi Alia,

In figure 1, why is the interface between application and IRS client
out of scope?

AB

---

From: Alia Atlas <[email-masked]>
Date: Thu, 20 Jun 2013 10:06:15 -0400

Hi AB,

It would be another type of interface to standardize and is neither the
I2RS client, agent or the specific communications between them.  The
interaction between network application and i2rs client could be many
things and may be programming language dependent.  In deciding what the
i2rs scope should be, we need to focus on having a feasible amount of work.

Do you have interest in standardizing this interface?

There is discussion that a network application could be an i2rs client for
interacting with a routing element and then also serve as an i2rs agent for
other network applications to talk to.  However, that is separate from the
interface between an i2rs client and the network application using it.

Alia

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 20 Jun 2013 18:01:06 +0200

Hi Alia,

Thanks for reply. I wanted to understand the draft intention within
Figure 1, so I agree that the I2RS WG has out of scope, but in the
draft when it says out of scope of IRS, I think it is the IRS protocol
(not WG from the Figure 1). If I understand the Figure 1, it shows
that IRS Client interacts with the application, so it looks like there
is scope, so I suggest that out-scope-interface to be one way drawed
not two way (delet one arrow). Furthermore, I will review the draft,
and give more comments.

Best Regards
AB

---

From: <[email-masked]>
Date: Fri, 21 Jun 2013 13:57:07 +0200

Hi Alia,

First of all I agree that the draft if a good base for a WG document ;) I went through the draft and I have a few comments:

  - Also decoupling of life cycles (e.g. between an application and the network functionality) is one problem which needs
    to addressed. At the moment in many cases there is (still and unfortunately) a close relationship between a (network)
    service and the configuration of the network nodes. E.g. configuration changes are necessary and even software updates
    in order to support a certain service required by a product. With I2RS we could make thos two things independent.
    The "application" uses the well defined I2RS interface in order to influence routing. No direct access to the nodes is
    necessary. Thefore in ideal case the software life cycle of the software on the node is independet of the software
    life cyles of the application.

  - Many nodes have an external interface to interact with the routing. Nevertheless those are varying from vendor
    to vendor which makes it difficult to integrate those into an existing network. I2RS would give us the possibility
    for easy interaction with a standardized interface. It reduces the time to integrate new nodes.

  - It should be mentioned that a solution needs "sufficient" security mechanisms in order to avoid abuse and/or
    unauthorized access to the network nodes through the I2RS interface.

  best regards

    Nic

________________________________
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Alia Atlas
Gesendet: Donnerstag, 20. Juni 2013 06:52
An: [email-masked]
Betreff: [i2rs] comments on draft-atlas-i2rs-problem-statement?

(WG chair hat off)  I am actively revising draft-atlas-i2rs-problem-statement and would welcome any and all reasonable comments on it this week.  I think it is a good base for a WG draft.

Thanks,
Alia