Subject: Re: [i2rs] Call for WG Adoption: draft-keyupate-irs-bgp-usecases-02

From: Alia Atlas <[email-masked]>
Date: Wed, 24 Jul 2013 18:09:14 -0400

And I've lost the ability to spell - apparently.
It's:  draft-keyupate-i2rs-bgp-usecases-00<https://datatracker.ietf.org/doc/draft-keyupate-i2rs-bgp-usecases/>

Alia

On Wed, Jul 24, 2013 at 6:04 PM, Alia Atlas <[email-masked]> wrote:

> Note that:  draft-keyupdate-i2rs-bgp-usecases-00 has only the basic
> changes from IRS to I2RS compared to draft-keyupdate-irs-bgp-usecases-02.
> Feel free to review and comment on draft-keyupdate-i2rs-bgp-usecases-00
> instead.
>
> Also - in this case, it is particularly important to have good
> conversation and discussion on the draft (unless you believe it is perfect)
> - to help guide the co-authors on how to improve the draft.
>
> Regards,
> Alia
>
>
>
>
> On Wed, Jul 24, 2013 at 5:59 PM, Alia Atlas <[email-masked]> wrote:
>
>> Please review draft-keyupdate-irs-bgp-usecases-02 and comment on whether
>> it should be adopted by I2RS.  Detailed technical conversation is also most
>> welcome.
>>
>> Authors: Are you aware of any IPR that applies to draft-keyupdate-irs-bgp-usecases-02.
>> Is so, has this IPR been disclosed in compliance with IETF IPR rules (see
>> RFCs 3979, 4879, 3669 and 5378 for more details).
>>
>> This WG call for adoption will complete on August 12.
>>
>> Thanks,
>> Alia
>>
>
>

---

From: "George, Wes" <[email-masked]>
Date: Thu, 25 Jul 2013 17:04:00 -0400

I'll echo Russ and Joel's comments - we need to resolve the question of scope as it regards section 2 and existing BGP config vs focusing more tightly on topology-aware routing manipulation and identifying where we can do something to extend our current capabilities instead of simply replacing CLI with [yet another] something else.  I think you could even make an argument that 2.2 makes a valid use case based on improvements to policy configuration that you could make with better topology knowledge, while the earlier sections might not be.

I do understand that it might be entirely possible (or even better) to standardize on one interface for all BGP config manipulation if you're already building one for topology-aware manipulation, but I'd view that as a happy side effect rather than a primary justification or goal, meaning that it would likely take a reduced form within the use cases draft.

I think we need to address this *before* we adopt this as a WG item so that we can stay focused on the right scope.

Thanks,

Wes George

From: [email-masked] [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Wednesday, July 24, 2013 6:09 PM
To: [email-masked]
Subject: Re: [i2rs] Call for WG Adoption: draft-keyupate-irs-bgp-usecases-02

Alia

On Wed, Jul 24, 2013 at 6:04 PM, Alia Atlas <[email-masked]<mailto:[email-masked]>> wrote:
Note that:  draft-keyupdate-i2rs-bgp-usecases-00 has only the basic changes from IRS to I2RS compared to draft-keyupdate-irs-bgp-usecases-02.   Feel free to review and comment on draft-keyupdate-i2rs-bgp-usecases-00 instead.

Also - in this case, it is particularly important to have good conversation and discussion on the draft (unless you believe it is perfect) - to help guide the co-authors on how to improve the draft.

Regards,
Alia

On Wed, Jul 24, 2013 at 5:59 PM, Alia Atlas <[email-masked]<mailto:[email-masked]>> wrote:
Please review draft-keyupdate-irs-bgp-usecases-02 and comment on whether it should be adopted by I2RS.  Detailed technical conversation is also most welcome.

Authors: Are you aware of any IPR that applies to draft-keyupdate-irs-bgp-usecases-02.  Is so, has this IPR been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).

Thanks,
Alia

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: "Keyur Patel (keyupate)" <[email-masked]>
Date: Thu, 25 Jul 2013 21:55:18 +0000

Hi Wes,

We can definitely cleanup section 2.1 if the wg believes that the protocol configuration is outside the scope of i2rs. That would address both, Joel and Russ's concern as well.

Best Regards,
Keyur

From: "George, Wes" <[email-masked]<mailto:[email-masked]>>
Date: Thu, 25 Jul 2013 17:04:00 -0400
To: Alia Atlas <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [i2rs] Call for WG Adoption: draft-keyupate-irs-bgp-usecases-02

I’ll echo Russ and Joel’s comments – we need to resolve the question of scope as it regards section 2 and existing BGP config vs focusing more tightly on topology-aware routing manipulation and identifying where we can do something to extend our current capabilities instead of simply replacing CLI with [yet another] something else.  I think you could even make an argument that 2.2 makes a valid use case based on improvements to policy configuration that you could make with better topology knowledge, while the earlier sections might not be.

I do understand that it might be entirely possible (or even better) to standardize on one interface for all BGP config manipulation if you’re already building one for topology-aware manipulation, but I’d view that as a happy side effect rather than a primary justification or goal, meaning that it would likely take a reduced form within the use cases draft.

Thanks,

Wes George

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Wednesday, July 24, 2013 6:09 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [i2rs] Call for WG Adoption: draft-keyupate-irs-bgp-usecases-02

Alia

Regards,
Alia

Thanks,
Alia

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.
_______________________________________________ i2rs mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/i2rs

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Sun, 28 Jul 2013 21:26:07 +0000

I support the adoption of this document by I2RS.

As the first "routing protocol" use-case document up for adoption, this will be a test of where the WG ought to focus. I do believe there is still an opportunity in this document to peel the onion more and also look at what things we cannot get easily with other interfaces, and (as others have said) topology (esp. virtual topologies) as well as policy, and less on config to bring up a neighbor. That said, this is a good start IMHO.

I have a large set of minor comments that I will send directly to the authors.

Thanks,

-- Carlos.

On Jul 25, 2013, at 12:09 AM, Alia Atlas <[email-masked]> wrote:

> It's:  draft-keyupate-i2rs-bgp-usecases-00
> 
> Alia
> 
> 
> _______________________________________________
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2rs