Subject: [i2rs] Call for WG Adoption: draft-nitinb-i2rs-rib-info-model-02

From: Edward Crabbe <[email-masked]>
Date: Mon, 26 Aug 2013 19:49:00 -0700

Hey all;

Nitin published an updated version of his RIB info model draft, available at:

http://tools.ietf.org/html/draft-nitinb-i2rs-rib-info-model-02

Please review this draft and comment on whether it should be adopted
as an I2RS document.

This WG call for adoption will finish on September 9th.

best,
   -ed

---

From: Joe Marcus Clarke <[email-masked]>
Date: Mon, 26 Aug 2013 23:46:15 -0400

> This WG call for adoption will finish on September 9th.

With the changes, I support adoption.

Joe

-- 
Joe Marcus Clarke, CCIE #5384,         |          |
SCJP, SCSA, SCNA, SCSECA, VCP        |||||      |||||
Distinguished Services Engineer ..:|||||||||::|||||||||:..
Phone: +1 (919) 392-2867         c i s c o  S y s t e m s
Email: [email-masked]

----------------------------------------------------------------------------

---

From: Thomas Nadeau <[email-masked]>
Date: Tue, 27 Aug 2013 07:28:35 -0400

Support. It is a good place to start this work.

	--Tom

On Aug 26, 2013:10:49 PM, at 10:49 PM, Edward Crabbe <[email-masked]> wrote:

> _______________________________________________
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2rs
>

---

From: "Toru Okatsu (tokatsu)" <[email-masked]>
Date: Tue, 27 Aug 2013 14:38:38 +0000

I support the adoption of this info model document.

I also have two feedback of this.

In the section 6 which is about RIB grammar, it is better to change the definition of <ipv4-route> and <ipv6-route> to accommodate not only multicast routing but also source address base routing.

Original:
   <ipv4-route> ::= <ipv4-prefix> [<multicast-source-ipv4-address>]
   <ipv4-prefix> ::= <IPV4_ADDRESS> <IPV4_ADDRESS_LENGTH>
   <multicast-source-ipv4-address> ::= <IPV4_ADDRESS> <IPV4_PREFIX_LENGTH>

   <ipv6-route> ::= <ipv6-prefix> [<multicast-source-ipv6-address>]
   <ipv6-prefix> ::= <IPV6_ADDRESS> <IPV6_PREFIX_LENGTH>
   <multicast-source-ipv6-address> ::= <IPV6_ADDRESS> <IPV6_PREFIX_LENGTH>

My comment:
   <ipv4-route> ::= <destination-ipv4-address> [<source-ipv4-address>]
   <destination-ipv4-address> ::= <ipv4-prefix>
   <source-ipv4-address> ::= <ipv4-prefix>
   <ipv4-prefix> ::= <IPV4_ADDRESS> <IPV4_PREFIX_LENGTH>

   <ipv6-route> ::= <destination-ipv6-prefix> [<source-ipv6-address>]
   <destination-ipv6-address> ::= <ipv6-prefix>
   <source-ipv6-address> ::= <ipv6-prefix>
   <ipv6-prefix> ::= <IPV6_ADDRESS> <IPV6_PREFIX_LENGTH>

Another comment is a minor correction. In the section 7.2.3, <network-list> should be <nexthop-list>.

Original:
   <nexthop-list> ::= (<nexthop-chain> <LOAD_BALANCE_WEIGHT>)
                      [(<nexthop-chain> <LOAD_BALANCE_WEIGHT>) ... ]
   <network-list> ::= (<nexthop> <LOAD_BALANCE_WEIGHT>)
                      [(<nexthop> <LOAD_BALANCE_WEIGHT>)... ]

My comment
   <nexthop-list> ::= (<nexthop-chain> <LOAD_BALANCE_WEIGHT>)
                      [(<nexthop-chain> <LOAD_BALANCE_WEIGHT>) ... ]
   <nexthop-list> ::= (<nexthop> <LOAD_BALANCE_WEIGHT>)
                      [(<nexthop> <LOAD_BALANCE_WEIGHT>)... ]

Thanks,

Toru

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Edward Crabbe
> Sent: Tuesday, August 27, 2013 11:49 AM
> To: [email-masked]
> Subject: [i2rs] Call for WG Adoption: draft-nitinb-i2rs-rib-info-model-02
> 
> Hey all;
> 
> Please review this draft and comment on whether it should be adopted as
> an I2RS document.
>

---

From: [email-masked]
Date: Thu, 29 Aug 2013 23:44:11 -0700

draft-02 is good but the RIB grammar still needs refinement as commented on draft-00 to the original authors.
Nexthop grammar as proposed is not kosher enough and would lead to incorrect modeling.
- Next hop grammar should unwrap itself to a route or an interface to not have dangling terms for example cannot end with a tunnel encap.
- Interface has to be defined in the grammar.
- (minor) next hop term is overused loosing its true meaning. (Need to have a better term for next hop chain)

Thanks
--Srinivas

---

From: Nitin Bahadur <[email-masked]>
Date: Fri, 30 Aug 2013 21:24:56 +0000

Hi Toru-san,

   Thanks for your feedback. Some comments as below.

>In the section 6 which is about RIB grammar, it is better to change the
>definition of <ipv4-route> and <ipv6-route> to accommodate not only
>multicast routing but also source address base routing.
>
>Original:

If you are doing source-based routing, then you may or may not need the
destination-address. So
<ipv4-route> ::= <destination-ipv4-address> [<source-ipv4-address>]
is incorrect.

The below might be more correct:

<ipv4-route> ::= (<destination-ipv4-address> [<source-ipv4-address>]) |
                 (<source-ipv4-address> [<destination-ipv4-address>])

>                      [(<nexthop> <LOAD_BALANCE_WEIGHT>)... ]

This will be fixed in the next revision.

Thanks
Nitin