Subject: [i2rs] Architecture Discussion 3: Operations are Immediate and continuing

From: Alia Atlas <[email-masked]>
Date: Thu, 12 Sep 2013 10:52:24 -0400

In draft-ietf-i2rs-architecture-00 Sec. 5.2.1:

" Given that the complexity of possible conditions is very large, and

   that some conditions may even cross network element boundaries,
   clearly some degree of handling must be provided on the I2RS client.
   As such, in this architecture it is assumed that all the complexity
   associated with this should be left to the I2RS client.  This
   architectural view does mean that reliability of the communication
   path between the I2RS client and I2RS agent is critical.  [[Editor's
   note: This requires more discussion in the working group.]]"

I would like to start this discussion and conclude it rapidly.

Personally, I have heard that this is a good simplification.  Removing the

ability to specify the start-time and end-time of an operation adds complexity

and we don't clearly have use-cases that need it.  Does anyone have a different

perspective?

Thanks,

Alia (WG-chair hat off)

---

From: Russ White <[email-masked]>
Date: Fri, 13 Sep 2013 07:56:41 -0700

> and we don't clearly have use-cases that need it.  Does anyone have a different

I think the simplifying assumption here is that the controller should hold the time state, not the agent. In other words, rather than telling the agent to start action x at time y, the controller should just wait until time y, and then send "start action x." 

The agent should designed with the minimal amount of state and complexity, to get adoption rates up, etc.

:-)

Russ

<><
[email-masked]
?@?.com (engineer without a portfolio)

---

From: Alia Atlas <[email-masked]>
Date: Fri, 13 Sep 2013 11:16:01 -0400

Oh, I totally agree as far as trying to have a minimal amount of state and
complexity.
My concern has been making the network from the client to the agent mission
critical,
but that's clearly documented in the architecture.  I just want to confirm
the consensus so
we can honestly remove the Editor's note and go forward.

Alia

On Fri, Sep 13, 2013 at 10:56 AM, Russ White <[email-masked]> wrote:

> I think the simplifying assumption here is that the controller should hold
> the time state, not the agent. In other words, rather than telling the
> agent to start action x at time y, the controller should just wait until
> time y, and then send "start action x."
>

---

From: Scott Whyte <[email-masked]>
Date: Sat, 14 Sep 2013 20:41:04 +0100

> and we don't clearly have use-cases that need it.  Does anyone have a different
I support this simplification.

-Scott

-- 
There was never any more inception than there is now,
Nor any more youth or age than there is now,
And will never be any more perfection than there is now,
Nor any more heaven or hell than there is now.
  -Walt Whitman