Subject: [i2rs] Soliciting WG feedback and comments on draft-jxf-i2rs-im-architecture-00

From: Yangang <[email-masked]>
Date: Mon, 21 Oct 2013 02:49:49 +0000

Hi:

We had submitted the a new draft: http://tools.ietf.org/html/draft-jxf-i2rs-im-architecture-00, Your feedback and comments on the rtgwg mailing list are appreciated.

When we code some program, some rules will help us to do some design, like "highly cohesive and low coupling", but in design of information model, northbound interfaces, there are some difficult to judge if this design is good or not, we try to provide a kind of this information model structure of the network device, try to get some roles to design the information model.

Thanks,
Rahul.Yan

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2013年10月18日 15:15
收件人: Tina TSOU; Jixiaofeng (Steven); Tina TSOU; Yangang
主题: New Version Notification for draft-jxf-i2rs-im-architecture-00.txt

A new version of I-D, draft-jxf-i2rs-im-architecture-00.txt
has been successfully submitted by Xiaofeng Ji and posted to the
IETF repository.

Filename:	 draft-jxf-i2rs-im-architecture
Revision:	 00
Title:		 An information model atchitecture of network device
Creation date:	 2013-10-18
Group:		 Individual Submission
Number of pages: 7
URL:             http://www.ietf.org/internet-drafts/draft-jxf-i2rs-im-architecture-00.txt
Status:          http://datatracker.ietf.org/doc/draft-jxf-i2rs-im-architecture
Htmlized:        http://tools.ietf.org/html/draft-jxf-i2rs-im-architecture-00

Abstract:
   Currently, network equipment already has some Northbound Interfaces,
   such as SNMP, NETCONF, TL1; and some languages are also provided to
   describe the data model, such as MIB, SCHEMA and even YANG.  While
   till now, there is not a clear defined information model.  In NETCONF
   domain, some standards are being defined.  In order to reduce the
   cost of NMS integration in customer side, a clear defined information
   model is necessary, just like the SID in TMF.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Jixiaofeng (Steven)" <[email-masked]>
Date: Tue, 29 Oct 2013 09:36:26 +0000

Dear all,

We had submitted a new draft: http://tools.ietf.org/html/ draft-jxf-i2rs-im-architecture-01. Your feedback and comments on the i2rs mailing list are appreciated. We will be looking to update the draft.

PS:

Cost of IM architecture
1) Guidance model-driven development.
2) Each module can find their place and relation module.
3) Management relation
4) Beneficial cutting the system
5) ...

Q&A  

Xiaofeng Ji with  Edward Crabbe

Q:
While the topic is definitely interesting, this draft is a little to skeletal to be able to determine what you'll actually be presenting on.  Can you provide some details?
In general, we want documents being presented to the wg to 1) have sufficient material to warrant initial submission and 2) have been posted on the list and preferably to have had some conversation around them.

A:
After defining the use cases, we will go on to define the information models. Before the work, we hope the information model architecture can be defined to guide us to define information models step by step.
This document's goal want provide a architecture for all i2rs information model.  In controller and router already use the architecture , just one architecture.
Because we consider there are many common requires for i2rs and there are many relations between model packages. ,  for example topology model, inventory model(interface object, tunnel object, etc.).
For manager these model packages and relations, we provide a architecture  and guide to define information models step by step.
We have already discuss with Yaohui Jin([email-masked]),  but use Chinese text in email.  In future, we will be some discussion on the IETF.

Xiaofeng Ji with  Xuan Luo and Yaohui Jin

Q:
file management与software install&update很多时候是一致的，尤其在基于linux内核的操作系统中，这里是如何切分到两层的？
In most cases, file management and software install & update is the same, especially in the linux kernel-based operating system, why assign to two-layer?
A:
Jxf：
文件系统和软件安装更新， 我们认为是两个层， 文件管理相当于操作系统5大管理中的一个， 而软件管理是操作系统之上的一个应用。
File management and software install&update, we consider that the two layers, file management is one of 5 management functions in operating system, but software management is an application on the operating system.

Q: 
layer与layer之间有依赖关系吗？如果有依赖关系，我不太理解为什么resource会依赖于policy？
Is there dependent relationship between layer and the layer? If a dependent relationship exists, I do not quite understand why the resource will depend on the policy?

A:
Jxf：
上层layer依赖下层layer， 不能反向， 
这里policy和resource的关系是这样的， 
比如我们制定一个“黑名单策略”，它是全网要部署的， 不和某台具体设备相关。我们说的Policy是指这种不依赖于资源的Policy。
而Policy和resource的结合， 是在业务层完成的。

1) Yes，there is dependent relationship between layer and the layer . The upper layer depends on the underlying layer, can not be reversed,
2) The relationship between policy and resource:
For example, we developed a "blacklist policy", it is the whole network to be deployed, and it does not depend specific device. So the Policy is not dependent on the resources.
The Policy and resource combination is done in the network service layer.

Q:
对于network container layer不太理解，给出的几个例子L3VPN/L2VPN/VLAN，个人认为都属于network service。 
I do not understand network container layer,  given a few examples of L3VPN/L2VPN/VLAN,  personally I think that all belong to network service layer.

A:	
Jxf：
具体建模时就会发现，  如果没有一个VPNID， 许多模型根本无法构建下去了，因为要依赖这个ID， 
所以最底层有一个网络容器，它至少提供网络、子网、虚拟网络的ID、名称等全局信息， 其他业务信息当然还是业务层。
很早的模型没有这个ID， 是因为网络还没有私有隔离（VPN还没出现）， 目前导致大量业界成型的模型需要重构。
预见到这个变化， 所以我们增加了这个层。
For specific modeling without a VPNID, many models simply can not build anymore, because they rely on the ID, so the bottom layer must have a network container.
It provides attribute( ID, name, etc. global information)  of  container  object (network, subnets, virtual network).

Early models do not have this ID, because the network has no private isolation (VPN not appeared), they resulted in substantial need for reconstruction molding industry. 
Foreseen this change, so we added this layer.

纪晓峰  （JI Xiaofeng）

Huawei Technologies Co., Ltd.
Phone: +86-010- 60613678
Fax: +86-010-60613678
Mobile: +86-13683264329
中国(China)-北京(Beijing)-海淀区中关村北清路156号实创科技示范园华为公司Q15
------------------------------------------------------------------------------------------------
This e-mail and its attachments contain confidential information from HUAWEI, which is intended only
for the person or entity whose address is listed above. Any use of the information contained herein in
any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) 
by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please 
notify the sender by phone or email immediately and delete it!

-----邮件原件-----
发件人: Yangang 
发送时间: 2013年10月21日 10:50
收件人: [email-masked]
抄送: Yangang; Jixiaofeng (Steven); Lizhenbin
主题: Soliciting WG feedback and comments on draft-jxf-i2rs-im-architecture-00

Hi:

Thanks,
Rahul.Yan

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2013年10月18日 15:15
收件人: Tina TSOU; Jixiaofeng (Steven); Tina TSOU; Yangang
主题: New Version Notification for draft-jxf-i2rs-im-architecture-00.txt

Abstract:

The IETF Secretariat