Subject: [i2rs] FW: New Version Notification for draft-krishnan-i2rs-large-flow-use-case-00.txt

From: ramki Krishnan <[email-masked]>
Date: Sun, 13 Oct 2013 22:07:45 -0700

Dear All,

Your comments on this draft are most welcome.

Thanks,
Ramki (on behalf of the co-authors)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Sunday, October 13, 2013 10:03 PM
To: Dave McDysan; Dave Mcdysan; ramki Krishnan; Sriganesh Kini; ramki Krishnan; Anoop Ghanwani
Subject: New Version Notification for draft-krishnan-i2rs-large-flow-use-case-00.txt

A new version of I-D, draft-krishnan-i2rs-large-flow-use-case-00.txt
has been successfully submitted by Ram Krishnan and posted to the
IETF repository.

Filename:	 draft-krishnan-i2rs-large-flow-use-case
Revision:	 00
Title:		 I2RS Large Flow Use Case
Creation date:	 2013-10-13
Group:		 Individual Submission
Number of pages: 9
URL:             http://www.ietf.org/internet-drafts/draft-krishnan-i2rs-large-flow-use-case-00.txt
Status:          http://datatracker.ietf.org/doc/draft-krishnan-i2rs-large-flow-use-case
Htmlized:        http://tools.ietf.org/html/draft-krishnan-i2rs-large-flow-use-case-00

Abstract:
   Demands on networking bandwidth are growing exponentially due to
   applications such as large file transfers and those with rich media.
   Link Aggregation Group (LAG) and Equal Cost Multipath (ECMP) are
   extensively deployed in networks to scale the bandwidth. However,
   the flow based load balancing techniques used today make inefficient
   use of the bandwidth in the presence of long lived large flows. This
   draft presents a use-case to improve the efficiency under such
   conditions and aims to drive requirements for the I2RS WG.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Anoop Ghanwani <[email-masked]>
Date: Tue, 15 Oct 2013 22:14:23 -0700

As an attempt to get the discussion on this draft going...

At a high-level level, this mechanisms detects flows (using methods outside
of I2RS) that consume a certain % of link BW.

Then, using I2RS' PBR, it pins that flow to a specific LAG/ECMP component
(which may or may not match what regular hashing would have done) AND it
adjusts the weights used to be used when hashing (which would affect all
the "small" flows to account for the large flow.  This is for what we call
local load balancing.

There's also global load balancing which involves programming a PBR entry
throughout the path of the flow.

Would appreciate any review/comments from folks.

Thanks,
Anoop

On Sun, Oct 13, 2013 at 10:07 PM, ramki Krishnan <[email-masked]> wrote:

> Subject: New Version Notification for
> draft-krishnan-i2rs-large-flow-use-case-00.txt
>
>
> URL:
> http://www.ietf.org/internet-drafts/draft-krishnan-i2rs-large-flow-use-case-00.txt
> Status:
> http://datatracker.ietf.org/doc/draft-krishnan-i2rs-large-flow-use-case
> Htmlized:
> http://tools.ietf.org/html/draft-krishnan-i2rs-large-flow-use-case-00
>
>
> Abstract:
> _______________________________________________
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2rs
>