Subject: Re: [i2rs] Fwd: New Version Notification for draft-clarke-i2rs-traceability-00.txt

From: Alia Atlas <[email-masked]>
Date: Thu, 3 Oct 2013 14:31:36 -0400

Hi Joe,

Thanks for writing this up.  I think that helps give a sense of the
complexity required by a basic troubleshooting information model.  I have a
couple minor comments (including transport session details beyond just the
client's IP address, ability to request logs (possibly outside of I2RS -
such as via scp)), but I think this gives a good sense of what would be
needed.

Has anyone else read the draft?  What do you think?

Regards,
Alia

On Sat, Sep 28, 2013 at 8:08 PM, Joe Marcus Clarke <[email-masked]>wrote:

> This is an answer to the suggestion by Alia for a document describing
> aspects of I2RS traceability.  Some of the ideas in this document are
> suggestions on how the overall I2RS protocol might be designed while at the
> same time knowing that changes will need to be made as the protocol evolves.
>
> Joe
>
> -------- Original Message --------
> Subject: New Version Notification for draft-clarke-i2rs-**
> traceability-00.txt
> Date: Sat, 28 Sep 2013 17:05:01 -0700
> From: <[email-masked]>
> To: Joe Clarke <[email-masked]>, Gonzalo Salgueiro <[email-masked]>,
> Carlos Pignataro <[email-masked]>
>
>
> A new version of I-D, draft-clarke-i2rs-**traceability-00.txt
> has been successfully submitted by Joe Clarke and posted to the
> IETF repository.
>
> Filename:        draft-clarke-i2rs-traceability
> Revision:        00
> Title:           Interface to the Routing System (I2RS) Traceability:
> Framework and Information Model
> Creation date:   2013-09-28
> Group:           Individual Submission
> Number of pages: 12
> URL: http://www.ietf.org/internet-**drafts/draft-clarke-i2rs-**
> traceability-00.txt<http://www.ietf.org/internet-drafts/draft-clarke-i2rs-traceability-00.txt>
> Status: http://datatracker.ietf.org/**doc/draft-clarke-i2rs-**traceability<http://datatracker.ietf.org/doc/draft-clarke-i2rs-traceability>
> Htmlized: http://tools.ietf.org/html/**draft-clarke-i2rs-**traceability-00<http://tools.ietf.org/html/draft-clarke-i2rs-traceability-00>
>
>
> Abstract:
>    This document describes a framework for traceability in the Interface
>    to the Routing System (I2RS) and information model for that
>    framework.  It specifies the motivation, requirements, use cases, and
>    defines an information model for recording interactions between
>    elements implementing the I2RS protocol.  This framework provides a
>    consistent tracing interface for components implementing the I2RS
>    architecture to record what was done, by which component, and when.
>    It aims to improve the management of I2RS implementations, and can be
>    used for troubleshooting, auditing, forensics, and accounting
>    purposes.
>
>
>
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>
>
> --
> Joe Marcus Clarke, CCIE #5384,         |          |
> SCJP, SCSA, SCNA, SCSECA, VCP        |||||      |||||
> Distinguished Services Engineer ..:|||||||||::|||||||||:..
> Phone: +1 (919) 392-2867         c i s c o  S y s t e m s
> Email: [email-masked]
>
> ------------------------------**------------------------------**
> ----------------
>
>
> ______________________________**_________________
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/i2rs<https://www.ietf.org/mailman/listinfo/i2rs>
>

---

From: Joe Marcus Clarke <[email-masked]>
Date: Thu, 03 Oct 2013 14:47:50 -0400

On 10/3/13 2:31 PM, Alia Atlas wrote:
> complexity required by a basic troubleshooting information model.  I
> have a couple minor comments (including transport session details beyond
> just the client's IP address, ability to request logs (possibly outside
> of I2RS - such as via scp)), but I think this gives a good sense of what
> would be needed.
> 

I received some comments individually.  As such we are working on
incorporating them.  We certainly expect this document to change as the
protocol becomes more fleshed out.

Joe

> 
> Regards,
> Alia
> 
> 
> On Sat, Sep 28, 2013 at 8:08 PM, Joe Marcus Clarke <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     This is an answer to the suggestion by Alia for a document
>     describing aspects of I2RS traceability.  Some of the ideas in this
>     document are suggestions on how the overall I2RS protocol might be
>     designed while at the same time knowing that changes will need to be
>     made as the protocol evolves.
> 
>     Joe
> 
>     Subject: New Version Notification for
>     draft-clarke-i2rs-__traceability-00.txt
>     From: <[email-masked] <mailto:[email-masked]>>
>     To: Joe Clarke <[email-masked] <mailto:[email-masked]>>,
>     Gonzalo Salgueiro <[email-masked] <mailto:[email-masked]>>,
>     Carlos Pignataro <[email-masked] <mailto:[email-masked]>>
> 
> 
>     A new version of I-D, draft-clarke-i2rs-__traceability-00.txt
>     Title:           Interface to the Routing System (I2RS)
>     Traceability: Framework and Information Model
>     URL:
>     http://www.ietf.org/internet-__drafts/draft-clarke-i2rs-__traceability-00.txt
>     <http://www.ietf.org/internet-drafts/draft-clarke-i2rs-traceability-00.txt>
>     Status:
>     http://datatracker.ietf.org/__doc/draft-clarke-i2rs-__traceability
>     <http://datatracker.ietf.org/doc/draft-clarke-i2rs-traceability>
>     Htmlized:
>     http://tools.ietf.org/html/__draft-clarke-i2rs-__traceability-00
>     <http://tools.ietf.org/html/draft-clarke-i2rs-traceability-00>
> 
> 
>     Abstract:
>     until the htmlized version and diff are available at tools.ietf.org
>     <http://tools.ietf.org>.
> 
>     The IETF Secretariat
> 
> 
>     -- 
>     Phone: +1 (919) 392-2867 <tel:%2B1%20%28919%29%20392-2867>         c
>     i s c o  S y s t e m s
>     Email: [email-masked] <mailto:[email-masked]>
> 
>     ------------------------------__------------------------------__----------------
> 
> 
>     _________________________________________________
>     i2rs mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/__listinfo/i2rs
>     <https://www.ietf.org/mailman/listinfo/i2rs>
> 
> 

----------------------------------------------------------------------------

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Thu, 3 Oct 2013 18:56:39 +0000

On 10/3/13 2:31 PM, "Alia Atlas" <[email-masked]<mailto:[email-masked]>> wrote:

Alia:

Hi!

I read it and sent some comments to Joe off line.

I think that it is a great start.  There is a need to clearly document the actions and result codes, but that is not to be done in this document.  As you said, it points at some of the things that need to be ironed out.

Alvaro.