Subject: Re: [i2rs] access network topology support in data model

From: Sriganesh Kini <[email-masked]>
Date: Mon, 2 Dec 2013 17:04:07 -0800

If a device has a routing system in it, then yes, it is in scope to be
reflected in the I2RS topology model.

Sri

On Thu, Nov 28, 2013 at 1:28 PM, Krishnan Subramanian <
[email-masked]> wrote:

>  Hi ,
>
>  Will access networks like broadband networks (cable, DSL, FTTH) be
> supported in the
> network topology data model? This would include everything from the CPE
> (ie. cable
> modem ) to the a node, CMTS, headend , backhaul network. In wireless
> networks this would include every topology component
> from the base station all the way up to the mobile backhaul network as
> well as access point to wireless controller.
> Providing such a complete network topology model would be helpful in
> delivering location based
> services in addition to analytics that are topology aware.
>
>  Regards,
>  Krishnan Subramanian
>
>
> _______________________________________________
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2rs
>
>

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 03 Dec 2013 10:47:23 +0100

> reflected in the I2RS topology model.

But isn't the restriction to unidirectional and PtP links too limiting for multiaccess networks? I understand that routing systems usually deal with some kind of pairwise adjacencies, but perhaps the topology model could be used in other contexts, too (as it is already the case in OpenDaylight).

Lada

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Sriganesh Kini <[email-masked]>
Date: Tue, 3 Dec 2013 06:25:03 -0800

Mutipoint links should be in scope. They can be modeled using multiple
p2p-unidirectional links just as IGPs have. The topology draft should
reflect this.

Sri

On Tue, Dec 3, 2013 at 1:47 AM, Ladislav Lhotka <[email-masked]> wrote:

> But isn't the restriction to unidirectional and PtP links too limiting for
> multiaccess networks? I understand that routing systems usually deal with
> some kind of pairwise adjacencies, but perhaps the topology model could be
> used in other contexts, too (as it is already the case in OpenDaylight).
>
> Lada
>
> >
> >
> > Sri
> >
> >