Subject: [i2rs] Question and new usecase

From: Anton Smith <[email-masked]>
Date: Tue, 3 Jun 2014 08:51:30 +0000

Hi all,

I have a question and a potential usecase. I was reading the charter today and it mentioned some fairly specific usecases. I've been thinking of another fairly specific class of usecase that I had hoped I2RS would deliver.

The question is, where do you raise discussion on a new usecase, is it here on the list?

The usecase itself is about flow installation or basically non-destination based routing and forwarding. Imagine a router participating in an IP/MPLS domain, which is running for example multiple L3VPNs, L2VPNs, or even just plain L3 routing.

It would be desirable to be able to dynamically push down new policy based rules to an access interface such that as traffic ingresses the node it can be redirected to either services (like an L3VPN context) or forwarded, based on whatever can be filtered/matched in the incoming packet.

In essence policy based forwarding (aka PBR), but allowing I2RS to push down the policies (match criteria, action, etc.), edit them, remove them, and so forth. This could allow for instance, based off orchestration layer decisions, the dynamic redirection or separation of traffic that would have been previously grouped together, and not restricted to just QoS separation but allowing path separation or service redirection. 

Regards,
Anton

---

From: "Russ White" <[email-masked]>
Date: Mon, 9 Jun 2014 06:35:35 -0400

> I have a question and a potential usecase. I was reading the charter today
> and it mentioned some fairly specific usecases. I've been thinking of
another
> fairly specific class of usecase that I had hoped I2RS would deliver.

If this new use case would add some specific new capability to the protocol
or requirement set, then it might be interesting. From what you've described
so far, I don't know if it would -- it seems like the requirements in what
you describe would already be covered in one of the other use cases already
put in draft format. If you think there are unique requirements your use
case would bring to the table, ping some folks off list (probably Sue and
I).

:-)

Russ