Subject: Re: [i2rs] Question and new use case

From: ramki Krishnan <[email-masked]>
Date: Tue, 3 Jun 2014 22:42:25 -0700

Hi Anton,

The draft below addresses the use case you are mentioning. Would love to have your comments.

http://datatracker.ietf.org/doc/draft-krishnan-i2rs-large-flow-use-case/?include_text=1

Thanks,
Ramki

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Anton Smith
Sent: Tuesday, June 03, 2014 1:51 AM
To: [email-masked]
Subject: [i2rs] Question and new usecase

Hi all,

I have a question and a potential usecase. I was reading the charter today and it mentioned some fairly specific usecases. I've been thinking of another fairly specific class of usecase that I had hoped I2RS would deliver.

The question is, where do you raise discussion on a new usecase, is it here on the list?

The usecase itself is about flow installation or basically non-destination based routing and forwarding. Imagine a router participating in an IP/MPLS domain, which is running for example multiple L3VPNs, L2VPNs, or even just plain L3 routing.

It would be desirable to be able to dynamically push down new policy based rules to an access interface such that as traffic ingresses the node it can be redirected to either services (like an L3VPN context) or forwarded, based on whatever can be filtered/matched in the incoming packet.

In essence policy based forwarding (aka PBR), but allowing I2RS to push down the policies (match criteria, action, etc.), edit them, remove them, and so forth. This could allow for instance, based off orchestration layer decisions, the dynamic redirection or separation of traffic that would have been previously grouped together, and not restricted to just QoS separation but allowing path separation or service redirection. 

Regards,
Anton

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs

---

From: Anton Smith <[email-masked]>
Date: Wed, 4 Jun 2014 06:16:15 +0000

Thanks Ramki,

Will take a look.

Rest regards
Anton

Sent from my iPhone

> On 4 jun 2014, at 07:42, "ramki Krishnan" <[email-masked]> wrote:
> 
> Hi Anton,
>

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 5 Jun 2014 16:32:22 -0400

Anton,

> http://datatracker.ietf.org/doc/draft-krishnan-i2rs-large-flow-use-case/?include_text=1

Additionally, some of this is covered in the service chaining draft as well
as the PBR info model.

A review of existing drafts might prove informative:

http://datatracker.ietf.org/wg/i2rs/