Subject: [i2rs] documenting existing implementations

From: Kent Watsen <[email-masked]>
Date: Mon, 17 Nov 2014 19:44:20 +0000

Dean, Alex, Jason,

My primary takeaway from the I2RS WG meeting is that existing implementations exist from ALU, Cisco, and Juniper.  It seems a practical engineering activity to document each of these implementations and discover where they converge/diverge, both with each other as well as the I2RS arch/req drafts.  After said activity, the WG can make an informed decision regarding next steps.

Would you and/or others from your companies be interest in producing such a report?

Thanks,
Kent

---

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Mon, 17 Nov 2014 19:55:52 +0000

Hi Kent,
which specific items are you referring to? I assume the YANG models for topology?
For what has been implemented as part of Open Daylight, please see https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Model_Reference
Can you please be a bit more specific as to what would be the goal of producing a report, and which informed decision regarding what steps this is intending to support?
Thanks
--- Alex

From: Kent Watsen [mailto:[email-masked]]
Sent: Monday, November 17, 2014 11:44 AM
To: Dean Bogdanovic; Jason Sterne; Alexander Clemm (alex)
Cc: [email-masked]
Subject: documenting existing implementations

Dean, Alex, Jason,

Thanks,
Kent

---

From: Kent Watsen <[email-masked]>
Date: Mon, 17 Nov 2014 20:51:11 +0000

I'm referring to support for dynamic/ephemeral configuration.

Thanks,
Kent

From: "Alexander Clemm (alex)" <[email-masked]<mailto:[email-masked]>>
Date: Monday, November 17, 2014 at 2:55 PM
To: Kent Watsen <[email-masked]<mailto:[email-masked]>>, Dean Bogdanovic <[email-masked]<mailto:[email-masked]>>, Jason Sterne <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: documenting existing implementations

Hi Kent,

Cc: [email-masked]<mailto:[email-masked]>

Dean, Alex, Jason,

Thanks,
Kent

---

From: Dean Bogdanovic <[email-masked]>
Date: Wed, 19 Nov 2014 19:24:37 +0000

Kent,

Thank you for brining this topic. I would suggest to start with each vendor writing their own draft and then we can get together, analyze and merge the documents. We, Juniper, already have implementation, but before publishing draft, we are checking with legal, as there is some IPR.

As soon I hear back from legal, will respond to this thread.

Dean

On Nov 17, 2014, at 3:51 PM, Kent Watsen <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,
Kent

Hi Kent,

Dean, Alex, Jason,

Thanks,
Kent