Subject: [i2rs] WG Adoption call for draft-clarke-i2rs-traceability-03 from 11/24 to 12/9/14

From: "Susan Hares" <[email-masked]>
Date: Tue, 25 Nov 2014 00:03:23 -0500

This is to begin a 2 week adoption call for
draft-clarke-i2rs-traceability-03.  Please include in your comments an
indication of "support" or "no support."

Thank you, 

Sue Hares and Jeff Haas

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 25 Nov 2014 00:08:25 -0500

I support adoption of this draft by the working group.  It identifies 
important issues not covered in  other documents, and does a good job 
describing them.

Yours,
Joel

On 11/25/14, 12:03 AM, Susan Hares wrote:
> indication of “support” or “no support.”
>
> Thank you,
>
> Sue Hares and Jeff Haas
>
>
>
> _______________________________________________
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2rs
>

---

From: Mach Chen <[email-masked]>
Date: Wed, 26 Nov 2014 08:21:34 +0000

I have read the draft, it documents a useful function of I2RS. I support the adoption of draft to be a WG document.

Best regards,
Mach

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, November 25, 2014 1:03 PM
To: [email-masked]
Cc: 'Jeffrey Haas'; 'Alia Atlas'
Subject: [i2rs] WG Adoption call for draft-clarke-i2rs-traceability-03 from 11/24 to 12/9/14

This is to begin a 2 week adoption call for draft-clarke-i2rs-traceability-03.  Please include in your comments an indication of "support" or "no support."

Thank you,
Sue Hares and Jeff Haas

---

From: ramki Krishnan <[email-masked]>
Date: Wed, 26 Nov 2014 22:11:46 +0000

Support.

Thanks,
Ramki

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Monday, November 24, 2014 9:03 PM
To: [email-masked]
Cc: 'Jeffrey Haas'; 'Alia Atlas'
Subject: [i2rs] WG Adoption call for draft-clarke-i2rs-traceability-03 from 11/24 to 12/9/14

Thank you,
Sue Hares and Jeff Haas

---

From: Kwang-koog Lee <[email-masked]>
Date: Thu, 27 Nov 2014 15:31:55 +0900

Hi. 

I also read this document and the adoption of working group document is essential.

Like us, many operators agree that SDN-based approach can reduce operational costs (the amount is depending on telco's infrastructures) and provide a base to build new business models on top of the software-based framework. But, SDN-based control technology is not still matured solution to control all functions of network elements, so the framework can be frequently changed for any updated functions and fixing bugs anytime. In such a case, operators may face with exceptional cases that they cannot know and recognize. If there’s no support of such traceability, many operators have difficulties for troubleshoot. So, the traceability which records logs in terms of SDN-based control transactions and retrieves some status of I2RS-based service models in network elements is essential. 

After the adoption of the working group document, I think the service model for the traceability itself is also needed (it includes some parameters for logs such as log policy, level, file size, and so on.) And, as the trace log field, service model name might be added. 

Thanks.
Kwang-koog Lee 

> 2014. 11. 27., 오전 7:11, ramki Krishnan <[email-masked]> 작성:
> 
> Support.
>  
> Thanks,
> Ramki
>  
> This is to begin a 2 week adoption call for draft-clarke-i2rs-traceability-03.  Please include in your comments an indication of “support” or “no support.”
>  
> Thank you, 
> Sue Hares and Jeff Haas

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Sat, 29 Nov 2014 01:24:42 +0000

Hi Sue, Jeff,

The document describes a good framework which enables trace-ability of the interactions amongst I2RS modules, and provides data points for record/debugging purposes. I believe this framework provides a good value, thus I support the adoption of this document as a WG document.

I do have one question/comment to the authors but not a blocker for its WG adoption.

The Log Entity describe one Timestamp. What does this Timestamp describe?

Realistically, I can see 4 possibilities.
- Time when I2RS agent received the request from an I2RS client.
- Time when I2RS agent made the request to the Routing System.
- Time when I2RS agent received the reply from the Routing System.
- Time when I2RS agent sent the reply to to the I2RS client.

If one was attempting to make sense of a scaled number of requests being processed by the I2RS agent (and some processed in parallel), having more than one Timestamp in a Log Entry may provide more insights into what was happening in the system.

Thanks!

-Nobo

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, November 25, 2014 12:03 AM
To: [email-masked]
Cc: 'Jeffrey Haas'; 'Alia Atlas'
Subject: [i2rs] WG Adoption call for draft-clarke-i2rs-traceability-03 from 11/24 to 12/9/14

Thank you,
Sue Hares and Jeff Haas

---

From: Joe Clarke <[email-masked]>
Date: Sat, 29 Nov 2014 12:36:15 -0500

On 11/28/14 8:24 PM, Nobo Akiya (nobo) wrote:
> Hi Sue, Jeff,
>
> The document describes a good framework which enables trace-ability of
> the interactions amongst I2RS modules, and provides data points for
> record/debugging purposes. I believe this framework provides a good
> value, thus I support the adoption of this document as a WG document.
>
> If one was attempting to make sense of a scaled number of requests being
> processed by the I2RS agent (and some processed in parallel), having
> more than one Timestamp in a Log Entry may provide more insights into
> what was happening in the system.

This is a very good observation, Nobo.  Initially, we meant for the 
timestamp to be the time at which the agent received the request from 
the client (since the request may not complete).  But we should have 
another timestamp populated upon completion so that one can gage 
performance as well.

This is the kind of feedback we want, and hopefully this will help drive 
the work forward as a working group item.  Thanks.

Joe

>
> Thanks!
>
> -Nobo
>
> *From:*i2rs [mailto:[email-masked]] *On Behalf Of *Susan Hares
> *Sent:* Tuesday, November 25, 2014 12:03 AM
> *To:* [email-masked]
> *Cc:* 'Jeffrey Haas'; 'Alia Atlas'
> *Subject:* [i2rs] WG Adoption call for draft-clarke-i2rs-traceability-03
> from 11/24 to 12/9/14
>

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Sun, 30 Nov 2014 02:06:43 +0000

Hi Joe,

> -----Original Message-----
> From: Joe Clarke (jclarke)
> Sent: Saturday, November 29, 2014 12:36 PM
> To: Nobo Akiya (nobo); Susan Hares; [email-masked]
> Subject: Re: [i2rs] WG Adoption call for draft-clarke-i2rs-traceability-03 from
> 11/24 to 12/9/14
> 
> > If one was attempting to make sense of a scaled number of requests
> > being processed by the I2RS agent (and some processed in parallel),
> > having more than one Timestamp in a Log Entry may provide more
> > insights into what was happening in the system.
> 
> timestamp to be the time at which the agent received the request from the
> client (since the request may not complete).  But we should have another
> timestamp populated upon completion so that one can gage performance as
> well.

Sounds like a good change that will improve the value of the data (i.e. Log Entry), thus improving the value of this document ;-)

Thanks for considering my comment!

-Nobo

> 
> This is the kind of feedback we want, and hopefully this will help drive the
> work forward as a working group item.  Thanks.
> 
> Joe
> 
> >
> > Thanks!
> >
> > -Nobo
> >
> > *Subject:* [i2rs] WG Adoption call for
> > draft-clarke-i2rs-traceability-03 from 11/24 to 12/9/14
> >