Subject: [i2rs] New "-00": draft-voit-i2rs-pub-sub-requirements

From: "Eric Voit (evoit)" <[email-masked]>
Date: Thu, 11 Dec 2014 15:21:55 +0000

A number of I2RS WG documents ask for Pub/Sub capabilities.  Other WG have addressed or are looking for similar mechanisms.  The document 
http://tools.ietf.org/html/draft-voit-i2rs-pub-sub-requirements-00 
assembles a view of requirements for a YANG Datastore from an I2RS perspective, and makes comparisons with capabilities in standards in and beyond the IETF. 

This document is a good companion document for
https://tools.ietf.org/html/draft-netmod-clemm-datastore-push-00 

Thanks,
Eric , Alex, & Alberto

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, December 11, 2014 10:03 AM
To: Alberto Gonzalez Prieto (albertgo); Alberto Gonzalez Prieto (albertgo); Alexander Clemm (alex); Eric Voit (evoit); Alexander Clemm (alex); Eric Voit (evoit)
Subject: New Version Notification for draft-voit-i2rs-pub-sub-requirements-00.txt

A new version of I-D, draft-voit-i2rs-pub-sub-requirements-00.txt
has been successfully submitted by Eric Voit and posted to the IETF repository.

Name:		draft-voit-i2rs-pub-sub-requirements
Revision:	00
Title:		Requirements for Subscription to YANG Datastores
Document date:	2014-12-10
Group:		Individual Submission
Pages:		13
URL:            http://www.ietf.org/internet-drafts/draft-voit-i2rs-pub-sub-requirements-00.txt
Status:         https://datatracker.ietf.org/doc/draft-voit-i2rs-pub-sub-requirements/
Htmlized:       http://tools.ietf.org/html/draft-voit-i2rs-pub-sub-requirements-00

Abstract:
   This document provides requirements for a service that allows client
   applications to subscribe to updates of a YANG datastore.  Based on
   criteria negotiated as part of a subscription, updates will be pushed
   to targeted recipients.  Such a capability eliminates the need for
   periodic polling of YANG datastores by applications and fills a
   functional gap in existing YANG transports (i.e.  Netconf and
   Restconf).  Such a service can be summarized as a "pub/sub" service
   for YANG datastore updates.  Beyond a set of basic requirements for
   the service, various refinements are addressed.  These refinements
   include: periodicity of object updates, filtering out of objects
   underneath a requested a subtree, and delivery QoS guarantees.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 11 Dec 2014 14:23:51 -0500

Eric:

Would you be available at 10-11 am ET on 12/16/2014 to present on this at
the next I2RS interim? 

Sue 

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Eric Voit (evoit)
Sent: Thursday, December 11, 2014 10:22 AM
To: [email-masked]
Cc: Alexander Clemm (alex); Alberto Gonzalez Prieto (albertgo)
Subject: [i2rs] New "-00": draft-voit-i2rs-pub-sub-requirements

A number of I2RS WG documents ask for Pub/Sub capabilities.  Other WG have
addressed or are looking for similar mechanisms.  The document 
http://tools.ietf.org/html/draft-voit-i2rs-pub-sub-requirements-00 
assembles a view of requirements for a YANG Datastore from an I2RS
perspective, and makes comparisons with capabilities in standards in and
beyond the IETF. 

Thanks,
Eric , Alex, & Alberto

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, December 11, 2014 10:03 AM
To: Alberto Gonzalez Prieto (albertgo); Alberto Gonzalez Prieto (albertgo);
Alexander Clemm (alex); Eric Voit (evoit); Alexander Clemm (alex); Eric Voit
(evoit)
Subject: New Version Notification for
draft-voit-i2rs-pub-sub-requirements-00.txt

A new version of I-D, draft-voit-i2rs-pub-sub-requirements-00.txt
has been successfully submitted by Eric Voit and posted to the IETF
repository.

Name:		draft-voit-i2rs-pub-sub-requirements
Revision:	00
Title:		Requirements for Subscription to YANG Datastores
Document date:	2014-12-10
Group:		Individual Submission
Pages:		13
URL:
http://www.ietf.org/internet-drafts/draft-voit-i2rs-pub-sub-requirements-00.
txt
Status:
https://datatracker.ietf.org/doc/draft-voit-i2rs-pub-sub-requirements/
Htmlized:
http://tools.ietf.org/html/draft-voit-i2rs-pub-sub-requirements-00

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Thu, 11 Dec 2014 19:28:12 +0000

Hi Susan,

I am off-grid next Tuesday.  Perhaps Alex or Alberto can present if there is a time constraint, otherwise I could present at the next interim.  Either way is fine with me.

Eric

> From: Susan Hares, December 11, 2014 2:24 PM
>
> Eric:
> 
> Would you be available at 10-11 am ET on 12/16/2014 to present on this at the
> next I2RS interim?
> 
> Sue
> 
> perspective, and makes comparisons with capabilities in standards in and beyond
> the IETF.
>