Subject: [i2rs] 2 week WG Adoption call (2/2 to 2/16/2015) - draft-voit-i2rs-pub-sub-requirements-00

From: "Susan Hares" <[email-masked]>
Date: Mon, 2 Feb 2015 18:53:16 -0500

This begins a 2 week WG Adoption call for:
draft-voit-i2rs-pub-sub-requirements-00  (2/2 to 2/16/2015).  You can access
the draft at: 

http://www.ietf.org/id/draft-voit-i2rs-pub-sub-requirements-00.txt

The current I2RS charter states: 

"The I2RS working group works to develop a high-level architecture that
describes the basic building-blocks necessary to enable the specific use
cases, and that will lead to an understanding of the abstract informational
models and requirements for encodings and protocols for the I2RS
interfaces."

This draft is part of setting the requirements for the I2RS protocol.  

As Andy has noted in early email, there may be nothing specific to I2RS in
draft-voit-i2rs-pub-sub-requirements-00.txt.  It may be something that
should be just a part of the netconf/restconf functionality.  As part of the
adoption of this draft, the I2RS chairs would like to hear your opinion of
Andy's statement.  Andy also suggests that
draft-netmod-clemm-datastore-push-00 should also be part of the I2RS
requirements. 

http://www.ietf.org/mail-archive/web/i2rs/current/msg02252.html

[chair hat-off] IMHO, I think Andy is correct. [chair-hat on ]. 

If the WG approves adoption of draft-voit-i2rs-pub-sub-requirements-00.txt
and the WG feels these drafts should be netmod WG drafts with I2RS holding a
requirement drafts, the I2RS chairs will do the right thing to make it
happen.   If enough people comment that draft-netmod-clemm-datastore-push-00
should be part of the I2RS requirements, we will do a WG adoption of call
for this requirement.  

Sue Hares

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 2 Feb 2015 19:30:15 -0500

Support.

> On Feb 2, 2015:6:53 PM, at 6:53 PM, Susan Hares <[email-masked]> wrote:
> 
> This begins a 2 week WG Adoption call for:  draft-voit-i2rs-pub-sub-requirements-00  (2/2 to 2/16/2015).  You can access the draft at: 
>  
> http://www.ietf.org/id/draft-voit-i2rs-pub-sub-requirements-00.txt <http://www.ietf.org/id/draft-voit-i2rs-pub-sub-requirements-00.txt>
>  
> “The I2RS working group works to develop a high-level architecture that describes the basic building-blocks necessary to enable the specific use  cases, and that will lead to an understanding of the abstract informational models and requirements for encodings and protocols for the I2RS interfaces.”
>  
> As Andy has noted in early email, there may be nothing specific to I2RS in draft-voit-i2rs-pub-sub-requirements-00.txt.  It may be something that should be just a part of the netconf/restconf functionality.  As part of the adoption of this draft, the I2RS chairs would like to hear your opinion of Andy’s statement.  Andy also suggests that draft-netmod-clemm-datastore-push-00 should also be part of the I2RS requirements. 
>  
> http://www.ietf.org/mail-archive/web/i2rs/current/msg02252.html <http://www.ietf.org/mail-archive/web/i2rs/current/msg02252.html>
>  
> If the WG approves adoption of draft-voit-i2rs-pub-sub-requirements-00.txt and the WG feels these drafts should be netmod WG drafts with I2RS holding a requirement drafts, the I2RS chairs will do the right thing to make it happen.   If enough people comment that draft-netmod-clemm-datastore-push-00 should be part of the I2RS requirements, we will do a WG adoption of call for this requirement.  
>  
> Sue Hares
>  
>  
> _______________________________________________
> i2rs mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/i2rs <https://www.ietf.org/mailman/listinfo/i2rs>

---

From: "Jan Medved (jmedved)" <[email-masked]>
Date: Tue, 3 Feb 2015 00:36:44 +0000

support

From: "Thomas D. Nadeau" <[email-masked]<mailto:[email-masked]>>
Date: Monday, February 2, 2015 at 4:30 PM
To: Susan Hares <[email-masked]<mailto:[email-masked]>>
Cc: Jeffrey Haas <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [i2rs] 2 week WG Adoption call (2/2 to 2/16/2015) - draft-voit-i2rs-pub-sub-requirements-00

Support.

On Feb 2, 2015:6:53 PM, at 6:53 PM, Susan Hares <[email-masked]<mailto:[email-masked]>> wrote:

Sue Hares

_______________________________________________
i2rs mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2rs

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 3 Feb 2015 09:03:27 +0100

> http://www.ietf.org/id/draft-voit-i2rs-pub-sub-requirements-00.txt

I like to point out that some statements in the draft are either
unclear or wrong.

   o  limited support for pushed notification of changes.  (Currently
      notifications are for configuration data only.  And even then,
      subscription mechanisms for such notifications are undefined.)

RFC 5277 defines a <create-subscription> mechanism. RFC 6470 defines
notifications that allow to track changes in a configuration
datastore. So why is the subscription mechanisms undefined?

But in more general terms, I am wondering what the scope of this work
is. Is the goal to provide a mechanism similar to what we have already
for 'config true' datastores for 'config false' datastores or is the
goal to replace the existing mechanism with a new mechanism that will
cover both 'config true' and 'config false' datastores?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 3 Feb 2015 17:34:09 +0000

> From: i2rs on Behalf Of Juergen Schoenwaelder, February 03, 2015 3:03 AM
> 
> > draft-voit-i2rs-pub-sub-requirements-00  (2/2 to 2/16/2015).  You can
> > access the draft at:
> >
> I like to point out that some statements in the draft are either unclear or wrong.

As a "00" draft, I do expect that there will be changes needed.  Your feedback is certainly appreciated. 
 
>       subscription mechanisms for such notifications are undefined.)

The sub-bullet was intended to refine the "existing YANG technology ecosystem" paragraph above it.   That said, the word "undefined" will be changed in the next draft. More below.
 
> notifications that allow to track changes in a configuration datastore. So why is
> the subscription mechanisms undefined?

Netconf Event Notifications RFC5277 is useful, and everything possible from it should be incorporated in the ultimate technology solution.  But RFC5277 does not follow the Pub/Sub paradigm. It predates YANG.  In addition, a goal of this document is to frame requirements so as not to preclude support for additional transports beyond Netconf.  

Netconf Base Notifications RFC6470 is applicable for configuration info only.   The I2RS requirements mean we need to track many other things such as routing changes.

> But in more general terms, I am wondering what the scope of this work is. Is the
> goal to provide a mechanism similar to what we have already for 'config true'
> datastores for 'config false' datastores or is the goal to replace the existing
> mechanism with a new mechanism that will cover both 'config true' and 'config
> false' datastores?

The goal of this document is to aggregate and refine the I2RS requirements which highlight the needs of YANG Pub/Sub.  I believe there are several interesting requirements areas to explore here, including, 
- Dampening: confining the visibility of volatility into something digestible by the subscriber
- Liveliness: what to do if subsets of YANG subtrees can no longer be monitored or are stale
- Presentation: how do we bundle a set of discrete object notifications into a single publishable update for a Subscription

Mechanisms will follow requirements.

Eric
 
> [email-masked]

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 3 Feb 2015 18:38:37 +0100

> Netconf Base Notifications RFC6470 is applicable for configuration info only.   The I2RS requirements mean we need to track many other things such as routing changes.

I understand all that I think but I still think the text quoted above
is incorrect and this should be fixed. I am not looking for long
explanation, a simple "we will change that text to '...'" would be
more efficient.

/js

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 3 Feb 2015 17:47:04 +0000

>>        subscription mechanisms for such notifications are undefined.)
<snip>
> I understand all that I think but I still think the text quoted above is incorrect and
> this should be fixed. I am not looking for long explanation, a simple "we will
> change that text to '...'" would be more efficient.

I can just delete everything between the parenthesis.  Would that be sufficient?
Eric

---

From: Joe Clarke <[email-masked]>
Date: Tue, 03 Feb 2015 12:52:32 -0500

> http://www.ietf.org/id/draft-voit-i2rs-pub-sub-requirements-00.txt

Support.  In fact, the traceability draft calls out pub-sub in 7.4.3. 
It would be nice to see this use case mentioned in the Voit draft.

Joe

> “The I2RS working group works to develop a high-level architecture
> thatdescribes the basic building-blocks necessary to enable the specific
> usecases, and that will lead to an understanding of the abstract
> informational models and requirements for encodings and protocols for
> the I2RS interfaces.”
>
> As Andy has noted in early email, there may be nothing specific to I2RS
> in draft-voit-i2rs-pub-sub-requirements-00.txt.  It may be something
> that should be just a part of the netconf/restconf functionality.  As
> part of the adoption of this draft, the I2RS chairs would like to hear
> your opinion of Andy’s statement.  Andy also suggests that
> If the WG approves adoption of
> draft-voit-i2rs-pub-sub-requirements-00.txt and the WG feels these
> drafts should be netmod WG drafts with I2RS holding a requirement
> drafts, the I2RS chairs will do the right thing to make it happen.   If
> enough people comment that draft-netmod-clemm-datastore-push-00 should
> be part of the I2RS requirements, we will do a WG adoption of call for
> this requirement.
>
> Sue Hares
>
>
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 3 Feb 2015 19:03:17 +0100

> I can just delete everything between the parenthesis.  Would that be sufficient?

This leaves it open what 'limited' means, which I think is not good
either. Perhaps:

o change notifications only for data residing in configuration
  datastores

/js

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 3 Feb 2015 18:19:01 +0000

> > > I understand all that I think but I still think the text quoted
> > > above is incorrect and this should be fixed. I am not looking for
> > > long explanation, a simple "we will change that text to '...'" would be more
> efficient.
> >
> This leaves it open what 'limited' means, which I think is not good either.
> Perhaps:
> 

Works for me.   I will insert that into "-01"

Eric

---

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Wed, 4 Feb 2015 21:20:18 +0000

I agree, this modification will make it more accurate.  
As mentioned earlier on the thread, this is a -00 draft and we should expect that some revisions will be needed.  
Thanks
--- Alex

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Eric Voit (evoit)
Sent: Tuesday, February 03, 2015 10:19 AM
To: Juergen Schoenwaelder
Cc: 'Jeffrey Haas'; [email-masked]; Susan Hares
Subject: Re: [i2rs] 2 week WG Adoption call (2/2 to 2/16/2015) - draft-voit-i2rs-pub-sub-requirements-00

Eric

---

From: Giles Heron <[email-masked]>
Date: Thu, 5 Feb 2015 15:36:16 +0000

support - it's a good starting point.