Subject: Re: [i2rs] Does I2RS charter include both the interface to Network Controller and the interface to devices (i.e. routers)?

From: Dean Bogdanovic <[email-masked]>
Date: Fri, 6 Feb 2015 16:32:41 +0000

Linda,

I understand now your question (based on reading I2NSF emails).

I2RS has two elements, agent and client and I2RS agent is sitting on the network device and exposes north bound interface to the I2RS client. How I2RS agent communicates to the device is not specified. This is up to the implementors to decide. How to communicate between I2RS agent and client, RESTCONF and YANG have been proposed. The interface from I2RS client northbound is not part of the WG.

Now interface between I2RS agent and client can have multiple capabilities, but my proposal is to expose basic capabilities (interface, routing, filtering, class of service) of the network device that can be used to manipulate traffic forwarding behavior of the device. There is nothing preventing to expose higher level capabilities, like LxVPNs, by I2RS agent to be controlled by I2RS client.

Please take a look at the Fig1 Figure 1: Architecture of I2RS clients and agents  in http://datatracker.ietf.org/doc/draft-ietf-i2rs-architecture/?include_text=1

Dean

On Jan 27, 2015, at 6:44 PM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:

I2RS charter states:

It is envisioned that users of the I2RS interfaces will be management
applications, network controllers, and user applications that make
specific demands on the network.

This statement makes me believe that I2RS charter includes both the interface to Network Controller (i.e. North Bound Interface) and the Interface to devices/routers (i.e. South Bound Interface).

The interface to “Network Controller” should be more Service oriented, e.g. allowing applications to indicate their desired features,  enforcing a specific QoS for some applications

The interface to “devices (routers)” should be more functional oriented, e.g. enabling ISIS on a specific port, or, etc.

Is it reasonable for I2RS to have two distinct layers of interfaces?

Linda Dunbar

_______________________________________________
i2rs mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2rs

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 10 Feb 2015 15:44:25 -0500

Dean:

I'm looking forward to your writing up of concepts of the capabilities
(interface, routing, filtering, class of services).   Let me know when you
have more to share for I2RS and I2NSF. 

Sue 

From: Dean Bogdanovic [mailto:[email-masked]] 
Sent: Friday, February 06, 2015 11:33 AM
To: Linda Dunbar
Cc: Susan Hares; [email-masked]; [email-masked]
Subject: Re: [i2rs] Does I2RS charter include both the interface to Network
Controller and the interface to devices (i.e. routers)?

Linda, 

I2RS has two elements, agent and client and I2RS agent is sitting on the
network device and exposes north bound interface to the I2RS client. How
I2RS agent communicates to the device is not specified. This is up to the
implementors to decide. How to communicate between I2RS agent and client,
RESTCONF and YANG have been proposed. The interface from I2RS client
northbound is not part of the WG.

Now interface between I2RS agent and client can have multiple capabilities,
but my proposal is to expose basic capabilities (interface, routing,
filtering, class of service) of the network device that can be used to
manipulate traffic forwarding behavior of the device. There is nothing
preventing to expose higher level capabilities, like LxVPNs, by I2RS agent
to be controlled by I2RS client.

Please take a look at the Fig1 Figure 1: Architecture of I2RS clients and
agents  in
http://datatracker.ietf.org/doc/draft-ietf-i2rs-architecture/?include_text=1

Dean

On Jan 27, 2015, at 6:44 PM, Linda Dunbar <[email-masked]> wrote:

I2RS charter states:

 

This statement makes me believe that I2RS charter includes both the
interface to Network Controller (i.e. North Bound Interface) and the
Interface to devices/routers (i.e. South Bound Interface).

The interface to "Network Controller" should be more Service oriented, e.g.
allowing applications to indicate their desired features,  enforcing a
specific QoS for some applications

The interface to "devices (routers)" should be more functional oriented,
e.g. enabling ISIS on a specific port, or, etc.

Linda Dunbar

_______________________________________________
i2rs mailing list
[email-masked]
 <https://www.ietf.org/mailman/listinfo/i2rs>
https://www.ietf.org/mailman/listinfo/i2rs