Subject: [i2rs] WG Adoption call for draft-wang-i2rs-rib-data-model-02 (

From: "Susan Hares" <[email-masked]>
Date: Tue, 10 Mar 2015 10:49:05 -0400

This is a 3 WG adoption call (3/10 - 3/31) for
draft-wang-i2rs-rib-data-model: 

  http://datatracker.ietf.org/doc/draft-wang-i2rs-rib-data-model

The RIB Design team has created this draft to provide the yang model that
the draft-ietf-i2rs-rib-info model has proposed.  You can find the draft
model at:  

http://datatracker.ietf.org/doc/draft-ietf-i2rs-rib-info-model/

This model will be presented at the IETF 92 session of I2RS (3/27/2015).
In your comments, please indicated "support" or "no-support".   Discussions
should distinguish between commenting on what is included
(drat-ietf-i2rs-rib-info-model), and the encoding of the model. 

Sue Hares

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 10 Mar 2015 19:46:47 +0100

Hi,

can someone explain how the model described here relates to the
routing model described in the core routing configuration data model?

https://tools.ietf.org/html/draft-ietf-netmod-routing-cfg-17

Any major differences or conflicts one should be aware of?

/js

> _______________________________________________
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2rs

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Hariharan Ananthakrishnan <[email-masked]>
Date: Thu, 26 Mar 2015 18:39:03 +0000

Support draft-wang-i2rs-rib-data-model as co-author.

Support draft-ietf-i2rs-rib-info-model.

- Hari

From: Susan Hares
Date: Tuesday, 10 March 2015 09:49
To: "[email-masked]<mailto:[email-masked]>"
Cc: 'Jeffrey Haas', 'Alia Atlas'
Subject: [i2rs] WG Adoption call for draft-wang-i2rs-rib-data-model-02 (

This is a 3 WG adoption call (3/10 – 3/31) for draft-wang-i2rs-rib-data-model:

The RIB Design team has created this draft to provide the yang model that the draft-ietf-i2rs-rib-info model has proposed.  You can find the draft model at:

This model will be presented at the IETF 92 session of I2RS (3/27/2015).   In your comments, please indicated “support” or “no-support”.   Discussions should distinguish between commenting on what is included (drat-ietf-i2rs-rib-info-model), and the encoding of the model.

Sue Hares

---

From: "Jan Medved (jmedved)" <[email-masked]>
Date: Thu, 26 Mar 2015 18:50:09 +0000

Support

From: Hariharan Ananthakrishnan <[email-masked]<mailto:[email-masked]>>
Date: Thursday, March 26, 2015 at 11:39 AM
To: Susan Hares <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: 'Jeffrey Haas' <[email-masked]<mailto:[email-masked]>>, 'Alia Atlas' <[email-masked]<mailto:[email-masked]>>
Subject: Re: [i2rs] WG Adoption call for draft-wang-i2rs-rib-data-model-02 (

- Hari

From: Susan Hares

Sue Hares

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 26 Mar 2015 18:54:47 +0000

Support.

Linda

From: Susan Hares

Sue Hares

---

From: Amit Dass <[email-masked]>
Date: Thu, 26 Mar 2015 18:57:58 +0000

Support draft-wang-i2rs-rib-data-model as a co-author.

Support draft-ietf-i2rs-rib-info-model !!!!

BR/AMit

From: Susan Hares

Sue Hares

---

From: Mach Chen <[email-masked]>
Date: Thu, 26 Mar 2015 19:05:03 +0000

Support as a co-author.

Best regards,
Mach

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, March 10, 2015 10:49 PM
To: [email-masked]
Cc: 'Jeffrey Haas'; 'Alia Atlas'
Subject: [i2rs] WG Adoption call for draft-wang-i2rs-rib-data-model-02 (

This is a 3 WG adoption call (3/10 - 3/31) for draft-wang-i2rs-rib-data-model:

This model will be presented at the IETF 92 session of I2RS (3/27/2015).   In your comments, please indicated "support" or "no-support".   Discussions should distinguish between commenting on what is included (drat-ietf-i2rs-rib-info-model), and the encoding of the model.

Sue Hares

---

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Thu, 26 Mar 2015 19:41:49 +0000

Support
--- Alex

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, March 10, 2015 9:49 AM
To: [email-masked]
Cc: 'Jeffrey Haas'; 'Alia Atlas'
Subject: [i2rs] WG Adoption call for draft-wang-i2rs-rib-data-model-02 (

Sue Hares

---

From: Sriganesh Kini <[email-masked]>
Date: Thu, 26 Mar 2015 12:43:04 -0700

Support as co-author

Sri

On Tue, Mar 10, 2015 at 7:49 AM, Susan Hares <[email-masked]> wrote:

> In your comments, please indicated “support” or “no-support”.   Discussions

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 26 Mar 2015 19:46:59 +0000

Support the adoption. The info and data model of rib are well defined and useful.

Best regards,
Jie

发件人: i2rs [mailto:[email-masked]] 代表 Susan Hares
发送时间: 2015年3月10日 9:49
收件人: [email-masked]
抄送: 'Jeffrey Haas'; 'Alia Atlas'
主题: [i2rs] WG Adoption call for draft-wang-i2rs-rib-data-model-02 (

Sue Hares

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 26 Mar 2015 21:51:21 +0100

> Any major differences or conflicts one should be aware of?

I am still waiting for a response to this question.

/js

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 26 Mar 2015 15:54:14 -0500

> I am still waiting for a response to this question.

There is strong overlap.  

I2RS requires ephemeral state.  Until we know what ephemeral state implementation looks like, we have some difficulty in fully analyzing overlap.  At best, we may be able to refactor common schema into a shared grouping.

-- Jeff

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 26 Mar 2015 15:56:33 -0500

> On 26 Mar 2015, at 15:51, Juergen Schoenwaelder <[email-masked]> wrote:
> 

+1. I believe it is possible to augment the ietf-routing module with the stuff defined in i2rs-rib-data-model-02, instead of using a separate tree. Unless, of course, there are some reasons for doing so, which I’d also like to hear.

Thanks, Lada

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 26 Mar 2015 22:02:01 +0100

> I2RS requires ephemeral state.  Until we know what ephemeral state implementation looks like, we have some difficulty in fully analyzing overlap.  At best, we may be able to refactor common schema…

Even if you believe you need to reinvent the wheel, at least key
abstractions better be the same. Are they?

/js

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 26 Mar 2015 17:09:33 -0400

Juergen: 

Thank you for this excellent question, and for your patience in waiting for
a response.    Due to travel, the Design Team requested time to discuss
their response.  I also wanted to talk to Lada.  The Design Team did not
think the modules conflicted. 

My brief conversation with Lada suggests that the I2RS RIB Model and the
draft-ietf-netmod-routing-cfg-17 did not conflict.   I hope that you will
provide information if you think the two yang modules conflict. 

In your review, will you remember the key question I asked the WG which is

"Does this yang module encode the RIB Information Model the I2RS WG has
already adopted." 
 
Sue 

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Thursday, March 26, 2015 4:51 PM
To: [email-masked]
Subject: Re: [i2rs] WG Adoption call for draft-wang-i2rs-rib-data-model-02 (

/js

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 26 Mar 2015 16:43:12 -0500

Hi Sue,

> On 26 Mar 2015, at 16:09, Susan Hares <[email-masked]> wrote:
> 
> Juergen: 
> 

Yes, I said the I2RS RIB *information* model is compatible with routing-cfg, and that’s certainly true. 

> provide information if you think the two yang modules conflict.

They cannot be in conflict because they don’t intersect. 

> already adopted.”

No, ietf-routing now barely defines anything besides the basic hierarchy, everything else is expected to be added via augments, and I believe you can do it now, even before the ephemeral state issue is resolved.

Lada

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 26 Mar 2015 16:52:19 -0500

> No, ietf-routing now barely defines anything besides the basic hierarchy, everything else is expected to be added via augments, and I believe you can do it now, even before the ephemeral state issu…

Part of the feedback in the Venn diagrams describing possible implementations of I2RS state cover the case of ephemeral state augmenting configuration state.

Feedback from some netconf members seemed to suggest this was one of the less preferred cases to potential implementation.

-- Jeff

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 26 Mar 2015 16:56:38 -0500

> Feedback from some netconf members seemed to suggest this was one of the less preferred cases to potential implementation.

For reference from the proceedings:
http://www.ietf.org/proceedings/91/slides/slides-91-i2rs-1.pdf

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 26 Mar 2015 17:57:00 -0400

Lada:

Whew!  I thought I was losing my mind/hearing.  Thank you for your note confirming our discussion that it was a non-intersecting relationship draft you were mentioning. 

Suggestions about how we should appropriately indicate RIB-Info should augment draft-ietf-netmod-routing-cfg-17 are gratefully accepted by this WG chair. 

Sue

-----Original Message-----
From: Ladislav Lhotka [mailto:[email-masked]] 
Sent: Thursday, March 26, 2015 5:43 PM
To: Susan Hares
Cc: Jürgen Schönwälder; [email-masked]
Subject: Re: [i2rs] WG Adoption call for draft-wang-i2rs-rib-data-model-02 (

Hi Sue,

> their response.  I also wanted to talk to Lada.  The Design Team did 
> not think the modules conflicted.
> 

> "Does this yang module encode the RIB Information Model the I2RS WG 
> has already adopted.”

Lada

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 26 Mar 2015 16:59:32 -0500

> On 26 Mar 2015, at 16:52, Jeffrey Haas <[email-masked]> wrote:
> 
> 

At any rate, my understanding is that the same data must be present in the RIB schema under “routing-state”, no matter whether they coincide with ephemeral data or not.

Lada

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 26 Mar 2015 17:07:39 -0500

> At any rate, my understanding is that the same data must be present in the RIB schema under “routing-state”, no matter whether they coincide with ephemeral data or not.

That would be good and is expected.  However, it would imply i2rs is a routing protocol and thus derived from the routing-protocol identity.  That behavior is not clear until we know how the state is added to the network element.

-- Jeff

---

From: wangzitao <[email-masked]>
Date: Thu, 26 Mar 2015 23:38:01 +0000

Support the adoption.

Michael

发送时间: 2015年3月10日 22:49

Sue Hares

---

From: Nitin Bahadur <[email-masked]>
Date: Mon, 30 Mar 2015 10:30:59 -0400

Support.

From:  wangzitao <[email-masked]>
Date:  Thursday, March 26, 2015 at 7:38 PM
To:  Susan Hares <[email-masked]>, "[email-masked]" <[email-masked]>
Cc:  'Jeffrey Haas' <[email-masked]>, 'Alia Atlas' <[email-masked]>
Subject:  Re: [i2rs] WG Adoption call for draft-wang-i2rs-rib-data-model-02
(

Support the adoption.
 
Michael

This is a 3 WG adoption call (3/10 – 3/31) for
draft-wang-i2rs-rib-data-model:

 

Sue Hares
 
_______________________________________________ i2rs mailing list
[email-masked] https://www.ietf.org/mailman/listinfo/i2rs