Subject: [i2rs] simple rechartering underway

From: Alia Atlas <[email-masked]>
Date: Fri, 6 Mar 2015 18:06:44 -0500

Given the excellent progress that the WG has been making - due to your work
and interest, I have been working on a simple rechartering with Sue and
Jeff.

The new proposed charter is at
http://datatracker.ietf.org/doc/charter-ietf-i2rs/.
It adds the ability to work on a filter-based RIB model.
It allows I2RS to work on YANG data models to supports its in-charter
use-cases.
It clarifies that the topology work will be done starting with a generic
topology model.

Regards,
Alia

---

From: Tina TSOU <[email-masked]>
Date: Sat, 7 Mar 2015 11:49:51 +0000

Dear Alia et al,

Questions for clarification, which interface does i2rs do? Between who and who?

Thank you,
Tina

On Mar 7, 2015, at 7:06 AM, Alia Atlas <[email-masked]<mailto:[email-masked]>> wrote:

Given the excellent progress that the WG has been making - due to your work
and interest, I have been working on a simple rechartering with Sue and Jeff.

The new proposed charter is at http://datatracker.ietf.org/doc/charter-ietf-i2rs/.
It adds the ability to work on a filter-based RIB model.
It allows I2RS to work on YANG data models to supports its in-charter use-cases.
It clarifies that the topology work will be done starting with a generic topology model.

Regards,
Alia

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 7 Mar 2015 23:17:48 +0000

This may be hard to reach consensus on but it would be great if there were statements positioning I2RS versus NETCONF configuration and management.
Thanks,
Acee

From: Tina TSOU <[email-masked]<mailto:[email-masked]>>
Date: Saturday, March 7, 2015 at 6:49 AM
To: Alia Atlas <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [i2rs] simple rechartering underway

Dear Alia et al,

Thank you,
Tina

Regards,
Alia

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 11 Mar 2015 08:24:53 +0100

> and interest, I have been working on a simple rechartering with Sue and

Here is the diff related to topology:

-  o The ability to extract information about topology from the network.
-    Injection and creation of topology will not be considered as an initial work item.
+  o The ability to extract information about topology from the network.
+     These models will be based on a generic topology model to support
+     multiple uses. Injection and creation of topology will not be considered
+     as a work item.

The first and third sentences are both about 'reading topology'. Does
this imply that the generic model will also be limited to 'reading
topology'? Or will the generic model also allow create topology?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Alia Atlas <[email-masked]>
Date: Wed, 11 Mar 2015 03:33:14 -0400

Juergen,

> topology'? Or will the generic model also allow create topology?

It's an interesting question.  What use-cases do you see where writing the
topology
is appropriate?  If one thinks of reading the topology as reading
operational state,
aren't read-write config and read-only operational recommended to be
separated in
YANG models (at least for now)?

Alia

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 11 Mar 2015 08:55:24 +0100

On Wed, Mar 11, 2015 at 03:33:14AM -0400, Alia Atlas wrote:
> It's an interesting question.  What use-cases do you see where
> writing the topology is appropriate?

If you want to do service management, you need to describe (configure)
the desired service topology. This is largely an interface to the
network manager (called a controller these days).

> If one thinks of reading the topology as reading operational state,
> separated in YANG models (at least for now)?

Yes, we love to separate config state from operational state. But this
has nothing to do with the scope of the work item added to the I2RS
charter.

/js

---

From: Alia Atlas <[email-masked]>
Date: Wed, 11 Mar 2015 04:03:02 -0400

On Wed, Mar 11, 2015 at 3:55 AM, Juergen Schoenwaelder <
[email-masked]> wrote:

> > > > Given the excellent progress that the WG has been making - due to
> your
> > > work

True - I see that as needing significantly more information, but having a
generic topology model to build upon would be useful.

> has nothing to do with the scope of the work item added to the I2RS

It is relevant if I2RS defines the operational topology for reading and
there
isn't an active need for writing the topology.

If there is an active need - presumably because of interest in modeling
interfaces
to a network manager - then I can massage the text.  I don't see a reason
to have separate drafts.

Alia

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 11 Mar 2015 15:51:22 +0100

> generic topology model to build upon would be useful.

The question was whether the generic topology is config true, config
false or both. The proposed charter text is not clear.
 
> there isn't an active need for writing the topology.
> 
> interfaces to a network manager - then I can massage the text.  I don't
> see a reason to have separate drafts.
>

It would be nice to have this scope issue clarified so other WGs know
what can be expected.

Thanks.

/js

---

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Wed, 11 Mar 2015 21:48:20 +0000

In general, I do think there are use cases for writeable topology information, for example in the case of service and application layer topologies (which may be provisionable).  Not sure whether it needs to be included in the charter, but in general I think it would be good to allow for this possibility.
--- Alex

From: i2rs [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Wednesday, March 11, 2015 1:03 AM
To: Juergen Schoenwaelder; Alia Atlas; [email-masked]
Subject: Re: [i2rs] simple rechartering underway

On Wed, Mar 11, 2015 at 3:55 AM, Juergen Schoenwaelder <[email-masked]<mailto:[email-masked]>> wrote:
On Wed, Mar 11, 2015 at 03:33:14AM -0400, Alia Atlas wrote:
> [email-masked]<mailto:[email-masked]>> wrote:
>

It is relevant if I2RS defines the operational topology for reading and there
isn't an active need for writing the topology.

If there is an active need - presumably because of interest in modeling interfaces
to a network manager - then I can massage the text.  I don't see a reason
to have separate drafts.

Alia

/js

--
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587<tel:%2B49%20421%20200%203587>         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103<tel:%2B49%20421%20200%203103>         <http://www.jacobs-university.de/>