Subject: [i2rs] Requirements for I2RS protocol and I2RS interim (6/24/2015 at 10:00 - 11:30am ET)

From: "Susan Hares" <[email-masked]>
Date: Tue, 23 Jun 2015 14:19:08 -0400

Netconf Working Group: 

The I2RS WG would like to pass you a set of requirements for the I2RS
protocol, and asks that you provide an analysis by IETF 93 on whether
NETCONF or RESTCONF can meet these requirements.   We expect that these
requirements may require changes to the either NETCONF or RESTCONF.  

The I2RS architecture document (
<https://datatracker.ietf.org/doc/draft-ietf-i2rs-architecture/>
draft-ietf-i2rs-architecture-09) provides a high-level overview of the I2RS
protocol.  The I2RS has compiled the following documents to provide the
additional details on the requirements for the protocols. 

1)       <https://datatracker.ietf.org/doc/draft-ietf-i2rs-ephemeral-state/>
draft-ietf-i2rs-ephemeral-state-00 

2)
<https://datatracker.ietf.org/doc/draft-ietf-i2rs-pub-sub-requirements/>
draft-ietf-i2rs-pub-sub-requirements-02 

3)       <https://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/>
draft-ietf-i2rs-traceability-03  

The draft-ietf-i2rs-ephemeral-state-00 contains the results of the
discussion from the 6/10 interim and the top 10 requirements for I2RS.  In
addition, the draft-ietf-i2rs-ephemeral-state-00 contains an set of detailed
requirements on how the I2RS WG sees the I2RS protocol operating.  These
detailed requirements are to be seen as suggestions on what type of solution
the I2RS WG would like to see, but I2RS WG is asking the NETCONF WG to
provide its best designed protocol.  Please note as part of these detailed
requirement the draft-ietf-i2rs-ephemeral-states-00 contains the idea of
using metadata to record secondary identity.   

The I2RS protocol is driven by data-models.  The approved data models for
protocol independent services are:

-
<https://datatracker.ietf.org/doc/draft-ietf-i2rs-rib-data-model/>
draft-ietf-i2rs-rib-data-model-00

-          Filter-Based RIBS:  draft-kini-i2rs-fb-rib-data-model.00
(released later this week)

-          Topology model which is a composite of:

o   Generic topology model:
<https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-network-topo/>
draft-ietf-i2rs-yang-network-topo-01 

o   L3 topology model:
<https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/>
draft-ietf-i2rs-yang-l3-topology-00 

o   L2 topology model:
<https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topology/>
draft-ietf-i2rs-yang-l2-network-topology-00 

o   L1 Topology model: draft-zhang-i2rs-l1-topo-yang-model-01 (-02 released
later this week). 

o   Service topology model: draft-hares-i2rs-service-topo-yang-model-00
(released on Wednesday)

At this time, none of the Topology models utilize Traffic engineering.  It
is anticipated that these models will support traffic engineering.
Estimated rates of transfer and timing requirements for these modules are
at: http://trac.tools.ietf.org/wg/i2rs/trac/wiki - under the protocol
requirements table. 

We hope that NETCONF WG can provide some initial feedback on these
requirements by IETF 93 at the Tuesday I2RS session.   I2RS will use the
6/24 interim at 10:00-11:30am ET  to provide a time for any participate in
the I2RS, netconf, or netmod group to ask additional questions on these
requirements. 

Sue Hares 

Interim time: 10:00-11:30am ET

Date 6/24/2015

Webex: 

https://ietf.webex.com/ietf/j.php?MTID=m4260bee7be61cb17b0008a3c52069d0f

agenda: 

10:00 - 10:05 - Bash Agenda

10:05 - 10:20- -  review of requirements from

draft-ietf-i2rs-ephemeral-state-00

draft-ietf-i2rs-pub-sub-requirements-02

draft-ietf-i2rs-traceability-03

Timing requirements 

10:20 - 10:30    Review of requirements for mutual authentication,

and transaction in  draft-hares-auth-trans-01 requirements 

10:30- 11:30     Open discussion for I2RS Requirements 

Proceedings and slides can be found at: 

http://www.ietf.org/proceedings/interim/2015/06/24/i2rs/proceedings.html

Sue Hares

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 30 Jun 2015 12:43:31 -0700

Susan,

The NETCONF WG acknowledges the receipt of the requirements.

These requirements need to be discussed in front of the NETCONF WG. Would suggest that i2rs WG present these requirements in front of the NETCONF WG during IETF 93 in Prague to kick start discussion within the WG. Please let us know how much time you (or someone from i2rs) would need to present the requirements.

Thanks.

> On Jun 23, 2015, at 11:19 AM, Susan Hares <[email-masked]> wrote:
> 
> Netconf Working Group: 
>  
> The I2RS WG would like to pass you a set of requirements for the I2RS protocol, and asks that you provide an analysis by IETF 93 on whether NETCONF or RESTCONF can meet these requirements.   We expect that these requirements may require changes to the either NETCONF or RESTCONF.  
>  
> The I2RS architecture document (draft-ietf-i2rs-architecture-09 <https://datatracker.ietf.org/doc/draft-ietf-i2rs-architecture/>) provides a high-level overview of the I2RS  protocol.  The I2RS has compiled the following documents to provide the additional details on the requirements for the protocols. 
>  
> 1)      draft-ietf-i2rs-ephemeral-state-00 <https://datatracker.ietf.org/doc/draft-ietf-i2rs-ephemeral-state/> 
> 2)      draft-ietf-i2rs-pub-sub-requirements-02 <https://datatracker.ietf.org/doc/draft-ietf-i2rs-pub-sub-requirements/> 
> 3)      draft-ietf-i2rs-traceability-03 <https://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/>  
>  
> The draft-ietf-i2rs-ephemeral-state-00 contains the results of the discussion from the 6/10 interim and the top 10 requirements for I2RS.  In addition, the draft-ietf-i2rs-ephemeral-state-00 contains an set of detailed requirements on how the I2RS WG sees the I2RS protocol operating.  These detailed requirements are to be seen as suggestions on what type of solution the I2RS WG would like to see, but I2RS WG is asking the NETCONF WG to provide its best designed protocol.  Please note as part of these detailed requirement the draft-ietf-i2rs-ephemeral-states-00 contains the idea of using metadata to record secondary identity.   
>  
> The I2RS protocol is driven by data-models.  The approved data models for protocol independent services are:
> -          draft-ietf-i2rs-rib-data-model-00 <https://datatracker.ietf.org/doc/draft-ietf-i2rs-rib-data-model/>
> -          Filter-Based RIBS:  draft-kini-i2rs-fb-rib-data-model.00 (released later this week)
> o   Generic topology model: draft-ietf-i2rs-yang-network-topo-01 <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-network-topo/> 
> o   L3 topology model: draft-ietf-i2rs-yang-l3-topology-00 <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/> 
> o   L2 topology model: draft-ietf-i2rs-yang-l2-network-topology-00 <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topology/> 
> o   L1 Topology model: draft-zhang-i2rs-l1-topo-yang-model-01 (-02 released later this week). 
> o   Service topology model: draft-hares-i2rs-service-topo-yang-model-00 (released on Wednesday)
>  
> At this time, none of the Topology models utilize Traffic engineering.  It is anticipated that these models will support traffic engineering.  Estimated rates of transfer and timing requirements for these modules are at: http://trac.tools.ietf.org/wg/i2rs/trac/wiki <http://trac.tools.ietf.org/wg/i2rs/trac/wiki> - under the protocol requirements table. 
>  
> We hope that NETCONF WG can provide some initial feedback on these requirements by IETF 93 at the Tuesday I2RS session.   I2RS will use the 6/24 interim at 10:00-11:30am ET  to provide a time for any participate in the I2RS, netconf, or netmod group to ask additional questions on these requirements. 
>  
> Sue Hares 
>  
> https://ietf.webex.com/ietf/j.php?MTID=m4260bee7be61cb17b0008a3c52069d0f <https://ietf.webex.com/ietf/j.php?MTID=m4260bee7be61cb17b0008a3c52069d0f>
>  
> agenda: 
>  
> 10:00 – 10:05 – Bash Agenda
> 10:05 – 10:20- -  review of requirements from
> 10:20 – 10:30    Review of requirements for mutual authentication,
> http://www.ietf.org/proceedings/interim/2015/06/24/i2rs/proceedings.html <http://www.ietf.org/proceedings/interim/2015/06/24/i2rs/proceedings.html>
>  
> Sue Hares 
>  
>  
> _______________________________________________
> netmod mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>
Mahesh Jethanandani
[email-masked]

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 30 Jun 2015 17:16:20 -0400

Mahesh: 

Ok.  I thought you were going to review the requirement documents and give I2RS an initial guess.  We have present these at 3 I2RS interims, and the slides are online.  I will send the minutes to the netconf working group for their review. 

The presentation of the requirements will need the following time: 

1)      10 top requirements – 5-10 minutes [Sue Hares] 

2)      Ephemeral state – 15 minutes [Jeff Haas] 

3)      Pub/sub requirements – 10-15 minutes [Eric Voit]

4)      Traceability [ 10-15 minutes] 

5)      Security [10 minutes] [Sue Hares and Joel Halpern]

6)      Review of I2RS models [5 minutes] 

7)       

If you have heard pub/sub and traceability requirements, you may delete this from timeline. 

Sue Hares 

From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of Mahesh Jethanandani
Sent: Tuesday, June 30, 2015 3:44 PM
To: Susan Hares
Cc: [email-masked]; [email-masked]; BRUNGARD, DEBORAH A; Netconf; NETMOD Working Group
Subject: Re: [Rtg-yang-coord] [netmod] Requirements for I2RS protocol and I2RS interim (6/24/2015 at 10:00 - 11:30am ET)

Susan,

Thanks.

Netconf Working Group: 

The I2RS architecture document ( <https://datatracker.ietf.org/doc/draft-ietf-i2rs-architecture/> draft-ietf-i2rs-architecture-09) provides a high-level overview of the I2RS  protocol.  The I2RS has compiled the following documents to provide the additional details on the requirements for the protocols. 

1)       <https://datatracker.ietf.org/doc/draft-ietf-i2rs-ephemeral-state/> draft-ietf-i2rs-ephemeral-state-00 

2)       <https://datatracker.ietf.org/doc/draft-ietf-i2rs-pub-sub-requirements/> draft-ietf-i2rs-pub-sub-requirements-02 

3)       <https://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/> draft-ietf-i2rs-traceability-03  

-           <https://datatracker.ietf.org/doc/draft-ietf-i2rs-rib-data-model/> draft-ietf-i2rs-rib-data-model-00

o   Generic topology model:  <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-network-topo/> draft-ietf-i2rs-yang-network-topo-01 

o   L3 topology model:  <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/> draft-ietf-i2rs-yang-l3-topology-00 

o   L2 topology model:  <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topology/> draft-ietf-i2rs-yang-l2-network-topology-00 

At this time, none of the Topology models utilize Traffic engineering.  It is anticipated that these models will support traffic engineering.  Estimated rates of transfer and timing requirements for these modules are at:  <http://trac.tools.ietf.org/wg/i2rs/trac/wiki> http://trac.tools.ietf.org/wg/i2rs/trac/wiki - under the protocol requirements table. 

Sue Hares 

Date 6/24/2015

Webex: 

 <https://ietf.webex.com/ietf/j.php?MTID=m4260bee7be61cb17b0008a3c52069d0f> https://ietf.webex.com/ietf/j.php?MTID=m4260bee7be61cb17b0008a3c52069d0f

agenda: 

Timing requirements 

 <http://www.ietf.org/proceedings/interim/2015/06/24/i2rs/proceedings.html> http://www.ietf.org/proceedings/interim/2015/06/24/i2rs/proceedings.html

Sue Hares 

_______________________________________________
netmod mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/netmod> https://www.ietf.org/mailman/listinfo/netmod

Mahesh Jethanandani

[email-masked]

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 30 Jun 2015 22:13:21 +0000

I presented PubSub ‘-01’ requirements in NETCONF at IETF 92.    Changes in ‘-02’ are likely not enough for a speaking slot.

What might be interesting for a NETCONF speaking slot is an analysis of what requirements from “draft-ietf-i2rs-pub-sub-requirements” are met by “draft-clemm-netconf-yang-push”.   (During IETF 92, NETCONF reviewed draft-clemm. There was a strawman poll (12 yes, 0 no) where the WG indicated interest.)

Would NETCONF want Alex or I to speak on a requirements-to-technology comparison in Prague?

Eric

From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, June 30, 2015 5:16 PM
To: 'Mahesh Jethanandani'
Cc: [email-masked]; [email-masked]; 'NETMOD Working Group'; 'Netconf'; 'BRUNGARD, DEBORAH A'
Subject: Re: [Rtg-yang-coord] [netmod] Requirements for I2RS protocol and I2RS interim (6/24/2015 at 10:00 - 11:30am ET)

Mahesh:

7)

Sue Hares

From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of Mahesh Jethanandani
Sent: Tuesday, June 30, 2015 3:44 PM
To: Susan Hares
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; BRUNGARD, DEBORAH A; Netconf; NETMOD Working Group
Subject: Re: [Rtg-yang-coord] [netmod] Requirements for I2RS protocol and I2RS interim (6/24/2015 at 10:00 - 11:30am ET)

Susan,

Thanks.

On Jun 23, 2015, at 11:19 AM, Susan Hares <[email-masked]<mailto:[email-masked]>> wrote:

Netconf Working Group:

The I2RS architecture document (draft-ietf-i2rs-architecture-09<https://datatracker.ietf.org/doc/draft-ietf-i2rs-architecture/>) provides a high-level overview of the I2RS  protocol.  The I2RS has compiled the following documents to provide the additional details on the requirements for the protocols.

1)      draft-ietf-i2rs-ephemeral-state-00<https://datatracker.ietf.org/doc/draft-ietf-i2rs-ephemeral-state/>
2)      draft-ietf-i2rs-pub-sub-requirements-02<https://datatracker.ietf.org/doc/draft-ietf-i2rs-pub-sub-requirements/>
3)      draft-ietf-i2rs-traceability-03<https://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/>

The I2RS protocol is driven by data-models.  The approved data models for protocol independent services are:
-          draft-ietf-i2rs-rib-data-model-00<https://datatracker.ietf.org/doc/draft-ietf-i2rs-rib-data-model/>
-          Filter-Based RIBS:  draft-kini-i2rs-fb-rib-data-model.00 (released later this week)
-          Topology model which is a composite of:
o   Generic topology model: draft-ietf-i2rs-yang-network-topo-01<https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-network-topo/>
o   L3 topology model: draft-ietf-i2rs-yang-l3-topology-00<https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/>
o   L2 topology model: draft-ietf-i2rs-yang-l2-network-topology-00<https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topology/>
o   L1 Topology model: draft-zhang-i2rs-l1-topo-yang-model-01 (-02 released later this week).
o   Service topology model: draft-hares-i2rs-service-topo-yang-model-00 (released on Wednesday)

At this time, none of the Topology models utilize Traffic engineering.  It is anticipated that these models will support traffic engineering.  Estimated rates of transfer and timing requirements for these modules are at: http://trac.tools.ietf.org/wg/i2rs/trac/wiki - under the protocol requirements table.

Sue Hares

agenda:

Sue Hares

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>