Subject: [i2rs] I-D Action: draft-ietf-i2rs-yang-network-topo-02.txt

From: [email-masked]
Date: Tue, 08 Dec 2015 20:20:48 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Interface to the Routing System Working Group of the IETF.

        Title           : A Data Model for Network Topologies
        Authors         : Alexander Clemm
                          Jan Medved
                          Robert Varga
                          Tony Tkacik
                          Nitin Bahadur
                          Hariharan Ananthakrishnan
	Filename        : draft-ietf-i2rs-yang-network-topo-02.txt
	Pages           : 30
	Date            : 2015-12-08

Abstract:
   This document defines an abstract (generic) YANG data model for
   network/service topologies and inventories.  The model serves as a
   base model which is augmented with technology-specific details in
   other, more specific topology and inventory models.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-network-topo/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-i2rs-yang-network-topo-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-i2rs-yang-network-topo-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Wed, 9 Dec 2015 04:29:18 +0000

Hi,

we have just posted a new revision of the draft.  

There are a number of updates that were applied:
- The model now uses YANG 1.1.  It leverages the new "require-instance" construct that allows to specify for leafrefs that a the referenced instance does not necessarily have to exist.  This helps address the case when a node in an underlay topology is deleted, which an overlay node refers to.  
- A top level container was introduced.
- State information is in a parallel tree, for clear separation of config and state.  
- A couple of fixes to namespace qualifiers in groupings (thank you, Xufeng!)

We expect to post another revision fairly shortly in which we hope to bring to closure two remaining open items (regarding the distinction of state vs configuration for server-provided and client-provided topologies, and regarding the use of URIs vs strings as identifiers).

Regards
--- Alex (on behalf of the coauthors)

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 08, 2015 8:21 PM
To: [email-masked]
Cc: [email-masked]
Subject: [i2rs] I-D Action: draft-ietf-i2rs-yang-network-topo-02.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs