Subject: [i2rs] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

From: "Susan Hares" <[email-masked]>
Date: Thu, 24 Mar 2016 13:02:27 -0400

Hi all: 

<wg chair hat on> 

The draft-ietf-i2rs-architecture document has been approved as an RFC.  In
the review, the OPS-DIR review indicated that "ephemeral" meant more than
"does not survive a reboot". They have asked the I2RS working group if
replacing "ephemeral" with non-persistent (across power on/off or reboot
cycles) would be a better choice.  

What do you think - leave at it at "ephemeral" or change to "non-persistent
(across power on/off or reboot cycles) ? We will have a 1 week call on 

This would mean every place that "ephemeral" is listed, the authors would
replace with "non-persistent".  In the first instance, we will indicate
"non-persistent (across power on/off or reboot cycles).

<wg chair hat off>  

As the author, I think we are better to define ephemeral at the beginning as
"non-persistent (across power on /off or reboot).  Changing the definition
at this point, I suspect will simply confuse people. 

Sue Hares

---

From: "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]>
Date: Thu, 24 Mar 2016 17:05:30 +0000

Agree.

Cheers,
Mehmet

From: OPS-DIR [mailto:[email-masked]] On Behalf Of EXT Susan Hares
Sent: Thursday, March 24, 2016 6:02 PM
To: [email-masked]
Cc: 'Joel Halpern Direct' <[email-masked]>; [email-masked]
Subject: [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

Hi all:

<wg chair hat on>
The draft-ietf-i2rs-architecture document has been approved as an RFC.  In the review, the OPS-DIR review indicated that "ephemeral" meant more than "does not survive a reboot". They have asked the I2RS working group if replacing "ephemeral" with non-persistent (across power on/off or reboot cycles) would be a better choice.

What do you think - leave at it at "ephemeral" or change to "non-persistent (across power on/off or reboot cycles) ? We will have a 1 week call on

This would mean every place that "ephemeral" is listed, the authors would replace with "non-persistent".  In the first instance, we will indicate "non-persistent (across power on/off or reboot cycles).

<wg chair hat off>

As the author, I think we are better to define ephemeral at the beginning as "non-persistent (across power on /off or reboot).  Changing the definition at this point, I suspect will simply confuse people.

Sue Hares

---

From: "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]>
Date: Thu, 24 Mar 2016 17:30:23 +0000

Let me say it a bit more clearly.

I think Sue (the author) is right. We should define the term ephemeral at the beginning of the document and keep using it throughout the document. It would be confusing for the people to change it to "non-persistent (across power on /off or reboot)".

Cheers,
Mehmet

From: OPS-DIR [mailto:[email-masked]] On Behalf Of EXT Ersue, Mehmet (Nokia - DE/Munich)
Sent: Thursday, March 24, 2016 6:06 PM
To: EXT Susan Hares <[email-masked]>; [email-masked]
Cc: 'Joel Halpern Direct' <[email-masked]>; [email-masked]
Subject: Re: [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

Agree.

Cheers,
Mehmet

From: OPS-DIR [mailto:[email-masked]] On Behalf Of EXT Susan Hares
Sent: Thursday, March 24, 2016 6:02 PM
To: [email-masked]<mailto:[email-masked]>
Cc: 'Joel Halpern Direct' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

Hi all:

<wg chair hat on>

<wg chair hat off>

Sue Hares

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 24 Mar 2016 14:21:40 -0400

Gunter: 

The goal is to explain it in the I2RS architecture statement, and then refer back to it in other documents (if needed). 

Sue

From: Gunter Van De Velde [mailto:[email-masked]] 
Sent: Thursday, March 24, 2016 2:08 PM
To: Susan Hares
Cc: [email-masked]; Joel Halpern Direct; [email-masked]
Subject: Re: [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

I am ok nowadays with using the terminology “Ephemeral”, although for a non-natve speaker it is non-trivial exotic word, particular if the intended usage doesn’t 100% reflect the Webster dictionary intended meaning.

It is only about a year ago i started reading up on i2rs and discovered this particular terminology, and at the time a google search on this terminology was not very conclusive and resulted to some confusion. 

I understand very well the confusion at play here from non-native english speaker perspective.

Adding text to explain the context in which the term Ephemeral is useful/advised. fwiw now that i am used to seeing ‘Ephemeral' as non-permanent config across reboot, i’m adapted its intended purpose… 

Is the goal to explain the intended meaning in each draft/rfc mentioning it?

Be well,

G/

On 24 Mar 2016, at 18:02, Susan Hares <[email-masked]> wrote:

Hi all: 

<wg chair hat on> 

The draft-ietf-i2rs-architecture document has been approved as an RFC.  In the review, the OPS-DIR review indicated that “ephemeral” meant more than “does not survive a reboot”. They have asked the I2RS working group if replacing “ephemeral” with non-persistent (across power on/off or reboot cycles) would be a better choice.  

What do you think – leave at it at “ephemeral” or change to “non-persistent (across power on/off or reboot cycles) ? We will have a 1 week call on 

This would mean every place that “ephemeral” is listed, the authors would replace with “non-persistent”.  In the first instance, we will indicate “non-persistent (across power on/off or reboot cycles).

<wg chair hat off>  

As the author, I think we are better to define ephemeral at the beginning as “non-persistent (across power on /off or reboot).  Changing the definition at this point, I suspect will simply confuse people. 

Sue Hares

_______________________________________________
OPS-DIR mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/ops-dir> https://www.ietf.org/mailman/listinfo/ops-dir

---

From: "Fedyk, Don" <[email-masked]>
Date: Thu, 24 Mar 2016 18:32:55 +0000

Hi

Sue I like maintaining the use of the term ephemeral and defining it as you indicated.  By defining the time scope of reboot cycles etc. I think the use is clear.  (I think if we used another term at this point we would have to similarly define that term too.)

Cheers
Don

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Thursday, March 24, 2016 1:02 PM
To: [email-masked]
Cc: 'Joel Halpern Direct' <[email-masked]>; [email-masked]; 'Fred Baker (fred)' <[email-masked]>
Subject: [i2rs] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

Hi all:

<wg chair hat on>

<wg chair hat off>

Sue Hares

---

From: Gunter Van De Velde <[email-masked]>
Date: Thu, 24 Mar 2016 19:07:35 +0100

Be well,
G/

> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ops-dir <https://www.ietf.org/mailman/listinfo/ops-dir>

---

From: "Steve Braaten (sbraaten)" <[email-masked]>
Date: Thu, 24 Mar 2016 19:31:04 +0000

All -

While I am not actively involved in i2rs, I have been watching it from the beginning and will admit the group's use of the term "ephemeral" has always been confusing to me.  So from an "outsider's" point of view:

While the dictionary will define "ephemeral" as "short-lived," in my 25+ years in networking it has meant "constantly changing."  I wouldn't bother with the semantic, except there is nothing to stop an implementation from storing ephemeral state persistently, such that when a box or software module dies or restarts, it can return to its last known state.  And in this way, I feel like term is actually being used technically incorrectly by i2rs.

I am not suggesting you change your proposed course of action, just pointing out what it looks like to someone who is not in the i2rs weeds.

Steve

From: i2rs [mailto:[email-masked]] On Behalf Of Fedyk, Don
Sent: Thursday, March 24, 2016 11:33 AM
To: Susan Hares <[email-masked]>; [email-masked]
Cc: 'Joel Halpern Direct' <[email-masked]>; [email-masked]; Fred Baker (fred) <[email-masked]>
Subject: Re: [i2rs] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

Hi

Cheers
Don

Cc: 'Joel Halpern Direct' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; 'Fred Baker (fred)' <[email-masked]<mailto:[email-masked]>>

Hi all:

<wg chair hat on>

<wg chair hat off>

Sue Hares

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Thu, 24 Mar 2016 18:59:17 +0000

My comment was a review comment, that the word was being used in a way that wasn't consistent with its dictionary definition (something with a short lifetime, quite irrespective of birth/death processes) or common usage (at least in my context). At this point, the draft has been sent to the RFC Editor, so to my mind this discussion is mostly moot. If in your other drafts you are pointing people to a glossary in the architecture document (which I imagine you already are) and the architecture document defines the term as you are using it, you have probably done enough.

> On Mar 24, 2016, at 11:07 AM, Gunter Van De Velde <[email-masked]> wrote:
> 
>> On 24 Mar 2016, at 18:02, Susan Hares <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi all:
>> 
>> <wg chair hat on>
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ops-dir

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 24 Mar 2016 15:37:14 -0400

I agree Fred, i2rs folks seem willing to carry the baggage of explaining a term
that some of us first-time readers felt was inconsistent with the dictionary
definition.  They can continue explaining their choice in every future talk, etc.

With respect to documents outside the shadow of i2rs, authors should feel
free to use terms that best match the idea or concept. Further, I think we
have indicated a preference for the term "non-persistent" to describe this
concept in future OPS-DIR reviews and memos from OPS area.

regards, and thanks for raising this issue in your review,
Al

________________________________
From: OPS-DIR [[email-masked]] On Behalf Of Fred Baker (fred) [[email-masked]]
Sent: Thursday, March 24, 2016 2:59 PM
To: Gunter Van De Velde
Cc: [email-masked]; [email-masked]; Joel Halpern Direct
Subject: Re: [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

On Mar 24, 2016, at 11:07 AM, Gunter Van De Velde <[email-masked]<mailto:[email-masked]>> wrote:

Be well,
G/

On 24 Mar 2016, at 18:02, Susan Hares <[email-masked]<mailto:[email-masked]>> wrote:

Hi all:

<wg chair hat on>

<wg chair hat off>

Sue Hares

_______________________________________________
OPS-DIR mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ops-dir

_______________________________________________
OPS-DIR mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ops-dir

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Fri, 25 Mar 2016 00:04:52 +0100

that would be fine by me.

Bert

On 24/03/16 18:30, Ersue, Mehmet (Nokia - DE/Munich) wrote:
> I think Sue (the author) is right. We should define the term ephemeral at the beginning of the document and keep using it 
> throughout the document. It would be confusing for the people to change it to “non-persistent (across power on /off or reboot)”.
>
> Cheers,
> Mehmet
>
> *From:* OPS-DIR [mailto:[email-masked]] *On Behalf Of *EXT Ersue, Mehmet (Nokia - DE/Munich)
> *Sent:* Thursday, March 24, 2016 6:06 PM
> *To:* EXT Susan Hares <[email-masked]>; [email-masked]
> *Cc:* 'Joel Halpern Direct' <[email-masked]>; [email-masked]
> *Subject:* Re: [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion
>
> Agree.
>
> Cheers,
> Mehmet
>
> *From:* OPS-DIR [mailto:[email-masked]] *On Behalf Of *EXT Susan Hares
> *Sent:* Thursday, March 24, 2016 6:02 PM
> *To:* [email-masked] <mailto:[email-masked]>
> *Cc:* 'Joel Halpern Direct' <[email-masked] <mailto:[email-masked]>>; [email-masked] 
> <mailto:[email-masked]>
> *Subject:* [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion
>
> Hi all:
>
> <wg chair hat on>
>
> The draft-ietf-i2rs-architecture document has been approved as an RFC.  In the review, the OPS-DIR review indicated that 
> “ephemeral” meant more than “does not survive a reboot”. They have asked the I2RS working group if replacing “ephemeral” with 
> non-persistent (across power on/off or reboot cycles) would be a better choice.
>
> This would mean every place that “ephemeral” is listed, the authors would replace with “non-persistent”.  In the first instance, 
> we will indicate “non-persistent (across power on/off or reboot cycles).
>
> <wg chair hat off>
>
> As the author, I think we are better to define ephemeral at the beginning as “non-persistent (across power on /off or reboot).  
> Changing the definition at this point, I suspect will simply confuse people.
>
> Sue Hares
>
>
>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 24 Mar 2016 18:05:10 -0700

On Thu, Mar 24, 2016 at 11:59 AM, Fred Baker (fred) <[email-masked]> wrote:

> My comment was a review comment, that the word was being used in a way
> that wasn't consistent with its dictionary definition (something with a
> short lifetime, quite irrespective of birth/death processes) or common
> usage (at least in my context). At this point, the draft has been sent to
> the RFC Editor, so to my mind this discussion is mostly moot. If in your
> other drafts you are pointing people to a glossary in the architecture
> document (which I imagine you already are) and the architecture document
> defines the term as you are using it, you have probably done enough.
>
>

I never liked this term in I2RS, mostly because I keep misspelling it ;-)

The thing about the ephemeral datastore that is interesting is that it
overrides the local running datastore. But I am not suggesting a name change
at this late date.

Andy

On Mar 24, 2016, at 11:07 AM, Gunter Van De Velde <
> [email-masked]> wrote:
>
> I am ok nowadays with using the terminology “Ephemeral”, although for a
> non-natve speaker it is non-trivial exotic word, particular if the intended
> usage doesn’t 100% reflect the Webster dictionary intended meaning.
>
> It is only about a year ago i started reading up on i2rs and discovered
> this particular terminology, and at the time a google search on this
> terminology was not very conclusive and resulted to some confusion.
> Adding text to explain the context in which the term Ephemeral is
> useful/advised. fwiw now that i am used to seeing ‘Ephemeral' as
> non-permanent config across reboot, i’m adapted its intended purpose…
>
> the review, the OPS-DIR review indicated that “ephemeral” meant more than
> “does not survive a reboot”. They have asked the I2RS working group if
> replacing “ephemeral” with non-persistent (across power on/off or reboot
> What do you think – leave at it at “ephemeral” or change to
> “non-persistent (across power on/off or reboot cycles) ? We will have a 1
> week call on
>
> This would mean every place that “ephemeral” is listed, the authors would
> replace with “non-persistent”.  In the first instance, we will indicate
> “non-persistent (across power on/off or reboot cycles).
>
> <wg chair hat off>
>
> As the author, I think we are better to define ephemeral at the beginning
> as “non-persistent (across power on /off or reboot).  Changing the
> definition at this point, I suspect will simply confuse people.
>
> Sue Hares
>
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2rs
>
>

---

From: Joe Clarke <[email-masked]>
Date: Thu, 24 Mar 2016 21:34:03 -0400

On 3/24/16 13:30, Ersue, Mehmet (Nokia - DE/Munich) wrote:
> I think Sue (the author) is right. We should define the term ephemeral
> at the beginning of the document and keep using it throughout the
> document. It would be confusing for the people to change it to
> “non-persistent (across power on /off or reboot)”.

Agree with this.  I think this definition covers what we've meant by 
ephemeral, and explicitly stating it once is good.

Joe

> *Cc:* 'Joel Halpern Direct' <[email-masked]
> <mailto:[email-masked]>>; [email-masked]
> The draft-ietf-i2rs-architecture document has been approved as an RFC.
> In the review, the OPS-DIR review indicated that “ephemeral” meant more
> than “does not survive a reboot”. They have asked the I2RS working group
> if replacing “ephemeral” with non-persistent (across power on/off or
> reboot cycles) would be a better choice.
>
> “non-persistent (across power on/off or reboot cycles) ? We will have a
> 1 week call on
>
> This would mean every place that “ephemeral” is listed, the authors
> would replace with “non-persistent”.  In the first instance, we will
> indicate “non-persistent (across power on/off or reboot cycles).
>
> <wg chair hat off>
>
> As the author, I think we are better to define ephemeral at the
> beginning as “non-persistent (across power on /off or reboot).  Changing
> the definition at this point, I suspect will simply confuse people.
>
> Sue Hares
>
>
>

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 25 Mar 2016 09:18:19 -0400

Fred: 

Thank you for the review, and your comments here.  I wished I’d asked about the word ephemeral earlier. 

Sue 

From: Fred Baker (fred) [mailto:[email-masked]] 
Sent: Thursday, March 24, 2016 2:59 PM
To: Gunter Van De Velde
Cc: Susan Hares; [email-masked]; [email-masked]; Joel Halpern Direct
Subject: Re: [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

Be well,

G/

Hi all: 

<wg chair hat on> 

<wg chair hat off>  

Sue Hares

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 25 Mar 2016 09:20:55 -0400

Al:

I appreciate your comments and Fred's comments.   In future documents, I
suspect I should get an early review from OPS-DIR on the terms.

Sue 

From: OPS-DIR [mailto:[email-masked]] On Behalf Of MORTON, ALFRED
C (AL)
Sent: Thursday, March 24, 2016 3:37 PM
To: Fred Baker (fred); Gunter Van De Velde
Cc: [email-masked]; [email-masked]; Joel Halpern Direct
Subject: Re: [OPS-DIR] Ephemeral - Should we use another word - (3/24 to
4/3) Call for opinion

I agree Fred, i2rs folks seem willing to carry the baggage of explaining a
term

definition.  They can continue explaining their choice in every future talk,
etc.

Al

  _____  

From: OPS-DIR [[email-masked]] On Behalf Of Fred Baker (fred)
[[email-masked]]
Sent: Thursday, March 24, 2016 2:59 PM
To: Gunter Van De Velde
Cc: [email-masked]; [email-masked]; Joel Halpern Direct
Subject: Re: [OPS-DIR] Ephemeral - Should we use another word - (3/24 to
4/3) Call for opinion

My comment was a review comment, that the word was being used in a way that
wasn't consistent with its dictionary definition (something with a short
lifetime, quite irrespective of birth/death processes) or common usage (at
least in my context). At this point, the draft has been sent to the RFC
Editor, so to my mind this discussion is mostly moot. If in your other
drafts you are pointing people to a glossary in the architecture document
(which I imagine you already are) and the architecture document defines the
term as you are using it, you have probably done enough. 

On Mar 24, 2016, at 11:07 AM, Gunter Van De Velde
<[email-masked]> wrote:

I am ok nowadays with using the terminology "Ephemeral", although for a
non-natve speaker it is non-trivial exotic word, particular if the intended
usage doesn't 100% reflect the Webster dictionary intended meaning.

It is only about a year ago i started reading up on i2rs and discovered this
particular terminology, and at the time a google search on this terminology
was not very conclusive and resulted to some confusion. 

I understand very well the confusion at play here from non-native english
speaker perspective.

Adding text to explain the context in which the term Ephemeral is
useful/advised. fwiw now that i am used to seeing 'Ephemeral' as
non-permanent config across reboot, i'm adapted its intended purpose. 

Be well,

G/

Hi all: 

<wg chair hat on> 

<wg chair hat off>  

Sue Hares

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 25 Mar 2016 09:29:31 -0400

Steve:

Thank you for your comments.  It was useful to hear from people who are
coming into I2RS. 

Sue 

From: Steve Braaten (sbraaten) [mailto:[email-masked]] 
Sent: Thursday, March 24, 2016 3:31 PM
To: Fedyk, Don; Susan Hares; [email-masked]
Cc: 'Joel Halpern Direct'; [email-masked]; Fred Baker (fred)
Subject: RE: [i2rs] Ephemeral - Should we use another word - (3/24 to 4/3)
Call for opinion

All -

While I am not actively involved in i2rs, I have been watching it from the
beginning and will admit the group's use of the term "ephemeral" has always
been confusing to me.  So from an "outsider's" point of view:

While the dictionary will define "ephemeral" as "short-lived," in my 25+
years in networking it has meant "constantly changing."  I wouldn't bother
with the semantic, except there is nothing to stop an implementation from
storing ephemeral state persistently, such that when a box or software
module dies or restarts, it can return to its last known state.  And in this
way, I feel like term is actually being used technically incorrectly by
i2rs.

I am not suggesting you change your proposed course of action, just pointing
out what it looks like to someone who is not in the i2rs weeds.

Steve

From: i2rs [mailto:[email-masked]] On Behalf Of Fedyk, Don
Sent: Thursday, March 24, 2016 11:33 AM
To: Susan Hares <[email-masked]>; [email-masked]
Cc: 'Joel Halpern Direct' <[email-masked]>; [email-masked];
Fred Baker (fred) <[email-masked]>
Subject: Re: [i2rs] Ephemeral - Should we use another word - (3/24 to 4/3)
Call for opinion

Hi 

Sue I like maintaining the use of the term ephemeral and defining it as you
indicated.  By defining the time scope of reboot cycles etc. I think the use
is clear.  (I think if we used another term at this point we would have to
similarly define that term too.) 

Cheers

Don 

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Thursday, March 24, 2016 1:02 PM
To: [email-masked]
Cc: 'Joel Halpern Direct' <[email-masked]>; [email-masked];
'Fred Baker (fred)' <[email-masked]>
Subject: [i2rs] Ephemeral - Should we use another word - (3/24 to 4/3) Call
for opinion

Hi all: 

<wg chair hat on> 

<wg chair hat off>  

Sue Hares

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 25 Mar 2016 10:01:49 -0400

Deborah: 

Section 2 is exactly the place I would put the definition of ephemeral. 

Sue 

From: BRUNGARD, DEBORAH A [mailto:[email-masked]] 
Sent: Friday, March 25, 2016 9:50 AM
To: Susan Hares; 'Fred Baker (fred)'; 'Gunter Van De Velde'
Cc: [email-masked]; [email-masked]; 'Joel Halpern Direct'
Subject: RE: [i2rs] [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

Hi all,

As Alia is a co-author, I was assigned as the responsible AD for this document. The document is not with the RFC Editor – it’s been approved by the IESG with a revised ID needed to address comments raised by the IESG. And so the current discussion.

I had also raised the concern on needing more clarity on the definition of ephemeral during my AD review. The authors added some information. That clearly was not enough. As the term is used multiple times in the document and is the basis for another draft on requirements (draft-ietf-i2rs-ephemeral-state) which refers extensively to the architecture document, I agree the authors need to add more definition. Fred has a good suggestion – the term should be visible in a glossary section early in the document. It’s not currently included in Section 2’s Terminology – Sue, how about adding it to that section?

I think the authors know what is needed and thank everyone for the discussion and their time reviewing.

Thanks,

Deborah

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Friday, March 25, 2016 9:18 AM
To: 'Fred Baker (fred)' <[email-masked]>; 'Gunter Van De Velde' <[email-masked]>
Cc: [email-masked]; [email-masked]; 'Joel Halpern Direct' <[email-masked]>
Subject: Re: [i2rs] [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

Fred: 

Sue 

Be well,

G/

Hi all: 

<wg chair hat on> 

<wg chair hat off>  

Sue Hares

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Fri, 25 Mar 2016 13:50:11 +0000

Hi all,

Thanks,
Deborah

Fred:

Sue

From: Fred Baker (fred) [mailto:[email-masked]]
Sent: Thursday, March 24, 2016 2:59 PM
To: Gunter Van De Velde
Cc: Susan Hares; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Joel Halpern Direct
Subject: Re: [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

Be well,
G/

Hi all:

<wg chair hat on>

<wg chair hat off>

Sue Hares

---

From: Dean Bogdanovic <[email-masked]>
Date: Fri, 25 Mar 2016 15:39:20 -0400

Sue,

IMO, ephemeral has two meaning in i2rs architecture

1. it doesn’t survive reboot
2. you can’t roll back to a previous ephemeral state

Dean

> On Mar 25, 2016, at 10:01 AM, Susan Hares <[email-masked]> wrote:
> 
> Deborah: 
>  
> From: i2rs [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Susan Hares
> To: 'Fred Baker (fred)' <[email-masked] <mailto:[email-masked]>>; 'Gunter Van De Velde' <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; 'Joel Halpern Direct' <[email-masked] <mailto:[email-masked]>>
> From: Fred Baker (fred) [mailto:[email-masked] <mailto:[email-masked]>] 
> Cc: Susan Hares; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; Joel Halpern Direct
>> On Mar 24, 2016, at 11:07 AM, Gunter Van De Velde <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: "Susan Hares" <[email-masked]>
Date: Sat, 26 Mar 2016 08:08:04 -0400

Dean: 

This is an excellent point.  I will include this in the architecture document. 

Sue 

From: Dean Bogdanovic [mailto:[email-masked]] 
Sent: Friday, March 25, 2016 3:39 PM
To: Susan Hares
Cc: BRUNGARD, DEBORAH A; Fred Baker (fred); Gunter Van De Velde; [email-masked]; [email-masked]; Joel Halpern Direct
Subject: Re: [i2rs] [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

Sue,

Dean

Deborah: 

Sue 

Hi all,

Thanks,

Deborah

From: i2rs [ <mailto:[email-masked]> mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Friday, March 25, 2016 9:18 AM
To: 'Fred Baker (fred)' < <mailto:[email-masked]> [email-masked]>; 'Gunter Van De Velde' < <mailto:[email-masked]> [email-masked]>
Cc:  <mailto:[email-masked]> [email-masked];  <mailto:[email-masked]> [email-masked]; 'Joel Halpern Direct' < <mailto:[email-masked]> [email-masked]>
Subject: Re: [i2rs] [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

Fred: 

Sue 

From: Fred Baker (fred) [ <mailto:[email-masked]> mailto:[email-masked]] 
Sent: Thursday, March 24, 2016 2:59 PM
To: Gunter Van De Velde
Cc: Susan Hares;  <mailto:[email-masked]> [email-masked];  <mailto:[email-masked]> [email-masked]; Joel Halpern Direct
Subject: Re: [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

On Mar 24, 2016, at 11:07 AM, Gunter Van De Velde < <mailto:[email-masked]> [email-masked]> wrote:

Be well,

G/

On 24 Mar 2016, at 18:02, Susan Hares < <mailto:[email-masked]> [email-masked]> wrote:

Hi all: 

<wg chair hat on> 

<wg chair hat off>  

Sue Hares

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Sat, 26 Mar 2016 14:01:22 +0100

Mmmmm... in this discussion between Ed Snowden, Gleen Greenwald and
Norm Chomskey, Ed uses the word ephemral many times.

http://livestream.com/azpm/events/4958510

worth watching I think. Two hours though.

Bert

  On 25/03/16 20:39, Dean Bogdanovic wrote:
>> On Mar 25, 2016, at 10:01 AM, Susan Hares <[email-masked] <mailto:[email-masked]>> wrote:
>>
>> Deborah:
>> *From:*BRUNGARD, DEBORAH A [mailto:[email-masked]]
>> *Sent:*Friday, March 25, 2016 9:50 AM
>> *To:*Susan Hares; 'Fred Baker (fred)'; 'Gunter Van De Velde'
>> *Cc:[email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; 'Joel Halpern Direct'
>> *Subject:*RE: [i2rs] [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion
>> Hi all,
>> As Alia is a co-author, I was assigned as the responsible AD for this document. The document is not with the RFC Editor – it’s 
>> been approved by the IESG with a revised ID needed to address comments raised by the IESG. And so the current discussion.
>> I had also raised the concern on needing more clarity on the definition of ephemeral during my AD review. The authors added some 
>> information. That clearly was not enough. As the term is used multiple times in the document and is the basis for another draft 
>> on requirements (draft-ietf-i2rs-ephemeral-state) which refers extensively to the architecture document, I agree the authors need 
>> to add more definition. Fred has a good suggestion – the term should be visible in a glossary section early in the document. It’s 
>> not currently included in Section 2’s Terminology – Sue, how about adding it to that section?
>> *From:*i2rs [mailto:[email-masked]]*On Behalf Of*Susan Hares
>> *Sent:*Friday, March 25, 2016 9:18 AM
>> *To:*'Fred Baker (fred)' <[email-masked] <mailto:[email-masked]>>; 'Gunter Van De Velde' <[email-masked] 
>> <mailto:[email-masked]>>
>> *Cc:[email-masked] <mailto:[email-masked]>;[email-masked] <mailto:[email-masked]>; 'Joel Halpern Direct' 
>> <[email-masked] <mailto:[email-masked]>>
>> *Subject:*Re: [i2rs] [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion
>> Fred:
>> *From:*Fred Baker (fred) [mailto:[email-masked]]
>> *Sent:*Thursday, March 24, 2016 2:59 PM
>> *To:*Gunter Van De Velde
>> *Cc:*Susan Hares;[email-masked] <mailto:[email-masked]>;[email-masked] <mailto:[email-masked]>; Joel Halpern Direct
>> *Subject:*Re: [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion
>> My comment was a review comment, that the word was being used in a way that wasn't consistent with its dictionary definition 
>> (something with a short lifetime, quite irrespective of birth/death processes) or common usage (at least in my context). At this 
>> point, the draft has been sent to the RFC Editor, so to my mind this discussion is mostly moot. If in your other drafts you are 
>> pointing people to a glossary in the architecture document (which I imagine you already are) and the architecture document 
>>> I am ok nowadays with using the terminology “Ephemeral”, although for a non-natve speaker it is non-trivial exotic word, 
>>> particular if the intended usage doesn’t 100% reflect the Webster dictionary intended meaning.
>>> It is only about a year ago i started reading up on i2rs and discovered this particular terminology, and at the time a google 
>>> search on this terminology was not very conclusive and resulted to some confusion.
>>> Adding text to explain the context in which the term Ephemeral is useful/advised. fwiw now that i am used to seeing ‘Ephemeral' 
>>> as non-permanent config across reboot, i’m adapted its intended purpose…
>>>> This would mean every place that “ephemeral” is listed, the authors would replace with “non-persistent”.  In the first 
>>>> instance, we will indicate “non-persistent (across power on/off or reboot cycles).
>>>> <wg chair hat off>
>> [email-masked] <mailto:[email-masked]>

---

From: <[email-masked]>
Date: Wed, 30 Mar 2016 09:58:48 +0200

Hi,

I think it's a good idea to give a definition in the beginning of the document. The i2rs definition matches also my definition which we are using to describe the fact, that a customer specific service "configuration" on a service node does not survive a reboot.

Just my 2 cents

Nic

Von: i2rs [mailto:[email-masked]] Im Auftrag von Susan Hares
Gesendet: Donnerstag, 24. März 2016 18:02
An: [email-masked]
Cc: 'Joel Halpern Direct'; [email-masked]; 'Fred Baker (fred)'
Betreff: [i2rs] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

Hi all:

<wg chair hat on>

<wg chair hat off>

Sue Hares

---

From: Gert Grammel <[email-masked]>
Date: Wed, 30 Mar 2016 17:29:56 +0000

As a long time observer I also admit to be a bit at odds with respect to the term ephemeral. Defining ephemeral as the set of data that doesn't survive a reboot (i.e. Power cycle) looks a bit rough.

There seem to be 3 cases for state info after reboot:
1) the server is able to recover lost data by local means. This is usually referred to as persistent. (Agent not involved, data is the same as before reboot)
2) an i2rs agent needs to reprovision data after reboot (Agent involved, data is controlled by agent)
3) the server reconstructs data from external sources other than i2rs clients. (Agent not involved, data not controlled)

The term 'non-persistent' covers 2&3.
The current draft text talks in section 1.2 about "ephemeral static state" which I interpret as 2) only. However it is not so clear why it is considered static.
That would mean case 3) is ephemeral dynamic state, but that isn't defined yet and it could be as static as 2).

I admit having used the term "ephemeral" meaning case 2) only, which occasionally causes confusion.

So yes, I am in favor of adding a definition to the architecture. At this point I am undecided if we need new terminology or if a  narrower definition would be sufficient.

Gert

Sent from my Apple ][

On 30 Mar 2016, at 10:02, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

I think it’s a good idea to give a definition in the beginning of the document. The i2rs definition matches also my definition which we are using to describe the fact, that a customer specific service “configuration” on a service node does not survive a reboot.

Just my 2 cents

Nic

Von: i2rs [mailto:[email-masked]] Im Auftrag von Susan Hares
Gesendet: Donnerstag, 24. März 2016 18:02
An: [email-masked]<mailto:[email-masked]>
Cc: 'Joel Halpern Direct'; [email-masked]<mailto:[email-masked]>; 'Fred Baker (fred)'
Betreff: [i2rs] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

Hi all:

<wg chair hat on>

<wg chair hat off>

Sue Hares

_______________________________________________
i2rs mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2rs

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 31 Mar 2016 20:09:20 +0000

Is “ephemeral” same as “volatile” (whose opposite state is ”non-volatile”)?

Is “non- ephemeral”  same as “persistent”  or “ non-volatile”?
Linda

From: OPS-DIR [mailto:[email-masked]] On Behalf Of Dean Bogdanovic
Sent: Friday, March 25, 2016 2:39 PM
To: Susan Hares
Cc: Joel Halpern Direct; [email-masked]; BRUNGARD, DEBORAH A; Gunter Van De Velde; [email-masked]
Subject: Re: [OPS-DIR] [i2rs] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

Sue,

Dean

On Mar 25, 2016, at 10:01 AM, Susan Hares <[email-masked]<mailto:[email-masked]>> wrote:

Deborah:

Sue

Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; 'Joel Halpern Direct'

Hi all,

Thanks,
Deborah

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Friday, March 25, 2016 9:18 AM
To: 'Fred Baker (fred)' <[email-masked]<mailto:[email-masked]>>; 'Gunter Van De Velde' <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; 'Joel Halpern Direct' <[email-masked]<mailto:[email-masked]>>
Subject: Re: [i2rs] [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

Fred:

Sue

Be well,
G/

Hi all:

<wg chair hat on>

<wg chair hat off>

Sue Hares

---

From: "Steve Braaten (sbraaten)" <[email-masked]>
Date: Thu, 31 Mar 2016 20:16:32 +0000

Ephemeral = “short-lived” or “changes frequently”

There is nothing to stop an implementation from storing the latest “ephemeral” state in a “persistent” way such that it returns to that state (the last known state) if it restarts for any reason (planned or un-planned).

My humble opinion.

Steve

From: i2rs [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Thursday, March 31, 2016 1:09 PM
To: Dean Bogdanovic <[email-masked]>; Susan Hares <[email-masked]>
Cc: Joel Halpern Direct <[email-masked]>; [email-masked]; [email-masked]; BRUNGARD, DEBORAH A <[email-masked]>; Gunter Van De Velde <[email-masked]>
Subject: Re: [i2rs] [OPS-DIR] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

From: OPS-DIR [mailto:[email-masked]] On Behalf Of Dean Bogdanovic
Sent: Friday, March 25, 2016 2:39 PM
To: Susan Hares
Cc: Joel Halpern Direct; [email-masked]<mailto:[email-masked]>; BRUNGARD, DEBORAH A; Gunter Van De Velde; [email-masked]<mailto:[email-masked]>
Subject: Re: [OPS-DIR] [i2rs] Ephemeral - Should we use another word - (3/24 to 4/3) Call for opinion

Sue,

Dean

Deborah:

Sue

Hi all,

Thanks,
Deborah

Fred:

Sue

Be well,
G/

Hi all:

<wg chair hat on>

<wg chair hat off>

Sue Hares

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 31 Mar 2016 16:23:49 -0400

As used for I2RS, and as will be clarified in the definition Sue is 
adding, "ephemeral" refers to not being preserved across restarts.

Yes, the word has multiple meanings.  Almost all English words do.

Yours,
Joel

On 3/31/16 4:16 PM, Steve Braaten (sbraaten) wrote:
> There is nothing to stop an implementation from storing the latest
> “ephemeral” state in a “persistent” way such that it returns to that
> state (the last known state) if it restarts for any reason (planned or
> un-planned).
>
> My humble opinion.
>
> Steve
>
> *From:*i2rs [mailto:[email-masked]] *On Behalf Of *Linda Dunbar
> *Sent:* Thursday, March 31, 2016 1:09 PM
> *To:* Dean Bogdanovic <[email-masked]>; Susan Hares <[email-masked]>
> *Cc:* Joel Halpern Direct <[email-masked]>;
> [email-masked]; [email-masked]; BRUNGARD, DEBORAH A <[email-masked]>;
> Gunter Van De Velde <[email-masked]>
> *Subject:* Re: [i2rs] [OPS-DIR] Ephemeral - Should we use another word -
> (3/24 to 4/3) Call for opinion
>
> *From:*OPS-DIR [mailto:[email-masked]] *On Behalf Of *Dean
> Bogdanovic
> *Sent:* Friday, March 25, 2016 2:39 PM
> *To:* Susan Hares
> *Cc:* Joel Halpern Direct; [email-masked] <mailto:[email-masked]>;
> BRUNGARD, DEBORAH A; Gunter Van De Velde; [email-masked]
> <mailto:[email-masked]>
> *Subject:* Re: [OPS-DIR] [i2rs] Ephemeral - Should we use another word -
> (3/24 to 4/3) Call for opinion
>
> Sue,
>
>     *Cc:[email-masked] <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>; 'Joel Halpern Direct'
>     As Alia is a co-author, I was assigned as the responsible AD for
>     this document. The document is not with the RFC Editor – it’s been
>     approved by the IESG with a revised ID needed to address comments
>     raised by the IESG. And so the current discussion.
>
>     I had also raised the concern on needing more clarity on the
>     definition of ephemeral during my AD review. The authors added some
>     information. That clearly was not enough. As the term is used
>     multiple times in the document and is the basis for another draft on
>     requirements (draft-ietf-i2rs-ephemeral-state) which refers
>     extensively to the architecture document, I agree the authors need
>     to add more definition. Fred has a good suggestion – the term should
>     be visible in a glossary section early in the document. It’s not
>     currently included in Section 2’s Terminology – Sue, how about
>     adding it to that section?
>
>     *To:*'Fred Baker (fred)' <[email-masked] <mailto:[email-masked]>>;
>     'Gunter Van De Velde' <[email-masked]
>     *Cc:[email-masked] <mailto:[email-masked]>;[email-masked]
>     <mailto:[email-masked]>; 'Joel Halpern Direct'
>     *Cc:*Susan Hares;[email-masked]
>     <mailto:[email-masked]>;[email-masked] <mailto:[email-masked]>;
>     Joel Halpern Direct
>     My comment was a review comment, that the word was being used in a
>     way that wasn't consistent with its dictionary definition (something
>     with a short lifetime, quite irrespective of birth/death processes)
>     or common usage (at least in my context). At this point, the draft
>     has been sent to the RFC Editor, so to my mind this discussion is
>     mostly moot. If in your other drafts you are pointing people to a
>     glossary in the architecture document (which I imagine you already
>     are) and the architecture document defines the term as you are using
>     it, you have probably done enough.
>
>         <[email-masked]
>         <mailto:[email-masked]>> wrote:
>
>         I am ok nowadays with using the terminology “Ephemeral”,
>         although for a non-natve speaker it is non-trivial exotic word,
>         It is only about a year ago i started reading up on i2rs and
>         discovered this particular terminology, and at the time a google
>         Adding text to explain the context in which the term Ephemeral
>         is useful/advised. fwiw now that i am used to seeing ‘Ephemeral'
>             The draft-ietf-i2rs-architecture document has been approved
>             as an RFC.  In the review, the OPS-DIR review indicated that
>             “ephemeral” meant more than “does not survive a reboot”.
>             They have asked the I2RS working group if replacing
>             “ephemeral” with non-persistent (across power on/off or
>             “non-persistent (across power on/off or reboot cycles) ? We
>             will have a 1 week call on
>
>             This would mean every place that “ephemeral” is listed, the
>             authors would replace with “non-persistent”.  In the first
>             As the author, I think we are better to define ephemeral at
>             the beginning as “non-persistent (across power on /off or
>             reboot).  Changing the definition at this point, I suspect
>             will simply confuse people.
>
>             Sue Hares
>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 31 Mar 2016 14:17:45 -0700

On Thu, Mar 31, 2016 at 1:16 PM, Steve Braaten (sbraaten) <
[email-masked]> wrote:

> “ephemeral” state in a “persistent” way such that it returns to that state
> (the last known state) if it restarts for any reason (planned or
> un-planned).
>
>
>
> My humble opinion.
>

There is little (or no) difference between a NETCONF server that
boots and gets its startup config from a configuration server,
and an I2RS agent that boots and gets its ephemeral state from an I2RS
client.

In NETCONF, NV-storage is mostly an implementation detail.
In I2RS, the architecture says its data MUST NOT persist across a reboot.
(No explanation why interoperability is harmed if an agent persisted its
I2RS data).

Andy

>
>
> *From:* i2rs [mailto:[email-masked]] *On Behalf Of *Linda Dunbar
> *Cc:* Joel Halpern Direct <[email-masked]>; [email-masked];
> [email-masked]; BRUNGARD, DEBORAH A <[email-masked]>; Gunter Van De Velde <
> [email-masked]>
> *From:* OPS-DIR [mailto:[email-masked]
> <[email-masked]>] *On Behalf Of *Dean Bogdanovic
> *Cc:* Joel Halpern Direct; [email-masked]; BRUNGARD, DEBORAH A; Gunter
> Van De Velde; [email-masked]
> *From:* BRUNGARD, DEBORAH A [mailto:[email-masked] <[email-masked]>]
> *Sent:* Friday, March 25, 2016 9:50 AM
> *To:* Susan Hares; 'Fred Baker (fred)'; 'Gunter Van De Velde'
> *Cc:* [email-masked]; [email-masked]; 'Joel Halpern Direct'
> *Subject:* RE: [i2rs] [OPS-DIR] Ephemeral - Should we use another word -
> As Alia is a co-author, I was assigned as the responsible AD for this
> document. The document is not with the RFC Editor – it’s been approved by
> the IESG with a revised ID needed to address comments raised by the IESG.
> And so the current discussion.
>
>
>
> I had also raised the concern on needing more clarity on the definition of
> ephemeral during my AD review. The authors added some information. That
> clearly was not enough. As the term is used multiple times in the document
> and is the basis for another draft on requirements
> (draft-ietf-i2rs-ephemeral-state) which refers extensively to the
> architecture document, I agree the authors need to add more definition.
> Fred has a good suggestion – the term should be visible in a glossary
> section early in the document. It’s not currently included in Section 2’s
> Terminology – Sue, how about adding it to that section?
>
>
>
> *From:* i2rs [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Susan Hares
> *Sent:* Friday, March 25, 2016 9:18 AM
> *To:* 'Fred Baker (fred)' <[email-masked]>; 'Gunter Van De Velde' <
> [email-masked]>
> *Cc:* [email-masked]; [email-masked]; 'Joel Halpern Direct' <
> [email-masked]>
> *From:* Fred Baker (fred) [mailto:[email-masked] <[email-masked]>]
> *Sent:* Thursday, March 24, 2016 2:59 PM
> *To:* Gunter Van De Velde
> *Cc:* Susan Hares; [email-masked]; [email-masked]; Joel Halpern Direct

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 31 Mar 2016 17:24:59 -0400

The harm from persisting the data is in terms of robustness, not in 
terms of interoperability.  With multiple interacting clients, and 
allowance for lowered error checking, things can go wrong.

The fallback in the case of I2RS is that reboot will drop all the state, 
so no persistent harm can be caused.

Yours,
Joel

On 3/31/16 5:17 PM, Andy Bierman wrote:
>
>
> On Thu, Mar 31, 2016 at 1:16 PM, Steve Braaten (sbraaten)
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Ephemeral = “short-lived” or “changes frequently”____
>
>     __ __
>
>     state (the last known state) if it restarts for any reason (planned
>     or un-planned).____
>
>     __ __
>
>     My humble opinion.
>
>
>     ____
>     __ __
>     Steve____
>     __
>     __
>     __ __
>     *From:*i2rs [mailto:[email-masked]
>     <mailto:[email-masked]>] *On Behalf Of *Linda Dunbar
>     *To:* Dean Bogdanovic <[email-masked]
>     <mailto:[email-masked]>>; Susan Hares <[email-masked]
>     <mailto:[email-masked]>>
>     *Cc:* Joel Halpern Direct <[email-masked]
>     <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>;
>     BRUNGARD, DEBORAH A <[email-masked] <mailto:[email-masked]>>; Gunter
>     Van De Velde <[email-masked]
>     *Subject:* Re: [i2rs] [OPS-DIR] Ephemeral - Should we use another
>     word - (3/24 to 4/3) Call for opinion____
>
>     __ __
>
>     Is “ephemeral” same as “volatile” (whose opposite state is
>     ”non-volatile”)? ____
>
>     __ __
>
>     Is “non- ephemeral”  same as “persistent”  or “ non-volatile”? ____
>
>     Linda____
>
>     __ __
>
>     *Cc:* Joel Halpern Direct; [email-masked]
>     <mailto:[email-masked]>; BRUNGARD, DEBORAH A; Gunter Van De Velde;
>     *Subject:* Re: [OPS-DIR] [i2rs] Ephemeral - Should we use another
>     word - (3/24 to 4/3) Call for opinion____
>
>     __ __
>
>     Sue,____
>
>     __ __
>
>     IMO, ephemeral has two meaning in i2rs architecture____
>
>     __ __
>
>     1. it doesn’t survive reboot____
>
>     2. you can’t roll back to a previous ephemeral state____
>
>     __ __
>
>     Dean____
>
>     __ __
>
>         On Mar 25, 2016, at 10:01 AM, Susan Hares <[email-masked]
>         <mailto:[email-masked]>> wrote:____
>
>         __ __
>
>         Deborah:____
>
>         ____
>
>         Section 2 is exactly the place I would put the definition of
>         ephemeral.____
>
>         ____
>
>         Sue____
>
>         ____
>
>         *Subject:*RE: [i2rs] [OPS-DIR] Ephemeral - Should we use another
>         word - (3/24 to 4/3) Call for opinion____
>
>         ____
>
>         Hi all,____
>
>         ____
>
>         this document. The document is not with the RFC Editor – it’s
>         been approved by the IESG with a revised ID needed to address
>         comments raised by the IESG. And so the current discussion.____
>
>         ____
>
>         definition of ephemeral during my AD review. The authors added
>         some information. That clearly was not enough. As the term is
>         used multiple times in the document and is the basis for another
>         draft on requirements (draft-ietf-i2rs-ephemeral-state) which
>         refers extensively to the architecture document, I agree the
>         authors need to add more definition. Fred has a good suggestion
>         – the term should be visible in a glossary section early in the
>         document. It’s not currently included in Section 2’s Terminology
>         – Sue, how about adding it to that section?____
>
>         ____
>
>         I think the authors know what is needed and thank everyone for
>         the discussion and their time reviewing.____
>
>         ____
>
>         Thanks,____
>
>         Deborah____
>
>         ____
>
>         ____
>
>         ____
>
>         *To:*'Fred Baker (fred)' <[email-masked]
>         <mailto:[email-masked]>>; 'Gunter Van De Velde'
>         *Subject:*Re: [i2rs] [OPS-DIR] Ephemeral - Should we use another
>         word - (3/24 to 4/3) Call for opinion____
>
>         ____
>
>         Fred:____
>
>         ____
>
>         Thank you for the review, and your comments here.  I wished I’d
>         asked about the word ephemeral earlier.____
>
>         ____
>
>         Sue____
>
>         ____
>
>         <mailto:[email-masked]>;[email-masked]
>         <mailto:[email-masked]>; Joel Halpern Direct
>         *Subject:*Re: [OPS-DIR] Ephemeral - Should we use another word -
>         (3/24 to 4/3) Call for opinion____
>
>         ____
>
>         My comment was a review comment, that the word was being used in
>         a way that wasn't consistent with its dictionary definition
>         (something with a short lifetime, quite irrespective of
>         birth/death processes) or common usage (at least in my context).
>         At this point, the draft has been sent to the RFC Editor, so to
>         my mind this discussion is mostly moot. If in your other drafts
>         you are pointing people to a glossary in the architecture
>         document (which I imagine you already are) and the architecture
>         document defines the term as you are using it, you have probably
>         done enough.____
>
>         ____
>
>             <mailto:[email-masked]>> wrote:____
>
>             ____
>
>             although for a non-natve speaker it is non-trivial exotic
>             word, particular if the intended usage doesn’t 100% reflect
>             the Webster dictionary intended meaning.____
>
>             ____
>
>             discovered this particular terminology, and at the time a
>             google search on this terminology was not very conclusive
>             and resulted to some confusion. ____
>
>             I understand very well the confusion at play here from
>             non-native english speaker perspective.____
>
>             ____
>
>             Adding text to explain the context in which the term
>             Ephemeral is useful/advised. fwiw now that i am used to
>             seeing ‘Ephemeral' as non-permanent config across reboot,
>             i’m adapted its intended purpose… ____
>
>             ____
>
>             Is the goal to explain the intended meaning in each
>             draft/rfc mentioning it?____
>
>             ____
>
>             Be well,____
>
>             G/____
>
>             ____
>
>                 On 24 Mar 2016, at 18:02, Susan Hares <[email-masked]
>                 <mailto:[email-masked]>> wrote:____
>
>                 ____
>
>                 Hi all:____
>
>                 ____
>
>                 <wg chair hat on>____
>
>                 The draft-ietf-i2rs-architecture document has been
>                 approved as an RFC.  In the review, the OPS-DIR review
>                 indicated that “ephemeral” meant more than “does not
>                 survive a reboot”. They have asked the I2RS working
>                 group if replacing “ephemeral” with non-persistent
>                 (across power on/off or reboot cycles) would be a better
>                 choice. ____
>
>                 ____
>
>                 What do you think – leave at it at “ephemeral” or change
>                 to “non-persistent (across power on/off or reboot
>                 cycles) ? We will have a 1 week call on____
>
>                 ____
>
>                 This would mean every place that “ephemeral” is listed,
>                 the authors would replace with “non-persistent”.  In the
>                 first instance, we will indicate “non-persistent (across
>                 power on/off or reboot cycles).____
>
>                 ____
>
>                 <wg chair hat off> ____
>
>                 ____
>
>                 As the author, I think we are better to define ephemeral
>                 at the beginning as “non-persistent (across power on
>                 /off or reboot).  Changing the definition at this point,
>                 I suspect will simply confuse people.____
>
>                 ____
>
>                 Sue Hares____
>
>                 ____
>
>                 https://www.ietf.org/mailman/listinfo/ops-dir____
>
>             ____
>
>             https://www.ietf.org/mailman/listinfo/ops-dir____
>
>         ____
>
>         https://www.ietf.org/mailman/listinfo/i2rs____
>
>     __ __
>
>