Subject: Re: [i2rs] I2RS Hackathon

From: Edwin Cordeiro <[email-masked]>
Date: Mon, 11 Apr 2016 10:33:42 +0200

Hi Susan,

I saw your presentation of the Hackathon and first sorry the VM wasn't
smaller, but those were the suggestions from ODL for running it inside a VM.

We are happy that you were able to find a workaround and we would like to
test and expand the result of the Hackathon, could you please share the
results?

Thank you

Edwin Cordeiro

On Thu, Mar 31, 2016 at 9:36 AM, Edwin Cordeiro <[email-masked]> wrote:

> Hi Susan,
>
> The VM is a Ubuntu so it is possible to run this emulated network in a
> native Ubuntu laptop. The only special requirement is for MiniNExT (
> https://github.com/USC-NSL/miniNExT), that does not currently support the
> latest version of Mininet, you must use Mininet version 2.1.0. I will add
> to the webpage a file with the config files used for Mininet and MiniNExT.
>
> Another option is to run the VM and configure the Virtualbox or VMware
> Player to make the network interface of the VM to be in bridge mode or in
> internal network with the host machine, that way you may use any program
> installed in the host machine to interact with the VM.
>
> BR
>
> Edwin Cordeiro
>
> On Thu, Mar 31, 2016 at 2:15 AM, Susan Hares <[email-masked]> wrote:
>
>> Edwin:
>>
>>
>>
>> Thank you for the client.  Do you think it would work on unbuntu?  I’ve
>> got an ODL environment in oracle Box and running native on the unbuntu
>> laptops.
>>
>>
>>
>> Sue
>>
>>
>>
>> *From:* i2rs [mailto:[email-masked]] *On Behalf Of *Edwin Cordeiro
>> *Sent:* Wednesday, March 30, 2016 11:33 AM
>> *To:* [email-masked]
>> *Subject:* [i2rs] I2RS Hackathon
>>
>>
>>
>> Hi all,
>>
>>
>>
>> As we are trying to make an I2RS implementation here at TU Munich, we
>> created a VM that is running Mininet (to emulate a network), MininExt (to
>> implement virtual routers) and OpenDayLight (that we trying to use as I2RS
>> agent), the I2RS client we are trying to make using Zebra. The I2RS agent
>> is the NETCONF + YANG modules of ODL, but it needs the YANG models to be
>> written. The I2RS client is not present as it is not yet ready for sharing.
>>
>>
>>
>> On the previous Hackathon, one of the difficulties for the I2RS was the
>> lack of an environment where it could be developed, so we decided to share
>> this VM and a basic tutorial to get this network running in the hope it
>> could be useful for the approaching Hackathon in Buenos Aires.
>>
>>
>>
>> The tutorial and VM are available at:
>>
>> http://www.net.in.tum.de/pub/i2rs/
>>
>> http://www.net.in.tum.de/pub/i2rs/I2RS-Dev-VM.ova -
>> md5: af70741cd12b39a9644b0881df516a55
>>
>>
>>
>> Unfortunately we will not be able to attend this next meeting in person,
>> but if you have any question, let us know. We hope the VM to be useful.
>>
>>
>>
>> Best Regards,
>>
>>
>>
>> Edwin Cordeiro
>>
>
>

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 11 Apr 2016 07:43:36 -0400

Edwin: 

Thank you for your environment.  Don Fedyk created a VM in the virtual box.  

•       Dev & execution environment: Linux (Ubuntu  14.3 native or in Virtual Box)

•       mininet and mininext (simulated network of routers)

•       Quagga 1.0.20160315 (including Zebra for route table access)

The following code needs will need to be downloaded to the following VM:   

•       Cisco/Tail-f confd 6.1

•       Yuma’s yangcli-pro 

•       ietf-i2rs-rib YANG model from draft-ietf-i2rs-rib-data-model-05.txt

•       I2RS FB-FIB 

I will post this in the I2RS github repository. 

Sue 

From: [email-masked] [mailto:[email-masked]] On Behalf Of Edwin Cordeiro
Sent: Monday, April 11, 2016 4:34 AM
To: Susan Hares
Cc: [email-masked]
Subject: Re: [i2rs] I2RS Hackathon

Hi Susan,

I saw your presentation of the Hackathon and first sorry the VM wasn't smaller, but those were the suggestions from ODL for running it inside a VM.

We are happy that you were able to find a workaround and we would like to test and expand the result of the Hackathon, could you please share the results?

Thank you

Edwin Cordeiro

Hi Susan,

The VM is a Ubuntu so it is possible to run this emulated network in a native Ubuntu laptop. The only special requirement is for MiniNExT (https://github.com/USC-NSL/miniNExT), that does not currently support the latest version of Mininet, you must use Mininet version 2.1.0. I will add to the webpage a file with the config files used for Mininet and MiniNExT.

Another option is to run the VM and configure the Virtualbox or VMware Player to make the network interface of the VM to be in bridge mode or in internal network with the host machine, that way you may use any program installed in the host machine to interact with the VM.

BR

Edwin Cordeiro

Edwin:

Thank you for the client.  Do you think it would work on unbuntu?  I’ve got an ODL environment in oracle Box and running native on the unbuntu laptops. 

Sue 

From: i2rs [mailto:[email-masked]] On Behalf Of Edwin Cordeiro
Sent: Wednesday, March 30, 2016 11:33 AM
To: [email-masked]
Subject: [i2rs] I2RS Hackathon

Hi all,

As we are trying to make an I2RS implementation here at TU Munich, we created a VM that is running Mininet (to emulate a network), MininExt (to implement virtual routers) and OpenDayLight (that we trying to use as I2RS agent), the I2RS client we are trying to make using Zebra. The I2RS agent is the NETCONF + YANG modules of ODL, but it needs the YANG models to be written. The I2RS client is not present as it is not yet ready for sharing.

On the previous Hackathon, one of the difficulties for the I2RS was the lack of an environment where it could be developed, so we decided to share this VM and a basic tutorial to get this network running in the hope it could be useful for the approaching Hackathon in Buenos Aires.

http://www.net.in.tum.de/pub/i2rs/I2RS-Dev-VM.ova - md5: af70741cd12b39a9644b0881df516a55

Unfortunately we will not be able to attend this next meeting in person, but if you have any question, let us know. We hope the VM to be useful.

Best Regards,

Edwin Cordeiro

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 11 Apr 2016 07:51:52 -0400

Edwin: 

Sorry, my first message did not address all your questions.  What would be useful for you to do is: 

1)      See if you can get an ODL based VM which is the same size as Don and Mamadou’s VM, 

2)      See if you can run Don and Mamadou’s VM in your environment. 

3)      Test the I2RS RIB with the Quagga code when I post it to github (~2 weeks) 

4)      Test the I2RS Filter-Based with the Quagga code when I post it to gitub (~4 weeks) 

I will try to get the ODL VM posted to github today.   

Sue 

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Monday, April 11, 2016 7:44 AM
To: 'Edwin Cordeiro'
Cc: [email-masked]
Subject: Re: [i2rs] I2RS Hackathon

Edwin: 

Thank you for your environment.  Don Fedyk and Mamadou Tahirou created a VM in the virtual box.  

•       Cisco/Tail-f confd 6.1

•       Yuma’s yangcli-pro 

•       I2RS FB-FIB Yang model  à link to IP-Table in Ubuntu  

This part of the code was not completed – so I will try to complete this 

Sue 

Hi Susan,

Thank you

Edwin Cordeiro

Hi Susan,

BR

Edwin Cordeiro

Edwin:

Sue 

Hi all,

Best Regards,

Edwin Cordeiro

---

From: Edwin Cordeiro <[email-masked]>
Date: Mon, 18 Apr 2016 11:42:48 +0200

Hi Sue,

In line comments.

Thanks,

Edwin Cordeiro

> 1)      See if you can get an ODL based VM which is the same size as Don
​Yes, it is possible to make a small VM with ODL if the graphical interface
is not needed.​

> 2)      See if you can run Don and Mamadou’s VM in your environment.
​If we can get a copy of this VM, we can surely test it.​

> 4)      Test the I2RS Filter-Based with the Quagga code when I post it to
​We will wait for it.​

> I will try to get the ODL VM posted to github today.
​I looked at the Hackathon (https://github.com/IETF-Hackathon/ietf95) and
the I2RS-WG (https://github.com/i2rs-wg) Github, but found no VM there.​
Are you using another repository?

>
> Sue
>
>
>
> *From:* i2rs [mailto:[email-masked]] *On Behalf Of *Susan Hares
> *Sent:* Monday, April 11, 2016 7:44 AM
> *To:* 'Edwin Cordeiro'
> *Cc:* [email-masked]
> *Subject:* Re: [i2rs] I2RS Hackathon
>
>
>
> Edwin:
>
>
>
> *From:* [email-masked] [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Edwin Cordeiro
> *Sent:* Monday, April 11, 2016 4:34 AM
> *To:* Susan Hares
> *Cc:* [email-masked]
> *Subject:* Re: [i2rs] I2RS Hackathon
>
>
>
> Hi Susan,
>
>
>

---

From: Giles Heron <[email-masked]>
Date: Mon, 18 Apr 2016 14:41:20 +0100

Hi Edwin,

> On 18 Apr 2016, at 10:42, Edwin Cordeiro <[email-masked]> wrote:
> 
> Hi Sue,
> 
> In line comments.
> 
> Thanks,
> 
> Edwin Cordeiro
> 
> On Mon, Apr 11, 2016 at 1:51 PM, Susan Hares <[email-masked] <mailto:[email-masked]>> wrote:
> Edwin:
> 
>  
> 
> ​Yes, it is possible to make a small VM with ODL if the graphical interface is not needed.​ 

yup - I have VMs that are about 1.5GB with ODL plus the stuff needed to run it (not sure if that’s “small”?).  You could probably build a much smaller VM if you too the time to strip out all the libraries you don't need.   I have a vagrant setup for it too (so only a couple of KB but downloads a lot of stuff when you run it).  Take a look in:

https://github.com/CiscoDevNet/opendaylight-setup <https://github.com/CiscoDevNet/opendaylight-setup>

Giles
> ​I looked at the Hackathon (https://github.com/IETF-Hackathon/ietf95 <https://github.com/IETF-Hackathon/ietf95>) and the I2RS-WG (https://github.com/i2rs-wg <https://github.com/i2rs-wg>) Github, but found no VM there.​ Are you using another repository?
> 
> 
>  
> 
> Sue
> 
>  
> 
> From: i2rs [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Susan Hares
> Cc: [email-masked] <mailto:[email-masked]>
> From: [email-masked] <mailto:[email-masked]> [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Edwin Cordeiro
> Cc: [email-masked] <mailto:[email-masked]>
> On Thu, Mar 31, 2016 at 9:36 AM, Edwin Cordeiro <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Hi Susan,
> 
>  
> 
> The VM is a Ubuntu so it is possible to run this emulated network in a native Ubuntu laptop. The only special requirement is for MiniNExT (https://github.com/USC-NSL/miniNExT <https://github.com/USC-NSL/miniNExT>), that does not currently support the latest version of Mininet, you must use Mininet version 2.1.0. I will add to the webpage a file with the config files used for Mininet and MiniNExT.
> 
>  
> 
> On Thu, Mar 31, 2016 at 2:15 AM, Susan Hares <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Edwin:
> 
>  
> 
> From: i2rs [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Edwin Cordeiro
> To: [email-masked] <mailto:[email-masked]>
> http://www.net.in.tum.de/pub/i2rs/ <http://www.net.in.tum.de/pub/i2rs/>
> http://www.net.in.tum.de/pub/i2rs/I2RS-Dev-VM.ova <http://www.net.in.tum.de/pub/i2rs/I2RS-Dev-VM.ova> - md5: af70741cd12b39a9644b0881df516a55
> 
>  
> 
> _______________________________________________
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2rs

---

From: "Jan Medved (jmedved)" <[email-masked]>
Date: Mon, 18 Apr 2016 14:01:04 +0000

Edwin, Giles, Sue:

As part of FD.io we are creating a stripped-down distribution of ODL that contains only Netconf, BGP and components required to support these two. This will be the management/control agent for VPP (project name Honeycomb). This would IMO be the best fit for the Hackathon platform. Please contact Maros Marsalek (the PTL for Honeycomb, copied) for more details.

Thanks,
Jan

From: i2rs <[email-masked]<mailto:[email-masked]>> on behalf of Giles Heron <[email-masked]<mailto:[email-masked]>>
Date: Monday, April 18, 2016 at 6:41 AM
To: Edwin Cordeiro <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Susan Hares <[email-masked]<mailto:[email-masked]>>
Subject: Re: [i2rs] I2RS Hackathon

Hi Edwin,

On 18 Apr 2016, at 10:42, Edwin Cordeiro <[email-masked]<mailto:[email-masked]>> wrote:

Hi Sue,

In line comments.

Thanks,

Edwin Cordeiro

On Mon, Apr 11, 2016 at 1:51 PM, Susan Hares <[email-masked]<mailto:[email-masked]>> wrote:
Edwin:

https://github.com/CiscoDevNet/opendaylight-setup

Giles

​We will wait for it.​

I will try to get the ODL VM posted to github today.
​I looked at the Hackathon (https://github.com/IETF-Hackathon/ietf95) and the I2RS-WG (https://github.com/i2rs-wg) Github, but found no VM there.​ Are you using another repository?

Sue

From: i2rs [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Susan Hares
Sent: Monday, April 11, 2016 7:44 AM
To: 'Edwin Cordeiro'
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [i2rs] I2RS Hackathon

Edwin:

The following code needs will need to be downloaded to the following VM:
•       Cisco/Tail-f confd 6.1
•       Yuma’s yangcli-pro
•       ietf-i2rs-rib YANG model from draft-ietf-i2rs-rib-data-model-05.txt
•       I2RS FB-FIB Yang model  --> link to IP-Table in Ubuntu

Sue

From:[email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Edwin Cordeiro
Sent: Monday, April 11, 2016 4:34 AM
To: Susan Hares
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [i2rs] I2RS Hackathon

Hi Susan,

Thank you

Edwin Cordeiro

On Thu, Mar 31, 2016 at 9:36 AM, Edwin Cordeiro <[email-masked]<mailto:[email-masked]>> wrote:
Hi Susan,

BR

Edwin Cordeiro

On Thu, Mar 31, 2016 at 2:15 AM, Susan Hares <[email-masked]<mailto:[email-masked]>> wrote:
Edwin:

Sue

From: i2rs [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Edwin Cordeiro
Sent: Wednesday, March 30, 2016 11:33 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [i2rs] I2RS Hackathon

Hi all,

Best Regards,

Edwin Cordeiro

_______________________________________________
i2rs mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2rs

---

From: "Fedyk, Don" <[email-masked]>
Date: Mon, 18 Apr 2016 14:24:48 +0000

This recommendation and even Giles recommendation sounds promising, we can always add to a VM what we need for the agent and client code.   Images in the 1-2 Gig range should be workable in my experience.  A vagrant script is a good way to maintain a reproducible environment getting rid of many mundane tasks.

Cheers
Don

From: i2rs [mailto:[email-masked]] On Behalf Of Jan Medved (jmedved)
Sent: Monday, April 18, 2016 10:01 AM
To: Giles Heron <[email-masked]>; Edwin Cordeiro <[email-masked]>; Maros Marsalek -X (mmarsale - PANTHEON TECHNOLOGIES at Cisco) <[email-masked]>
Cc: [email-masked]; Susan Hares <[email-masked]>
Subject: Re: [i2rs] I2RS Hackathon

Edwin, Giles, Sue:

Thanks,
Jan

Hi Edwin,

Hi Sue,

In line comments.

Thanks,

Edwin Cordeiro

Giles

Sue

Edwin:

Sue

Hi Susan,

Thank you

Edwin Cordeiro

BR

Edwin Cordeiro

Sue

Hi all,

Best Regards,

Edwin Cordeiro

---

From: "Maros Marsalek -X (mmarsale - PANTHEON TECHNOLOGIES at Cisco)" <[email-masked]>
Date: Mon, 18 Apr 2016 14:40:39 +0000

Hi everyone,

Jan is right, we are trying to produce a minimal ODL distribution for the Honeycomb project. However we have quite a bit of work ahead of us, before the minimal distribution will be available: https://jira.fd.io/browse/HONEYCOMB-18

And we do not have an exact date for when this will be available. It might take a couple months before we start and finish with this effort.

Maros

From: Jan Medved (jmedved)
Sent: Monday, April 18, 2016 4:01 PM
To: Giles Heron <[email-masked]>; Edwin Cordeiro <[email-masked]>; Maros Marsalek -X (mmarsale - PANTHEON TECHNOLOGIES at Cisco) <[email-masked]>
Cc: [email-masked]; Susan Hares <[email-masked]>
Subject: Re: [i2rs] I2RS Hackathon

Edwin, Giles, Sue:

Thanks,
Jan

Hi Edwin,

Hi Sue,

In line comments.

Thanks,

Edwin Cordeiro

Giles

Sue

Edwin:

Sue

Hi Susan,

Thank you

Edwin Cordeiro

BR

Edwin Cordeiro

Sue

Hi all,

Best Regards,

Edwin Cordeiro

---

From: "Jan Medved (jmedved)" <[email-masked]>
Date: Mon, 18 Apr 2016 15:44:16 +0000

I was thinking the target would be the Berlin IETF in July.

From: "Maros Marsalek -X (mmarsale - PANTHEON TECHNOLOGIES at Cisco)" <[email-masked]<mailto:[email-masked]>>
Date: Monday, April 18, 2016 at 7:40 AM
To: Jan Medved <[email-masked]<mailto:[email-masked]>>, Giles Heron <[email-masked]<mailto:[email-masked]>>, Edwin Cordeiro <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Susan Hares <[email-masked]<mailto:[email-masked]>>
Subject: RE: [i2rs] I2RS Hackathon

Hi everyone,

Maros

From: Jan Medved (jmedved)
Sent: Monday, April 18, 2016 4:01 PM
To: Giles Heron <[email-masked]<mailto:[email-masked]>>; Edwin Cordeiro <[email-masked]<mailto:[email-masked]>>; Maros Marsalek -X (mmarsale - PANTHEON TECHNOLOGIES at Cisco) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Susan Hares <[email-masked]<mailto:[email-masked]>>
Subject: Re: [i2rs] I2RS Hackathon

Edwin, Giles, Sue:

Thanks,
Jan

Hi Edwin,

Hi Sue,

In line comments.

Thanks,

Edwin Cordeiro

Giles

Sue

Edwin:

Sue

Hi Susan,

Thank you

Edwin Cordeiro

BR

Edwin Cordeiro

Sue

Hi all,

Best Regards,

Edwin Cordeiro

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 18 Apr 2016 14:31:16 -0400

Jan and Maros: 

This would be wonderful to have the minimal distribution at Berlin so we could try it out. 

Sue 

From: Jan Medved (jmedved) [mailto:[email-masked]] 
Sent: Monday, April 18, 2016 11:44 AM
To: Maros Marsalek -X (mmarsale - PANTHEON TECHNOLOGIES at Cisco); Giles Heron; Edwin Cordeiro
Cc: [email-masked]; Susan Hares
Subject: Re: [i2rs] I2RS Hackathon

From: "Maros Marsalek -X (mmarsale - PANTHEON TECHNOLOGIES at Cisco)" <[email-masked]>
Date: Monday, April 18, 2016 at 7:40 AM
To: Jan Medved <[email-masked]>, Giles Heron <[email-masked]>, Edwin Cordeiro <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Susan Hares <[email-masked]>
Subject: RE: [i2rs] I2RS Hackathon

Hi everyone,

Maros

Edwin, Giles, Sue:

 

Thanks,

Jan

From: i2rs < <mailto:[email-masked]> [email-masked]> on behalf of Giles Heron < <mailto:[email-masked]> [email-masked]>
Date: Monday, April 18, 2016 at 6:41 AM
To: Edwin Cordeiro < <mailto:[email-masked]> [email-masked]>
Cc: " <mailto:[email-masked]> [email-masked]" < <mailto:[email-masked]> [email-masked]>, Susan Hares < <mailto:[email-masked]> [email-masked]>
Subject: Re: [i2rs] I2RS Hackathon

Hi Edwin, 

On 18 Apr 2016, at 10:42, Edwin Cordeiro < <mailto:[email-masked]> [email-masked]> wrote:

Hi Sue,

In line comments.

Thanks,

Edwin Cordeiro

On Mon, Apr 11, 2016 at 1:51 PM, Susan Hares < <mailto:[email-masked]> [email-masked]> wrote:

Edwin: 

 

 <https://github.com/CiscoDevNet/opendaylight-setup> https://github.com/CiscoDevNet/opendaylight-setup

Giles

​We will wait for it.​

​I looked at the Hackathon ( <https://github.com/IETF-Hackathon/ietf95> https://github.com/IETF-Hackathon/ietf95) and the I2RS-WG ( <https://github.com/i2rs-wg> https://github.com/i2rs-wg) Github, but found no VM there.​ Are you using another repository?

Sue 

From: i2rs [mailto: <mailto:[email-masked]> [email-masked]] On Behalf Of Susan Hares
Sent: Monday, April 11, 2016 7:44 AM
To: 'Edwin Cordeiro'
Cc:  <mailto:[email-masked]> [email-masked]
Subject: Re: [i2rs] I2RS Hackathon

Edwin: 

•       Cisco/Tail-f confd 6.1

•       Yuma’s yangcli-pro 

Sue 

From: <mailto:[email-masked]> [email-masked] [ <mailto:[email-masked]> mailto:[email-masked]] On Behalf Of Edwin Cordeiro
Sent: Monday, April 11, 2016 4:34 AM
To: Susan Hares
Cc:  <mailto:[email-masked]> [email-masked]
Subject: Re: [i2rs] I2RS Hackathon

Hi Susan,

Thank you

Edwin Cordeiro

Hi Susan,

The VM is a Ubuntu so it is possible to run this emulated network in a native Ubuntu laptop. The only special requirement is for MiniNExT ( <https://github.com/USC-NSL/miniNExT> https://github.com/USC-NSL/miniNExT), that does not currently support the latest version of Mininet, you must use Mininet version 2.1.0. I will add to the webpage a file with the config files used for Mininet and MiniNExT.

BR

Edwin Cordeiro

Edwin:

Sue 

From: i2rs [mailto: <mailto:[email-masked]> [email-masked]] On Behalf Of Edwin Cordeiro
Sent: Wednesday, March 30, 2016 11:33 AM
To:  <mailto:[email-masked]> [email-masked]
Subject: [i2rs] I2RS Hackathon

Hi all,

 <http://www.net.in.tum.de/pub/i2rs/> http://www.net.in.tum.de/pub/i2rs/

 <http://www.net.in.tum.de/pub/i2rs/I2RS-Dev-VM.ova> http://www.net.in.tum.de/pub/i2rs/I2RS-Dev-VM.ova - md5: af70741cd12b39a9644b0881df516a55

Best Regards,

Edwin Cordeiro

_______________________________________________
i2rs mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/i2rs> https://www.ietf.org/mailman/listinfo/i2rs

---

From: "Maros Marsalek -X (mmarsale - PANTHEON TECHNOLOGIES at Cisco)" <[email-masked]>
Date: Tue, 19 Apr 2016 14:42:43 +0000

Hi Jan,

We would definitely like to have IETF in July as target for this task. However we are still formalizing the requirements for new features (e.g. from FDS project https://jira.fd.io/browse/HONEYCOMB-30) and finishing other refactoring tasks. So it is possible we will not be able to fully finish it before July since other new features (blockers for other projects) have higher priority.

Regards,
Maros

From: Jan Medved (jmedved)
Sent: Monday, April 18, 2016 5:44 PM
To: Maros Marsalek -X (mmarsale - PANTHEON TECHNOLOGIES at Cisco) <[email-masked]>; Giles Heron <[email-masked]>; Edwin Cordeiro <[email-masked]>
Cc: [email-masked]; Susan Hares <[email-masked]>
Subject: Re: [i2rs] I2RS Hackathon

Hi everyone,

Maros

Edwin, Giles, Sue:

Thanks,
Jan

Hi Edwin,

Hi Sue,

In line comments.

Thanks,

Edwin Cordeiro

Giles

Sue

Edwin:

Sue

Hi Susan,

Thank you

Edwin Cordeiro

BR

Edwin Cordeiro

Sue

Hi all,

Best Regards,

Edwin Cordeiro

---

From: "Maros Marsalek -X (mmarsale - PANTHEON TECHNOLOGIES at Cisco)" <[email-masked]>
Date: Wed, 20 Apr 2016 15:19:29 +0000

Hello Sue,

I may have not been clear regarding the Honeycomb project/distribution so here’s some clarification:

We are working hard to make Honeycomb project/distribution available for IETF in July and we will. I was just referring to the minimal distribution story planned for Honeycomb, which covers improvements/optimizations planned just for the Honeycomb distribution, that already exists in the project. Those improvements are not essential for any feature development and would just further strip down Honeycomb executables in its distribution.

Regards,
Maros

From: Susan Hares [mailto:[email-masked]]
Sent: Monday, April 18, 2016 8:31 PM
To: Jan Medved (jmedved) <[email-masked]>; Maros Marsalek -X (mmarsale - PANTHEON TECHNOLOGIES at Cisco) <[email-masked]>; 'Giles Heron' <[email-masked]>; 'Edwin Cordeiro' <[email-masked]>
Cc: [email-masked]
Subject: RE: [i2rs] I2RS Hackathon

Jan and Maros:

Sue

Cc: [email-masked]<mailto:[email-masked]>; Susan Hares

Hi everyone,

Maros

Edwin, Giles, Sue:

Thanks,
Jan

Hi Edwin,

Hi Sue,

In line comments.

Thanks,

Edwin Cordeiro

Giles

Sue

Edwin:

Sue

Hi Susan,

Thank you

Edwin Cordeiro

BR

Edwin Cordeiro

Sue

Hi all,

Best Regards,

Edwin Cordeiro

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 25 Apr 2016 19:43:10 +0000

My thinking after a quick look is to use Giles setup at https://github.com/CiscoDevNet/opendaylight-setup and during step 3 point to whatever distro is most appropriate at that time. By the time of the IETF 96 hackathon this could be the minimal distro targeted for Honeycomb, but other distros are easily accommodated in the meantime.

Cheers,
Charles

From: i2rs <[email-masked]<mailto:[email-masked]>> on behalf of "Maros Marsalek -X (mmarsale - PANTHEON TECHNOLOGIES at Cisco)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, April 20, 2016 at 5:19 PM
To: Susan Hares <[email-masked]<mailto:[email-masked]>>, "Jan Medved (jmedved)" <[email-masked]<mailto:[email-masked]>>, 'Giles Heron' <[email-masked]<mailto:[email-masked]>>, 'Edwin Cordeiro' <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [i2rs] I2RS Hackathon

Hello Sue,

Regards,
Maros

To: Jan Medved (jmedved) <[email-masked]<mailto:[email-masked]>>; Maros Marsalek -X (mmarsale - PANTHEON TECHNOLOGIES at Cisco) <[email-masked]<mailto:[email-masked]>>; 'Giles Heron' <[email-masked]<mailto:[email-masked]>>; 'Edwin Cordeiro' <[email-masked]<mailto:[email-masked]>>

Jan and Maros:

Sue

Hi everyone,

Maros

Edwin, Giles, Sue:

Thanks,
Jan

Hi Edwin,

Hi Sue,

In line comments.

Thanks,

Edwin Cordeiro

Giles

Sue

Edwin:

Sue

Hi Susan,

Thank you

Edwin Cordeiro

BR

Edwin Cordeiro

Sue

Hi all,

Best Regards,

Edwin Cordeiro