Subject: Re: [i2rs] FW: New Version Notification for draft-hares-i2rs-protocol-strawman-02.txt - 3.1.1

From: Susan Hares <[email-masked]>
Date: Mon, 09 May 2016 19:24:25 -0400

Andy
Great.  This solves the Nottingham bult for i2rs.  Does the same deviation work for i2rs included but configured off.
Sue

Sent via the Samsung Galaxy Note5, an AT&T 4G LTE smartphone-------- Original message --------From: Andy Bierman <[email-masked]> Date: 5/9/2016  7:11 PM  (GMT-05:00) To: Susan Hares <[email-masked]> Cc: [email-masked], "Joel M. Halpern" <[email-masked]>, Netconf <[email-masked]> Subject: Re: [i2rs] FW: New Version Notification for draft-hares-i2rs-protocol-strawman-02.txt - 3.1.1 

On Mon, May 9, 2016 at 3:09 PM, Susan Hares <[email-masked]> wrote:
Andy and Joel:
These are good points.
What happens if the data model has some ephemeral sections and the I2RS agent is not supported by the routing system.  The data model would specify the ephemeral section, but there would be no support by i2rs.  Is the support of the ephemeral not a variable  condition to be indicated in Yang module library?

The server should have a deviations file for the parts it does not support.
   deviation /some/ephemeral/node {      deviate delete {         i2rs:ephemeral;      }   }

Sue

Andy
 Sent via the Samsung Galaxy Note5, an AT&T 4G LTE smartphone-------- Original message --------From: Andy Bierman <[email-masked]> Date: 5/7/2016  12:53 PM  (GMT-05:00) To: "Joel M. Halpern" <[email-masked]> Cc: [email-masked], Netconf <[email-masked]>, Susan Hares <[email-masked]> Subject: Re: [i2rs] FW: New Version Notification for draft-hares-i2rs-protocol-strawman-02.txt - 3.1.1 

On Fri, May 6, 2016 at 8:51 AM, Joel M. Halpern <[email-masked]> wrote:
Reading the latest revision, in section 3.1.1, the text in bullet 5 says that the data model indicates which portions are ephemeral.  That makes sense to me.

Then bullet 6 says that the management protocol needs to signal (in its yang library) which parts are ephemeral.

Why the second requirement?  If the data model is supported, and the data model states that certain items are ephemeral, what would it mean if the signaling did not also say that.  Conversely, what would it mean if the signaling said something was ephemeral that the model does not define as ephemeral?

It may be that I am misreading bullet 6.  Please explain.

I think you are correct that the YANG library does not need any changesto identify ephemeral data.  Only the variable components ofYANG conformance are contained in the library.

Thank you,

Joel

Andy 
_______________________________________________

i2rs mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/i2rs

---

From: Andy Bierman <[email-masked]>
Date: Mon, 9 May 2016 16:31:59 -0700

On Mon, May 9, 2016 at 4:24 PM, Susan Hares <[email-masked]> wrote:

> Andy
>
> Great.  This solves the Nottingham bult for i2rs.  Does the same deviation
> work for i2rs included but configured off.
>
>
I don't understand the point of specifying this property in the YANG module
if the operator is allowed to configure it on/off.

Deviations alter the schema definition.
Configuration alters instances of the data.

IMO I2RS does not need such complex configuration.
Access control can be used to configure I2RS on or off on specific data
nodes.

Sue

Andy

>
>
> Sent via the Samsung Galaxy Note5, an AT&T 4G LTE smartphone
> -------- Original message --------
> From: Andy Bierman <[email-masked]>
> Date: 5/9/2016 7:11 PM (GMT-05:00)
> To: Susan Hares <[email-masked]>
> Cc: [email-masked], "Joel M. Halpern" <[email-masked]>, Netconf <
> [email-masked]>
> Subject: Re: [i2rs] FW: New Version Notification for
> draft-hares-i2rs-protocol-strawman-02.txt - 3.1.1
>
>
>
>> What happens if the data model has some ephemeral sections and the I2RS
>> agent is not supported by the routing system.  The data model would specify
>> the ephemeral section, but there would be no support by i2rs.  Is the
>> support of the ephemeral not a variable  condition to be indicated in Yang
>> module library?
>>
>>
>    deviation /some/ephemeral/node {
>       deviate delete {
>          i2rs:ephemeral;
>       }
>    }
>
>
> Sue
>>
>
>
> Andy
>
>
>
>> Sent via the Samsung Galaxy Note5, an AT&T 4G LTE smartphone
>> -------- Original message --------
>> From: Andy Bierman <[email-masked]>
>> Date: 5/7/2016 12:53 PM (GMT-05:00)
>> To: "Joel M. Halpern" <[email-masked]>
>> Cc: [email-masked], Netconf <[email-masked]>, Susan Hares <
>> [email-masked]>
>> Subject: Re: [i2rs] FW: New Version Notification for
>> draft-hares-i2rs-protocol-strawman-02.txt - 3.1.1
>>
>>
>>
>>> Reading the latest revision, in section 3.1.1, the text in bullet 5 says
>>> that the data model indicates which portions are ephemeral.  That makes
>>> sense to me.
>>>
>>> Why the second requirement?  If the data model is supported, and the
>>> data model states that certain items are ephemeral, what would it mean if
>>> the signaling did not also say that.  Conversely, what would it mean if the
>>> signaling said something was ephemeral that the model does not define as
>>> ephemeral?
>>>
>> I think you are correct that the YANG library does not need any changes
>> to identify ephemeral data.  Only the variable components of
>> YANG conformance are contained in the library.
>>
>>
>> Thank you,
>>> Joel
>>>
>>>
>>
>> Andy
>>
>>