Subject: Re: [i2rs] FW: New Version Notification for draft-hares-i2rs-protocol-strawman-02.txt - 3.1.1

From: Susan Hares <[email-masked]>
Date: Mon, 09 May 2016 18:09:18 -0400

Andy and Joel:
These are good points.
What happens if the data model has some ephemeral sections and the I2RS agent is not supported by the routing system.  The data model would specify the ephemeral section, but there would be no support by i2rs.  Is the support of the ephemeral not a variable  condition to be indicated in Yang module library?
SueSent via the Samsung Galaxy Note5, an AT&T 4G LTE smartphone-------- Original message --------From: Andy Bierman <[email-masked]> Date: 5/7/2016  12:53 PM  (GMT-05:00) To: "Joel M. Halpern" <[email-masked]> Cc: [email-masked], Netconf <[email-masked]>, Susan Hares <[email-masked]> Subject: Re: [i2rs] FW: New Version Notification for draft-hares-i2rs-protocol-strawman-02.txt - 3.1.1 

On Fri, May 6, 2016 at 8:51 AM, Joel M. Halpern <[email-masked]> wrote:
Reading the latest revision, in section 3.1.1, the text in bullet 5 says that the data model indicates which portions are ephemeral.  That makes sense to me.

Then bullet 6 says that the management protocol needs to signal (in its yang library) which parts are ephemeral.

Why the second requirement?  If the data model is supported, and the data model states that certain items are ephemeral, what would it mean if the signaling did not also say that.  Conversely, what would it mean if the signaling said something was ephemeral that the model does not define as ephemeral?

It may be that I am misreading bullet 6.  Please explain.

I think you are correct that the YANG library does not need any changesto identify ephemeral data.  Only the variable components ofYANG conformance are contained in the library.

Thank you,

Joel

Andy 
_______________________________________________

i2rs mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/i2rs

---

From: Andy Bierman <[email-masked]>
Date: Mon, 9 May 2016 16:11:04 -0700

On Mon, May 9, 2016 at 3:09 PM, Susan Hares <[email-masked]> wrote:

> Andy and Joel:
>
> These are good points.
>
> What happens if the data model has some ephemeral sections and the I2RS
> agent is not supported by the routing system.  The data model would specify
> the ephemeral section, but there would be no support by i2rs.  Is the
> support of the ephemeral not a variable  condition to be indicated in Yang
> module library?
>
>
The server should have a deviations file for the parts it does not support.

   deviation /some/ephemeral/node {
      deviate delete {
         i2rs:ephemeral;
      }
   }

Sue

Andy

> Sent via the Samsung Galaxy Note5, an AT&T 4G LTE smartphone
> -------- Original message --------
> From: Andy Bierman <[email-masked]>
> Date: 5/7/2016 12:53 PM (GMT-05:00)
> To: "Joel M. Halpern" <[email-masked]>
> Cc: [email-masked], Netconf <[email-masked]>, Susan Hares <
> [email-masked]>
> Subject: Re: [i2rs] FW: New Version Notification for
> draft-hares-i2rs-protocol-strawman-02.txt - 3.1.1
>
>
>
>> Reading the latest revision, in section 3.1.1, the text in bullet 5 says
>> that the data model indicates which portions are ephemeral.  That makes
>> sense to me.
>>
>> Why the second requirement?  If the data model is supported, and the data
>> model states that certain items are ephemeral, what would it mean if the
>> signaling did not also say that.  Conversely, what would it mean if the
>> signaling said something was ephemeral that the model does not define as
>> ephemeral?
>>
> I think you are correct that the YANG library does not need any changes
> to identify ephemeral data.  Only the variable components of
> YANG conformance are contained in the library.
>
>
> Thank you,
>> Joel
>>
>>
>
> Andy
>
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 10 May 2016 01:34:10 -0400

As I understand it, if a model requires ephemeral elements, and the 
agent does not support ephemeral, then the agent can not claim to 
support the model.

Yes, deviations allow you to specify this, as Andy says.  But this is 
specifying a failure to conform.

I would go far as to say that such an agent is not an I2RS agent, but 
that is a step beyond the NetConf compliance definitions.

Yours,
Joel

On 5/9/16 6:09 PM, Susan Hares wrote:
> agent is not supported by the routing system.  The data model would
> specify the ephemeral section, but there would be no support by i2rs.
>  Is the support of the ephemeral not a variable  condition to be
> indicated in Yang module library?
>
> Sue
> Cc: [email-masked], Netconf <[email-masked]>, Susan Hares
> <[email-masked]>
> On Fri, May 6, 2016 at 8:51 AM, Joel M. Halpern <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Reading the latest revision, in section 3.1.1, the text in bullet 5
>     says that the data model indicates which portions are ephemeral.
>     That makes sense to me.
>
>     Then bullet 6 says that the management protocol needs to signal (in
>     its yang library) which parts are ephemeral.
>
>     Why the second requirement?  If the data model is supported, and the
>     data model states that certain items are ephemeral, what would it
>     mean if the signaling did not also say that.  Conversely, what would
>     it mean if the signaling said something was ephemeral that the model
>     does not define as ephemeral?
>
>     [email-masked] <mailto:[email-masked]>

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 10 May 2016 07:25:29 -0400

Joel: 

What happens if the code supports the I2RS agent, but the I2RS agent is configured to be "off"?  Is this covered by the deviations or is this variable configuration? 

Sue 

-----Original Message-----
From: Joel M. Halpern [mailto:[email-masked]] 
Sent: Tuesday, May 10, 2016 1:34 AM
To: Susan Hares; Andy Bierman
Cc: [email-masked]; Netconf
Subject: Re: [i2rs] FW: New Version Notification for draft-hares-i2rs-protocol-strawman-02.txt - 3.1.1

As I understand it, if a model requires ephemeral elements, and the agent does not support ephemeral, then the agent can not claim to support the model.

Yes, deviations allow you to specify this, as Andy says.  But this is specifying a failure to conform.

I would go far as to say that such an agent is not an I2RS agent, but that is a step beyond the NetConf compliance definitions.

Yours,
Joel

On 5/9/16 6:09 PM, Susan Hares wrote:
> Andy and Joel:
>
> These are good points.
>
> What happens if the data model has some ephemeral sections and the 
> I2RS agent is not supported by the routing system.  The data model 
> would specify the ephemeral section, but there would be no support by i2rs.
> I think you are correct that the YANG library does not need any 
> changes to identify ephemeral data.  Only the variable components of