Subject: [i2rs] FW: [RTG-DIR] Routing directorate QA review of draft-ietf-i2rs-yang-l2-network-topology

From: "Zhangxian (Xian)" <[email-masked]>
Date: Wed, 18 May 2016 08:50:54 +0000

To get the attention of draft authors and the WG to the following review/comments. 

Thank Henning for the constructive comments. 

Cheers,
Xian

-----Original Message-----
From: rtg-dir [mailto:[email-masked]] On Behalf Of Henning Rogge
Sent: 2016年5月17日 15:07
To: Zhangxian (Xian); [email-masked]; [email-masked]; [email-masked] >> Susan Hares
Cc: [email-masked]
Subject: Re: [RTG-DIR] Routing directorate QA review of draft-ietf-i2rs-yang-l2-network-topology

Hi,

I have been asked to provide a review to the following document to the 
routing directorate mailing list.

Please be aware that this is the first time I work with YANG and related 
drafts.

Document: draft-ietf-i2rs-yang-l2-network-topology-02

Reviewer: Henning Rogge
Review Date: Mai 16th, 2016

Intended Status: Standards Track

The data structure suggested by the draft is reasonable and would fit 
most Layer2 network technologies. I have a couple of points on the draft 
document which might be worth looking into:

* The introduction in 
https://tools.ietf.org/html/draft-ietf-i2rs-yang-l2-network-topology-02 
includes a link to "I-D.ietf-netmod-rfc6020bis" that links back to the 
draft document itself. Maybe some links in the document refer to an 
older name of the draft?

* the "termination-point" element only contains the types "ethernet" and 
"legacy" (which does not contain any data like mac-address). Is this 
reasonable or should a few data elements moved from the "ethernet" 
category to the "l2-termination-point-attributes" category?

* there are different types of VLAN tags be used... should there be 
another field ("vlan-type" ?) to announce 802.1ad QinQ usage? I think 
the 802.1ad tag is also sometimes also used to move VLAN over a switch 
that doesn't support it (unknown Ethertypes are usually just ignored), 
which means just knowing the VLAN-id is not enough to reach the endpoint.

* the type of ethernet (100, 1000, 10000) or data-rate could be an 
important attribute for an ethernet termination point, not only for links.

Henning Rogge
-- 
Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
Kommunikation, Informationsverarbeitung und Ergonomie FKIE
Kommunikationssysteme (KOM)
Fraunhofer Straße 20, 53343 Wachtberg, Germany
Telefon +49 228 9435-961,   Fax +49 228 9435 685
mailto:[email-masked] http://www.fkie.fraunhofer.de

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 26 May 2016 13:21:30 -0400

Henning: 

Thank you for reviewing draft-ietf-i2rs-yang-l2-netconf-topology.  Jie Dong will be getting back to you shortly. 

Sue 

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Zhangxian (Xian)
Sent: Wednesday, May 18, 2016 4:51 AM
To: [email-masked]; [email-masked]
Cc: Henning Rogge; Susan Hares
Subject: [i2rs] FW: [RTG-DIR] Routing directorate QA review of draft-ietf-i2rs-yang-l2-network-topology

Cheers,
Xian

-----Original Message-----
From: rtg-dir [mailto:[email-masked]] On Behalf Of Henning Rogge
Sent: 2016年5月17日 15:07
To: Zhangxian (Xian); [email-masked]; [email-masked]; [email-masked] >> Susan Hares
Cc: [email-masked]
Subject: Re: [RTG-DIR] Routing directorate QA review of draft-ietf-i2rs-yang-l2-network-topology

Hi,

I have been asked to provide a review to the following document to the routing directorate mailing list.

Please be aware that this is the first time I work with YANG and related drafts.

Reviewer: Henning Rogge

* The introduction in 

Henning Rogge

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Sat, 28 May 2016 02:32:26 +0000

Hi Henning, 

Thanks a lot for your review and sorry for the late response. Please see my replies inline:

> Sent: Wednesday, May 18, 2016 4:51 PM
> Cc: Henning Rogge <[email-masked]>; Susan Hares <[email-masked]>
> To: Zhangxian (Xian); [email-masked];
> [email-masked]; [email-masked] >> Susan Hares
> Cc: [email-masked]

I found out that if you click the link in the main text, it will go to the reference at the end of the draft. Then if you click the link in the reference, it will open the 6020bis draft. Not quite sure why it works like this, but the draft name is correct in both places.

> category to the "l2-termination-point-attributes" category?

Good question. Previously we didn't add much data under the legacy type, but as you said, something like mac-address for Ethernet should also be included for legacy. We will consider this in next revision.

> which means just knowing the VLAN-id is not enough to reach the endpoint.

In this draft an identityref " eth-encapsulation" is used to specify the Ethernet encapsulation of the termination point, which can be native Ethernet, QinQ, Mac-in-Mac, etc. For each encapsulation type, an identity is defined.

> important attribute for an ethernet termination point, not only for links.

Yes, the data rate (bandwidth) of a link can be determined by the type/capability of the connected physical interfaces. 

While as this L2 topology model is designed to be applicable for both physical and virtual layer 2 networks, attributes of physical interfaces are not included.

Best regards,
Jie