Subject: Re: [i2rs] I2RS Interim Meeting - June 1, 2016 - 10:00am - 11:00am -? Topic: Ephemeral State Requirements

From: Susan Hares <[email-masked]>
Date: Thu, 02 Jun 2016 10:40:38 -0400

Juergen
The definition I was using was operational state (read only )  that is defined under a node defined ephemeral.  Joel challenged that definition saying with split operational state from config - operational state does not need to be under an ephemeral node.
Sue

Sent via the Samsung Galaxy Note5, an AT&T 4G LTE smartphone-------- Original message --------From: Juergen Schoenwaelder <[email-masked]> Date: 6/2/2016  7:50 AM  (GMT-05:00) To: Susan Hares <[email-masked]> Cc: 'Jeffrey Haas' <[email-masked]>, [email-masked], 'Benoit Claise' <[email-masked]>, 'Alia Atlas' <[email-masked]> Subject: Re: [i2rs] I2RS Interim Meeting - June 1,
  2016 - 10:00am - 11:00am -?  Topic: Ephemeral State Requirements 
I might be able to answer the picture question once I know what is
really meant by 'ephemeral operational state'.

/js

On Thu, Jun 02, 2016 at 07:15:34AM -0400, Susan Hares wrote:
> Juergen: 
> 
>  
> 
> On first sentence, ... restated 
> 
> Do you believe the "ephemeral operational state" belongs in the ephemeral
> requirements? If so, we can add it.  Perhaps we should also add a definition
> for ephemeral configuration. 
> 
>  
> 
> On picture -- here is your picture: 
> 
>  
> 
>    +-------------+                  +-----------+
> 
>    | <candidate> |                  | <startup> |
> 
>    |  (ct, rw)   |<---+        +--->| (ct, rw)  |
> 
>    +-------------+    |        |    +-----------+
> 
>           |           |        |           |
> 
>           |         +------------+         |
> 
>           +-------->| <running>  |<--------+
> 
>                     | (ct, rw)   |
> 
>                     +------------+
> 
>                           |         // e.g., removal of 'inactive' nodes
> 
>                           v
> 
>                     +------------+
> 
>                     | <intended> |  // subject to validation
> 
>                     | (ct, ro)   |
> 
>                     +------------+
> 
>                           |         // e.g., missing resources or delays
> 
>                           v
> 
>                     +------------+
> 
>                     | <applied>  |
> 
>                     | (ct, ro)   |
> 
>                     +------------+
> 
>                           |         // e.g., autodiscovery of values
> 
>                           v
> 
>           +--------------------------------+
> 
>           | <operational-state>            |<-- control plane and
> 
>           | (ct + cf, ro)                  |    ephemeral datastores
> 
>           +--------------------------------+
> 
>  
> 
> Is this part of the picture 
> 
>  
> 
>           +--------------------------------+
> 
>           | <operational-state>            |<-- control plane and
> 
>           | (ct + cf, ro)                  |    ephemeral datastores
> 
>           +--------------------------------+
> 
>  
> 
> Really 
> 
>   +--------------------+    +--------------------------+
> +-----------------------+
> 
>  |    opstate         |    | ephemeral config  |   | applied  config    |
> 
>  | (cf, ro)               |    |   (ct, ro, ephemeral|  | (ct, ro)
> |
> 
>  +--------------------+    +---------------------------+
> +-------------------------+
> 
>  
> 
> Or just 
> 
>   +--------------------+    +--------------------------+    
> 
>   |    opstate         |    | ephemeral config  |    
> 
>   | (cf, ro)               |    |   (ct, ro, ephemeral 
> 
>   +--------------------+    +---------------------------+   
> 
>  
> 
>  
> 
> Sue 
> 
>  
> 
> -----Original Message-----
> From: i2rs [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
> Sent: Thursday, June 02, 2016 7:05 AM
> To: Susan Hares
> Cc: 'Jeffrey Haas'; [email-masked]; 'Benoit Claise'; 'Alia Atlas'
> Subject: Re: [i2rs] I2RS Interim Meeting - June 1, 2016 - 10:00am - 11:00am
> -? Topic: Ephemeral State Requirements
> 
>  
> 
> On Thu, Jun 02, 2016 at 06:53:42AM -0400, Susan Hares wrote:
> 
> > Juergen:
> 
> > 
> 
> > Do you think this definition belongs in the ephemeral requirements?  If
> so,
> 
> > we can add it.   But perhaps we should define both ephemeral configuration
> 
> > and ephemeral operational state.  Joel point out at the I2RS interim 
> 
> > that ephemeral operational state is just like all other operational state
> - it
> 
> > disappears upon reboot.   It is ephemeral configuration which is different
> 
> > than normal configuration - since it disappears upon reboot where 
> 
> > normal configuration does not.
> 
> > 
> 
> > Is this diagram close to your existing model where opstate and 
> 
> > ephemeral configuration are parallel?
> 
> > 
> 
> > +--------------------+    +--------------------------+
> 
> > |    opstate         |    | ephemeral config  |
> 
> > +--------------------+    +--------------------------+
> 
> > 
> 
>  
> 
> I see two boxes, I am unsure what you think these boxes drawn this way mean.
> What is 'this definition' in your first sentence? I really have problems to
> follow what is going on.
> 
>  
> 
> /js
> 
>  
> 
> -- 
> 
> Juergen Schoenwaelder           Jacobs University Bremen gGmbH
> 
> Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
> 
> Fax:   +49 421 200 3103         < <http://www.jacobs-university.de/>
> http://www.jacobs-university.de/>
> 
>  
> 
> _______________________________________________
> 
> i2rs mailing list
> 
>  <mailto:[email-masked]> [email-masked]
> 
>  <https://www.ietf.org/mailman/listinfo/i2rs>
> https://www.ietf.org/mailman/listinfo/i2rs
> 

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs

---

From: Susan Hares <[email-masked]>
Date: Thu, 02 Jun 2016 12:07:50 -0400

Joel
I agree with you.  My first question to Juergen was trying to poke in that direction to explore his model based on that concept. 
Unfortunately, he required I defined what I meant Tuesday/Wednesday by ephemeral opstate.
I am at a meeting so my email is busy
Sue

Sent via the Samsung Galaxy Note5, an AT&T 4G LTE smartphone-------- Original message --------From: "Joel M. Halpern" <[email-masked]> Date: 6/2/2016  11:14 AM  (GMT-05:00) To: Juergen Schoenwaelder <[email-masked]>, [email-masked], 'Benoit Claise' <[email-masked]> Subject: Re: [i2rs] I2RS Interim Meeting - June 1,
  2016 - 10:00am - 11:00am -? Topic: Ephemeral State Requirements 
 From where I sit, there is no such thing as "ephemeral operational 
state".  There is "operational state" that reflects the effect of 
"ephemeral configuration", but as far as I can tell, it is still just 
"operational state".

Putting aside the operational state aspects, we do need to work out the 
diagramming / positioning of the ephemeral configuration and its 
relationship to the other components in the base diagram.

Yours,
Joel