Subject: [i2rs] ephemeral requirements - REQ 08 bullet 1

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 1 Jun 2016 10:47:31 -0400

Existing Text:
1.  protocol version support for I2RS modifications - (e.g.  I2RS
        version 1)

Proposed Text:
1. Support for communication mechanisms to enable an I2RS client to 
determine that an I2RS agent supports the mechanisms needed for I2RS 
operation.

This probably is already met by existing NetConf mechanisms.  I think it 
is useful to state anyway, so that solution development will verify that 
it is met.

Yours,
Joel

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 1 Jun 2016 11:49:31 -0400

Joel: 

I agree with this text.  I will add it to version 10 of the text. 

Sue 

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Joel M. Halpern
Sent: Wednesday, June 01, 2016 10:48 AM
To: [email-masked]
Subject: [i2rs] ephemeral requirements - REQ 08 bullet 1

Existing Text:

Proposed Text:

This probably is already met by existing NetConf mechanisms.  I think it is
useful to state anyway, so that solution development will verify that it is
met.

Yours,
Joel

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 1 Jun 2016 11:56:28 -0400

Joel,

On Wed, Jun 01, 2016 at 10:47:31AM -0400, Joel M. Halpern wrote:
> This probably is already met by existing NetConf mechanisms.  I
> think it is useful to state anyway, so that solution development
> will verify that it is met.

I'm fine with that.  An example of such an implementation is covered in
section 6.3 of draft-hares-i2rs-protocol-strawman-02.

-- Jeff

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 1 Jun 2016 22:48:15 +0000

Joel, 

The existing text and the proposed test mean different things to me. The existing text is to say support I2RS Version 1, whereas the proposed text states a very obvious statement. 

If I2RS client didn't have the needed "communication mechanisms" to I2RS agent or can't decide if the communications mechanisms needed is supported, how can I2RS client even start to send commands to I2RS agent?  

Linda

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Joel M. Halpern
Sent: Wednesday, June 01, 2016 9:48 AM
To: [email-masked]
Subject: [i2rs] ephemeral requirements - REQ 08 bullet 1

Existing Text:

Proposed Text:
1. Support for communication mechanisms to enable an I2RS client to determine that an I2RS agent supports the mechanisms needed for I2RS operation.

This probably is already met by existing NetConf mechanisms.  I think it is useful to state anyway, so that solution development will verify that it is met.

Yours,
Joel

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 1 Jun 2016 19:13:09 -0400

Linda, the problem is that there is no such thing as an I2RS protocol, 
much less version 1 of such a protocol.  If I2RS is using NetConf, the 
protocol is NetConf.  If it is using RestConf, then that is the protocol.

Further, the exact mechanism to express what the agent can do over these 
protocols is defined by those mechanisms.

I can't argue with your observation that there is not much to the 
requirement as reworded.  I consider that it is not vacuous because it 
confirms that we need the relevant capability information.  I recognize 
that the NetConf and NetMod working groups have been very good about 
doing that.

My primary point, as I have said several times on the list, and saqid on 
the webex, is that the requirement as written was not a description of 
what we requried, but of a possible (and in my personal view incorrect) 
way of meeting the requirement.

Yours,
Joel

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 1 Jun 2016 23:48:33 +0000

Joel,

Does it hurt if this requirement is removed from the document? 

To me, it is more to say needing a reliable communication channel between I2RS client and agent (which should be assumed with NETCONF protocol). Therefore, I don't think we need to have it in the I2RS Ephemeral requirement.

Linda  

-----Original Message-----
From: Joel M. Halpern [mailto:[email-masked]] 
Sent: Wednesday, June 01, 2016 6:13 PM
To: Linda Dunbar; [email-masked]
Subject: Re: [i2rs] ephemeral requirements - REQ 08 bullet 1

Linda, the problem is that there is no such thing as an I2RS protocol, much less version 1 of such a protocol.  If I2RS is using NetConf, the protocol is NetConf.  If it is using RestConf, then that is the protocol.

Further, the exact mechanism to express what the agent can do over these protocols is defined by those mechanisms.

I can't argue with your observation that there is not much to the requirement as reworded.  I consider that it is not vacuous because it confirms that we need the relevant capability information.  I recognize that the NetConf and NetMod working groups have been very good about doing that.

My primary point, as I have said several times on the list, and saqid on the webex, is that the requirement as written was not a description of what we requried, but of a possible (and in my personal view incorrect) way of meeting the requirement.

Yours,
Joel

---

From: Joel Halpern Direct <[email-masked]>
Date: Wed, 1 Jun 2016 19:50:03 -0400

I can live with removing it entirely.  Others had expressed that they 
felt it was important to include.

Yours,
Joel

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 2 Jun 2016 12:50:28 +0200

I understood the proposed text as 'be able to determine whether the
protocol implementation supports the mechanisms required by I2RS',
which is different from 'needing a reliable communication channel'.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 2 Jun 2016 10:21:38 -0400

> which is different from 'needing a reliable communication channel'.

+1

Whether this is simply considered a profile of netconf/restconf is fine, in
my opinion.

-- Jeff

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 6 Jun 2016 10:50:30 -0400

Joel and Linda: 

Unless you have an objection, I will leave Ephemeral-REQ-08 bullet 1 in. 

Sue 

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Joel Halpern Direct
Sent: Wednesday, June 01, 2016 7:50 PM
To: Linda Dunbar; Joel M. Halpern; [email-masked]
Subject: Re: [i2rs] ephemeral requirements - REQ 08 bullet 1

I can live with removing it entirely.  Others had expressed that they felt
it was important to include.

Yours,
Joel

On 6/1/16 7:48 PM, Linda Dunbar wrote:
> To me, it is more to say needing a reliable communication channel between
I2RS client and agent (which should be assumed with NETCONF protocol).
Therefore, I don't think we need to have it in the I2RS Ephemeral
requirement.
requirement as reworded.  I consider that it is not vacuous because it
confirms that we need the relevant capability information.  I recognize that
the NetConf and NetMod working groups have been very good about doing that.
> My primary point, as I have said several times on the list, and saqid on
the webex, is that the requirement as written was not a description of what
we requried, but of a possible (and in my personal view incorrect) way of
meeting the requirement.
>> The existing text and the proposed test mean different things to me. The
existing text is to say support I2RS Version 1, whereas the proposed text
states a very obvious statement.
>>
>> If I2RS client didn't have the needed "communication mechanisms" to I2RS
agent or can't decide if the communications mechanisms needed is supported,
how can I2RS client even start to send commands to I2RS agent?
>> This probably is already met by existing NetConf mechanisms.  I think it
is useful to state anyway, so that solution development will verify that it
is met.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 6 Jun 2016 11:30:42 -0400

If you mean "leave it in, with the wording that was sent to the list 
after the call", then yes, that works for me.

Yours,
Joel

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 6 Jun 2016 12:11:10 -0400

Joel: 

Yes, this is exactly what I meant. 

Sue 

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Joel M. Halpern
Sent: Monday, June 06, 2016 11:31 AM
To: Susan Hares; 'Linda Dunbar'; [email-masked]
Subject: Re: [i2rs] ephemeral requirements - REQ 08 bullet 1

If you mean "leave it in, with the wording that was sent to the list after
the call", then yes, that works for me.

Yours,
Joel

On 6/6/16 10:50 AM, Susan Hares wrote:
> confirms that we need the relevant capability information.  I 
> recognize that the NetConf and NetMod working groups have been very good
about doing that.
> what we requried, but of a possible (and in my personal view 
> incorrect) way of meeting the requirement.
>>
>> Yours,
>> Joel
>>
> existing text is to say support I2RS Version 1, whereas the proposed 
> text states a very obvious statement.
>>>
> agent or can't decide if the communications mechanisms needed is 
> supported, how can I2RS client even start to send commands to I2RS agent?
>>>
>>> Linda
>>>
>>> think it
> is useful to state anyway, so that solution development will verify 
> that it is met.
>>>
>>> Yours,
>>> Joel
>>>