Subject: [i2rs] I-D Action: draft-ietf-i2rs-yang-network-topo-03.txt

From: [email-masked]
Date: Thu, 09 Jun 2016 15:08:49 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Interface to the Routing System of the IETF.

        Title           : A Data Model for Network Topologies
        Authors         : Alexander Clemm
                          Jan Medved
                          Robert Varga
                          Tony Tkacik
                          Nitin Bahadur
                          Hariharan Ananthakrishnan
                          Xufeng Liu
	Filename        : draft-ietf-i2rs-yang-network-topo-03.txt
	Pages           : 31
	Date            : 2016-06-09

Abstract:
   This document defines an abstract (generic) YANG data model for
   network/service topologies and inventories.  The model serves as a
   base model which is augmented with technology-specific details in
   other, more specific topology and inventory models.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-network-topo/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-i2rs-yang-network-topo-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-i2rs-yang-network-topo-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Thu, 9 Jun 2016 22:29:19 +0000

Hi,

we have just refreshed the topology draft, draft-ietf-i2rs-yang-network-topo-03.txt.  

The YANG model has not changed over prior versions.  However, one suggestion has been brought up for an alternative solution regarding distinguishing between topology information that is configured (e.g. by a controller), vs populated (e.g. by an embedded application on a server itself).  We added a brief discussion of this in a discussion of design alternatives.  This alternative would involve making use of YANG Metadata (per Lada's metadata draft) to tag topology items that are populated by a server as "server-provided.  A new metadata tag would be introduced for that purpose, which could be a boolean or a type "empty".   The  semantics of the tag would be that it is applied to any topology data that comes into being (respectively is configured) by an embedded  application on the network, as opposed to e.g. a controller application.  The metadata will be set automatically by the server as applicable.  This solution provides a conceptually more elegant solution than the current one; however, as a caveat, it is currently not implemented; Open Daylight (which is implementing the current topology model) has no support for metadata planned at this time.  

Regards
--- Alex (on behalf of the coauthors)

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, June 09, 2016 3:09 PM
To: [email-masked]
Cc: [email-masked]
Subject: [i2rs] I-D Action: draft-ietf-i2rs-yang-network-topo-03.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs