Subject: [i2rs] draft-zhuang-i2rs-yang-dc-fabric-network-topology-00.txt: YANG compilation error

From: Benoit Claise <[email-masked]>
Date: Sat, 16 Jul 2016 20:09:46 +0200

Dear authors,

Part of the IETF hackathon today, I integrated confdc , as a second YANG 
module compiler, in http://www.claise.be/IETFYANGPageCompilation.html. 
Reason? For example, confdc validates xpath while pyang doesn't.
And confdc found an issue with your draft, which is now flagged as 
failing the YANG compilation.
Please correct this issue.
Note: you're not alone, look at the green dip today on green graph 
<http://claise.be/IETFYANGPageCompilation.png>!

During the hackathon today, Carl Moberg also integrated the confdc 
output in his www.yangalidtor.com.
This might help you.

Regards, Benoit

---

From: William Atwood <[email-masked]>
Date: Sat, 16 Jul 2016 14:47:52 -0400

The link to www.yangalidtor.com gives a "server not found" error message.

  Bill

On 16/07/2016 2:09 PM, Benoit Claise wrote:
> Dear authors,
>
> Part of the IETF hackathon today, I integrated confdc , as a second
> YANG module compiler, in
> http://www.claise.be/IETFYANGPageCompilation.html. Reason? For
> example, confdc validates xpath while pyang doesn't.
> _______________________________________________
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2rs

-- 

Dr. J.W. Atwood, Eng.             tel:   +1 (514) 848-2424 x3046
Distinguished Professor Emeritus  fax:   +1 (514) 848-2830
Department of Computer Science
   and Software Engineering
Concordia University EV 3.185     email:[email-masked]
1455 de Maisonneuve Blvd. West    http://users.encs.concordia.ca/~bill
Montreal, Quebec Canada H3G 1M8

---

From: Benoit Claise <[email-masked]>
Date: Sat, 16 Jul 2016 20:59:28 +0200

http://www.yangvalidator.com/

Benoit
> Concordia University EV 3.185email:[email-masked]
> 1455 de Maisonneuve Blvd. Westhttp://users.encs.concordia.ca/~bill

---

From: "Zhuangyan (Yan)" <[email-masked]>
Date: Tue, 19 Jul 2016 10:07:42 +0000

Hi all,

Thank you very much for the compilation report. We will fix it up and Sorry for the late response.

Best Regards,

Yan

发件人: Benoit Claise [mailto:[email-masked]]
发送时间: 2016年7月17日 2:59
收件人: William Atwood; [email-masked]
抄送: [email-masked]; Carl Moberg (camoberg)
主题: Re: [i2rs] draft-zhuang-i2rs-yang-dc-fabric-network-topology-00.txt: YANG compilation error

Benoit

The link to www.yangalidtor.com<http://www.yangalidtor.com> gives a "server not found" error message.

  Bill

Part of the IETF hackathon today, I integrated confdc , as a second YANG module compiler, in http://www.claise.be/IETFYANGPageCompilation.html. Reason? For example, confdc validates xpath while pyang doesn't.
And confdc found an issue with your draft, which is now flagged as failing the YANG compilation.
Please correct this issue.
Note: you're not alone, look at the green dip today on green graph<http://claise.be/IETFYANGPageCompilation.png>!

During the hackathon today, Carl Moberg also integrated the confdc output in his www.yangalidtor.com<http://www.yangalidtor.com>.
This might help you.

Regards, Benoit

i2rs mailing list

[email-masked]<mailto:[email-masked]>

--

   and Software Engineering

Concordia University EV 3.185     email:[email-masked]<mailto:email:[email-masked]>

1455 de Maisonneuve Blvd. West    http://users.encs.concordia.ca/~bill<http://users.encs.concordia.ca/%7Ebill>