Subject: [i2rs] Subscribing to Network Elements @ IETF96 - Thursday 10AM

From: "Eric Voit (evoit)" <[email-masked]>
Date: Wed, 13 Jul 2016 19:24:37 +0000

In response to the RFC 7923<https://tools.ietf.org/html/rfc7923> requirements from I2RS, NETCONF is working a set of Subscription technology drafts.   With subscriptions, an Operator can see and react to configuration / operational changes on Network Elements as they occur.

Because the drafts have evolved over the last few IETFs, it is worthwhile to provide a technology overview.  We are having an Intro session for those of you who haven't followed this daily.

               Subscribing to Network Elements
               IETF-96
Thursday  10:00-11:30AM
               Tegel Conference Room

Material covered:

               Requirements for Subscription to YANG Datastores (from I2RS)
RFC 7923<https://tools.ietf.org/html/rfc7923>

Subscriptions for Event Notifications  (RFC5277bis)
draft-gonzalez-netconf-5277bis<https://datatracker.ietf.org/doc/draft-gonzalez-netconf-5277bis/>

YANG Datastore Push

draft-ietf-netconf-yang-push<https://datatracker.ietf.org/doc/draft-ietf-netconf-yang-push/>

NETCONF Transport for Event Notifications
draft-gonzalez-netconf-event-notifications<https://datatracker.ietf.org/doc/draft-gonzalez-netconf-event-notifications/>

RESTCONF & HTTP Transport for Event Notifications
draft-voit-netconf-restconf-notif<https://datatracker.ietf.org/doc/draft-voit-netconf-restconf-notif/>

Thanks!
Eric (on behalf of the authors and contributors<https://github.com/netconf-wg/yang-push/wiki/Contributors>)

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Thu, 21 Jul 2016 19:36:05 +0000

Thanks to those of you who came to the Technology Intro session today.   As promised, materials are here:
https://github.com/netconf-wg/yang-push/blob/master/Subscriptions-Intro-IETF96.ppt

Slides include:
Two Views of the Network’s Job
Must have Alternative to Polling
Generalized Publisher Capabilities
Consumption Models
Applicability beyond the Network Element
Event Notifications ≠ Raw Datastore Objects
When to use Event Notifications or YANG Datastore Push
Some Use Cases
Event & YANG Subscription Drafts
Subscription Drafts in Layered Framework
Context with OC-Telemetry.yang
Requirements of RFC 7923
Dampening Eventing vs. Periodic Behavior
Prioritization of Subscriptions
Reviewing the YANG Models
rfc5277bis
yang-push

Thanks,
Eric & Alex

From: i2rs [mailto:[email-masked]] On Behalf Of Eric Voit (evoit)
Sent: Wednesday, July 13, 2016 3:25 PM
To: [email-masked]
Subject: [i2rs] Subscribing to Network Elements @ IETF96 - Thursday 10AM

Because the drafts have evolved over the last few IETFs, it is worthwhile to provide a technology overview.  We are having an Intro session for those of you who haven’t followed this daily.

Material covered:

YANG Datastore Push

Thanks!