Subject: [i2rs] WG LC on draft-ietf-i2rs-yang-network-topo-05.txt extended and draft-ietf-i2rs-yang-l3-network-topo-06.txt (

From: "Susan Hares" <[email-masked]>
Date: Tue, 20 Sep 2016 10:08:49 -0400

This begins a 2 week WG LC on draft-ietf-i2rs-yang-network-topo-04.txt (9/20
to 10/4) and draft-ietf-i2rs-yang-l3-network-topo-06.txt from 9/20 to 10/3.

https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-network-topo/
https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/
<https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/> 

In considering this draft, the I2RS WG should consider:

1)      Does the implementations of this draft in ODL open source code base
sufficient experience on the Yang drafts?

2)      Does anyone know of other implementations of this model?

3)       Do you believe this Yang model is stable enough to publish and
distribute to yang libraries?

 We did a WG LC in August, but we suspect this got caught in the August
vacation email.  

Sue Hares and Russ White

Co-chairs

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Fri, 23 Sep 2016 15:37:11 +0000

Drafts look good.

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, September 20, 2016 10:09 AM
To: [email-masked]
Cc: Benoit Claise (bclaise) <[email-masked]>; 'Russ White' <[email-masked]>; 'Alia Atlas' <[email-masked]>
Subject: [i2rs] WG LC on draft-ietf-i2rs-yang-network-topo-05.txt extended and draft-ietf-i2rs-yang-l3-network-topo-06.txt (

This begins a 2 week WG LC on draft-ietf-i2rs-yang-network-topo-04.txt (9/20 to 10/4) and draft-ietf-i2rs-yang-l3-network-topo-06.txt from 9/20 to 10/3.

https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/<https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/>
In considering this draft, the I2RS WG should consider:

1)     Does the implementations of this draft in ODL open source code base sufficient experience on the Yang drafts?

3)      Do you believe this Yang model is stable enough to publish and distribute to yang libraries?
 We did a WG LC in August, but we suspect this got caught in the August vacation email.
Sue Hares and Russ White
Co-chairs

---

From: "Xufeng Liu" <[email-masked]>
Date: Tue, 27 Sep 2016 10:31:01 -0400

I think that the documents are stable enough for publication.

Thanks,

- Xufeng

From: i2rs [mailto:[email-masked]] On Behalf Of Eric Voit (evoit)
Sent: Friday, September 23, 2016 11:37 AM
To: Susan Hares <[email-masked]>; [email-masked]
Cc: Benoit Claise (bclaise) <[email-masked]>; 'Russ White' <[email-masked]>;
'Alia Atlas' <[email-masked]>
Subject: Re: [i2rs] WG LC on draft-ietf-i2rs-yang-network-topo-05.txt
extended and draft-ietf-i2rs-yang-l3-network-topo-06.txt (

Drafts look good.

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, September 20, 2016 10:09 AM
To: [email-masked] <mailto:[email-masked]> 
Cc: Benoit Claise (bclaise) <[email-masked] <mailto:[email-masked]> >;
'Russ White' <[email-masked] <mailto:[email-masked]> >; 'Alia Atlas'
<[email-masked] <mailto:[email-masked]> >
Subject: [i2rs] WG LC on draft-ietf-i2rs-yang-network-topo-05.txt extended
and draft-ietf-i2rs-yang-l3-network-topo-06.txt (

Sue Hares and Russ White

Co-chairs

---

From: Giles Heron <[email-masked]>
Date: Tue, 27 Sep 2016 16:43:59 -0700

Agreed.

the base network and topology models are absolutely fundamental and need to be progressed.   The draft has been through a bunch of iterations, and there’s plenty of implementation experience.   The separation of the topology into the separate network and topology models is a good step, as we’ve found in e.g. OpenDaylight that many “topologies” are really more like inventory (so you have lists of nodes, but no links).

The L3 topology is probably the key augment of the base models and again has been through a bunch of iterations, and again we’ve had plenty of implementation experience.  So again we should progress it.

Giles

> On 23 Sep 2016, at 08:37, Eric Voit (evoit) <[email-masked]> wrote:
> 
> Drafts look good.
>  
> From: i2rs [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Susan Hares
> Cc: Benoit Claise (bclaise) <[email-masked] <mailto:[email-masked]>>; 'Russ White' <[email-masked] <mailto:[email-masked]>>; 'Alia Atlas' <[email-masked] <mailto:[email-masked]>>
> https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-network-topo/ <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-network-topo/>
> https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/ <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/>
> _______________________________________________
> i2rs mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/i2rs <https://www.ietf.org/mailman/listinfo/i2rs>

---

From: Nitin Bahadur <[email-masked]>
Date: Tue, 27 Sep 2016 22:18:42 -0700

Support WG LC  (as draft co-author). The fast iteration between theory
(draft) and adoption (ODL) is a good leading indicator for this draft.

 
_______________________________________________ i2rs mailing list
[email-masked] https://www.ietf.org/mailman/listinfo/i2rs

---

From: <[email-masked]>
Date: Tue, 27 Sep 2016 23:11:41 -0700

It probably goes without saying, but I am supporting both drafts as well
(also as coauthor).  

--- Alex

From: i2rs [mailto:[email-masked]] On Behalf Of Nitin Bahadur
Sent: Tuesday, September 27, 2016 10:19 PM
To: 'Susan Hares' <[email-masked]>; [email-masked]
Cc: 'Benoit Claise (bclaise)' <[email-masked]>; 'Russ White'
<[email-masked]>; 'Alia Atlas' <[email-masked]>
Subject: Re: [i2rs] WG LC on draft-ietf-i2rs-yang-network-topo-05.txt
extended and draft-ietf-i2rs-yang-l3-network-topo-06.txt (

 

Sue Hares and Russ White

Co-chairs

_______________________________________________ i2rs mailing list
[email-masked] <mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2rs

---

From: wangzitao <[email-masked]>
Date: Wed, 28 Sep 2016 09:38:25 +0000

I have read these two draft, and yes, I support  this WG LC.

Best Regards!
-Michael

发件人: i2rs [mailto:[email-masked]] 代表 Susan Hares
发送时间: 2016年9月20日 22:09
收件人: [email-masked]
抄送: 'Benoit Claise'; 'Russ White'; 'Alia Atlas'
主题: [i2rs] WG LC on draft-ietf-i2rs-yang-network-topo-05.txt extended and draft-ietf-i2rs-yang-l3-network-topo-06.txt (

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 28 Sep 2016 10:38:20 -0400

<individual contributor hat on> 

Support WG LC.  ODL implementation have improved and matured this draft.  

Sue Hares 

</individual contributor hat off

From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, September 28, 2016 2:12 AM
To: 'Nitin Bahadur'; 'Susan Hares'; [email-masked]
Cc: 'Benoit Claise (bclaise)'; 'Russ White'; 'Alia Atlas'
Subject: RE: [i2rs] WG LC on draft-ietf-i2rs-yang-network-topo-05.txt
extended and draft-ietf-i2rs-yang-l3-network-topo-06.txt (

--- Alex

 

 

Sue Hares and Russ White

Co-chairs

---

From: "Russ White" <[email-masked]>
Date: Wed, 28 Sep 2016 12:54:59 -0400

> Support WG LC.  ODL implementation have improved and matured this draft.

+1 -- support as WG member.

:-)

Russ

---

From: Hariharan Ananthakrishnan <[email-masked]>
Date: Thu, 29 Sep 2016 23:43:22 +0000

Support as co-author.

- Hari

From: i2rs <[email-masked]> on behalf of Susan Hares <[email-masked]>
Date: Tuesday, 20 September 2016 at 07:08
To: "[email-masked]" <[email-masked]>
Cc: 'Benoit Claise' <[email-masked]>, 'Russ White' <[email-masked]>, 'Alia Atlas' <[email-masked]>
Subject: [i2rs] WG LC on draft-ietf-i2rs-yang-network-topo-05.txt extended and draft-ietf-i2rs-yang-l3-network-topo-06.txt (

---

From: "Zhuangyan (Yan)" <[email-masked]>
Date: Fri, 30 Sep 2016 02:40:24 +0000

Support. The model is stable to publish and ready for more applications.

Does anyone know of other implementations of this model?
Yes. We have an extension of this model for DC network application which is also implemented in an ODL project.

The draft for this extension was presented in last meeting and is revised as per feedback  which is available at https://datatracker.ietf.org/doc/draft-zhuang-i2rs-yang-dc-fabric-network-topology/.

Best Regards,

Yan

---

From: wangzitao <[email-masked]>
Date: Fri, 30 Sep 2016 07:45:53 +0000

2)     Does anyone know of other implementations of this model?
The “network model” also be extended and referenced by LIME WG’s connectionless oam model:  https://datatracker.ietf.org/doc/draft-ietf-lime-yang-connectionless-oam/

Best Regards!
-Michael

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 30 Sep 2016 09:53:27 +0000

Support both drafts.

The base network topology model is fundamental for other topology models, and the L3 topology model is an important augmentation to the base model. Both drafts are in good shape.

Best regards,
Jie

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, September 20, 2016 10:09 PM
To: [email-masked]
Cc: 'Benoit Claise' <[email-masked]>; 'Russ White' <[email-masked]>; 'Alia Atlas' <[email-masked]>
Subject: [i2rs] WG LC on draft-ietf-i2rs-yang-network-topo-05.txt extended and draft-ietf-i2rs-yang-l3-network-topo-06.txt (

---

From: Eric Gray <[email-masked]>
Date: Fri, 30 Sep 2016 16:29:25 +0000

I have no issues with publishing both of these drafts.

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 30 Sep 2016 21:06:27 +0000

Support.

Linda Dunbar

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, September 20, 2016 10:09 AM
To: [email-masked]<mailto:[email-masked]>
Cc: 'Benoit Claise' <[email-masked]<mailto:[email-masked]>>; 'Russ White' <[email-masked]<mailto:[email-masked]>>; 'Alia Atlas' <[email-masked]<mailto:[email-masked]>>
Subject: [i2rs] WG LC on draft-ietf-i2rs-yang-network-topo-05.txt extended and draft-ietf-i2rs-yang-l3-network-topo-06.txt (