Subject: [i2rs] AD review of draft-ietf-i2rs-yang-network-topo

From: Alia Atlas <[email-masked]>
Date: Mon, 5 Dec 2016 16:55:16 -0500

As is customary, I have done my AD review
of draft-ietf-i2rs-yang-network-topo-09.  First I would like to thank the
authors, Alex, Jan, Hari, Nitin, Robert, & Xufeng, for their work on a very
nicely written document.

I do see that there are 6 authors.  I am open to hearing why and how each
author has and will continue to be an active participant - including
through AUTH48, but this is higher than the normal limit.

I am requesting that IETF Last Call start and have scheduled this for the
IESG telechat on Jan 5, 2017.

I do have a few minor comments below:

1) Section 5 mentions I-D.draft-acee-rtgwg-yang-rib-extend.  Since this is
an individual draft, it's probably better not to include it as a reference.

2) On p. 25-26, in list link description:  "Layering dependencies on links
in underlay topologies are
          not represented, as the layering information of nodes and of
          termination points is sufficient."  This seems to contradict
earlier text and the exice of the list supporting link that is immediately
after.  Could you please clean up or clarify?

Regards,
Alia

---

From: <[email-masked]>
Date: Mon, 5 Dec 2016 16:35:51 -0800

Hello Alia,

Thank you for your comments.  

Re: 1, we are happy to take the reference out.  We felt that it would be useful to have it for explanatory reasons to delineate it from other efforts, but do not feel strongly about it. 

Re: 2, I am re-reading it and yes, the description is indeed contradictory.  We will take out the corresponding sentence. 

Thanks

--- Alex  

From: Alia Atlas [mailto:[email-masked]] 
Sent: Monday, December 5, 2016 1:55 PM
To: [email-masked]; [email-masked]
Subject: AD review of draft-ietf-i2rs-yang-network-topo

As is customary, I have done my AD review of draft-ietf-i2rs-yang-network-topo-09.  First I would like to thank the authors, Alex, Jan, Hari, Nitin, Robert, & Xufeng, for their work on a very nicely written document.

I do see that there are 6 authors.  I am open to hearing why and how each author has and will continue to be an active participant - including through AUTH48, but this is higher than the normal limit.

I am requesting that IETF Last Call start and have scheduled this for the IESG telechat on Jan 5, 2017.

1) Section 5 mentions I-D.draft-acee-rtgwg-yang-rib-extend.  Since this is an individual draft, it's probably better not to include it as a reference.

2) On p. 25-26, in list link description:  "Layering dependencies on links in underlay topologies are
          not represented, as the layering information of nodes and of
          termination points is sufficient."  This seems to contradict earlier text and the exice of the list supporting link that is immediately after.  Could you please clean up or clarify?

Regards,

Alia

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 6 Dec 2016 09:33:24 -0500

Alex:

The remaining question Alia needs to hear is why and how each author has supported this work. 

Here’s my understanding from our earlier discussions:

1)      Alex – why (main author),  how (editing text and coordinating input), 

2)      Jan -  why (early developer of yang modules (server-side in ODL), how (created initial yang modules) 

3)      Hari – why (early developer of yang modules (client side)), how (created initial yang modules) 

Perhaps you could fill out the same input for the rest of the team: Nitin, Robert, and Xufeng.

I will update the shepherd’s report if you send it to the list. 

Sue  

From: i2rs [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 5, 2016 7:36 PM
To: 'Alia Atlas'; [email-masked]; [email-masked]
Subject: Re: [i2rs] AD review of draft-ietf-i2rs-yang-network-topo

Hello Alia,

Thanks

--- Alex  

Regards,

Alia

---

From: <[email-masked]>
Date: Tue, 13 Dec 2016 23:15:00 -0800

Hi Susan, Alia, 

Apologies for the delay. 

Here is the table regarding the coauthors of the topology model draft:

1)      Alex - main editor of draft, coauthor of initial yang modules 

2)      Jan -  early developer of yang module (server-side in ODL), coauthor of initial yang modules 

3)      Robert – early developer of yang modules and lead in implementation in ODL, coauthor of initial yang modules

4)      Nitin – early developer of yang modules, coauthor of initial yang modules, in part some earlier efforts coming from different origins got merged 

5)      Hari – early developer of yang module implementations (client side), coauthor of initial yang modules 

6)      Xufeng – scrutinization and refinement of important yang module details, derivation of and integration with other topolog yang modules including TE topology, Layer 1 topology, L3 TE topology, and SR topology providing important adjustments in the model for greater robustness 

I sincerely believe that having all six of us listed as authors is justified.  The draft is the result of the collaboration of multiple persons from several independent teams (originally, Jan/Robert/myself were working on this problem in one collaboration, whereas Nitin and Hari had a separate collaboration and Xufeng coming from a different direction still, but we all came together to combine our designs) and coming from very different directions (with controller and ODL perspective in mind, with routing perspective in mind, with TE perspective in mind, with optical perspective in mind) over a long period of time.   In addition, all six of us represent different organizations/companies.  

Thanks

--- Alex 

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, December 6, 2016 6:33 AM
To: [email-masked]; 'Alia Atlas' <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [i2rs] AD review of draft-ietf-i2rs-yang-network-topo

Alex:

Sue  

From: i2rs [mailto:[email-masked]] On Behalf Of [email-masked] <mailto:[email-masked]> 
Sent: Monday, December 5, 2016 7:36 PM
To: 'Alia Atlas'; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> 
Subject: Re: [i2rs] AD review of draft-ietf-i2rs-yang-network-topo

Hello Alia,

Thanks

--- Alex  

From: Alia Atlas [mailto:[email-masked]] 
Sent: Monday, December 5, 2016 1:55 PM
To: [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> 
Subject: AD review of draft-ietf-i2rs-yang-network-topo

Regards,

Alia