Subject: [i2rs] Benjamin Kaduk's No Objection on draft-ietf-i2rs-rib-info-model-15: (with COMMENT)

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 04 Apr 2018 18:37:23 -0700

Benjamin Kaduk has entered the following ballot position for
draft-ietf-i2rs-rib-info-model-15: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-i2rs-rib-info-model/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I share Warren's question (and, IIRC, asked a similar one about
the associated data-model document).

Just one other minor question: in Section 4

   Route programming in the RIB MUST result in a return code that
   contains the following attributes:

   o  Installed - Yes/No (Indicates whether the route got installed in
      the FIB)

   o  Active - Yes/No (Indicates whether a route is fully resolved and
      is a candidate for selection)

   o  Reason - e.g., Not authorized

Is the Reason only relevant when one of the other two is "No"?

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 4 Apr 2018 21:43:07 -0400

Benjamin: 

Thank you for your comments.  The authors work will to clarify this portion. 

As I recall (and my memory may be spotty), the reason was available for both "yes" and "no" in case "yes" it is active, and "no" it is not installed (example - 20 ECMP routes and only 10 get installed).   Nitin may have more details on this RFC. 

Cheerily, Susan Hares

-----Original Message-----
From: Benjamin Kaduk [mailto:[email-masked]] 
Sent: Wednesday, April 4, 2018 9:37 PM
To: The IESG
Cc: [email-masked]; Susan Hares; [email-masked]; [email-masked]; [email-masked]
Subject: Benjamin Kaduk's No Objection on draft-ietf-i2rs-rib-info-model-15: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

I share Warren's question (and, IIRC, asked a similar one about the associated data-model document).

---

From: Nitin Bahadur <[email-masked]>
Date: Thu, 12 Apr 2018 23:19:14 -0700

Hi Benjamin/Sue,

NB> The reason string is indeed not relevant for the success case. The success case is "Installed is TRUE AND Active is TRUE". For everything else a reason will help. It will help the client to know why something was installed but is not active.

    Cheerily, Susan Hares

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 13 Apr 2018 12:00:52 -0400

Nitin: 

Thank you for email.  It really helps the process!

Sue 

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Nitin Bahadur
Sent: Friday, April 13, 2018 2:19 AM
To: Susan Hares; 'Benjamin Kaduk'; 'The IESG'
Cc: [email-masked]; [email-masked];
[email-masked]
Subject: Re: [i2rs] Benjamin Kaduk's No Objection on
draft-ietf-i2rs-rib-info-model-15: (with COMMENT)

Hi Benjamin/Sue,

NB> The reason string is indeed not relevant for the success case. The
success case is "Installed is TRUE AND Active is TRUE". For everything else
a reason will help. It will help the client to know why something was
installed but is not active.

    As I recall (and my memory may be spotty), the reason was available for
both "yes" and "no" in case "yes" it is active, and "no" it is not installed
(example - 20 ECMP routes and only 10 get installed).   Nitin may have more
details on this RFC. 
    
    Cheerily, Susan Hares
    
    -----Original Message-----
    From: Benjamin Kaduk [mailto:[email-masked]] 
    Sent: Wednesday, April 4, 2018 9:37 PM
    To: The IESG
    Cc: [email-masked]; Susan Hares;
[email-masked]; [email-masked]; [email-masked]
    Subject: Benjamin Kaduk's No Objection on
draft-ietf-i2rs-rib-info-model-15: (with COMMENT)

    Please refer to
https://www.ietf.org/iesg/statement/discuss-criteria.html
    for more information about IESG DISCUSS and COMMENT positions.

    
    
    I share Warren's question (and, IIRC, asked a similar one about the
associated data-model document).

    

    

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs