Subject: [i2rs] Ignas Bagdonas' No Objection on draft-ietf-i2rs-rib-info-model-15: (with COMMENT)

From: Ignas Bagdonas <[email-masked]>
Date: Thu, 05 Apr 2018 05:01:17 -0700

Ignas Bagdonas has entered the following ballot position for
draft-ietf-i2rs-rib-info-model-15: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-i2rs-rib-info-model/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

A few nits:

Terminology: rib family vs address family. Address family term is more widely
used in the industry.

VPLS is a subset of L2VPN.

ROUTER_ID usage is orthogonal to router virtualization. MUST restriction for
the domain is factually incorrect - it is typically per source protocol, not
per domain.

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 5 Apr 2018 08:39:05 -0400

Ignas:

Thank you for your comments.  I will check that these are addressed in the next version. 

Cheerily, Susan Hares

-----Original Message-----
From: Ignas Bagdonas [mailto:[email-masked]] 
Sent: Thursday, April 5, 2018 8:01 AM
To: The IESG
Cc: [email-masked]; Susan Hares; [email-masked]; [email-masked]; [email-masked]
Subject: Ignas Bagdonas' No Objection on draft-ietf-i2rs-rib-info-model-15: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

A few nits:

Terminology: rib family vs address family. Address family term is more widely used in the industry.

ROUTER_ID usage is orthogonal to router virtualization. MUST restriction for the domain is factually incorrect - it is typically per source protocol, not per domain.

---

From: Nitin Bahadur <[email-masked]>
Date: Sun, 22 Apr 2018 09:24:41 -0700

Hi Ignas,

  Thanks for the review. Please see NB> below for responses.

    A few nits:

NB> You are right. Updating the draft.

NB> Yes indeed. Given how prevalent VPLS is in the industry now, it was felt necessary to call it out specifically.

 NB> Source protocols (like OSPF) indeed do have their own router-id. In the context of the RIB model, we are calling out ROUTER_ID as an identifier for a virtual router. It will be used by a RIB client to uniquely ID a routing instance (across multiple network devices).