Subject: [i2rs] Suresh Krishnan's No Objection on draft-ietf-i2rs-rib-info-model-15: (with COMMENT)

From: Suresh Krishnan <[email-masked]>
Date: Wed, 04 Apr 2018 22:08:18 -0700

Suresh Krishnan has entered the following ballot position for
draft-ietf-i2rs-rib-info-model-15: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-i2rs-rib-info-model/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

* Section 2.3.

Regarding the OSPF route for 2001:DB8::1/32

Did you mean 2001:DB8::1/128 for the host route? If not, this example is wrong
since 2001:DB8::1/32 expands to 2001:DB8:0000:0000:0000:0000:0000:1/32 ->
2001:DB8::/32 as the route

* Figure 4.

Shouldn't the tunnel-encap and tunnel-decap also loop the packet back into
nexthop processing just like the derived nexthops do?

* Section 6

I would have expected the match type to have some indication about whether it
requires an exact match or LPM (e.g. A MAC route uses an exact match but an
IPv6 route uses LPM). Has the WG discussed this?

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 5 Apr 2018 08:42:42 -0400

Suresh: 

On WG discussions, 

LPM = Longest prefix match?   If so, LPM was discussed. 

I will follow-up with the authors on resolving this in section 6.  Thanks for catching this error. 

Cheerily, Sue 

-----Original Message-----
From: Suresh Krishnan [mailto:[email-masked]] 
Sent: Thursday, April 5, 2018 1:08 AM
To: The IESG
Cc: [email-masked]; Susan Hares; [email-masked]; [email-masked]; [email-masked]
Subject: Suresh Krishnan's No Objection on draft-ietf-i2rs-rib-info-model-15: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

* Section 2.3.

Did you mean 2001:DB8::1/128 for the host route? If not, this example is wrong since 2001:DB8::1/32 expands to 2001:DB8:0000:0000:0000:0000:0000:1/32 ->
2001:DB8::/32 as the route

* Figure 4.

Shouldn't the tunnel-encap and tunnel-decap also loop the packet back into nexthop processing just like the derived nexthops do?

* Section 6

I would have expected the match type to have some indication about whether it requires an exact match or LPM (e.g. A MAC route uses an exact match but an
IPv6 route uses LPM). Has the WG discussed this?

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 5 Apr 2018 10:05:10 -0400

Suresh:

Thank you for catching these errors.  See my comments below.  

Summary: 
Section 2.3 (good catch).  
Section 4 and 6 - I think the document represents the WG consensus.  I will
review the emails, WG documents, and contact previous chairs. 

Susan Hares 

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Suresh Krishnan
Sent: Thursday, April 5, 2018 1:08 AM
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]
Subject: [i2rs] Suresh Krishnan's No Objection on
draft-ietf-i2rs-rib-info-model-15: (with COMMENT)

When responding, please keep the subject line intact and reply to all email
addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

* Section 2.3.

Did you mean 2001:DB8::1/128 for the host route? If not, this example is
wrong since 2001:DB8::1/32 expands to 2001:DB8:0000:0000:0000:0000:0000:1/32
->
2001:DB8::/32 as the route

Sue: Yes - this is an error. 

* Figure 4.

Suresh - I need to check the email list archives and get back to you on this
point.  My recollection was that there was a case where things  people did
not want to automatically loop this  back. However, I cannot bring the
discussion of 3.5 years ago to mind. I will take this as an action item as a
reviewer to try to recreate the discussion.   Thank you for mentioning this
point. It is important to clarify in either case. 

* Section 6

I would have expected the match type to have some indication about whether
it requires an exact match or LPM (e.g. A MAC route uses an exact match but
an
IPv6 route uses LPM). Has the WG discussed this?

The short answer is yes, extensive in early interims, list discussions and
in session.  Can you provide more depth to your questions.  For the early
discussions, I may need to query Alia Atlas and Jeff Haas (previous chairs)
to get the institutional memory on this topic.  (One of the reason I really
want to have this document discussed with Alia Atlas as AD0. 

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs

---

From: Suresh Krishnan <[email-masked]>
Date: Mon, 9 Apr 2018 15:44:23 +0000

Thanks for checking Sue. Hope the 2.3 text will be fixed in the next rev.

Regards
Suresh

On Apr 5, 2018, at 10:05 AM, Susan Hares <[email-masked]<mailto:[email-masked]>> wrote:

Suresh:

Summary:

Susan Hares

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Suresh Krishnan
Sent: Thursday, April 5, 2018 1:08 AM
To: The IESG
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>;
[email-masked]<mailto:[email-masked]>
Subject: [i2rs] Suresh Krishnan's No Objection on
draft-ietf-i2rs-rib-info-model-15: (with COMMENT)

* Section 2.3.

* Figure 4.

* Section 6

_______________________________________________
i2rs mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2rs

---

From: Nitin Bahadur <[email-masked]>
Date: Thu, 12 Apr 2018 22:51:50 -0700

Hi Suresh,

Thanks for the review. Please see NB> below for comments.

NB> Nice catch. Fixing it in next rev.
    
    * Figure 4.

NB> Sue is right that there were some cases where folks did not want the packet to be automatically sent back for lookup. They wanted an explicit specification on what to do with the packet.  I believe the reasoning was there might be L2 processing that needs to be performed after the encap/decap and L2 processing was mainly out of scope of this draft.

    * Section 6

    
NB> Quoting from the grammar

	<ipv4-route> ::= <ip-route-type>
              	     (<destination-ipv4-address> | <source-ipv4-address> |
                    (<destination-ipv4-address> <source-ipv4-address>))
	<destination-ipv4-address> ::= <ipv4-prefix>
  	<source-ipv4-address> ::= <ipv4-prefix>
  	<ipv4-prefix> ::= <IPV4_ADDRESS> <IPV4_PREFIX_LENGTH>

Thus IP addresses have a "prefix length" associated with them indicating a LPM (or exact-match if prefix length is 32). A MAC route is expected to have an exact match. LPM for MAC routes was out of scope.

Thanks
Nitin

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 13 Apr 2018 12:11:37 -0400

Nitin:

Thanks for fixing Suresh's comments.  I've trimmed the text below to text tunnel-encap/decap text and LPM text.  

I will do a deep dive on the tunnel encap/decap on the mail list to see if I can find any additional comments to help your text.  However, I suspect that what you will naturally write will be the best text. 

On the LPM, let's see if Suresh has a suggestion on where to add text.   Again, I'm sure you will do a great job writing up the text. 

Would you remember to send the revised text to Warren and to Ignas.  We could really use their review of the revisions for these two points.   Warren and Ignas have experience with RIBs. 

Sue Hares 

-----Original Message-----
From: Nitin Bahadur [mailto:[email-masked]] 
Sent: Friday, April 13, 2018 1:52 AM
To: Susan Hares; 'Suresh Krishnan'; 'The IESG'
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [i2rs] Suresh Krishnan's No Objection on draft-ietf-i2rs-rib-info-model-15: (with COMMENT)

  Suresh:   

Sue> Could you put this in the draft?  It makes my recollection.  I will be doing a deep dive on the I2RS mail list and presentation today to provide additional test. 

Suresh> 
    * Section 6

    

Sue: This matches my understanding.   If Suresh is confused, others will be.  Let's see if Suresh has a suggestion on where to add text.  Will you follow up with Suresh on this point?