Subject: [i2rs] Yangdoctors early review of draft-ietf-i2rs-yang-l2-network-topology-04

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 02 May 2018 06:32:28 -0700

Reviewer: Ladislav Lhotka
Review result: Ready

This draft and YANG modules contained therein fit into the framework of I2RS
network topology models. I have no substantial comments, from the YANG point of
view this document is ready to be published.

Comments and questions:

1. What is the purpose of the 'flag-type' type and 'flag-identity' identity?
There are no identities derived from the latter.

2. Some descriptions overuse capitalization. For example, instead of 'VLAN
Name' I would suggest 'VLAN name'.

3. An example of an instance document in an appendix would be very helpful.

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 4 May 2018 02:08:37 +0000

Hi Lada, 

Thanks a lot for your review comments. Please see some replies inline:

> -----Original Message-----
> From: Ladislav Lhotka [mailto:[email-masked]]
> Sent: Wednesday, May 02, 2018 9:32 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked];
> [email-masked]
> Subject: Yangdoctors early review of draft-ietf-i2rs-yang-l2-network-topology-04
> 
> network topology models. I have no substantial comments, from the YANG point
> of view this document is ready to be published.
> 
> Comments and questions:
> 

The "flag-type" type is used in the grouping "l2-network-attributes", "l2-node-attributes" and "l2-link-attributes".

While there is no identities derived from the "flag-identity", it is used in the typedef flag-type. Is this OK?

> 2. Some descriptions overuse capitalization. For example, instead of 'VLAN Name'
> I would suggest 'VLAN name'.

Thanks for catching this. Will fix in next revision.

> 3. An example of an instance document in an appendix would be very helpful.

Thanks for your suggestion. We will add an example to the appendix.

Best regards,
Jie

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 04 May 2018 10:04:48 +0200

On Fri, 2018-05-04 at 02:08 +0000, Dongjie (Jimmy) wrote:
> The "flag-type" type is used in the grouping "l2-network-attributes", "l2-
> node-attributes" and "l2-link-attributes".
> 

>From the YANG point of view it is certainly OK. Do you expect other modules to
define identities derived from "flag-identity"?

> Thanks for your suggestion. We will add an example to the appendix.

Thanks, Lada

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 4 May 2018 16:39:18 -0400

Jie and Lada: 

I've recently listened to the I2RS meeting in IETF 101.  

Chris Hopps asked about the notifications in L2.  He was asking about a more
general use of the notification that might be useful in the 

I'm not really sure how to approach responding to his operational request -
since it really impacts all topology models.  My inclination is to push this
draft through into RFC usage, and then to work through a "-bis"
functionality.  

Jie - would you ask the individuals pushing for L2 model if that works for
them. 

Lada - would you ask the Yang doctors if this is the right approach to take.
Of course, this might be easier if we had versioning instead of a model name
change.  

Sue Hares 
-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Dongjie (Jimmy)
Sent: Thursday, May 3, 2018 10:09 PM
To: Ladislav Lhotka; [email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]
Subject: Re: [i2rs] Yangdoctors early review of
draft-ietf-i2rs-yang-l2-network-topology-04

Hi Lada, 

Thanks a lot for your review comments. Please see some replies inline:

> Subject: Yangdoctors early review of 
> draft-ietf-i2rs-yang-l2-network-topology-04
> 
> This draft and YANG modules contained therein fit into the framework 
> of I2RS network topology models. I have no substantial comments, from 
> the YANG point of view this document is ready to be published.
> 
> Comments and questions:
> 

The "flag-type" type is used in the grouping "l2-network-attributes",
"l2-node-attributes" and "l2-link-attributes".

While there is no identities derived from the "flag-identity", it is used in
the typedef flag-type. Is this OK?

> 2. Some descriptions overuse capitalization. For example, instead of 'VLAN
Name'

Best regards,
Jie

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs

---

From: Alexander Clemm <[email-masked]>
Date: Fri, 4 May 2018 21:58:54 +0000

One way to support notifications for topology in a generic way will be through YANG-Push (see https://tools.ietf.org/html/draft-ietf-netconf-yang-push-15).  Configure a subscription for on-change updates against the topology data tree.  That will give applications what they need without the definition of custom notifications (which can of course also still be done).

--- Alex

> From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
> Sent: Friday, May 04, 2018 1:39 PM
> To: Dongjie (Jimmy) <[email-masked]>; 'Ladislav Lhotka' <[email-masked]>
> Cc: [email-masked]; 'Martin Vigoureux' <[email-masked]>
> Subject: Re: [i2rs] Yangdoctors early review of draft-ietf-i2rs-yang-l2-network-
> topology-04
> 
> Jie and Lada:
> 
> I'm not really sure how to approach responding to his operational request - since
> it really impacts all topology models.  My inclination is to push this draft through
> into RFC usage, and then to work through a "-bis"
> functionality.
> 
> Jie - would you ask the individuals pushing for L2 model if that works for them.
>

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 8 May 2018 02:05:55 +0000

Hi Sue, 

I agree Chris's comment is generic and applicable to all topology models, and what Alex suggested could be a solution to it. 

And your proposal looks good to us (coauthors of L2 model).

Best regards,
Jie

> From: Susan Hares [mailto:[email-masked]]
> Sent: Saturday, May 05, 2018 4:39 AM
> Subject: RE: [i2rs] Yangdoctors early review of