Subject: [i2rs] WG LC: draft-ietf-i2rs-yang-l2-network-topology-07.txt

From: "Susan Hares" <[email-masked]>
Date: Fri, 9 Aug 2019 11:42:22 -0400

Greetings: 

This draft on L2 network topology has been reviewed by the I2RS WG 3 times. 

However, in discussion with the ADs it is deemed appropriate to do one more 

WG LC and include any input from rtgwg or grow. 

Please indicate whether you support publication of this document. 

In your comments, please indicate "support" or no "support". 

If you feel there issues that need to be resolved, 

Please indicate whether these issues are editorial, 

Yang syntax, or technical content. 

It would be helpful to indicate whether you know of 

Network deployments or potential network deployments of this draft. 

Cheerily, 

Sue Hares

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 15 Aug 2019 08:21:36 +0000

Support as coauthor.

Best regards,
Jie

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Friday, August 09, 2019 11:42 PM
To: [email-masked]
Cc: [email-masked]
Subject: [i2rs] WG LC: draft-ietf-i2rs-yang-l2-network-topology-07.txt

Greetings:

Cheerily,

Sue Hares

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 15 Aug 2019 16:39:12 +0000

Support,

Linda Dunbar

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Friday, August 09, 2019 11:42 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [i2rs] WG LC: draft-ietf-i2rs-yang-l2-network-topology-07.txt

Greetings:

Cheerily,

Sue Hares

---

From: tom petch <[email-masked]>
Date: Fri, 16 Aug 2019 12:00:26 +0000

Not ready

The text says
    /*Consider udpating this part to make use of
draft-ietf-softwire-iftunnel*/
Well yes, consider it and come to a conclusion otherwise I cannot see
how this is ready to advance.

The YANG module contains many references - good - but they are not in
the I-D references; again, not ready to advance.  I see

4761
4762
6325
6326
7348

802.1ad
802.1ah
802.1Q

IANA considerations references RFC7950 - RFC 6020 is better here as all
that RFC7950 says is go see RFC6020.

OLD

       This version of this YANG module is part of
       draft-ietf-i2rs-yang-l2-network-topo-07;

NEW
       This version of this YANG module is part of
        "RFC XXXX: A YANG Data Model for Layer-2 Network Topologies"

You also have this unsuitable reference twice in the state module

The state module lacks references for the imports

The state module description clause seems misleading; it is only the
state part of a module when NMDA is not supported.

Appendix A - is it Normative?  The customary convention is the
Appendices are not unless stated otherwise and there is no statement
here.

'An Example' does not use the addresses set aside for documentation

What is the closing date for this Last call?

Tom Petch

----- Original Message -----
From: "Susan Hares" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, August 09, 2019 4:42 PM

> Network deployments or potential network deployments of this draft.

------------------------------------------------------------------------
--------

> _______________________________________________
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2rs
>