Subject: Re: [i2rs] I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt

From: Qin Wu <[email-masked]>
Date: Mon, 19 Aug 2019 07:08:17 +0000

v-09 is posted to address Tom's comments.
The diff is:
https://www.ietf.org/rfcdiff?url2=draft-ietf-i2rs-yang-l2-network-topology-09
Becuase datatracker pyang integration tool issue, Data model "ieee802-dot1q-types" can not been found
And imported into the model defined in this draft.

-Qin
-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2019年8月19日 15:04
收件人: [email-masked]
抄送: [email-masked]
主题: I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Interface to the Routing System WG of the IETF.

        Title           : A YANG Data Model for Layer-2 Network Topologies
        Authors         : Jie Dong
                          Xiugang Wei
                          Qin Wu
                          Mohamed Boucadair
                          Anders Liu
	Filename        : draft-ietf-i2rs-yang-l2-network-topology-09.txt
	Pages           : 31
	Date            : 2019-08-19

Abstract:
   This document defines a YANG data model for Layer 2 network
   topologies.

Editorial Note (To be removed by RFC Editor)

   Please update these statements within the document with the RFC
   number to be assigned to this document:

   o  "This version of this YANG module is part of RFC XXXX;"

   o  "RFC XXXX: A YANG Data Model for Layer-2 Network Topologies";

   o  reference: RFC XXXX

   Please update the "revision" date of the YANG module.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topology/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-i2rs-yang-l2-network-topology-09
https://datatracker.ietf.org/doc/html/draft-ietf-i2rs-yang-l2-network-topology-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-i2rs-yang-l2-network-topology-09

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: tom petch <[email-masked]>
Date: Wed, 21 Aug 2019 08:53:20 +0000

Qin

You had a note in -07 about whether or not to import definitions from
draft-ietf-softwire; and now I see that -09 imports definitions from
IEEE 802.1Q.

Um.  Different.

I have seen this before but in an I-D that AFAICT never progressed.

I am uncertain what the implications of this are, in terms of the
evolution of the model, of the YANG language and so on, given the
different philosophies of the IETF and IEEE.  I think that it needs a
wider review than it will get on this list so I will flag this to NETMOD
and perhaps again at IETF Last call.

Tom Petch

----- Original Message -----
From: "Qin Wu" <[email-masked]>
To: <[email-masked]>
Cc: "Susan Hares" <[email-masked]>; "tom petch" <[email-masked]>
Sent: Monday, August 19, 2019 8:08 AM

> v-09 is posted to address Tom's comments.
https://www.ietf.org/rfcdiff?url2=draft-ietf-i2rs-yang-l2-network-topolo
gy-09
> The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topolog
y/
https://datatracker.ietf.org/doc/html/draft-ietf-i2rs-yang-l2-network-to
pology-09
> A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-i2rs-yang-l2-network-topolo
gy-09
>
>
> Please note that it may take a couple of minutes from the time of
submission until the htmlized version and diff are available at
tools.ietf.org.
> Internet-Draft directories: http://www.ietf.org/shadow.html or
ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 21 Aug 2019 09:35:13 -0400

Tom:

Would you like me to check with the NM/OPS AD as well on this point?  They
may have an agreement with the IEEE folks on yang models. 

Cheerily, Sue 

-----Original Message-----
From: tom petch [mailto:[email-masked]] 
Sent: Wednesday, August 21, 2019 4:53 AM
To: Qin Wu; [email-masked]
Cc: Susan Hares
Subject: Re: I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt

Qin

You had a note in -07 about whether or not to import definitions from
draft-ietf-softwire; and now I see that -09 imports definitions from IEEE
802.1Q.

Um.  Different.

I am uncertain what the implications of this are, in terms of the evolution
of the model, of the YANG language and so on, given the different
philosophies of the IETF and IEEE.  I think that it needs a wider review
than it will get on this list so I will flag this to NETMOD and perhaps
again at IETF Last call.

Tom Petch

---

From: tom petch <[email-masked]>
Date: Wed, 21 Aug 2019 16:37:37 +0000

----- Original Message -----
From: "Susan Hares" <[email-masked]>
Sent: Wednesday, August 21, 2019 2:35 PM

Tom:

Would you like me to check with the NM/OPS AD as well on this point?
They
may have an agreement with the IEEE folks on yang models.

<tp>

Sue

Yes please.

I have posted to Netmod where Rob Wilton thinks that it is fine and
copied it to Scott Mansfield.  My unease is rather vague that the IETF
and IEEE may take separate paths, on YANG, at some point. I see this not
as technical, where IEEE clearly have the skills in 802, but rather as
political or management, noting that the tools do not cope with this, as
Qin has found, that the module does not appear in the IANA registry (and
cannot from 802.1Q as it is RFC Required), that Rob sees the reference
as 801.1Qcp and not 802.1Q and so on.  We are making the IETF dependent
on something we have no control and little influence over.

I would like an AD to say that they can see the issues and are content
that there will be no problem in future (I may turn round in five years
time and say 'I told you so' but that is business as usual, for me).

Tom Petch

Cheerily, Sue

-----Original Message-----
From: tom petch [mailto:[email-masked]]
Sent: Wednesday, August 21, 2019 4:53 AM
To: Qin Wu; [email-masked]
Cc: Susan Hares

Qin

IEEE
802.1Q.

Um.  Different.

evolution

Tom Petch

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 21 Aug 2019 17:05:38 +0000

Hi Tom,

I've no issues with Sue checking with the ADs, but it might be helpful to point out:
 - There is already a regular IEEE/IETF liaison meeting that invariable includes discussion on YANG issues.  The sub-interface VLAN YANG model was part of this meeting for several years (due to technology overlap).
 - The VLAN definitions are in ieee802-dot1q-types.yang because (i) that is what we asked them to do, and (ii) they own the technology, and want to maintain control over it.
 - Generally, I think that IEEE and IETF currently have good form working together.  Of course, that could change in the future, but I suspect that if the IEEE decided to completely ditch YANG then I would expect them to be willing to find a solution for ieee802-dot1q-types.yang as well.

Also looking at this from the other direction, if we want to redefine these types then I think that we would risk slowing down the draft to get permission from the IEEE 802.1 WG that they are happy for us to redefine these types (my initial instinct from my previous interactions is that IEEE 802.1 WG would probably not be happy - although of course I do not and cannot speak for them!)

Thanks,
Rob

> From: i2rs <[email-masked]> On Behalf Of tom petch
> Sent: 21 August 2019 17:38
> To: Susan Hares <[email-masked]>; 'Qin Wu' <[email-masked]>;
> [email-masked]
> Subject: Re: [i2rs] I-D Action: draft-ietf-i2rs-yang-l2-network-topology-
> 09.txt
> 
> I have posted to Netmod where Rob Wilton thinks that it is fine and copied
> it to Scott Mansfield.  My unease is rather vague that the IETF and IEEE
> may take separate paths, on YANG, at some point. I see this not as
> technical, where IEEE clearly have the skills in 802, but rather as
> cannot from 802.1Q as it is RFC Required), that Rob sees the reference as
> 801.1Qcp and not 802.1Q and so on.  We are making the IETF dependent on
> something we have no control and little influence over.
> 
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2rs

---

From: Susan Hares <[email-masked]>
Date: Wed, 21 Aug 2019 19:13:54 -0400

RobI knew about all these efforts with IEEE.  My suggested approach to Qin aligns with yours.  However I am glad to talk to ADs to check Sent via the Samsung Galaxy S7 edge, an AT&T 4G LTE smartphone
-------- Original message --------From: "Rob Wilton (rwilton)" <[email-masked]> Date: 8/21/19  1:05 PM  (GMT-05:00) To: tom petch <[email-masked]>, Susan Hares <[email-masked]>, 'Qin Wu' <[email-masked]>, [email-masked] Subject: RE: I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt Hi Tom,I've no issues with Sue checking with the ADs, but it might be helpful to point out: - There is already a regular IEEE/IETF liaison meeting that invariable includes discussion on YANG issues.  The sub-interface VLAN YANG model was part of this meeting for several years (due to technology overlap). - The VLAN definitions are in ieee802-dot1q-types.yang because (i) that is what we asked them to do, and (ii) they own the technology, and want to maintain control over it. - Generally, I think that IEEE and IETF currently have good form working together.  Of course, that could change in the future, but I suspect that if the IEEE decided to completely ditch YANG then I would expect them to be willing to find a solution for ieee802-dot1q-types.yang as well.Also looking at this from the other direction, if we want to redefine these types then I think that we would risk slowing down the draft to get permission from the IEEE 802.1 WG that they are happy for us to redefine these types (my initial instinct from my previous interactions is that IEEE 802.1 WG would probably not be happy - although of course I do not and cannot speak for them!)Thanks,Rob> -----Original Message-----> From: i2rs <[email-masked]> On Behalf Of tom petch> Sent: 21 August 2019 17:38> To: Susan Hares <[email-masked]>; 'Qin Wu' <[email-masked]>;> [email-masked]> Subject: Re: [i2rs] I-D Action: draft-ietf-i2rs-yang-l2-network-topology-> 09.txt> > ----- Original Message -----> From: "Susan Hares" <[email-masked]>> Sent: Wednesday, August 21, 2019 2:35 PM> > Tom:> > Would you like me to check with the NM/OPS AD as well on this point?> They> may have an agreement with the IEEE folks on yang models.> > <tp>> > Sue> > Yes please.> > I have posted to Netmod where Rob Wilton thinks that it is fine and copied> it to Scott Mansfield.  My unease is rather vague that the IETF and IEEE> may take separate paths, on YANG, at some point. I see this not as> technical, where IEEE clearly have the skills in 802, but rather as> political or management, noting that the tools do not cope with this, as> Qin has found, that the module does not appear in the IANA registry (and> cannot from 802.1Q as it is RFC Required), that Rob sees the reference as> 801.1Qcp and not 802.1Q and so on.  We are making the IETF dependent on> something we have no control and little influence over.> > I would like an AD to say that they can see the issues and are content> that there will be no problem in future (I may turn round in five years> time and say 'I told you so' but that is business as usual, for me).> > Tom Petch> > Cheerily, Sue> > -----Original Message-----> From: tom petch [mailto:[email-masked]]> Sent: Wednesday, August 21, 2019 4:53 AM> To: Qin Wu; [email-masked]> Cc: Susan Hares> > Qin> > You had a note in -07 about whether or not to import definitions from> draft-ietf-softwire; and now I see that -09 imports definitions from IEEE> 802.1Q.> > Um.  Different.> > I have seen this before but in an I-D that AFAICT never progressed.> > I am uncertain what the implications of this are, in terms of the> evolution of the model, of the YANG language and so on, given the> different philosophies of the IETF and IEEE.  I think that it needs a> wider review than it will get on this list so I will flag this to NETMOD> and perhaps again at IETF Last call.> > Tom Petch> > > ----- Original Message -----> From: "Qin Wu" <[email-masked]>> To: <[email-masked]>> Cc: "Susan Hares" <[email-masked]>; "tom petch" <[email-masked]>> Sent: Monday, August 19, 2019 8:08 AM> > > v-09 is posted to address Tom's comments.> > The diff is:> >> https://www.ietf.org/rfcdiff?url2=draft-ietf-i2rs-yang-l2-network-topolo> gy-09> > Becuase datatracker pyang integration tool issue, Data model> "ieee802-dot1q-types" can not been found> > And imported into the model defined in this draft.> >> > -Qin> > -----邮件原件-----> > 发件人: I-D-Announce [mailto:[email-masked]] 代表> [email-masked]> > 发送时间: 2019年8月19日 15:04> > 收件人: [email-masked]> > 抄送: [email-masked]> > 主题: I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt> >> >> > A New Internet-Draft is available from the on-line Internet-Drafts> directories.> > This draft is a work item of the Interface to the Routing System WG of> the IETF.> >> >         Title           : A YANG Data Model for Layer-2 Network> Topologies> >         Authors         : Jie Dong> >                           Xiugang Wei> >                           Qin Wu> >                           Mohamed Boucadair> >                           Anders Liu> > Filename        : draft-ietf-i2rs-yang-l2-network-topology-09.txt> > Pages           : 31> > Date            : 2019-08-19> >> > Abstract:> >    This document defines a YANG data model for Layer 2 network> >    topologies.> >> > Editorial Note (To be removed by RFC Editor)> >> >    Please update these statements within the document with the RFC> >    number to be assigned to this document:> >> >    o  "This version of this YANG module is part of RFC XXXX;"> >> >    o  "RFC XXXX: A YANG Data Model for Layer-2 Network Topologies";> >> >    o  reference: RFC XXXX> >> >    Please update the "revision" date of the YANG module.> >> >> > The IETF datatracker status page for this draft is:> >> https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topolog> y/> >> > There are also htmlized versions available at:> >> https://tools.ietf.org/html/draft-ietf-i2rs-yang-l2-network-topology-09> >> https://datatracker.ietf.org/doc/html/draft-ietf-i2rs-yang-l2-network-to> pology-09> >> > A diff from the previous version is available at:> >> https://www.ietf.org/rfcdiff?url2=draft-ietf-i2rs-yang-l2-network-topolo> gy-09> >> >> > Please note that it may take a couple of minutes from the time of> submission until the htmlized version and diff are available at> tools.ietf.org.> >> > Internet-Drafts are also available by anonymous FTP at:> > ftp://ftp.ietf.org/internet-drafts/> >> > _______________________________________________> > I-D-Announce mailing list> > [email-masked]> > https://www.ietf.org/mailman/listinfo/i-d-announce> > Internet-Draft directories: http://www.ietf.org/shadow.html or> ftp://ftp.ietf.org/ietf/1shadow-sites.txt> >> > > _______________________________________________> i2rs mailing list> [email-masked]> https://www.ietf.org/mailman/listinfo/i2rs

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 21 Aug 2019 19:28:42 -0400

Rob:

You and I are aligned our opinions of the correct approach and what I need to chat with the ADs about. 

However, as a chair my responsibility is to grease the wheels of progress by checking with the ADs before we send in the document. 

Dutifully  Sue 

-----Original Message-----
From: Rob Wilton (rwilton) [mailto:[email-masked]] 
Sent: Wednesday, August 21, 2019 1:06 PM
To: tom petch; Susan Hares; 'Qin Wu'; [email-masked]
Subject: RE: I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt

Hi Tom,

Thanks,
Rob

> Subject: Re: [i2rs] I-D Action: 
> draft-ietf-i2rs-yang-l2-network-topology-
> 09.txt
> 
> and IEEE may take separate paths, on YANG, at some point. I see this 
> not as technical, where IEEE clearly have the skills in 802, but 
> rather as political or management, noting that the tools do not cope 
> with this, as Qin has found, that the module does not appear in the 
> IANA registry (and cannot from 802.1Q as it is RFC Required), that Rob 
> sees the reference as 801.1Qcp and not 802.1Q and so on.  We are 
> making the IETF dependent on something we have no control and little influence over.
> 
> that there will be no problem in future (I may turn round in five 
> years time and say 'I told you so' but that is business as usual, for me).
> 
> Tom Petch
> 
> Cheerily, Sue
> 
> wider review than it will get on this list so I will flag this to 
> NETMOD and perhaps again at IETF Last call.
> 
> Tom Petch
> 
> 
> > This draft is a work item of the Interface to the Routing System WG 
> > of
> the IETF.
> >

---

From: tom petch <[email-masked]>
Date: Fri, 23 Aug 2019 12:02:21 +0000

----- Original Message -----
From: "Rob Wilton (rwilton)" <[email-masked]>
Sent: Wednesday, August 21, 2019 6:05 PM

>  - There is already a regular IEEE/IETF liaison meeting that
invariable includes discussion on YANG issues.  The sub-interface VLAN
YANG model was part of this meeting for several years (due to technology
overlap).
>  - The VLAN definitions are in ieee802-dot1q-types.yang because (i)
that is what we asked them to do, and (ii) they own the technology, and
want to maintain control over it.

Rob

Sounds good as long as people know about it and know what to do.

VLAN ID appears in many YANG I-D, in such as CCAMP and BESS.  CCAMP have
a types module which defines VLAN ID.  I see a comment in the model
about overlap with I2RS and a question as to whether they should import
the I2RS definition so it seems that they know of the I2RS work but
would seem ignorant - like me - of any  activity by the IEEE in this
area.

It is fine for the IEEE to want ownership of their technology, as the
IETF wants ownership of YANG and base definitions of types and models,
but that brings a responsibility to liaise with others what is
happening.  I often see this happening with ITU-T but not with IEEE.  It
may be that the IEEE is communicating with the IETF and the failure is
with the IETF in disseminating the information but to me there is a
failure, of different WG, different AD, reinventing the wheel which may
be fine if it is the IETF's wheel but perhaps not when it is another
SDO.

And there are still practical issues with YANG models of another SDO of
tools that give validation failures, modules not registered and so on.

Tom Petch

>  - Generally, I think that IEEE and IETF currently have good form
working together.  Of course, that could change in the future, but I
suspect that if the IEEE decided to completely ditch YANG then I would
expect them to be willing to find a solution for
ieee802-dot1q-types.yang as well.
>
> Also looking at this from the other direction, if we want to redefine
these types then I think that we would risk slowing down the draft to
get permission from the IEEE 802.1 WG that they are happy for us to
redefine these types (my initial instinct from my previous interactions
is that IEEE 802.1 WG would probably not be happy - although of course I
do not and cannot speak for them!)
> > I have posted to Netmod where Rob Wilton thinks that it is fine and
copied
> > that there will be no problem in future (I may turn round in five
years
IEEE
> > wider review than it will get on this list so I will flag this to
NETMOD
> > > This draft is a work item of the Interface to the Routing System
WG of

---

From: tom petch <[email-masked]>
Date: Fri, 23 Aug 2019 16:39:09 +0000

Qin

I said that I might look some more and I have.

I still think that you need references for 802.1ad and 802.1ah.  It is
not a question of whether or not they are imported, it is where does the
reader go to find out more about e.g. QinQ and that needs nailing down
to a specific document, and in the case of the IEEE, that needs a date,
as you give for 802.1Q.

Talking of which, I find that Rob imports that IEEE module from a
different document; 802.1Qcp; um.

And, in the same vein, I would like a reference for LLDP.

/defned/defined/

leaf rate
what are the units?

        leaf maximum-frame-size {
what is a frame, what headers are included and what not?  This is a
fraught topic

/ternimation point/termination point/

     leaf vlan-name {
any constraints on length or character set?  I like them although am
conscious that some YANG doctors do not.

     leaf encapsulation {
the description exceeds the permissible line length for an RFC

          type enumeration {
            enum in-use {
             value 0;
again a personal preference - I like to see zero kept for a special
purpose (e.g. cannot be determined) unless there is a strong reason to
use it (e.g. it is what the protocol has been using for years)

Tom Petch

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 27 Aug 2019 13:23:01 +0000

Hi Tom,

Please see inline ...

> Sent: 23 August 2019 17:39
> To: Qin Wu <[email-masked]>; [email-masked]
> Cc: Susan Hares <[email-masked]>
> I still think that you need references for 802.1ad and 802.1ah.  It is not
> a question of whether or not they are imported, it is where does the
> reader go to find out more about e.g. QinQ and that needs nailing down to
> a specific document, and in the case of the IEEE, that needs a date, as
> you give for 802.1Q.
> 
[RW] 
802.1Qcp (https://standards.ieee.org/standard/802_1Qcp-2018.html) is the amendment to 802.1Q-2018 (https://standards.ieee.org/standard/802_1Q-2018.html) that defines some bridging YANG models and the ieee802-dot1q-types.yang YANG models.

I've emailed the relevant folks at IEEE to ask what the correct reference is, and then presumably we can be consistent for all RFCs.

Thanks,
Rob

> purpose (e.g. cannot be determined) unless there is a strong reason to use
> it (e.g. it is what the protocol has been using for years)
> 
> Tom Petch
>

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 27 Aug 2019 15:14:02 +0000

Hi Tom, Qin,

> From: Rob Wilton (rwilton)
> Sent: 27 August 2019 14:23
> To: tom petch <[email-masked]>; Qin Wu <[email-masked]>;
> [email-masked]
> > not a question of whether or not they are imported, it is where does
> > the reader go to find out more about e.g. QinQ and that needs nailing
> > down to a specific document, and in the case of the IEEE, that needs a
> > date, as you give for 802.1Q.
> >
> 802.1Qcp (https://standards.ieee.org/standard/802_1Qcp-2018.html) is the
> amendment to 802.1Q-2018 (https://standards.ieee.org/standard/802_1Q-
> 2018.html) that defines some bridging YANG models and the ieee802-dot1q-
> types.yang YANG models.
> 
> I've emailed the relevant folks at IEEE to ask what the correct reference
> is, and then presumably we can be consistent for all RFCs.

[RW]
The conclusion from the IEEE 802 YANG folks (on email, and confirmed on the IEEE Yangsters call today) is that the reference should be to "IEEE Std 802.1Qcp-2018".

Thanks,
Rob