Subject: [i2rs] I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt

From: [email-masked]
Date: Mon, 19 Aug 2019 00:03:35 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Interface to the Routing System WG of the IETF.

        Title           : A YANG Data Model for Layer-2 Network Topologies
        Authors         : Jie Dong
                          Xiugang Wei
                          Qin Wu
                          Mohamed Boucadair
                          Anders Liu
	Filename        : draft-ietf-i2rs-yang-l2-network-topology-09.txt
	Pages           : 31
	Date            : 2019-08-19

Abstract:
   This document defines a YANG data model for Layer 2 network
   topologies.

Editorial Note (To be removed by RFC Editor)

   Please update these statements within the document with the RFC
   number to be assigned to this document:

   o  "This version of this YANG module is part of RFC XXXX;"

   o  "RFC XXXX: A YANG Data Model for Layer-2 Network Topologies";

   o  reference: RFC XXXX

   Please update the "revision" date of the YANG module.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topology/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-i2rs-yang-l2-network-topology-09
https://datatracker.ietf.org/doc/html/draft-ietf-i2rs-yang-l2-network-topology-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-i2rs-yang-l2-network-topology-09

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Qin Wu <[email-masked]>
Date: Wed, 21 Aug 2019 09:23:45 +0000

Good, that is my initial intent, i.e., try to reuse everything that has already been defined somewhere else.

-Qin
-----邮件原件-----
发件人: Rob Wilton (rwilton) [mailto:[email-masked]] 
发送时间: 2019年8月21日 17:18
收件人: Qin Wu <[email-masked]>; tom petch <[email-masked]>; [email-masked]
抄送: Susan Hares <[email-masked]>
主题: RE: I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt

Hi Qin,

I think that you should use ieee802-dot1q-types.yang.

Similarly, if required, I would expect IEEE to use an IP address type defined by an IETF YANG types module rather than define their own version ...

Thanks,
Rob

-----Original Message-----
From: i2rs <[email-masked]> On Behalf Of Qin Wu
Sent: 21 August 2019 10:02
To: tom petch <[email-masked]>; [email-masked]
Cc: Susan Hares <[email-masked]>
Subject: Re: [i2rs] I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt

Hi, Tom:
Yes, I am also not sure whether I should reference ieee802-dot1q-types for vlan type definition.
If you see this as an issue, I am fine with falling back to the previous version and remove reference to ieee802-dot1q-types And define vlan type in ietf-l2-topology.yang as follows:
"
    typedef vlan {
      type uint16 {
        range "1..4094";
      }
      description "Virual LAN using 802.1Q";
    }
"

-Qin
-----邮件原件-----
发件人: tom petch [mailto:[email-masked]]
发送时间: 2019年8月21日 16:53
收件人: Qin Wu <[email-masked]>; [email-masked]
抄送: Susan Hares <[email-masked]>
主题: Re: I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt

Qin

You had a note in -07 about whether or not to import definitions from draft-ietf-softwire; and now I see that -09 imports definitions from IEEE 802.1Q.

Um.  Different.

I have seen this before but in an I-D that AFAICT never progressed.

I am uncertain what the implications of this are, in terms of the evolution of the model, of the YANG language and so on, given the different philosophies of the IETF and IEEE.  I think that it needs a wider review than it will get on this list so I will flag this to NETMOD and perhaps again at IETF Last call.

Tom Petch

----- Original Message -----
From: "Qin Wu" <[email-masked]>
To: <[email-masked]>
Cc: "Susan Hares" <[email-masked]>; "tom petch" <[email-masked]>
Sent: Monday, August 19, 2019 8:08 AM

> v-09 is posted to address Tom's comments.
> The diff is:
>
https://www.ietf.org/rfcdiff?url2=draft-ietf-i2rs-yang-l2-network-topolo
gy-09
> Becuase datatracker pyang integration tool issue, Data model
"ieee802-dot1q-types" can not been found
> And imported into the model defined in this draft.
>
> -Qin
> -----邮件原件-----
> 发件人: I-D-Announce [mailto:[email-masked]] 代表
[email-masked]
> 发送时间: 2019年8月19日 15:04
> 收件人: [email-masked]
> 抄送: [email-masked]
> 主题: I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt
>
>
https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topolog
y/
https://datatracker.ietf.org/doc/html/draft-ietf-i2rs-yang-l2-network-to
pology-09
> A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-i2rs-yang-l2-network-topolo
gy-09
>
>
> Please note that it may take a couple of minutes from the time of
submission until the htmlized version and diff are available at tools.ietf.org.
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html or
ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs

---

From: Qin Wu <[email-masked]>
Date: Mon, 26 Aug 2019 12:51:43 +0000

Thanks Tom for follow up comments, please see my reply inline below.
-----邮件原件-----
发件人: tom petch [mailto:[email-masked]] 
发送时间: 2019年8月24日 0:39
收件人: Qin Wu <[email-masked]>; [email-masked]
抄送: Susan Hares <[email-masked]>
主题: Re: I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt

Qin

I said that I might look some more and I have.

I still think that you need references for 802.1ad and 802.1ah.  It is not a question of whether or not they are imported, it is where does the reader go to find out more about e.g. QinQ and that needs nailing down to a specific document, and in the case of the IEEE, that needs a date, as you give for 802.1Q.

Talking of which, I find that Rob imports that IEEE module from a different document; 802.1Qcp; um.

[Qin]: Okay, will add all these IEEE related references.
And, in the same vein, I would like a reference for LLDP.

[Qin]:I think it is IEEE 802.1AB and will add.
/defned/defined/
[Qin]: Thanks.
leaf rate
what are the units?
[Qin]: We select Mbps as units and will add.

        leaf maximum-frame-size {
what is a frame, what headers are included and what not?  This is a fraught topic

[Qin]: It is layer 2 frame, it could be Ethernet frame, it could be PPP frame, they are all layer 2 frame.

/ternimation point/termination point/

[Qin]: Fixed, thanks.
     leaf vlan-name {
any constraints on length or character set?  I like them although am conscious that some YANG doctors do not.
[Qin]:Good point, the constraint is 32 characters and will length constraint, thanks.
     leaf encapsulation {
the description exceeds the permissible line length for an RFC
[Qin]:Fixed, thanks.
          type enumeration {
            enum in-use {
             value 0;
again a personal preference - I like to see zero kept for a special purpose (e.g. cannot be determined) unless there is a strong reason to use it (e.g. it is what the protocol has been using for years)
[Qin]:Good, I will skip value 0, thanks!

Tom Petch

----- Original Message -----
From: "Qin Wu" <[email-masked]>
Sent: Monday, August 19, 2019 8:08 AM

[email-masked]

---

From: Qin Wu <[email-masked]>
Date: Wed, 28 Aug 2019 06:57:05 +0000

Rob, Thanks for the update.

-Qin
-----邮件原件-----
发件人: i2rs [mailto:[email-masked]] 代表 Rob Wilton (rwilton)
发送时间: 2019年8月27日 23:14
收件人: tom petch <[email-masked]>; Qin Wu <[email-masked]>; [email-masked]
抄送: Susan Hares <[email-masked]>
主题: Re: [i2rs] I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt

Hi Tom, Qin,

> From: Rob Wilton (rwilton)
> Sent: 27 August 2019 14:23
> To: tom petch <[email-masked]>; Qin Wu <[email-masked]>; 
> [email-masked]
> Subject: RE: I-D Action: 
> draft-ietf-i2rs-yang-l2-network-topology-09.txt
> 
> Hi Tom,
> 
> Please see inline ...
> 
> > From: i2rs <[email-masked]> On Behalf Of tom petch
> > Sent: 23 August 2019 17:39
> > To: Qin Wu <[email-masked]>; [email-masked]
> > Subject: Re: [i2rs] I-D Action:
> > draft-ietf-i2rs-yang-l2-network-topology-
> > 09.txt
> >
> > Qin
> >
> > I still think that you need references for 802.1ad and 802.1ah.  It 
> > is not a question of whether or not they are imported, it is where 
> > does the reader go to find out more about e.g. QinQ and that needs 
> > nailing down to a specific document, and in the case of the IEEE, 
> > that needs a date, as you give for 802.1Q.
> >
> [RW]
> 802.1Qcp (https://standards.ieee.org/standard/802_1Qcp-2018.html) is 
> the amendment to 802.1Q-2018 
> (https://standards.ieee.org/standard/802_1Q-
> 2018.html) that defines some bridging YANG models and the 
> ieee802-dot1q- types.yang YANG models.
> 
> I've emailed the relevant folks at IEEE to ask what the correct 
> reference is, and then presumably we can be consistent for all RFCs.

[RW]
The conclusion from the IEEE 802 YANG folks (on email, and confirmed on the IEEE Yangsters call today) is that the reference should be to "IEEE Std 802.1Qcp-2018".

Thanks,
Rob

> > again a personal preference - I like to see zero kept for a special 
> > purpose (e.g. cannot be determined) unless there is a strong reason 
> > to use it (e.g. it is what the protocol has been using for years)
> >
> > Tom Petch
> >
> > https://www.ietf.org/rfcdiff?url2=draft-ietf-i2rs-yang-l2-network-to
> > po
> > lo
> > gy-09
> > > This draft is a work item of the Interface to the Routing System 
> > > WG of
> > the IETF.
> > >
> > https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-top
> > ol
> > og
> > y/
> > >
> > https://tools.ietf.org/html/draft-ietf-i2rs-yang-l2-network-topology
> > -0
> > 9
> > >
> > https://datatracker.ietf.org/doc/html/draft-ietf-i2rs-yang-l2-networ
> > k-
> > to
> > pology-09
> > >
> > https://www.ietf.org/rfcdiff?url2=draft-ietf-i2rs-yang-l2-network-to
> > po
> > lo
> > gy-09
> > >
> > >