Subject: Re: [i2rs] I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt

From: Qin Wu <[email-masked]>
Date: Wed, 21 Aug 2019 09:02:11 +0000

Hi, Tom:
Yes, I am also not sure whether I should reference ieee802-dot1q-types for vlan type definition.
If you see this as an issue, I am fine with falling back to the previous version and remove reference to ieee802-dot1q-types
And define vlan type in ietf-l2-topology.yang as follows:
"
    typedef vlan {
      type uint16 {
        range "1..4094";
      }
      description "Virual LAN using 802.1Q";
    }
"

-Qin
-----邮件原件-----
发件人: tom petch [mailto:[email-masked]] 
发送时间: 2019年8月21日 16:53
收件人: Qin Wu <[email-masked]>; [email-masked]
抄送: Susan Hares <[email-masked]>
主题: Re: I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt

Qin

You had a note in -07 about whether or not to import definitions from draft-ietf-softwire; and now I see that -09 imports definitions from IEEE 802.1Q.

Um.  Different.

I have seen this before but in an I-D that AFAICT never progressed.

I am uncertain what the implications of this are, in terms of the evolution of the model, of the YANG language and so on, given the different philosophies of the IETF and IEEE.  I think that it needs a wider review than it will get on this list so I will flag this to NETMOD and perhaps again at IETF Last call.

Tom Petch

----- Original Message -----
From: "Qin Wu" <[email-masked]>
To: <[email-masked]>
Cc: "Susan Hares" <[email-masked]>; "tom petch" <[email-masked]>
Sent: Monday, August 19, 2019 8:08 AM

> v-09 is posted to address Tom's comments.
> The diff is:
>
https://www.ietf.org/rfcdiff?url2=draft-ietf-i2rs-yang-l2-network-topolo
gy-09
> Becuase datatracker pyang integration tool issue, Data model
"ieee802-dot1q-types" can not been found
> And imported into the model defined in this draft.
>
> -Qin
> -----邮件原件-----
> 发件人: I-D-Announce [mailto:[email-masked]] 代表
[email-masked]
> 发送时间: 2019年8月19日 15:04
> 收件人: [email-masked]
> 抄送: [email-masked]
> 主题: I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt
>
>
> A New Internet-Draft is available from the on-line Internet-Drafts
directories.
> This draft is a work item of the Interface to the Routing System WG of
the IETF.
>
>         Title           : A YANG Data Model for Layer-2 Network
Topologies
>         Authors         : Jie Dong
>                           Xiugang Wei
>                           Qin Wu
>                           Mohamed Boucadair
>                           Anders Liu
> Filename        : draft-ietf-i2rs-yang-l2-network-topology-09.txt
> Pages           : 31
> Date            : 2019-08-19
>
> Abstract:
>    This document defines a YANG data model for Layer 2 network
>    topologies.
>
> Editorial Note (To be removed by RFC Editor)
>
>    Please update these statements within the document with the RFC
>    number to be assigned to this document:
>
>    o  "This version of this YANG module is part of RFC XXXX;"
>
>    o  "RFC XXXX: A YANG Data Model for Layer-2 Network Topologies";
>
>    o  reference: RFC XXXX
>
>    Please update the "revision" date of the YANG module.
>
>
> The IETF datatracker status page for this draft is:
>
https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topolog
y/
>
> There are also htmlized versions available at:
>
https://tools.ietf.org/html/draft-ietf-i2rs-yang-l2-network-topology-09
https://datatracker.ietf.org/doc/html/draft-ietf-i2rs-yang-l2-network-to
pology-09
>
> A diff from the previous version is available at:
>
https://www.ietf.org/rfcdiff?url2=draft-ietf-i2rs-yang-l2-network-topolo
gy-09
>
>
> Please note that it may take a couple of minutes from the time of
submission until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html or
ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 21 Aug 2019 09:18:11 +0000

Hi Qin,

I think that you should use ieee802-dot1q-types.yang.

Similarly, if required, I would expect IEEE to use an IP address type defined by an IETF YANG types module rather than define their own version ...

Thanks,
Rob

-----Original Message-----
From: i2rs <[email-masked]> On Behalf Of Qin Wu
Sent: 21 August 2019 10:02
To: tom petch <[email-masked]>; [email-masked]
Cc: Susan Hares <[email-masked]>
Subject: Re: [i2rs] I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt

Hi, Tom:
Yes, I am also not sure whether I should reference ieee802-dot1q-types for vlan type definition.
If you see this as an issue, I am fine with falling back to the previous version and remove reference to ieee802-dot1q-types And define vlan type in ietf-l2-topology.yang as follows:
"
    typedef vlan {
      type uint16 {
        range "1..4094";
      }
      description "Virual LAN using 802.1Q";
    }
"

-Qin
-----邮件原件-----
发件人: tom petch [mailto:[email-masked]]
发送时间: 2019年8月21日 16:53
收件人: Qin Wu <[email-masked]>; [email-masked]
抄送: Susan Hares <[email-masked]>
主题: Re: I-D Action: draft-ietf-i2rs-yang-l2-network-topology-09.txt

Qin

Um.  Different.

Tom Petch

----- Original Message -----
From: "Qin Wu" <[email-masked]>
To: <[email-masked]>
Cc: "Susan Hares" <[email-masked]>; "tom petch" <[email-masked]>
Sent: Monday, August 19, 2019 8:08 AM

[email-masked]
directories.
the IETF.
Topologies

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs