Subject: [i2rs] Mail regarding draft-ietf-i2rs-yang-l3-topology: Modelling of L3 links supported by a L2 broadcast network

From: Stephen Cheng <[email-masked]>
Date: Wed, 23 Oct 2019 03:46:19 +0000

Authors of RFC 8346,

I have a few questions regarding RFC 8346, and would appreciate your illumination.

  1.  Is RFC 8346 ietf-l3-topology intended to cover modelling of L3 links that is supported by a L2 broadcast network (such as an Ethernet network)?
  2.  If so, would it be correct to model the L3 connection between every pair of L3 device on the L2 broadcast network as a pair of unidirectional l3 unicast link ? For example if there are 100 devices on 192.168.1/24 network, should there be 9900 unidirectional l3 unicast links?
Thanks.

Warm regards,
Stephen Cheng

---

From: Alia Atlas <[email-masked]>
Date: Tue, 22 Oct 2019 23:53:11 -0400

Hi Stephen,

An L2 broadcast network is usually modeled with a pseudo-node and then
separate links between that pseudonode and
each L3 device.  Please take a look at Section B.1.2 where one of the
example ospf-node-attributes is a pseudonode.

Regards,
Alia

On Tue, Oct 22, 2019 at 11:46 PM Stephen Cheng <[email-masked]>
wrote:

>    1. Is RFC 8346 ietf-l3-topology intended to cover modelling of L3
>    links that is supported by a L2 broadcast network (such as an Ethernet
>    network)?
>    2. If so, would it be correct to model the L3 connection between every
>    pair of L3 device on the L2 broadcast network as a pair of unidirectional
>    l3 unicast link ? For example if there are 100 devices on 192.168.1/24
>    network, should there be 9900 unidirectional l3 unicast links?
>
> Thanks.
>
>
>
> Warm regards,
>
> Stephen Cheng
>
>
> _______________________________________________
> i2rs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2rs
>