Subject: [Ice] checklist states

From: Peter Saint-Andre - &yet <[email-masked]>
Date: Tue, 20 Oct 2015 08:42:10 -0600

In a review of the trickle-ice spec, Pal Martinsen asked whether we 
might want to modify the state chart for checklist states. Right now, we 
have states of Running, Failed, and Succeeded. Pal suggested that it 
might be reasonable to add states of Frozen and Waiting to ICEbis, and 
to add a state of Waiting for Candidates to trickle-ice. (Pal, do you 
make a distinction between "Waiting" and "Waiting for Candidates"?)

WG discussion of this topic would be good. :-)

Peter

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Wed, 21 Oct 2015 09:24:34 +0000

> On 20 Oct 2015, at 16:42, Peter Saint-Andre - &yet <[email-masked]> wrote:
> 
> In a review of the trickle-ice spec, Pal Martinsen asked whether we might want to modify the state chart for checklist states. Right now, we have states of Running, Failed, and Succeeded. Pal suggested that it might be reasonable to add states of Frozen and Waiting to ICEbis,
The reason for this is in section 5.6.4 just before the states are defined.

One of the check lists will have some number of pairs in the Waiting
state, and the other check lists will have all of their pairs in the
Frozen state.  A check list with at least one pair that is Waiting is
called an active check list, and a check list with all pairs Frozen
is called a frozen check list.

From a development perspective it make sense (to me at least) to have the checklist state be set to frozen.

Maybe the main question to discuss first is, do we still need the frozen algorithm? How much does it really speed up ICE? Is it worth the complexity?

> and to add a state of Waiting for Candidates to trickle-ice. (Pal, do you make a distinction between “Waiting" and "Waiting for Candidates"?)
> 

Yes, “Waiting” is a candidate pair state. “Waiting for candidates” should be a checklist state indication that it has no active checks, but have not yet receive and end of candidates signal. 

> WG discussion of this topic would be good. :-)
Yup

.-.
Pål-Erik