Subject: [Ice] 5245bis: New ICE option to prevent legacy peers from using aggressive nomination

From: Christer Holmberg <[email-masked]>
Date: Wed, 4 May 2016 15:51:20 +0000

Hi,

As agreed in Buenos Aires, 5245bis endpoints will not use aggressive nomination, and we also agreed to define a new ICE option to be used by 5245 endpoints in order to prevent legacy peers from using aggressive nomination (as legacy peers would not support the ICE option, they are expected not to use aggressive nomination).

However, defining a dummy ICE option just to prevent legacy peers from using aggressive nomination would not be good protocol design, in my opinion.

Also, scoping the ICE option to nomination may not be smart either. In my opinion the ICE option should indicate that the endpoint is compliant with 5245bis in general.

Do people agree with that?

If so, do you have suggestions for the ICE option name? :)

Regards,

Christer

---

From: Roman Shpount <[email-masked]>
Date: Wed, 4 May 2016 12:48:32 -0400

I agree and would suggest option name ice-bis.

_____________
Roman Shpount

On Wed, May 4, 2016 at 11:51 AM, Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
>
>
> As agreed in Buenos Aires, 5245bis endpoints will not use aggressive
> nomination, and we also agreed to define a new ICE option to be used by
> 5245 endpoints in order to prevent legacy peers from using aggressive
> nomination (as legacy peers would not support the ICE option, they are
> expected not to use aggressive nomination).
>
>
>
> However, defining a dummy ICE option just to prevent legacy peers from
> using aggressive nomination would not be good protocol design, in my
> opinion.
>
>
>
> Also, scoping the ICE option to nomination may not be smart either. In my
> opinion the ICE option should indicate that the endpoint is compliant with
> 5245bis in general.
>
>
>
> _______________________________________________
> Ice mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ice
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 4 May 2016 19:49:40 +0000

Hi,

I was thinking of "bus" too. But, it's a temporary working name. And, what about the next time we make a bis? :)

Regards,

Christer

Sent from my Windows Phone
________________________________
From: Roman Shpount<mailto:[email-masked]>
Sent: ‎04/‎05/‎2016 19:48
To: Christer Holmberg<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Ice] 5245bis: New ICE option to prevent legacy peers from using aggressive nomination

_____________
Roman Shpount

On Wed, May 4, 2016 at 11:51 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

_______________________________________________
Ice mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ice

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 20 May 2016 10:15:17 +0000

I have received no further suggestions, so I guess we can call it “simplified”.

Regards,

Christer

From: Ice <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Wednesday 4 May 2016 at 22:49
To: Roman Shpount <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Ice] 5245bis: New ICE option to prevent legacy peers from using aggressive nomination

Hi,

Regards,

Christer

Sent: 04/05/2016 19:48

_____________
Roman Shpount

Regards,

Christer

---

From: Roman Shpount <[email-masked]>
Date: Fri, 20 May 2016 09:52:42 -0400

How about naming it "simple"? This would be shorter and easier to read.

_____________
Roman Shpount

On Fri, May 20, 2016 at 6:15 AM, Christer Holmberg <
[email-masked]> wrote:

> From: Ice <[email-masked]> on behalf of Christer Holmberg <
> [email-masked]>
> To: Roman Shpount <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> ------------------------------
> From: Roman Shpount <[email-masked]>
> Sent: 04/05/2016 19:48
> To: Christer Holmberg <[email-masked]>
> Cc: [email-masked]

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 20 May 2016 13:56:20 +0000

WFM.

Regards,

Christer

Sent: ‎20/‎05/‎2016 16:52

_____________
Roman Shpount

On Fri, May 20, 2016 at 6:15 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
I have received no further suggestions, so I guess we can call it “simplified”.

Regards,

Christer

Hi,

Regards,

Christer

_____________
Roman Shpount

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 22 May 2016 13:47:41 +0000

Hi,

Another question is whether we can define the ICE option in 5245bis, or whether it should be defined somewhere else. The whole ICE option concept has moved to draft-ice-sip-sdp, so…

Regards,

Christer

From: Ice [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 20 May 2016 16:56
To: Roman Shpount <[email-masked]>
Cc: [email-masked]
Subject: Re: [Ice] 5245bis: New ICE option to prevent legacy peers from using aggressive nomination

WFM.

Regards,

Christer

_____________
Roman Shpount

Regards,

Christer

Hi,

Regards,

Christer

_____________
Roman Shpount

Regards,

Christer

---

From: Bernard Aboba <[email-masked]>
Date: Sun, 22 May 2016 09:48:11 -0700

Christer said:
"As agreed in Buenos Aires, 5245bis endpoints will not use aggressive
nomination, and we also agreed to define a new ICE option to be used by
5245 endpoints"

[BA] Don't you mean "used by RFC 5245bis endpoints?"  RFC 5245 endpoints
cannot be expected to implement or understand new ICE options - they are
the legacy implementations here.

"in order to prevent legacy peers from using aggressive nomination (as
legacy peers would not support the ICE option, they are expected not to use
aggressive nomination)."

[BA] Legacy peers implementing RFC 5245 won't understand the new ICE
option, so their behavior will be unmodified.  If a legacy implementation
is inclined to do aggressive nomination, the new ICE option won't change
that.

What *is* possible is for an RFC 5245bis implementation to negotiate with
another RFC 5245bis implementation to not use aggressive nomination.
However, since the new ICE option will be ignored by a legacy peer,  the
RFC 5245bis implementation will need to be prepared to handle aggressive
nomination by the legacy peer.

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 22 May 2016 17:30:41 +0000

Hi Bernard,

>>"As agreed in Buenos Aires, 5245bis endpoints will not use aggressive nomination, and we also agreed to define a new ICE option to be used by 5245 endpoints"
>
>[BA] Don't you mean "used by RFC 5245bis endpoints?"  RFC 5245 endpoints cannot be expected to implement or understand new ICE options - they are the legacy implementations here.
>
>"in order to prevent legacy peers from using aggressive nomination (as legacy peers would not support the ICE option, they are expected not to use aggressive nomination)."
>
>[BA] Legacy peers implementing RFC 5245 won't understand the new ICE option, so their behavior will be unmodified.  If a legacy implementation is inclined to do aggressive nomination, the new ICE >option won't change that.
>
>What *is* possible is for an RFC 5245bis implementation to negotiate with another RFC 5245bis implementation to not use aggressive nomination.  However, since the new ICE option will be ignored by a >legacy peer,  the RFC 5245bis implementation will need to be prepared to handle aggressive nomination by the legacy peer.

If an 5245 endpoint does not understand an ICE option (no matter what the semantics of the ICE option is), the endpoint MUST NOT use aggressive nomination. That is according to RFC 5245. Now, I don’t remember the reason of binding aggressive nomination with not understanding ICE options, but that is what RFC 5245 says :)

Regards,

Christer

Hi,

Regards,

Christer

---

From: Bernard Aboba <[email-masked]>
Date: Sun, 22 May 2016 10:47:00 -0700

Christer said:

"If an 5245 endpoint does not understand an ICE option (no matter what the
semantics of the ICE option is), the endpoint MUST NOT use aggressive
nomination. That is according to RFC 5245. Now, I don’t remember the reason
of binding aggressive nomination with not understanding ICE options, but
that is what RFC 5245 says :)"

[BA] AFAICT, most implementations of RFC 5245 that support aggressive
nomination do not disable it on receiving an ICE option they do not
understand, despite what RFC 5245 says.  So in practice, I would not expect
the new ICE option to have the desired effect.

On Sun, May 22, 2016 at 10:30 AM, Christer Holmberg <
[email-masked]> wrote:

> is inclined to do aggressive nomination, the new ICE >option won't change
> that.
>
> >
>
> However, since the new ICE option will be ignored by a >legacy peer,  the
> If an 5245 endpoint does not understand an ICE option (no matter what the
> semantics of the ICE option is), the endpoint MUST NOT use aggressive
> nomination. That is according to RFC 5245. Now, I don’t remember the reason
> of binding aggressive nomination with not understanding ICE options, but
> that is what RFC 5245 says :)
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
>
>
>
>
>
>
> Hi,
>
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 22 May 2016 17:57:19 +0000

Hi,

>Christer said:
>
>"If an 5245 endpoint does not understand an ICE option (no matter what the semantics of the ICE option is), the endpoint MUST NOT use aggressive nomination. That is according to RFC 5245. Now, I >don’t remember the reason of binding aggressive nomination with not understanding ICE options, but that is what RFC 5245 says :)"
>
>[BA] AFAICT, most implementations of RFC 5245 that support aggressive nomination do not disable it on receiving an ICE option they do not understand, despite what RFC 5245 says.  So >in practice, I would not expect the new ICE option to have the desired effect.

And for that reason 5245bis endpoints will continue to support the case where the remote peer (a legacy endpoint) does use aggressive nomination (even if the ICE option was included) :)

I hope that is stated in the meeting minutes.

Regards,

Christer

On Sun, May 22, 2016 at 10:30 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi Bernard,

Regards,

Christer

Hi,

Regards,

Christer

---

From: Ari Keränen <[email-masked]>
Date: Wed, 25 May 2016 14:05:00 +0000

> On 22 May 2016, at 20:57, Christer Holmberg <[email-masked]> wrote:
> 

The meeting minutes say that we agreed to use both discussed options to take care of this case. This includes "Endpoint must still be able to receive aggressive nomination".

Cheers,
Ari