Subject: Re: [Ice] AD Evaluation of draft-ietf-ice-dualstack-fairness-02

From: "Ben Campbell" <[email-masked]>
Date: Tue, 07 Jun 2016 17:23:40 -0500

Hi,

IIUC, the ball is in the authors court to submit a new revision. Can 
people offer an estimate of when that might happen?

Thanks!

Ben.

On 23 May 2016, at 9:25, Ben Campbell wrote:

> I'm okay with this approach in general. Some comments inline:
>
> Thanks!
>
> Ben.
>
> On 23 May 2016, at 5:58, Pal Martinsen (palmarti) wrote:
>
>> On 22 May 2016, at 22:34, Ari Keränen <[email-masked]> 
>> wrote:
>>>
>>> Hi,
>>>
>>> Regarding the split to different drafts, our goal with the ICEbis 
>>> work was to fix errors and make sure we have the right hooks and 
>>> text for the extensions that we need. And we decided that everything 
>>> else, such as new features/extra functionality, would go to 
>>> different document(s). Of course the DS draft is a borderline case, 
>>> but given how much material (e.g., the algorithm) there is, to me 
>>> (chair hat off) separate document sounds still like a better idea.
>>>
>>> But yes, the current text in ICEbis about RFC6724 needs to be 
>>> updated and point to the dual-stack document. Having text there 
>>> about the general procedure makes sense.
>>>
>>> Regarding BCP or Informational for the DS draft status, I don't 
>>> think we considered the BCP option. Now thinking about it, BCP seems 
>>> reasonable option.
>>>
>>
>>
>> +1 BCP Seems like a better option.
>>
>> The current proposal for progressing this draft:
>> - Move from Informational to BCP
>
> I think that makes sense, if we keep it separate from ICEBis. As an 
> individual, I think merging it into ICEBis would be the best long-term 
> choice, but as AD I'm ok with progressing things as is for 
> "historical" reasons. (read: Because we've gotten this far separately, 
> merging them would create a fair amount of re-work.) But do not be 
> surprised if this comes up again during IESG review.
>
>> - ICEbis will have a normative reference to ICE-Dualstack fairness. 
>> (So this can potentially hold up ICEbis, but probably not)
>> - Text can be shortened a lot if we assume readers are more familiar 
>> with ICE and only reference the appropriate ICE sections. I prefer 
>> the current text as it saves readers familiar with ICE but without 
>> fresh memories of details some time looking up the appropriate ICE 
>> section.
>
> The big issue here is, since ICEBis is still in play, do we expect the 
> explanatory text to stay "current"? Otherwise, it's just a matter of 
> making being clear that whatever explanatory material exists makes it 
> clear that it is not authoritative.
>
> I'll leave this to the authors an chairs to decide. My personal advice 
> would be to keep some explanatory text, but shorten it quite a bit. 
> It's reasonable to have enough to give a reader a sense of what is 
> going on, but it's also reasonable to expect people to understand ICE 
> to fully understand this.
>
>> - Normative references to ICEbis instead of ICE. Work with ICEbis to 
>> remove current ambiguity of SHOULD wording regarding 6724 (Will hold 
>> publication of draft until ICEbis is complete).
>
> +1
>
>>
>> Not sure if this requires a new WGLC. The chairs will decide that.
>
> Things like changing to BCP, changing normative references, etc need 
> to be confirmed with the working group. It might make sense to 
> reconfirm the split draft approach, but I will leave that to the 
> chairs to decide. I don't think these things need a full WGLC, but if 
> that's the easiest way forward it doesn't hurt.

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Thu, 9 Jun 2016 13:37:31 +0000

On 08 Jun 2016, at 00:23, Ben Campbell <[email-masked]> wrote:

Hi,

IIUC, the ball is in the authors court to submit a new revision. Can people offer an estimate of when that might happen?

Next week, sorry for the delay.

.-.
Pål-Erik

Thanks!

Ben.

Thanks!

Ben.

On 22 May 2016, at 22:34, Ari Keränen <[email-masked]> wrote:

Hi,

Regarding the split to different drafts, our goal with the ICEbis work was to fix errors and make sure we have the right hooks and text for the extensions that we need. And we decided that everything else, such as new features/extra functionality, would go to different document(s). Of course the DS draft is a borderline case, but given how much material (e.g., the algorithm) there is, to me (chair hat off) separate document sounds still like a better idea.

But yes, the current text in ICEbis about RFC6724 needs to be updated and point to the dual-stack document. Having text there about the general procedure makes sense.

Regarding BCP or Informational for the DS draft status, I don't think we considered the BCP option. Now thinking about it, BCP seems reasonable option.

I think that makes sense, if we keep it separate from ICEBis. As an individual, I think merging it into ICEBis would be the best long-term choice, but as AD I'm ok with progressing things as is for "historical" reasons. (read: Because we've gotten this far separately, merging them would create a fair amount of re-work.) But do not be surprised if this comes up again during IESG review.

- ICEbis will have a normative reference to ICE-Dualstack fairness. (So this can potentially hold up ICEbis, but probably not)
- Text can be shortened a lot if we assume readers are more familiar with ICE and only reference the appropriate ICE sections. I prefer the current text as it saves readers familiar with ICE but without fresh memories of details some time looking up the appropriate ICE section.

The big issue here is, since ICEBis is still in play, do we expect the explanatory text to stay "current"? Otherwise, it's just a matter of making being clear that whatever explanatory material exists makes it clear that it is not authoritative.

I'll leave this to the authors an chairs to decide. My personal advice would be to keep some explanatory text, but shorten it quite a bit. It's reasonable to have enough to give a reader a sense of what is going on, but it's also reasonable to expect people to understand ICE to fully understand this.

- Normative references to ICEbis instead of ICE. Work with ICEbis to remove current ambiguity of SHOULD wording regarding 6724 (Will hold publication of draft until ICEbis is complete).

+1

Things like changing to BCP, changing normative references, etc need to be confirmed with the working group. It might make sense to reconfirm the split draft approach, but I will leave that to the chairs to decide. I don't think these things need a full WGLC, but if that's the easiest way forward it doesn't hurt.