Subject: [Ice] 5245bis: Pull request to implement unfreezing change suggested by Emil in Berlin

From: Christer Holmberg <[email-masked]>
Date: Wed, 30 Nov 2016 14:27:41 +0000

Hi,

Based on the discussions in Berlin (yes, Berlin), where Emil presented a change to the initial candidate unfreezing procedure, I have created a pull request. I ask people to take a look:

https://github.com/ice-wg/rfc5245bis/pull/24

The main change is:

Previously, only candidate pairs (one pair per foundation) in the first check list were placed in the Waiting state. The paris in all other lists remained Frozen.

With the change, candidate pairs (still, only one pair per foundation) throughout all check lists will be placed in the Waiting state.

Emil used a very nice table (“Emil’s table”) in Berlin to illustrate this. I have not implemented the table in the pull request, but if people think it’s needed it’s something we can work on.

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 30 Nov 2016 18:35:14 +0000

Hi,

The pull request also contained a number of editorial changes, which made it difficult to parse the change based on Emil's suggestion. So, I've created a new pull request, without the editorial changes.

https://github.com/ice-wg/rfc5245bis/pull/25

Regards,

Christer

From: Ice [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 30 November 2016 16:28
To: [email-masked]
Subject: [Ice] 5245bis: Pull request to implement unfreezing change suggested by Emil in Berlin

Hi,

The main change is:

Emil used a very nice table ("Emil's table") in Berlin to illustrate this. I have not implemented the table in the pull request, but if people think it's needed it's something we can work on.

Regards,

Christer