Subject: [Ice] 5245bis: From where to send triggered checks?

From: Christer Holmberg <[email-masked]>
Date: Mon, 7 Nov 2016 11:50:29 +0000

Hi,

Section 5.1.4 of 5245bis says:

   "When the timer fires and there is no triggered check to be sent, the
   agent MUST choose an ordinary check as follows:

   o  Find the highest-priority pair in that check list that is in the
      Waiting state.

   o  If there is such a pair:

      *  Send a STUN check from the local candidate of that pair to the
         remote candidate of that pair.  The procedures for forming the
         STUN request for this purpose are described in Section 6.1.2.”

Doesn’t the “Send a STUN check…” text also apply to triggered checks?

Regards,

Christer

---

From: Nils Ohlmeier <[email-masked]>
Date: Tue, 15 Nov 2016 17:13:32 -0800

Hi,

> On Nov 7, 2016, at 03:50, Christer Holmberg <[email-masked]> wrote:
My interpretation is yes. And the very first paragraph in section 5.1.4 in my opinion describes exactly that:
 - take the first entry from the triggered check queue (which is a queue and not a sorted list)
 - if triggered check queue is empty proceed to the check list

Might be worth considering rolling that first paragraph up into the into the action list in paragraph three of the same section.

Best
  Nils

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 16 Nov 2016 06:20:14 +0000

Hi,

      Waiting state.

> Might be worth considering rolling that first paragraph up into the into the action list in paragraph three of the same section.

Correct. The STUN check is sent in the same way no matter whether the check is triggered or ordinary, so it should be enough to describe how it’s sent in one place.

Regards,

Christer

---

From: Nils Ohlmeier <[email-masked]>
Date: Tue, 15 Nov 2016 23:35:28 -0800

> On Nov 15, 2016, at 22:20, Christer Holmberg <[email-masked]> wrote:

+1

Best
  Nils