Subject: [Ice] 5245bis: active and frozen check lists

From: Christer Holmberg <[email-masked]>
Date: Mon, 7 Nov 2016 07:33:54 +0000

Hi,

Section 5.1.3.4 of 5245bis defines the following check list states: running, completed, failed.

 The check list itself is associated with a state, which captures the
   state of ICE checks for that media stream.  There are three states:

   Running:  In this state, ICE checks are still in progress for this
      media stream.

   Completed:  In this state, ICE checks have produced nominated pairs
      for each component of the media stream.

   Failed:  In this state, the ICE checks have not completed
      successfully for this media stream.

However, the section also defines two “types” of check lists: active check list and frozen check list.

   One of the check lists will have some number of pairs in the Waiting
   state, and the other check lists will have all of their pairs in the
   Frozen state.  A check list with at least one pair that is Waiting is
   called an active check list, and a check list with all pairs Frozen
   is called a frozen check list.

Q1: Why can’t Frozen simply be a check list state?

Q2: What’s the state of a Frozen check list?

Q3: What’s the difference between an active check list and an active check list in Running state?

Regards,

Christer

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Mon, 7 Nov 2016 14:01:29 +0000

On 7 Nov 2016, at 08:33, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

+1 This have been discussed before..

https://www.ietf.org/mail-archive/web/ice/current/msg00064.html

Running? (But frozen)?

Q3: What’s the difference between an active check list and an check list in Running state?

No idea..

.-.
Pål-Erik
Regards,

Christer

_______________________________________________
Ice mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ice

---

From: Ari Keränen <[email-masked]>
Date: Mon, 7 Nov 2016 15:47:43 +0000

> On 07 Nov 2016, at 16:01, Pal Martinsen (palmarti) <[email-masked]> wrote:
> 
> 
>> On 7 Nov 2016, at 08:33, Christer Holmberg <[email-masked]> wrote:
>> 
>> Hi,
>> 
>> Running
>> :  In this state, ICE checks are still in progress for this
>>       media stream.
>> 
>>    
>> Completed
>> :  In this state, ICE checks have produced nominated pairs
>> Failed
>> :  In this state, the ICE checks have not completed
>>    called an 
>> active check list
>> , and a check list with all pairs Frozen
>>    is called a 
>> frozen check list.
>> 
>> Q1:
>> Why can’t Frozen simply be a check list state?
> 

+1. Unless someone objects, let's make that change.

>> Q2: What’s the state of a Frozen check list?

If we do the change above, that'd be Frozen (right?).

>> Q3: What’s the difference between an active check list and an check list in Running state?

Seems there's no difference. Might be worthwhile to unify terminology here.

Cheers,
Ari

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 7 Nov 2016 18:40:20 +0000

Hi,

> +1. Unless someone objects, let's make that change.

+1

> If we do the change above, that'd be Frozen (right?).

Yes.
 
> Seems there's no difference. Might be worthwhile to unify terminology here.

I assume the state is "Running".

If we want to use "active check list" terminology, we should bind it to the state, e.g., by saying "a check list which state is Running is called an active check list".

Regards,

Christer

---

From: Nils Ohlmeier <[email-masked]>
Date: Tue, 15 Nov 2016 23:55:54 -0800

> On Nov 6, 2016, at 23:33, Christer Holmberg <[email-masked]> wrote:

In our implementation that is the case. We have a Frozen state before Running.

> Q2: What’s the state of a Frozen check list?

In our case “Frozen” :-)

> Q3: What’s the difference between an active check list and an active check list in Running state?

None?

Best
  Nils