Subject: [Ice] 5245bis: check list for first media stream

From: Christer Holmberg <[email-masked]>
Date: Mon, 7 Nov 2016 13:51:17 +0000

Hi,

If I understand section 5.1.3.4 of 5245bis correctly, initially there will only be one active check list (the check list associated with the “first media stream” - whatever that means). All other check lists will be frozen.

Then, based on my understanding of section 6.1.2.4.3, other checks lists won’t become active until all pairs in the previous check list have become either Succeeded or Failed.

Q1: What is the reason for “activating” only one check list, and keep the others frozen, instead of activating all check lists at the same time?

Regards,

Christer

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Mon, 7 Nov 2016 18:52:33 +0000

On 7 Nov 2016, at 14:51, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

I think the rationale behind this is a form of “global pacing” to avoid overloading of the NAT.

Not sure if that rationale is still valid. I bought a couple of the cheapest WiFi routers and could not break them. But then again ICE might operate in weird networks that are severely constrained.

.-.
Pål-Erik

Regards,

Christer
_______________________________________________
Ice mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ice

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 7 Nov 2016 19:12:46 +0000

Hi,

[Christer] I think overloading is already considered, as the check timer is calculated using Ta*N, where N is the number of active check list.

But, it is also unclear to me when we will have multiple active check lists to begin with. Are ALL frozen check lists activated once the first check list is done?

Regards,

Christer