Subject: [Ice] draft-5245bis: We seem to allow connectivity checks more frequent than Ta

From: Christer Holmberg <[email-masked]>
Date: Thu, 8 Dec 2016 13:20:58 +0000

Hi,

In draft-5245bis I gave a name to the timer which is used to trigger whether a check list contains a pair to be tested. I call the timer Tc.

The formula for Tc is unchanged, it is N*Ta, where N is the number of active check lists.

The idea of N was to make sure that a check list is not triggered (for some of the check list) more frequent than Ta.

However, nothing currently guarantees that it won’t happen more frequently than Ta.

The text says:

   "Implementations SHOULD spread out the starting of the Tc timers
   associated with each check list, so that Tc for each check list do
   not fire at the same time.”

Q1: As this is only a SHOULD, there is a chance that agents do not spread out, which could mean that the Tc timers for each check list fires at the same time

Q2: Even if the agent does spread out, there is no guarantee that there will be a time delay of Ta between each time Tc fires, as there is no rule how the spread out is done.

I think we have two alternatives to solve this:

ALTERNATIVE 1 (FIX THE CURRENT TEXT):

  *   We say that implementations MUST spread out the starting of the Tc timers
  *   We say that the time between two Tc timers fires MUST be at least the value of Ta

ALTERNATIVE 2 (MAKE THINGS SIMPLE):

  *   We only use ONE single timer, Ta, for the WHOLE check list set, and whenever it fires one check list is processed. The next time Ta fires, the next check list is processed, etc. That is more simple (as there is no need to spread out timers), and the result would be the same as in Alternative 1.

Alternative 2 also makes life easier when the number of active check list changes, and a new timer has to be calculated, as there is no need to “re-spred” any timers associated with each check list.

My suggestion is Alternative 2.

Comments?

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 8 Dec 2016 14:09:57 +0000

Pull request for Alternative 2:

https://github.com/ice-wg/rfc5245bis/pull/27

Regards,

Christer

From: Ice <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Thursday 8 December 2016 at 16:20
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Ice] draft-5245bis: We seem to allow connectivity checks more frequent than Ta

Hi,

The text says:

Comments?

Regards,

Christer