Subject: [Ice] 5245bis: A pair fails - the whole foundation fails?

From: Christer Holmberg <[email-masked]>
Date: Sun, 4 Dec 2016 08:55:26 +0000

Hi,

Section 6.1.2.4.1.  (Failure Cases) of draft-5245bis describes connectivity check failure cases where the candidate pair state will be set to Failed.

BUT, shouldn't the state of EVERY pair sharing the foundation be set to Failed? Isn't that the whole idea behind freezing?

Regards,

Christer

---

From: Ari Keränen <[email-masked]>
Date: Mon, 5 Dec 2016 11:52:45 +0000

> On 4 Dec 2016, at 10.55, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
>  
> BUT, shouldn’t the state of EVERY pair sharing the foundation be set to Failed? Isn’t that the whole idea behind freezing?

I think we should not set them to failed. 

The core idea of ICE is to test everything and the freezing algorithm is used just to optimize the order of how things are checked. Maybe just a particular port was blocked (or given different QoS or whatever) and hence different candidate with same foundation might work.

Of course the controlling agent could decide to use this piece of information as indication to settle for e.g. relayed candidate earlier, but the controlled agent should not be making such choices. This is especially important for backward compatibility.

Cheers,
Ari

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 5 Dec 2016 21:04:49 +0000

Hi,

> The core idea of ICE is to test everything and the freezing algorithm is used just to optimize the order of how things
> are checked. Maybe just a particular port was blocked (or given different QoS or whatever) and hence different candidate 
> with same foundation might work.
>
> Of course the controlling agent could decide to use this piece of information as indication to settle for e.g. relayed 
> candidate earlier, but the controlled agent should not be making such choices. This is especially important for backward 
> compatibility.

Perhaps it would be useful to add a note that explicitly says that. Something like:

"NOTE: When the ICE agent sets the candidate pair state to Failed as a
result a connectivity check error case, the agent does not change the states 
of other candidate pairs with the same foundation."

Regards,

Christer