Subject: [Ice] ICE on the side IETF98 summary

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Tue, 28 Mar 2017 14:29:40 +0000

Hi,

Apologies for short notice and the poorly planned remote participation options.

Disclaimer, this was not an official WG meeting and was just informal discussions, but openness is always good so posting a summary here.

ICE TLS
- Demux point when running 443. What call is the incomming connection for?
- ALPN

Other
- IPV6 and ICE-TCP? Better connectivity?
- What do ISP do when deploying? FW? Emulate NAT behaviour? Filter ports

ICE v2
- Start requirements document?
   - Continuous re-nomination
   - When can local sockets be closed?
   - Dynamic behaviour (Better path available)
   - General multipath support (IP, TCP, TLS)
   - Mobility

Path MTU discovery
- Pushed to ICE by DISPACTH
- How, when etc..

- HIP Workinggroup
  - ICE for HIP draft (Please review)

.-.
Pål-Erik

---

From: Ari Keränen <[email-masked]>
Date: Tue, 28 Mar 2017 15:43:22 +0000

> On 28 Mar 2017, at 09:29, Pal Martinsen (palmarti) <[email-masked]> wrote:
> 

Here's the latest revision: https://tools.ietf.org/html/draft-ietf-hip-native-nat-traversal-19

The draft is currently in WGLC and was just updated to address review comments. Please send comments to the HIP WG mailing list ([email-masked]).

Thanks,
Ari

---

From: Roman Shpount <[email-masked]>
Date: Tue, 28 Mar 2017 12:32:01 -0400

> - Demux point when running 443. What call is the incomming connection for?

This can be no different then ICE-TCP. TLS connection is accepted and once
STUN BIND message is received this connection, connection is assigned to a
specific call based on ufrag in the STUN message.

I have a related question -- do we want to validate certificates for this
TLS connection, i.e. do something similar to fingerprint? I would assume
not.

Regards,
_____________
Roman Shpount