Subject: Re: [Ice] TLS Candidates

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Wed, 1 Mar 2017 08:43:54 +0000

Hi,

Seems like we have rough consensus that this is something that is useful.

We currently have:
- A problem that the WG is willing to work on and solve.
- A draft that describes a possible solutions (Text and other drafts are of-course welcome).
- A working implementation. (Library is open source, no open source client uses it yet..)
- Discussion on list on whats working and whats not.

Seems like a good recipe for a RFC.

What er our options to speed up the process since we are not meeting during the next IETF?
There is no need to rush, but always good to get work done and finished. Especially since this touches on connectivity and not optimisation.

.-.
Pål-Erik

On 17 Feb 2017, at 22:55, Bernard Aboba <[email-masked]<mailto:[email-masked]>> wrote:

I have read this draft, and like it.  In practice there are enough customers restricting connectivity via UDP or TLS to make it worthwhile to implement TLS candidates.

My experience is that customers who only allow TLS to port 443 also tend to impose other restrictions, such as forcing connections through an HTTPS proxy of some kind.  So the considerations discussed in Section 6 are quite important.

On Mon, Jan 23, 2017 at 11:28 AM, Pal Martinsen (palmarti) <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

There is a need for TLS candidates. We did an implementations, so we thought is was a good idea to write up a draft.

Is this something others are interested in as well?
(As there seems to be no ICE meeting next IETF it would be nice to get the discussion started on the list)

.-.
Pål-Erik

Begin forwarded message:

From: <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-martinsen-ice-tls-candidates-00.txt
Date: 20 January 2017 at 14:08:09 GMT+1
To: Nathan Buckles <[email-masked]<mailto:[email-masked]>>, Paal-Erik Martinsen <[email-masked]<mailto:[email-masked]>>

A new version of I-D, draft-martinsen-ice-tls-candidates-00.txt
has been successfully submitted by Paal-Erik Martinsen and posted to the
IETF repository.

Name: draft-martinsen-ice-tls-candidates
Revision: 00
Title: TLS Candidates for ICE
Document date: 2017-01-20
Group: Individual Submission
Pages: 6
URL:            https://www.ietf.org/internet-drafts/draft-martinsen-ice-tls-candidates-00.txt
Status:         https://datatracker.ietf.org/doc/draft-martinsen-ice-tls-candidates/
Htmlized:       https://tools.ietf.org/html/draft-martinsen-ice-tls-candidates-00

Abstract:
  This document introduces TLS candidates to ICE.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

The IETF Secretariat

_______________________________________________
Ice mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ice

---

From: Ari Keränen <[email-masked]>
Date: Wed, 22 Mar 2017 15:10:53 +0000

Hi Pål-Erik et al,

Indeed there seems to be interest in this topic. In order to progress on this, while the topic is in our charter, we would eventually need a new milestone for it. Right now there has been few individuals who agree this is an interesting topic, but would be good to have more people voice out on the list that they consider this important.

Even though we don't have an ICE meeting at Chicago, you could consider having a side meeting to get more folks involved.

Cheers,
Ari

> On 01 Mar 2017, at 10:43, Pal Martinsen (palmarti) <[email-masked]> wrote:
> 
> Hi,
> 
>> On 17 Feb 2017, at 22:55, Bernard Aboba <[email-masked]> wrote:
>> 
>> On Mon, Jan 23, 2017 at 11:28 AM, Pal Martinsen (palmarti) <[email-masked]> wrote:
>> Hi all,
>> 
>>> From: <[email-masked]>
>>> To: Nathan Buckles <[email-masked]>, Paal-Erik Martinsen <[email-masked]>
>>> 
>>> 
>>> Revision:
>>> 00
>>> Document date:
>>> 2017-01-20
>>> Pages:
>>> 6
>>> until the htmlized version and diff are available at tools.ietf.org.
>>> 
>>> The IETF Secretariat
>>> 
>> 
>> 
>> [email-masked]
> [email-masked]