Subject: [Ice] 5245bis: ICE states

From: Christer Holmberg <[email-masked]>
Date: Fri, 21 Apr 2017 07:43:36 +0000

Hi,

Below is a list of the different states/status/flags in ICE, and some questions related to it.

Note that my questions are not (at least not at this point) change suggestions, but more questions for clarifications.

-------------

ICE LEVEL:
=========

ICE State:

  *   Running, Completed, Failed

QUESTION: Is this really needed? I realise ICE can complete, fail etc, but do we really need to have a state machine for it?

MEDIA STREAM LEVEL:
===================

CHECK LISTS:

Check list state:

  *   Running, Completed, Failed

Check list status:

  *   Frozen, Active

QUESTION: Do we need the check list status? Could we somehow incorporate it into the check list state machine?

PAIRS:

Candidate pair state:

  *   Waiting, In-Progress, Succeeded, Failed, Frozen

Candidate pair Nomination flag:

  *   false, true

QUESTION: Do we need the nomination flag? Could “Nominated” be a state?

Regards,

Christer

---

From: Peter Saint-Andre <[email-masked]>
Date: Sun, 23 Apr 2017 15:05:15 -0600

On 4/21/17 1:43 AM, Christer Holmberg wrote:
> Note that my questions are not (at least not at this point) change
> suggestions, but more questions for clarifications.
> 
> -------------
> 
> /ICE LEVEL:/
> =========
> 
> *ICE State:*
> 
> *QUESTION: Is this really needed? I realise ICE can complete, fail etc,
> but do we really need to have a state machine for it?*

I tend to think we don't need this.

> /MEDIA STREAM LEVEL:/
> *CHECK LISTS:*
> *
> *
> *QUESTION: Do we need the check list status? Could we
> somehow **incorporate it into the check list state machine?*

I find state vs. status confusing. Integrating them sounds like a good idea.

> *
> *
> *PAIRS:*
> *QUESTION: Do we need the nomination flag? Could “Nominated” be a state?*

Seems feasible.

Peter