Subject: [Ice] I-D Action: draft-ietf-ice-trickle-10.txt

From: [email-masked]
Date: Tue, 09 May 2017 10:11:37 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Interactive Connectivity Establishment of the IETF.

        Title           : Trickle ICE: Incremental Provisioning of Candidates for the Interactive Connectivity Establishment (ICE) Protocol
        Authors         : Emil Ivov
                          Eric Rescorla
                          Justin Uberti
                          Peter Saint-Andre
	Filename        : draft-ietf-ice-trickle-10.txt
	Pages           : 32
	Date            : 2017-05-09

Abstract:
   This document describes "Trickle ICE", an extension to the
   Interactive Connectivity Establishment (ICE) protocol that enables
   ICE agents to send and receive candidates incrementally rather than
   exchanging complete lists.  With such incremental provisioning, ICE
   agents can begin connectivity checks while they are still gathering
   candidates and considerably shorten the time necessary for ICE
   processing to complete.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ice-trickle/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ice-trickle-10
https://datatracker.ietf.org/doc/html/draft-ietf-ice-trickle-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ice-trickle-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 9 May 2017 11:13:57 -0600

Some adjustments to reflect recent list discussion.

This should be ready for working group last call!

Peter

On 5/9/17 11:11 AM, [email-masked] wrote:
> _______________________________________________
> Ice mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ice
>

---

From: Ari Keränen <[email-masked]>
Date: Fri, 12 May 2017 20:07:55 +0000

Thanks Peter!

I reviewed the changes and they looked good to me. Below some editorial comments.

Unfortunately some of the section numbers of ICE-bis have changed and this document still refers to the old numbers. Here's what I spotted:

Section 7.1:
> The ICE specification [rfc5245bis], Section 5.1.5, requires that

Now Section 5.1.4

Section 8.1.1:
>    When an agent commences ICE processing, in accordance with
>    Section 5.1.3.6 of [rfc5245bis] 

I think you mean 5.1.2.6 ("Computing Candidate Pair States"). 

Also in:
>    Then, as the checks proceed (see Section 6.1.2.4.2.3 of [rfc5245bis] 

Now Section 6.2.5.3.4. 

Same issue in section 7.2.

Section 12:
> ICE processing described in Section 6.2 of [rfc5245bis], and Trickle

Now Section 7.

Finally, in Section 16:
>   c=IN IP4 2001:db8:a0b:12f0::1

s/IP4/IP6/

Cheers,
Ari

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 12 May 2017 14:11:31 -0600

> I reviewed the changes and they looked good to me. Below some editorial comments.

Thanks, Ari, those are good catches. We'll double-check all
cross-references and fix the things you've found. Shall we spin a -11 to
address these?

Also, do we foresee section numbers changing again in 5245bis? If so, it
might make more sense to remove the specific references (although I
think they're helpful because it can be difficult to find exact text in
5245bis without the section numbers).

Peter

---

From: Ari Keränen <[email-masked]>
Date: Fri, 12 May 2017 20:27:27 +0000

> On 12 May 2017, at 23:11, Peter Saint-Andre <[email-masked]> wrote:
> 

Thanks! Peter Thatcher is also reviewing the doc to make sure we didn't miss anything. You may want to wait for his comments/OK, but either way is fine for me.

> 5245bis without the section numbers).

They may change; but we'll try to avoid that. And I agree specific references are good. Luckily it's relatively easy to update them by comparing the section numbers of the different versions wrt references in this draft. If you don't mind doing that, please keep the specific ones.

Cheers,
Ari

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 12 May 2017 19:25:38 -0600

> They may change; but we'll try to avoid that. And I agree specific references are good. Luckily it's relatively easy to update them by comparing the section numbers of the different versions wrt re…

That all makes sense. I think we'll wait to hear from Peter before
posting a revised I-D.

Peter

---

From: Peter Saint-Andre <[email-masked]>
Date: Sat, 13 May 2017 18:07:36 -0600

> Same issue in section 7.2.

I think that's actually 6.2.5.4, right?

Peter