Subject: Re: [Ice] Peter's review of ICEbis - Why do we model valid candidate pairs as a separate list of separate candidates from the normal check list?

From: Christer Holmberg <[email-masked]>
Date: Mon, 29 May 2017 06:50:01 +0000

Hi,

> - Why do we model valid candidate pairs as a separate list of separate candidates from the normal check list?
> Why not just say that some candidate pairs are valid.  Why have this list of them?    Seems like we could remove the concept.

This is related to an e-mail I sent some time ago, where I asked whether we really need all states etc, and even suggested we could remove some of it. However, I then decided not to do it, because it could end up in a real mess.

But, related to your question, when I had a look at it I was thinking that “VALID” could just be a candidate pair state value, rather than a separate list.

Regards,

Christer

---

From: Peter Thatcher <[email-masked]>
Date: Thu, 01 Jun 2017 01:20:49 +0000

What's the different between "valid" and "succeeded"?

On Sun, May 28, 2017 at 11:50 PM Christer Holmberg <
[email-masked]> wrote:

> > Why not just say that some candidate pairs are valid.  Why have this
> list of them?    Seems like we could remove the concept.
>
> This is related to an e-mail I sent some time ago, where I asked whether
> we really need all states etc, and even suggested we could remove some of
> it. However, I then decided not to do it, because it could end up in a real
> mess.
>
> But, related to your question, when I had a look at it I was thinking that
> “VALID” could just be a candidate pair state value, rather than a separate
> list.
>
> Regards,
>
> Christer
>
>
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 1 Jun 2017 06:18:45 +0000

Hi,

I need to take one step back.

Keep in mind that pairs in the VALID LIST do not necessarily exist in any CHECK LIST.

See section 6.2.5.3.2.

Regards,

Christer

From: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Thursday 1 June 2017 at 04:20
To: Christer Holmberg <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Ice] Peter's review of ICEbis - Why do we model valid candidate pairs as a separate list of separate candidates from the normal check list?

On Sun, May 28, 2017 at 11:50 PM Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer