Subject: [Ice] draft-trickle-11: Comment on section 3

From: Christer Holmberg <[email-masked]>
Date: Mon, 5 Jun 2017 08:30:17 +0000

Section 3

The text says:

   "If an agent determines that the remote party does not support Trickle ICE, it
   MUST fall back to using regular ICE or abandon the entire session."

This is confusing, because earlier the draft says that half trickle can be used if the remote party doesn’t support trickle. And, I don’t think “regular ICE” and “half trickle” are the same things, are they?

Regards,

Christer

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 8 Jun 2017 20:59:13 -0600

On 6/5/17 2:30 AM, Christer Holmberg wrote:
> *Section 3*
> This is confusing, because earlier the draft says that half trickle can
> be used if the remote party doesn’t support trickle. 

Section 2 states:

      The [half trickle]
      mechanism is mostly meant for use in cases where the remote
      agent's support for Trickle ICE cannot be confirmed prior to
      conveying the initial ICE parameters.

Not being able to determine the remote agent's support for trickle is
different from definitively determining that the remote agent does not
support trickle (the case covered by the text in Section 3).

If this is not sufficiently clear, we can improve the text.

> And, I don’t think
> “regular ICE” and “half trickle” are the same things, are they?

I don't think the spec implies that they are.

Peter

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 14 Jun 2017 21:47:29 -0600

Christer, is this clear or would you like me to improve the text?

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 15 Jun 2017 06:22:30 +0000

Hi,

I¹m ok for now, based on your reply.

Regards,

Christer

On 15/06/17 06:47, "Peter Saint-Andre" <[email-masked]> wrote:

>>> be used if the remote party doesn¹t support trickle.
>> 
>> Section 2 states:
>> 
>>       The [half trickle]
>>> And, I don¹t think
>>> ³regular ICE² and ³half trickle² are the same things, are they?
>>

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 15 Jun 2017 14:52:32 -0600

Great, thanks! Your feedback is appreciated. :-)