Subject: [Ice] draft-trickle-11: Comment on section 2 (Terminology)

From: Christer Holmberg <[email-masked]>
Date: Mon, 5 Jun 2017 08:29:26 +0000

Section 2 (Terminology)

There is a definition for “candidate gatherer”. Do we really need that? There is no such thing in 5245bis, and I fail to see why trickle would need it.

I don’t think the “ICE parameter” definition is aligned with 5245bis. 5245bis doesn’t seem to have a clear definition of “ICE parameter” (perhaps we should fix that), but it doesn’t seem to exclude candidate specific parameters.

Also, in the definition for “Full Trickle” it seems to indicate that ICE parameters can carry candidates. Also later in the document there is text about using ICE parameters to carry candidates.

I think using “ICE parameters” in these definitions is confusing. Shouldn’t we talk about candidates that are individually exchanged at some point, once the ICE session has been initiated, before the nomination?

Regards,

Christer

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 8 Jun 2017 20:54:45 -0600

On 6/5/17 2:29 AM, Christer Holmberg wrote:
> 
> *Section 2 (Terminology)*
> 
> There is a definition for “candidate gatherer”. Do we really need that?
> There is no such thing in 5245bis, and I fail to see why trickle would
> need it.

This is probably an implementation detail that we can leave out.

> I don’t think the “ICE parameter” definition is aligned with 5245bis.
> 5245bis doesn’t seem to have a clear definition of “ICE parameter”
> (perhaps we should fix that),

That would be helpful. Then we can just include that definition
reference in the trickle spec.

> but it doesn’t seem to exclude candidate
> specific parameters. 

The closest I find is in Section 17.4 of 5245bis:

   ICE parameters .... include
   the type of each candidate (host, server reflexive, or relayed),
   along with their related addresses.

> Also, in the definition for “Full Trickle” it seems to indicate that ICE
> parameters can carry candidates. Also later in the document there is
> text about using ICE parameters to carry candidates.                    

Good catch.

This is likely an artifact of changing many instances of "ICE
Description" to "ICE Parameters" in version -09, which we did because
Taylor felt that "ICE Description" sounded too much like an offer/answer
construct.

> I think using “ICE parameters” in these definitions is confusing.

We could, of course, just go back to the phrase "ICE Description" -
personally I didn't feel that was a bad phrase and I think Emil felt the
same.

> Shouldn’t we talk about candidates that are individually exchanged
> at some point, once the ICE session has been initiated, before the
> nomination?

Sure. The point of "ICE description" or "initial ICE description" was
that in trickle the agent doesn't necessarily include candidates in the
initial description, because all the candidates are sent (trickled)
after that point.

Peter