Subject: Re: [Ice] trickle-11: Unfreezing of candidate pairs on connectivity check success

From: Peter Thatcher <[email-masked]>
Date: Fri, 02 Jun 2017 00:35:34 +0000

Ah, you are right.  That seems wrong to me.    But I'd like it if Emil can
double check.

On Wed, May 31, 2017 at 11:49 PM Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
> > I'm a little confused about the second point.  It seems like the text is
> saying to unfreeze the pairs with the same foundation in all check lists,
> and that sounds correct to me.
>
> That is what it should say :)
>
> But the text says “for the SAME media stream and foundation”. It should
> say “for ALL media streams with the same foundation”.
>
> Also, in Figure 3 only m2 is set to W. m3 and m4 should also be set to W.
>
> Now, in Figure 4 m3 and m4 ARE set to W, so maybe my issue is that I
> don’t really see the difference between Figure 3 and 4. Couldn't Figure 3
> be removed?
>
> Regards,
>
> Christer
>
>
>
>
>
>
>
>
> On Mon, May 29, 2017 at 5:17 AM Christer Holmberg <
> [email-masked]> wrote:
>
>> Hi,
>>
>> We may have discussed this before, but as it still exists in
>> draft-trickle-11 I will comment on it:
>>
>> Section 8.1.1. contains the following text:
>>
>>         "Then, as the checks proceed (see Section 6.2.5.4 of
>> [rfc5245bis]),
>>         for each pair that enters the Succeeded state (denoted here by
>> "S"),
>>         the agent will unfreeze all pairs for the same media stream and
>>         foundation (e.g., if the pair in column 1, row 1 succeeds then the
>>         agent will unfreeze the pair in column 1, row 2).²
>>
>>
>> First, I believe the 5245bis section to reference is 6.2.5.3.3.
>>
>> Second, according to the text in section 6.2.5.3.3 of 5245bis, *all* pairs
>> for *all* streams (for a given foundation) are unfrozen once the checked
>> pair succeeds - not only pairs for the same stream.
>>
>>         "The success of the connectivity check might also cause the state
>> of
>>         other candidate pairs to change.  The ICE agent MUST set the
>> states
>>         for all other Frozen candidate pairs (in each CHECK LIST in the
>> CHECK
>>         LIST SET) with the same foundation to Waiting."
>>
>>
>> Regards,
>>
>> Christer
>>
>> _______________________________________________
>> Ice mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/ice
>>
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 8 Jun 2017 21:23:58 -0600

On 6/1/17 6:35 PM, Peter Thatcher wrote:
> Ah, you are right.  That seems wrong to me. 

Agreed.

>   But I'd like it if
> Emil can double check.

I'll look, too (and double-check the figures while I'm at it).

> 
> On Wed, May 31, 2017 at 11:49 PM Christer Holmberg 
> <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
> Hi,
> 
>> I'm a little confused about the second point.  It seems like the
>> text is saying to unfreeze the pairs with the same foundation in
>> all check lists, and that sounds correct to me.
> 
> But the text says “for the SAME media stream and foundation”. It 
> should say “for ALL media streams with the same foundation”.
> 
> don’t really see the difference between Figure 3 and 4. Couldn't 
> Figure 3 be removed?
> 
> Regards,
> 
> Christer
> 
> 
> 
> 
> 
> 
> 
> 
> On Mon, May 29, 2017 at 5:17 AM Christer Holmberg 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> Hi,
> 
> "Then, as the checks proceed (see Section 6.2.5.4 of [rfc5245bis]), 
> for each pair that enters the Succeeded state (denoted here by "S"), 
> Second, according to the text in section 6.2.5.3.3 of 5245bis, *all*
> pairs for *all* streams (for a given foundation) are unfrozen once
> the checked pair succeeds - not only pairs for the same stream.
> 
> "The success of the connectivity check might also cause the state of 
> other candidate pairs to change.  The ICE agent MUST set the states 
> CHECK LIST SET) with the same foundation to Waiting."
> 
> 
> Regards,
> 
> Christer
> 
> _______________________________________________ Ice mailing list 
> [email-masked] <mailto:[email-masked]> 
> _______________________________________________ Ice mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/ice
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Sun, 11 Jun 2017 17:25:48 -0600

On 6/1/17 12:48 AM, Christer Holmberg wrote:
> Hi,
> 
>> I'm a little confused about the second point.  It seems like the text is saying to unfreeze the pairs with the same foundation in all check lists, and that sounds correct to me. 
> 

I agree that this seems correct.

> don’t really see the difference between Figure 3 and 4. Couldn't Figure
> 3 be removed?

Yes, it can. Consider it done (unless Emil objects).

Peter