Subject: Re: [Ice] Peter's review of ICEbis - Why do we model valid candidate pairs as a separate list of separate candidates from the normal check list?

From: Peter Thatcher <[email-masked]>
Date: Fri, 02 Jun 2017 00:33:27 +0000

If it's not in any check list, then why not just add it to a check list in
the Succeeded state?

On Wed, May 31, 2017 at 11:20 PM Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
> I need to take one step back.
>
> Keep in mind that pairs in the VALID LIST do not necessarily exist in any
> CHECK LIST.
>
> See section 6.2.5.3.2.
>
> Regards,
>
> Christer
>
> From: "[email-masked]" <[email-masked]>
> Date: Thursday 1 June 2017 at 04:20
> To: Christer Holmberg <[email-masked]>, "[email-masked]" <
> [email-masked]>
> Subject: Re: [Ice] Peter's review of ICEbis - Why do we model valid
> candidate pairs as a separate list of separate candidates from the normal
> check list?
>
> What's the different between "valid" and "succeeded"?
>
>
> On Sun, May 28, 2017 at 11:50 PM Christer Holmberg <
> [email-masked]> wrote:
>
>> Hi,
>>
>> > - Why do we model valid candidate pairs as a separate list of separate
>> candidates from the normal check list?
>> > Why not just say that some candidate pairs are valid.  Why have this
>> list of them?    Seems like we could remove the concept.
>>
>> This is related to an e-mail I sent some time ago, where I asked whether
>> we really need all states etc, and even suggested we could remove some of
>> it. However, I then decided not to do it, because it could end up in a real
>> mess.
>>
>> But, related to your question, when I had a look at it I was thinking
>> that “VALID” could just be a candidate pair state value, rather than a
>> separate list.
>>
>> Regards,
>>
>> Christer
>>
>>
>>
>>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 2 Jun 2017 06:24:12 +0000

Hi,

>If it's not in any check list, then why not just add it to a check list in the Succeeded state?

I haven’t studied it in detail, but I GUESS it could be done that way too. Also, implementers can choose to do it that way.

But, repeal of VALID LIST would require quite a bit of work. Also note that VALID LIST is used in draft-trickle etc, so I wonder whether it’s worth the effort…

Regards,

Christer

On Wed, May 31, 2017 at 11:20 PM Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Keep in mind that pairs in the VALID LIST do not necessarily exist in any CHECK LIST.

See section 6.2.5.3.2.

Regards,

Christer

From: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Thursday 1 June 2017 at 04:20
To: Christer Holmberg <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Ice] Peter's review of ICEbis - Why do we model valid candidate pairs as a separate list of separate candidates from the normal check list?

On Sun, May 28, 2017 at 11:50 PM Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

> - Why do we model valid candidate pairs as a separate list of separate candidates from the normal check list?
> Why not just say that some candidate pairs are valid.  Why have this list of them?    Seems like we could remove the concept.

This is related to an e-mail I sent some time ago, where I asked whether we really need all states etc, and even suggested we could remove some of it. However, I then decided not to do it, because it could end up in a real mess.

But, related to your question, when I had a look at it I was thinking that “VALID” could just be a candidate pair state value, rather than a separate list.

Regards,

Christer

---

From: Peter Thatcher <[email-masked]>
Date: Fri, 02 Jun 2017 22:30:11 +0000

Yes, it would be a big change.  I'll see if I have some time next week to
take a crack at it.

On Thu, Jun 1, 2017 at 11:27 PM Christer Holmberg <
[email-masked]> wrote:

> I haven’t studied it in detail, but I GUESS it could be done that way too.
> Also, implementers can choose to do it that way.
>
> But, repeal of VALID LIST would require quite a bit of work. Also note
> that VALID LIST is used in draft-trickle etc, so I wonder whether it’s
> worth the effort…
>
> Regards,
>
> Christer
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 5 Jun 2017 07:45:54 +0000

Hi,

>Yes, it would be a big change.  I'll see if I have some time next week to take a crack at it.

You can of course always write a PR, but in order not to waste your time I think the community should first decide on whether we want to do such change.

Also, as your suggestion means that SUCCEEDED means valid, it also removes the current requirement that you need to have SUCCEEDED pairs for EACH component of a stream in order for a pair to be valid. I know there is a separate suggestion to remove the component concept, and consider everything separate streams, so we really need to consider how far we want to go.

Regards,

Christer

On Thu, Jun 1, 2017 at 11:27 PM Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

See section 6.2.5.3.2.

Regards,

Christer

Regards,

Christer

---

From: Peter Thatcher <[email-masked]>
Date: Mon, 05 Jun 2017 16:47:22 +0000

Ah, so that's the root difference between succeeded and valid.  I was
wondering what it was.  Well, then we can just add a valid state to
candidate pairs, which means that it has succeeded and so has its "buddy".

On Mon, Jun 5, 2017 at 12:47 AM Christer Holmberg <
[email-masked]> wrote:

> You can of course always write a PR, but in order not to waste your time I
> think the community should first decide on whether we want to do such
> change.
>
> Also, as your suggestion means that SUCCEEDED means valid, it also removes
> the current requirement that you need to have SUCCEEDED pairs for EACH
> component of a stream in order for a pair to be valid. I know there is a
> separate suggestion to remove the component concept, and consider
> everything separate streams, so we really need to consider how far we want
> to go.
>
> Regards,
>
> Christer
>
>
>
>> I haven’t studied it in detail, but I GUESS it could be done that way
>> too. Also, implementers can choose to do it that way.
>>
>>>> > - Why do we model valid candidate pairs as a separate list of
>>>> separate candidates from the normal check list?
>>>> This is related to an e-mail I sent some time ago, where I asked
>>>> whether we really need all states etc, and even suggested we could remove
>>>> some of it. However, I then decided not to do it, because it could end up
>>>> in a real mess.
>>>>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 8 Jun 2017 10:11:44 +0000

Hi,

> Ah, so that's the root difference between succeeded and valid.  I was wondering what it was.  Well, then we can just add a valid state to candidate pairs, which means that it has succeeded and so has its "buddy".

Assuming the order of pairs in the valid list doesn’t matter, I guess it could be done that way (I wouldn’t be surprised if that’s how some implementations are done).

Regards,

Christer

On Mon, Jun 5, 2017 at 12:47 AM Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

Regards,

Christer

See section 6.2.5.3.2.

Regards,

Christer

Regards,

Christer

---

From: Peter Thatcher <[email-masked]>
Date: Thu, 08 Jun 2017 16:37:45 +0000

That's how ours is done :).

On Thu, Jun 8, 2017 at 3:11 AM Christer Holmberg <
[email-masked]> wrote:

> Assuming the order of pairs in the valid list doesn’t matter, I guess it
> could be done that way (I wouldn’t be surprised if that’s how some
> implementations are done).
>
> Regards,
>
> Christer
>
>
>
>
>> You can of course always write a PR, but in order not to waste your time
>> I think the community should first decide on whether we want to do such
>> change.
>>
>> Also, as your suggestion means that SUCCEEDED means valid, it also
>> removes the current requirement that you need to have SUCCEEDED pairs for
>> EACH component of a stream in order for a pair to be valid. I know there is
>> a separate suggestion to remove the component concept, and consider
>>>> To: Christer Holmberg <[email-masked]>, "[email-masked]"
>>>> <[email-masked]>
>>>>> > Why not just say that some candidate pairs are valid.  Why have
>>>>> this list of them?    Seems like we could remove the concept.
>>>>>