Subject: [Ice] trickle-ice-11: Comment on section 1 (Introduction)

From: Christer Holmberg <[email-masked]>
Date: Mon, 5 Jun 2017 08:28:18 +0000

Hi,

Section 1 (Introduction):

The text says:

   "This document defines an alternative or supplementary mode of
   operation for ICE implementations, known as "Trickle ICE", in which
   candidates can be exchanged incrementally.  This enables ICE agents
   to exchange candidates as soon as an ICE session has been initiated."

- “alternative or supplementary” sounds strange. I think we can remove that, and simply say “an operation for ICE implementations,…”

- I suggest to enhance the second sentence by saying “…as soon as an ICE session has been initiated an a candidate becomes available.”

- For “ICE session”, please add a reference to draft-5245bis. The definition for ICE session will show up there in the next version of the draft (PR exists)… :)

Regards,

Christer

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 7 Jun 2017 09:45:58 -0600

On 6/5/17 2:28 AM, Christer Holmberg wrote:
> 
> Hi,
> 
> *Section 1 (Introduction):*
> 
> The text says:
> 
> - “alternative or supplementary” sounds strange. I think we can remove
> that, and simply say “an operation for ICE implementations,…”

Well, it does supplement (not replace) what's defined in 5245bis - I
think Emil added those words to make it clear that the trickle mechanism
wasn't meant to replace the methods in ICE core.

> - I suggest to enhance the second sentence by saying “…as soon as an ICE
> session has been initiated an a candidate becomes available.”

Makes sense.

> - For “ICE session”, please add a reference to draft-5245bis. The
> definition for ICE session will show up there in the next version of the
> draft (PR exists)… :)

Great, thanks!

Peter

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 8 Jun 2017 10:07:37 +0000

Hi,

>> - ³alternative or supplementary² sounds strange. I think we can remove
>> that, and simply say ³an operation for ICE implementations,Š²
>

Ok, so I can understand the use of ³supplementary². But, I still don¹t get
³alternative². ³Alternative² does sound like a replacement :)

Regards,

Christer

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 8 Jun 2017 05:56:37 -0600

> On Jun 8, 2017, at 4:07 AM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
> 

Right - I suggest that we remove "alternative".

Peter