Subject: [Ice] ICE session at Prague IETF

From: Ari Keränen <[email-masked]>
Date: Mon, 17 Jul 2017 13:13:02 +0000

Hi all,

Our goal for the ICE WG session in Prague IETF meeting is to resolve remaining comments on ICE-bis to extent that we can start WGLC after the meeting.

The plan is to get consensus on the changes proposed in the PRs in the Github:
https://github.com/ice-wg/rfc5245bis/pulls
(note that PR #38 is a subset of #35)

Would be great if you can have a look and comment PRs before the meeting. Issues that seem to require more review / hammering for consensus, we'll take during the f2f meeting. Including editorial fixes that have a risk of unintentionally changing behavior. For this session, it would be important to have people joining who are familiar with the specification and can comment whether the proposed fixes cause unintentional side effects. 

Peter Thatcher will unfortunately not be in Prague in person, but Flemming Andreasen volunteered to co-chair the ICE WG session. Thank you Flemming!

Cheers,
Ari

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 17 Jul 2017 09:54:49 -0600

On 7/17/17 7:13 AM, Ari Keränen wrote:
> Hi all,
> 
> Our goal for the ICE WG session in Prague IETF meeting is to resolve
> remaining comments on ICE-bis to extent that we can start WGLC after
> the meeting.
> 
> The plan is to get consensus on the changes proposed in the PRs in
> the Github: https://github.com/ice-wg/rfc5245bis/pulls (note that PR
> #38 is a subset of #35)

The editorial changes looked fine to me. It was difficult at times to
review the more substantive changes because they were all mixed into a
large diff.

Peter

---

From: Ari Keränen <[email-masked]>
Date: Wed, 19 Jul 2017 15:46:30 +0000

I marked set of changes in the P38 with "for IETF 99 session":
https://github.com/ice-wg/rfc5245bis/pull/38/files

I believe these changes in particular would benefit from few extra pair of eyes to see that we did not cause unintentional side effects with these changes. 

In particular one of them is quite substantial (look for "Need to take off-line?" comment).

Cheers,
Ari

> On 17 Jul 2017, at 15.13, Ari Keränen <[email-masked]> wrote:
> 
> Hi all,
> 
> _______________________________________________
> Ice mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ice

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Wed, 19 Jul 2017 17:50:07 +0000

Hi, 

Sorry, away from any decent keyboard. Camping with the family.. 

I do not have any concerns at this stage. I promise to do a thorough review when I return. 

Sent from my iPhone

> On 17 Jul 2017, at 17:55, Peter Saint-Andre <[email-masked]> wrote:
>

---

From: Peter Thatcher <[email-masked]>
Date: Thu, 20 Jul 2017 01:11:57 +0000

I left some comments on them.  I agree that a few could use a double check
to make sure they are equivalent.  And a few are somewhat non-editorial and
should get confirmation.

But the "offline?" one I don't understand.  It seems like I didn't change
anything except make it shorter.

On Wed, Jul 19, 2017 at 8:47 AM Ari Keränen <[email-masked]>
wrote:

> I believe these changes in particular would benefit from few extra pair of
> eyes to see that we did not cause unintentional side effects with these
> changes.
>
> remaining comments on ICE-bis to extent that we can start WGLC after the
> meeting.
> >
> > Would be great if you can have a look and comment PRs before the
> meeting. Issues that seem to require more review / hammering for consensus,
> we'll take during the f2f meeting. Including editorial fixes that have a
> risk of unintentionally changing behavior. For this session, it would be
> important to have people joining who are familiar with the specification
> and can comment whether the proposed fixes cause unintentional side effects.
> >
> > Peter Thatcher will unfortunately not be in Prague in person, but
> Flemming Andreasen volunteered to co-chair the ICE WG session. Thank you
> Flemming!
> >
> >
> > Cheers,
> > Ari

---

From: Ari Keränen <[email-masked]>
Date: Thu, 20 Jul 2017 05:58:29 +0000

Thanks Peter! And yes, I agree the change marked "offline" doesn't appear to change behavior, but it was so many lines of text that it might be hard to handle in f2f session without someone looking into it before the session. 

Cheers,
Ari

> On 20 Jul 2017, at 3.12, Peter Thatcher <[email-masked]> wrote:
> 
> I left some comments on them.  I agree that a few could use a double check to make sure they are equivalent.  And a few are somewhat non-editorial and should get confirmation.
> 
> But the "offline?" one I don't understand.  It seems like I didn't change anything except make it shorter.
> 
>> On Wed, Jul 19, 2017 at 8:47 AM Ari Keränen <[email-masked]> wrote:

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Thu, 20 Jul 2017 12:28:39 +0200

I really appreciate the work Thatcher and others put in to trying to clarify this but the mix of editorial and technical stuff all together in here make it very hard to review. I tired to review it and no idea if I agree with it or not. I know that's not really useful but that's where i am. 

> On Jul 19, 2017, at 5:46 PM, Ari Keränen <[email-masked]> wrote:
>

---

From: Nils Ohlmeier <[email-masked]>
Date: Thu, 20 Jul 2017 12:30:40 +0200

I must admit that I agree with that as well. I started reviewing it, but gave up at some point, because the mix of minor editorial changes with bigger deletion of potentially important paragraphs was getting to complicated.

Best
  Nils

> On Jul 20, 2017, at 12:28, Cullen Jennings (fluffy) <[email-masked]> wrote:
> 
>

---

From: Ari Keränen <[email-masked]>
Date: Thu, 20 Jul 2017 11:02:20 +0000

Hi,

Everything in PR38 should be editorial (i.e., not changing behaviour). But I agree it's a lot of changes. I reviewed them all and marked with "IETF 99" the ones that were bit more substantial, about 20 of them. If you focus on those, you should be fine.

Cheers,
Ari

> On 20 Jul 2017, at 12.30, Nils Ohlmeier <[email-masked]> wrote:
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 20 Jul 2017 16:24:32 -0600

>From a process standpoint, this seems rather messy (I had the same
experience that Cullen and Nils did). Perhaps the authors can bring the
substantive issues to the list (one issue per thread, with clear
demarcation of old and new text) so that we can have a clearer view of
proposed changes? Of course, we're going to have a revised I-D at some
point and that will help, but in the meantime it's hard to follow the
conversation.

Peter

---

From: Nils Ohlmeier <[email-masked]>
Date: Fri, 21 Jul 2017 00:48:10 +0200

Peter,

We did today discuss during the ICE meeting all 20 items which Ari marked in the GitHub PR with “ietf 99” (if you use Firefox to search in the side by side view of the PR you should be able find them).
I don’t see the recordings yet on the IETF 99 page.
But I think Ari made notes in the PR and I just dumped my meeting notes into the Etherpad here https://etherpad.tools.ietf.org/p/notes-ietf-99-ice?useMonospaceFont=true <https://etherpad.tools.ietf.org/p/notes-ietf-99-ice?useMonospaceFont=true> so you can get an idea what we decided.

I think it would have helped if the PR would have had a git commit per change.
That would have allowed to look at each change separately and (after rebasing) only merge the one which got accepted without changes.

  Nils

> On Jul 21, 2017, at 00:24, Peter Saint-Andre <[email-masked]> wrote:
>