Subject: [Ice] Changing the text for when we can free candidates

From: Peter Thatcher <[email-masked]>
Date: Thu, 07 Sep 2017 16:42:15 +0000

At IETF 99, we discussed PR38 (https://github.com/ice-wg/rfc5245bis/pull/38/),
which I just updated, and the only really unclear remaining is related to
when an agent can free candidates.  The decision at IETF 99 was that we
would have something closer to the original text (which covers forking),
but make the meaning of "Completed" more clear.  So, I have updated the PR
to be like that, and here is the updated paragraph (which is very close to
the original, but with the improvements suggested):

"Once a checklist has reached the Completed state, the agent SHOULD wait an
additional three seconds, and then it can cease responding to checks or
generating triggered checks on all local candidates other than
the ones in the selected candidate pairs (one for each component).
Once all ICE sessions have ceased using a given local candidate
(a candidate may be used by multiple ICE sessions, e.g. in forking
scenarios), the agent can free that candidate.  The three-second delay
handles cases when aggressive nomination is used, and the selected pairs
can quickly change after ICE has completed. Freeing of server reflexive
candidates is never explicit; it happens by lack of a keepalive.  "

And, for reference, here is the old paragraph:

"Once ICE processing has reached the Completed state for all peers for
media streams using those candidates, the agent SHOULD wait an
additional three seconds, and then it MAY cease responding to checks or
generating triggered checks on that candidate.  It MAY free the
candidate at that time. Freeing of server reflexive candidates is never
explicit; it happens by lack of a keepalive.  The three-second delay
handles cases when aggressive nomination is used, and the selected pairs
can quickly change after ICE has completed."

Does this change cover what we were looking for at IETF 99?

---

From: Peter Thatcher <[email-masked]>
Date: Thu, 07 Sep 2017 16:49:46 +0000

Here's a nicer view of the diff on github:

https://github.com/ice-wg/rfc5245bis/pull/38/files#diff-2545e307f242412e07ae64a9f1e69222L2995

On Thu, Sep 7, 2017 at 9:42 AM Peter Thatcher <[email-masked]> wrote:

> At IETF 99, we discussed PR38 (
> https://github.com/ice-wg/rfc5245bis/pull/38/), which I just updated, and
> the only really unclear remaining is related to when an agent can free
> candidates.  The decision at IETF 99 was that we would have something
> closer to the original text (which covers forking), but make the meaning of
> "Completed" more clear.  So, I have updated the PR to be like that, and
> here is the updated paragraph (which is very close to the original, but
> with the improvements suggested):
>
>
> "Once a checklist has reached the Completed state, the agent SHOULD wait
> an additional three seconds, and then it can cease responding to checks or

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 8 Sep 2017 07:34:08 +0000

Hi,

A minor nit. The text says:

"The three-second delay handles cases when aggressive nomination is used, and the selected pairs can quickly change after ICE has completed.”

Earlier the text says that the three-second delay starts once the CHECKLIST is Completed, so I think the text above should be aligned:

"The three-second delay handles cases when aggressive nomination is used, and the selected pairs can quickly change after a checklist has reached the Completed state.”

Regards,

Christer

From: Ice <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Thursday 7 September 2017 at 19:49
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Ice] Changing the text for when we can free candidates

On Thu, Sep 7, 2017 at 9:42 AM Peter Thatcher <[email-masked]<mailto:[email-masked]>> wrote:
At IETF 99, we discussed PR38 (https://github.com/ice-wg/rfc5245bis/pull/38/), which I just updated, and the only really unclear remaining is related to when an agent can free candidates.  The decision at IETF 99 was that we would have something closer to the original text (which covers forking), but make the meaning of "Completed" more clear.  So, I have updated the PR to be like that, and here is the updated paragraph (which is very close to the original, but with the improvements suggested):

"Once a checklist has reached the Completed state, the agent SHOULD wait an additional three seconds, and then it can cease responding to checks or generating triggered checks on all local candidates other than
the ones in the selected candidate pairs (one for each component).
Once all ICE sessions have ceased using a given local candidate
(a candidate may be used by multiple ICE sessions, e.g. in forking scenarios), the agent can free that candidate.  The three-second delay handles cases when aggressive nomination is used, and the selected pairs can quickly change after ICE has completed. Freeing of server reflexive candidates is never explicit; it happens by lack of a keepalive.  "

---

From: Peter Thatcher <[email-masked]>
Date: Tue, 12 Sep 2017 15:13:29 +0000

Good idea.  I updated the PR to match that.

On Fri, Sep 8, 2017 at 12:34 AM Christer Holmberg <
[email-masked]> wrote:

> "The three-second delay handles cases when aggressive nomination is used,
> and the selected pairs can quickly change after ICE has completed.”
>
> Earlier the text says that the three-second delay starts once the
> CHECKLIST is Completed, so I think the text above should be aligned:
>
> "The three-second delay handles cases when aggressive nomination is used,
> and the selected pairs can quickly change after a checklist has reached the
> Completed state.”
>
> Regards,
>
> Christer
>
>
> From: Ice <[email-masked]> on behalf of "[email-masked]" <
> [email-masked]>
> To: "[email-masked]" <[email-masked]>
>> https://github.com/ice-wg/rfc5245bis/pull/38/), which I just updated,
>> and the only really unclear remaining is related to when an agent can free

---

From: Ari Keränen <[email-masked]>
Date: Wed, 27 Sep 2017 14:53:30 +0000

Looks good to me. Thanks!

Cheers,
Ari

On 12 Sep 2017, at 18.13, Peter Thatcher <[email-masked]<mailto:[email-masked]>> wrote:

On Fri, Sep 8, 2017 at 12:34 AM Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

_______________________________________________
Ice mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ice