Subject: [Ice] 5245bis: Clarification on receiving media

From: Christer Holmberg <[email-masked]>
Date: Tue, 5 Sep 2017 07:54:39 +0000

Hi,

Section 11.2 of 5245bis contains the following text:

   "Even though ICE agents are only allowed to send media using valid
   candidate pairs (and, once a candidate pair has been selected, only
   on the selected pair) ICE implementations SHOULD by default be
   prepared to receive media on any of the candidates provided in the
   most recent candidate exchange with the peer."

I think we need to clarify that being prepared to receive media on any candidate also only applies until a candidate pair has been selected.

Regards,

Christer

---

From: Peter Thatcher <[email-masked]>
Date: Tue, 05 Sep 2017 23:50:25 +0000

I think that's implied by the fact that resources can be release upon
nomination.  Plus it's only "SHOULD".  But if I'd be OK with adding a
phrase to make it more explicit.

On Tue, Sep 5, 2017 at 12:55 AM Christer Holmberg <
[email-masked]> wrote:

> _______________________________________________
> Ice mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ice
>

---

From: Peter Thatcher <[email-masked]>
Date: Tue, 05 Sep 2017 23:51:44 +0000

Actually, it gets a little complicated, because if the controlling side
should probably still be prepared to receive media until the binding
response from the nomination, to make sure the controlled side knows to
stop sending before the controlling side stops receiving.

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 6 Sep 2017 10:03:38 +0000

Hi,

>Actually, it gets a little complicated, because if the controlling side should probably still be prepared to receive media until the binding response from the nomination, to make sure the controlled side knows to stop sending before the controlling side stops receiving.

Sure.

But, before nomination, why should an endpoint be prepared to receive media on ANY candidate? Media should only be send on VALID pairs.

Regards,

Christer

On Tue, Sep 5, 2017 at 4:50 PM Peter Thatcher <[email-masked]<mailto:[email-masked]>> wrote:
I think that's implied by the fact that resources can be release upon nomination.  Plus it's only "SHOULD".  But if I'd be OK with adding a phrase to make it more explicit.

On Tue, Sep 5, 2017 at 12:55 AM Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

_______________________________________________
Ice mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ice