Subject: [Ice] 5245bis: Receiving of connectivity check with USE-CANDIDATE attribute set

From: Christer Holmberg <[email-masked]>
Date: Wed, 18 Oct 2017 09:58:33 +0000

Hi,

Section  6.3.1.5. (Updating the Nominated Flag) describes the STUN server procedures when a connectivity check with the USE-CANDIDATE attribute set is received.

However, it only covers pairs in Succeeded and In-Progress state.

What about pairs in Waiting, Frozen or Failed state?

According to section 6.3.1.4 a check will be generated for pairs in those states, but there is no work on setting the nominated flag when the response to such checks arrives.

In my opinion, when a connectivity check with the USE-CANDIDATE attribute set is receive, the agent creates a connectivity check in case of ANY non-Succeeded state, and sets to nominated flag if the check succeeds.

Regards,

Christer

---

From: Taylor Brandstetter <[email-masked]>
Date: Wed, 18 Oct 2017 09:44:53 -0700

I agree section 6.3.1.5 is lacking. If the state of a pair is "Frozen" and
a check is received, a triggered check will be generated but the state
won't be changed.

We could probably just change the bullets to "if the state is Succeeded"
and "If the state is not Succeeded", as opposed to "if the state is
In-Progress". The point of this section is to say "if the state is
*already* Succeeded,
set the nominated flag. Otherwise wait for it to become Succeeded before
setting the nominated flag".

On Wed, Oct 18, 2017 at 2:58 AM, Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
> Section  6.3.1.5. (Updating the Nominated Flag) describes the STUN server
> procedures when a connectivity check with the USE-CANDIDATE attribute set
> is received.
>
> According to section 6.3.1.4 a check will be generated for pairs in those
> states, but there is no work on setting the nominated flag when the
> response to such checks arrives.
>
> In my opinion, when a connectivity check with the USE-CANDIDATE attribute
> set is receive, the agent creates a connectivity check in case of ANY
> non-Succeeded state, and sets to nominated flag if the check succeeds.
>
> Regards,
>
> Christer
>
> _______________________________________________
> Ice mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ice
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 18 Oct 2017 20:16:59 +0000

Agree.

Regards,

Christer

From: Taylor Brandstetter [mailto:[email-masked]]
Sent: 18 October 2017 18:45
To: Christer Holmberg <[email-masked]>
Cc: [email-masked]
Subject: Re: [Ice] 5245bis: Receiving of connectivity check with USE-CANDIDATE attribute set

I agree section 6.3.1.5 is lacking. If the state of a pair is "Frozen" and a check is received, a triggered check will be generated but the state won't be changed.

We could probably just change the bullets to "if the state is Succeeded" and "If the state is not Succeeded", as opposed to "if the state is In-Progress". The point of this section is to say "if the state is already Succeeded, set the nominated flag. Otherwise wait for it to become Succeeded before setting the nominated flag".

On Wed, Oct 18, 2017 at 2:58 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

_______________________________________________
Ice mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ice