Subject: [Ice] 5245bis: Controlled agent connectivity check failure

From: Christer Holmberg <[email-masked]>
Date: Wed, 18 Oct 2017 10:17:05 +0000

Hi,

Section describes how the controlled agent, when it receives a connectivity check with the USE-CANDIDATE attribute, generates a connectivity check, and when the response arrives sets the nominated flag.

The text seems to assume that the connectivity check will succeed.

In my opinion, it should be stated that if the check fails, the controlled agent shall set the check list state to Failed (in the same way the controlling agent does if the nomination connectivity check request fails).

Regards,

Christer

---

From: Taylor Brandstetter <[email-masked]>
Date: Wed, 18 Oct 2017 09:53:07 -0700

I assume you're talking about section 6.3.1.5, "Updating the Nominated
Flag"? But isn't connectivity check failure covered by Section 6.2.5.2, for
both controlling and controlled agents? 6.3.1.5 describes when the
nominated flag is set to "true", but I don't think it needs to describe
when it's *not* set to true; that's implied by omission.

On Wed, Oct 18, 2017 at 3:17 AM, Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
> Section describes how the controlled agent, when it receives a
> connectivity check with the USE-CANDIDATE attribute, generates a
> connectivity check, and when the response arrives sets the nominated flag.
>
> In my opinion, it should be stated that if the check fails, the controlled
> agent shall set the check list state to Failed (in the same way the
> controlling agent does if the nomination connectivity check request fails).
>
> Regards,
>
> Christer
>
> _______________________________________________
> Ice mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ice
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 19 Oct 2017 04:41:14 +0000

Hi,

>I assume you're talking about section 6.3.1.5, "Updating the Nominated Flag"? >But isn't connectivity check failure covered by Section 6.2.5.2, for both >controlling and controlled agents?

There is general text, but I was thinking that it would be more explicit – nomination does not happen just by sending a connectivity check, the check also needs to succeed.

Regards,

Christer

On Wed, Oct 18, 2017 at 3:17 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

_______________________________________________
Ice mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ice