Subject: Re: [Ice] Review of draft-holmberg-ice-pac-01

From: Justin Uberti <[email-masked]>
Date: Thu, 18 Apr 2019 14:50:06 -0700

Note that the app can always decide to declare failure at any point and
invoke an ICE restart.

On Sun, Mar 31, 2019 at 1:12 AM Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
>
>
> Doing an ICE restart means you have to collect and exchange candidates
> again. Of course one can do that once ICE failure has been declared, and
> nothing prevents one from doing an ICE restart after that if one thinks the
> result will be different. But, the focus of the draft is not to declare ICE
> failure while working candidates may still arrive.
>
>
>
> Having said that, one should of course not wait forever for the peer
> reflexive candidates. The draft will not mandate a specific time value, but
> there probably will be a little more text about things to take into
> consideration when determining how long to wait.
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
> *From: *Ice <[email-masked]> on behalf of Qingsi Wang <qingsi=
> [email-masked]>
> *Date: *Saturday, 30 March 2019 at 3.05
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *[Ice] Review of draft-holmberg-ice-pac-01
>
>
>
> If all available candidate pairs have either performed triggered checks or
> sent check response, but have timed out their checks however, should we
> cancel the timer and conclude a failure? The rationale is to wait for
> inbound checks, but if at least one round of checks are received, it's
> unclear to me if the waiting would benefit compared to allowing the app
> trigger an ICE restart after firing an failure.
>
>
>
> The rest looks good to me.
>
>
>
> Best,
>
> Qingsi
> _______________________________________________
> Ice mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ice
>

---

From: Justin Uberti <[email-masked]>
Date: Thu, 18 Apr 2019 14:51:12 -0700

Tracking this in https://github.com/cdh4u/draft-ice-pac/issues/10

On Thu, Apr 18, 2019 at 2:50 PM Justin Uberti <[email-masked]> wrote:

>> If all available candidate pairs have either performed triggered checks
>> or sent check response, but have timed out their checks however, should we