Subject: Re: [Id-event] Use case document

From: Marius Scurtescu <[email-masked]>
Date: Thu, 29 Jun 2017 16:42:16 -0700

I just submitted the RISC use cases at:
https://tools.ietf.org/html/draft-scurtescu-secevent-risc-use-cases-00

It is very basic right now, I just wanted to make sure that there is at
least a basic version submitted before the deadline.

I will expand the descriptions and add diagrams.

Let me know if anyone else would like to be an author.

Marius

Marius

On Wed, May 31, 2017 at 6:24 PM, Dick Hardt <[email-masked]> wrote:

> Agreed. There is no requirement for these to be in the same document.
>
> On Wed, May 31, 2017 at 5:33 PM, Phil Hunt (IDM) <[email-masked]>
> wrote:
>
>> Marius,
>>
>> Go ahead an submit as an individual draft. I will submit scim cases in a
>> separate draft.
>>
>> Afaik there is no plan to have this he a single wg document.
>>
>> Phil
>>
>> On May 31, 2017, at 9:22 PM, Marius Scurtescu <[email-masked]>
>> wrote:
>>
>> Here is an initial use case document, for now it has only the RISC use
>> cases we discussed so far. When Phil gets back I will coordinate with him
>> to add SCIM use cases to this same I-D. I will get this into a decent shape
>> for the IETF meeting.
>>
>> Marius
>>
>> On Thu, May 4, 2017 at 11:28 AM, Yaron Sheffer <[email-masked]>
>> wrote:
>>
>>> Whatever works for you - and that's the whole point of *individual*
>>> I-Ds.
>>>
>>> Thanks,
>>>
>>>     Yaron
>>>
>>> On 04/05/17 18:25, Marius Scurtescu wrote:
>>>
>>> Do we need one document for all use cases (all profiles) or one for each
>>> profiles?
>>>
>>> I am happy to create the one document or the one for RISC (if one per
>>> profile).
>>>
>>> Marius
>>>
>>> On Thu, May 4, 2017 at 3:36 AM, Yaron Sheffer <[email-masked]>
>>> wrote:
>>>
>>>> My strong preference would be an individual I-D that (as Justin says)
>>>> will NOT be pushed to RFC. Why an I-D at all? Because this is what IETF
>>>> folks are used to, and it is referenced from the WG agenda and minutes.
>>>>
>>>> Thanks,
>>>>
>>>>     Yaron
>>>>
>>>> On 04/05/17 07:57, Justin Richer wrote:
>>>>
>>>> In fact, I’m going to ask that we *not* push a use cases document
>>>> toward RFC. Use case documents are wonderful tools for guiding development,
>>>> but should be discarded as artifacts of that process once said process is
>>>> completed (or even well on its way).
>>>>
>>>> As such, RFC, wiki, blog post, or anything referenced from the list and
>>>> easily findable works.
>>>>
>>>>  — Justin
>>>>
>>>> On May 3, 2017, at 4:45 PM, Dick Hardt <[email-masked]> wrote:
>>>>
>>>> As the more experienced chair, I will defer to Yaron for guidance.
>>>>
>>>> So far no one has expected it to be adopted as an RFC
>>>>
>>>> On Wed, May 3, 2017 at 4:39 PM, Phil Hunt <[email-masked]> wrote:
>>>>
>>>>> Depends on what the WG wants.
>>>>>
>>>>> Email cases,
>>>>> Github posted document,
>>>>> Individual IDs posted to the working group, or
>>>>> an ID that gets adopted as a WG draft to end up as RFC (e.g. JOSE has
>>>>> RFC7165, and SCIM itself had RFC7642, Oauth had a WG draft
>>>>> https://tools.ietf.org/html/draft-ietf-oauth-use-cases-03
>>>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Doauth-2Duse-2Dcases-2D03&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk&s=_t4GRDPaCMns1jW640uMNo_o5BHH8kJCCQXUTLi9Qak&e=>
>>>>> ).
>>>>>
>>>>> Let us know what form and what format.
>>>>>
>>>>> We can also use one for OpenID Backchannel Logout.  This is
>>>>> particularly important because it will be triggered by (or is related to)
>>>>> SCIM and by RISC events such as account resets, authentication factor
>>>>> changes etc.
>>>>>
>>>>> Phil
>>>>>
>>>>> Oracle Corporation, Identity Cloud Services Architect & Standards
>>>>> @independentid
>>>>> www.independentid.com
>>>>> <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.independentid.com_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk&s=5rKXnv7GYvvsJ5huPmoGI3PpP85fUnQZrrKByzbbmYA&e=>
>>>>> [email-masked]
>>>>>
>>>>> On May 3, 2017, at 4:31 PM, Dick Hardt <[email-masked]> wrote:
>>>>>
>>>>> Hi Phil
>>>>>
>>>>> per
>>>>>
>>>>> https://mailarchive.ietf.org/arch/msg/id-event/FGuz9IsUMKqKe
>>>>> q2OjEBjCZ9cBcI
>>>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_id-2Devent_FGuz9IsUMKqKeq2OjEBjCZ9cBcI&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=ebhqgdwBfmclFpVn-cScD6uoiYqkmZVlRpC3XXk91Es&e=>
>>>>>
>>>>> you offered to put them in a WG doc (see quate below). Would that not
>>>>> be an ID. Also, as I read over the document, it is hard to follow what the
>>>>> use cases are as it is very verbose.
>>>>>
>>>>> On Tue, Apr 18, 2017 at 11:27 AM, Phil Hunt <[email-masked]> <[email-masked]&gt>; wrote:
>>>>>
>>>>> > All,
>>>>> >
>>>>> > Dick asked me if I would enumerate the SCIM use cases.  Here is the SCIM
>>>>> > case. Happy to put these somewhere in a working group document.
>>>>>
>>>>>
>>>>> On Wed, May 3, 2017 at 4:16 PM, Phil Hunt <[email-masked]> wr
>>>>> ote:
>>>>>
>>>>>> My understanding was you wanted informal cases not IDs. The SCIM
>>>>>> cases have been posted to the mailing list. I believe Marius is close on
>>>>>> the RISC cases.
>>>>>>
>>>>>> Phil
>>>>>>
>>>>>> Oracle Corporation, Identity Cloud Services Architect & Standards
>>>>>> @independentid
>>>>>> www.independentid.com
>>>>>> <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.independentid.com&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=nBNO3_d_Mw4enpU54VxuTcoqCJSXkSSzg8LnXIkI5bg&e=>
>>>>>> [email-masked]
>>>>>>
>>>>>> On May 3, 2017, at 3:56 PM, Dick Hardt <[email-masked]> wrote:
>>>>>>
>>>>>> Phil / Marius
>>>>>>
>>>>>> At the Chicago meeting, the two of you agreed to work on a document
>>>>>> containing use cases you considered to be relevant for secevent so that the
>>>>>> WG could decide which ones were in scope and which ones were out of scope.
>>>>>>
>>>>>> Checking in on the status of the use case document. Would you provide
>>>>>> an update when you have a chance?
>>>>>>
>>>>>> /Dick
>>>>>>
>>>>>> _______________________________________________
>>>>>> Id-event mailing list
>>>>>> [email-masked]
>>>>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iet
>>>>>> f.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHv
>>>>>> lZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzj
>>>>>> WwlNKe4C_lLIGk&m=HWdy4Q9fHAYB3f-DZ2GWUJnaZDGcZQRaMexC2oHuR7g
>>>>>> &s=JTwCxbXPzY_A62IiywTMIjRB-XsMY8UPafBs4oPwOTc&e=
>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Subscribe to the HARDTWARE
>>>>> <https://urldefense.proofpoint.com/v2/url?u=http-3A__hardtware.com_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=uVstd9R0_1UCdJ6s_rcX7xhYo6fyGuk22APkiwL0vpI&e=>
>>>>>  mail list to learn about projects I am working on!
>>>>> _______________________________________________
>>>>> Id-event mailing list
>>>>> [email-masked]
>>>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iet
>>>>> f.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHv
>>>>> lZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzj
>>>>> WwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q
>>>>> &s=fzkXYKa7l9vPc2VrpDeaBZo7bH9cDrk9wUethVbuCS8&e=
>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>> --
>>>> Subscribe to the HARDTWARE
>>>> <https://urldefense.proofpoint.com/v2/url?u=http-3A__hardtware.com_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk&s=vljaqeEQFcDwsi_zNO5R2uecLv2B3VE8QvdEVBRHIGI&e=>
>>>>  mail list to learn about projects I am working on!
>>>> _______________________________________________
>>>> Id-event mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/id-event
>>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk&s=t5e3IvZ_e-KRHUBVMfjtwKEs74yLZva4z-6OkkgmSjo&e=>
>>>>
>>>>
>>>>
>>>>
>>>
>>>
>> <draft-scurtescu-secevent-use-cases.txt>
>>
>> <draft-scurtescu-secevent-use-cases.pdf>
>>
>> _______________________________________________
>> Id-event mailing list
>> [email-masked]
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iet
>> f.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHv
>> lZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivz
>> jWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0v
>> k&s=t5e3IvZ_e-KRHUBVMfjtwKEs74yLZva4z-6OkkgmSjo&e=
>>
>>
>
>
> --
> Subscribe to the HARDTWARE <http://hardtware.com/> mail list to learn
> about projects I am working on!
>

---

From: Mike Jones <[email-masked]>
Date: Fri, 30 Jun 2017 00:17:28 +0000

Wearing my OpenID member hat – why isn’t this a RISC working group document, rather than an SECEVENT working group document?

From: Id-event [mailto:[email-masked]] On Behalf Of Marius Scurtescu
Sent: Thursday, June 29, 2017 4:42 PM
To: Dick Hardt <[email-masked]>
Cc: Yaron Sheffer <[email-masked]>; SecEvent <[email-masked]>; Justin Richer <[email-masked]>; Phil Hunt (IDM) <[email-masked]>
Subject: Re: [Id-event] Use case document

It is very basic right now, I just wanted to make sure that there is at least a basic version submitted before the deadline.

Marius

Marius

On Wed, May 31, 2017 at 6:24 PM, Dick Hardt <[email-masked]<mailto:[email-masked]>> wrote:
Agreed. There is no requirement for these to be in the same document.

On Wed, May 31, 2017 at 5:33 PM, Phil Hunt (IDM) <[email-masked]<mailto:[email-masked]>> wrote:
Marius,

Go ahead an submit as an individual draft. I will submit scim cases in a separate draft.

Phil

On May 31, 2017, at 9:22 PM, Marius Scurtescu <[email-masked]<mailto:[email-masked]>> wrote:
Here is an initial use case document, for now it has only the RISC use cases we discussed so far. When Phil gets back I will coordinate with him to add SCIM use cases to this same I-D. I will get this into a decent shape for the IETF meeting.

Marius

On Thu, May 4, 2017 at 11:28 AM, Yaron Sheffer <[email-masked]<mailto:[email-masked]>> wrote:

Whatever works for you - and that's the whole point of *individual* I-Ds.

Thanks,

    Yaron

On 04/05/17 18:25, Marius Scurtescu wrote:
Do we need one document for all use cases (all profiles) or one for each profiles?

I am happy to create the one document or the one for RISC (if one per profile).

Marius

On Thu, May 4, 2017 at 3:36 AM, Yaron Sheffer <[email-masked]<mailto:[email-masked]>> wrote:

My strong preference would be an individual I-D that (as Justin says) will NOT be pushed to RFC. Why an I-D at all? Because this is what IETF folks are used to, and it is referenced from the WG agenda and minutes.

Thanks,

    Yaron

On 04/05/17 07:57, Justin Richer wrote:
In fact, I’m going to ask that we *not* push a use cases document toward RFC. Use case documents are wonderful tools for guiding development, but should be discarded as artifacts of that process once said process is completed (or even well on its way).

As such, RFC, wiki, blog post, or anything referenced from the list and easily findable works.

 — Justin

On May 3, 2017, at 4:45 PM, Dick Hardt <[email-masked]<mailto:[email-masked]>> wrote:

On Wed, May 3, 2017 at 4:39 PM, Phil Hunt <[email-masked]<mailto:[email-masked]>> wrote:
Depends on what the WG wants.

Email cases,
Github posted document,
Individual IDs posted to the working group, or
an ID that gets adopted as a WG draft to end up as RFC (e.g. JOSE has RFC7165, and SCIM itself had RFC7642, Oauth had a WG draft https://tools.ietf.org/html/draft-ietf-oauth-use-cases-03<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Doauth-2Duse-2Dcases-2D03&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk&s=_t4GRDPaCMns1jW640uMNo_o5BHH8kJCCQXUTLi9Qak&e=>).

We can also use one for OpenID Backchannel Logout.  This is particularly important because it will be triggered by (or is related to) SCIM and by RISC events such as account resets, authentication factor changes etc.

Phil

Oracle Corporation, Identity Cloud Services Architect & Standards
@independentid
www.independentid.com<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.independentid.com_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk&s=5rKXnv7GYvvsJ5huPmoGI3PpP85fUnQZrrKByzbbmYA&e=>
[email-masked]<mailto:[email-masked]>

On May 3, 2017, at 4:31 PM, Dick Hardt <[email-masked]<mailto:[email-masked]>> wrote:

Hi Phil

per

https://mailarchive.ietf.org/arch/msg/id-event/FGuz9IsUMKqKeq2OjEBjCZ9cBcI<https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_id-2Devent_FGuz9IsUMKqKeq2OjEBjCZ9cBcI&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=ebhqgdwBfmclFpVn-cScD6uoiYqkmZVlRpC3XXk91Es&e=>

you offered to put them in a WG doc (see quate below). Would that not be an ID. Also, as I read over the document, it is hard to follow what the use cases are as it is very verbose.

> case. Happy to put these somewhere in a working group document.

On Wed, May 3, 2017 at 4:16 PM, Phil Hunt <[email-masked]<mailto:[email-masked]>> wrote:
My understanding was you wanted informal cases not IDs. The SCIM cases have been posted to the mailing list. I believe Marius is close on the RISC cases.

Phil

Oracle Corporation, Identity Cloud Services Architect & Standards
@independentid
www.independentid.com<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.independentid.com&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=nBNO3_d_Mw4enpU54VxuTcoqCJSXkSSzg8LnXIkI5bg&e=>
[email-masked]<mailto:[email-masked]>

On May 3, 2017, at 3:56 PM, Dick Hardt <[email-masked]<mailto:[email-masked]>> wrote:

Phil / Marius

At the Chicago meeting, the two of you agreed to work on a document containing use cases you considered to be relevant for secevent so that the WG could decide which ones were in scope and which ones were out of scope.

Checking in on the status of the use case document. Would you provide an update when you have a chance?

/Dick

_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=HWdy4Q9fHAYB3f-DZ2GWUJnaZDGcZQRaMexC2oHuR7g&s=JTwCxbXPzY_A62IiywTMIjRB-XsMY8UPafBs4oPwOTc&e=

--
Subscribe to the HARDTWARE<https://urldefense.proofpoint.com/v2/url?u=http-3A__hardtware.com_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=uVstd9R0_1UCdJ6s_rcX7xhYo6fyGuk22APkiwL0vpI&e=> mail list to learn about projects I am working on!
_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=fzkXYKa7l9vPc2VrpDeaBZo7bH9cDrk9wUethVbuCS8&e=

--
Subscribe to the HARDTWARE<https://urldefense.proofpoint.com/v2/url?u=http-3A__hardtware.com_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk&s=vljaqeEQFcDwsi_zNO5R2uecLv2B3VE8QvdEVBRHIGI&e=> mail list to learn about projects I am working on!
_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/id-event<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk&s=t5e3IvZ_e-KRHUBVMfjtwKEs74yLZva4z-6OkkgmSjo&e=>

<draft-scurtescu-secevent-use-cases.txt>
<draft-scurtescu-secevent-use-cases.pdf>
_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk&s=t5e3IvZ_e-KRHUBVMfjtwKEs74yLZva4z-6OkkgmSjo&e=

--
Subscribe to the HARDTWARE<http://hardtware.com/> mail list to learn about projects I am working on!

---

From: "Phil Hunt (IDM)" <[email-masked]>
Date: Thu, 29 Jun 2017 17:20:28 -0700

Marius

Thanks!

I plan to publish the SCIM cases as well soon. 

Phil

> On Jun 29, 2017, at 4:42 PM, Marius Scurtescu <[email-masked]> wrote:
> 
>>> On Wed, May 31, 2017 at 5:33 PM, Phil Hunt (IDM) <[email-masked]> wrote:
>> 
>>> Marius,
>>> 
>>>> On May 31, 2017, at 9:22 PM, Marius Scurtescu <[email-masked]> wrote:
>>>> 
>>>>> On Thu, May 4, 2017 at 11:28 AM, Yaron Sheffer <[email-masked]> wrote:
>>>>>>> On Thu, May 4, 2017 at 3:36 AM, Yaron Sheffer <[email-masked]> wrote:
>>>>>>>>>> an ID that gets adopted as a WG draft to end up as RFC (e.g. JOSE has RFC7165, and SCIM itself had RFC7642, Oauth had a WG draft https://tools.ietf.org/html/draft-ietf-oauth-use-cases-03).
>>>>>>>>>> 
>>>>>>>>>>> https://mailarchive.ietf.org/arch/msg/id-event/FGuz9IsUMKqKeq2OjEBjCZ9cBcI
>>>>>>>>>>> 
>>>>>>>>>>> On Tue, Apr 18, 2017 at 11:27 AM, Phil Hunt <[email-masked]>; wrote:
>>>>>>>>>>> 
>>>>>>>>>>> > All,
>>>>>>>>>>> >
>>>>>>>>>>>> On Wed, May 3, 2017 at 4:16 PM, Phil Hunt <[email-masked]> wrote:
>>>>>>>>>>> Subscribe to the HARDTWARE mail list to learn about projects I am working on!
>>>>>>>>> Subscribe to the HARDTWARE mail list to learn about projects I am working on!
>> Subscribe to the HARDTWARE mail list to learn about projects I am working on!
>

---

From: Dick Hardt <[email-masked]>
Date: Thu, 29 Jun 2017 17:20:57 -0700

Wearing my secevent chair hat.

We asked secevent participants to provide use cases. Marius was writing
them for RISC. As I recall, Phil was going to write them for SCIM.

On Thu, Jun 29, 2017 at 5:17 PM, Mike Jones <[email-masked]>
wrote:

> Wearing my OpenID member hat – why isn’t this a RISC working group
> document, rather than an SECEVENT working group document?
>
>
>
> *From:* Id-event [mailto:[email-masked]] * On Behalf Of *Marius
> Scurtescu
> *Sent:* Thursday, June 29, 2017 4:42 PM
> *To:* Dick Hardt <[email-masked]>
> *Cc:* Yaron Sheffer <[email-masked]>; SecEvent <[email-masked]>;
> Justin Richer <[email-masked]>; Phil Hunt (IDM) <[email-masked]>
> *Subject:* Re: [Id-event] Use case document
>
>
>
> My strong preference would be an individual I-D that (as Justin says) will
> NOT be pushed to RFC. Why an I-D at all? Because this is what IETF folks
> are used to, and it is referenced from the WG agenda and minutes.
>
> Thanks,
>
>     Yaron
>
>
>
> In fact, I’m going to ask that we *not* push a use cases document toward
> RFC. Use case documents are wonderful tools for guiding development, but
> should be discarded as artifacts of that process once said process is
> We can also use one for OpenID Backchannel Logout.  This is particularly
> important because it will be triggered by (or is related to) SCIM and by
> RISC events such as account resets, authentication factor changes etc.
>
>
>
> Phil
>
>
>
> you offered to put them in a WG doc (see quate below). Would that not be
> an ID. Also, as I read over the document, it is hard to follow what the use
> cases are as it is very verbose.
>
>
>
> My understanding was you wanted informal cases not IDs. The SCIM cases
> have been posted to the mailing list. I believe Marius is close on the RISC
> cases.
>
>
>
> Phil
>
>
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=
> RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=
> JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=HWdy4Q9fHAYB3f-
> DZ2GWUJnaZDGcZQRaMexC2oHuR7g&s=JTwCxbXPzY_A62IiywTMIjRB-
> XsMY8UPafBs4oPwOTc&e=
>
>
>
>
>
>
>
> --
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=
> RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=
> JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=
> bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=
> fzkXYKa7l9vPc2VrpDeaBZo7bH9cDrk9wUethVbuCS8&e=
>
>
>
>
>
>
>
> --
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=
> RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=
> JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-
> LWrcrcTS6Ly1w14yDo0vk&s=t5e3IvZ_e-KRHUBVMfjtwKEs74yLZva4z-6OkkgmSjo&e=
>
>
>
>
>
> --
>

-- 
Subscribe to the HARDTWARE <http://hardtware.com/> mail list to learn about
projects I am working on!

---

From: Dick Hardt <[email-masked]>
Date: Thu, 29 Jun 2017 17:21:28 -0700

Thanks Phil!

On Thu, Jun 29, 2017 at 5:20 PM, Phil Hunt (IDM) <[email-masked]>
wrote:

> <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dscurtescu-2Dsecevent-2Drisc-2Duse-2Dcases-2D00&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=tjsYXq_mrcdpu3SY0cMGnrJ8mP9mJFWP4FmuuQquso8&s=9y2RyAg9C03RYJyE_OynfRfi055mtkWrZ5_DXXT77iM&e=>
>
>>>>>>> Checking in on the status of the use case document. Would you
>>>>>>> provide an update when you have a chance?
>>>>>>>
>>>>>>> /Dick
>>>>>>>
>>> WwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk
>>> &s=t5e3IvZ_e-KRHUBVMfjtwKEs74yLZva4z-6OkkgmSjo&e=
>>>
>>>
>>
>>
>> --
>> <https://urldefense.proofpoint.com/v2/url?u=http-3A__hardtware.com_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=tjsYXq_mrcdpu3SY0cMGnrJ8mP9mJFWP4FmuuQquso8&s=_ru-WnihtifEcXBG9FHuP7GlFGZZwVpwSiO-ONzr7EE&e=>

---

From: Yaron Sheffer <[email-masked]>
Date: Fri, 30 Jun 2017 20:59:48 -0700

Hi Mike,

I think the abstract explains it very clearly: "This document describes 
the RISC use cases for security events and helps with defining the 
requirements for token format and event distribution."

This is a useful document in the secevent context (though not a working 
group document). In addition, Marius is free of course to republish his 
document in RISC or elsewhere.

Thanks,

     Yaron

On 29/06/17 17:17, Mike Jones wrote:
> *From:* Id-event [mailto:[email-masked]] *On Behalf Of 
> *Marius Scurtescu
> *Cc:* Yaron Sheffer <[email-masked]>; SecEvent 
> <[email-masked]>; Justin Richer <[email-masked]>; Phil Hunt (IDM) 
> <[email-masked]>
> It is very basic right now, I just wanted to make sure that there is 
> at least a basic version submitted before the deadline.
>
>     On Wed, May 31, 2017 at 5:33 PM, Phil Hunt (IDM)
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>         Marius,
>
>         On May 31, 2017, at 9:22 PM, Marius Scurtescu
>         <[email-masked] <mailto:[email-masked]>> wrote:
>
>             Here is an initial use case document, for now it has only
>             the RISC use cases we discussed so far. When Phil gets
>             back I will coordinate with him to add SCIM use cases to
>             this same I-D. I will get this into a decent shape for the
>             IETF meeting.
>
>
>             Marius
>
>             On Thu, May 4, 2017 at 11:28 AM, Yaron Sheffer
>             <[email-masked] <mailto:[email-masked]>> wrote:
>
>                     On Thu, May 4, 2017 at 3:36 AM, Yaron Sheffer
>                     <[email-masked]
>                     <mailto:[email-masked]>> wrote:
>
>                         My strong preference would be an individual
>                         I-D that (as Justin says) will NOT be pushed
>                         to RFC. Why an I-D at all? Because this is
>                         what IETF folks are used to, and it is
>                         referenced from the WG agenda and minutes.
>
>                         Thanks,
>
>                             Yaron
>
>                             In fact, I’m going to ask that we *not*
>                             push a use cases document toward RFC. Use
>                             case documents are wonderful tools for
>                             guiding development, but should be
>                             discarded as artifacts of that process
>                             once said process is completed (or even
>                             well on its way).
>
>                             As such, RFC, wiki, blog post, or anything
>                             referenced from the list and easily
>                             findable works.
>
>                              — Justin
>
>                                 On May 3, 2017, at 4:45 PM, Dick Hardt
>                                 <[email-masked]
>                                 <mailto:[email-masked]>> wrote:
>
>                                 On Wed, May 3, 2017 at 4:39 PM, Phil
>                                 Hunt<[email-masked]
>                                 <mailto:[email-masked]>>wrote:
>
>                                     an ID that gets adopted as a WG
>                                     draft to end up as RFC (e.g. JOSE
>                                     has RFC7165, and SCIM itself had
>                                     RFC7642, Oauth had a WG
>                                     drafthttps://tools.ietf.org/html/draft-ietf-oauth-use-cases-03
>                                     <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Doauth-2Duse-2Dcases-2D03&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk&s=_t4GRDPaCMns1jW640uMNo_o5BHH8kJCCQXUTLi9Qak&e=>).
>
>                                     particularly important because it
>                                     will be triggered by (or is
>                                     related to) SCIM and by RISC
>                                     events such as account resets,
>                                     authentication factor changes etc.
>
>                                     Phil
>
>                                     <mailto:[email-masked]>
>
>                                         On May 3, 2017, at 4:31 PM,
>                                         Dick Hardt
>                                         <[email-masked]
>                                         <mailto:[email-masked]>>
>                                         wrote:
>
>                                         Hi Phil
>
>                                         per
>
>                                         you offered to put them in a
>                                         WG doc (see quate below).
>                                         Would that not be an ID. Also,
>                                         as I read over the document,
>                                         it is hard to follow what the
>                                         On Tue, Apr 18, 2017 at 11:27
>                                         AM, Phil Hunt
>                                         <[email-masked]>
>                                         <mailto:[email-masked]&gt>;
>                                         wrote:
>
>                                         > All,
>
>                                         >
>
>                                         On Wed, May 3, 2017 at 4:16
>                                         PM, Phil
>                                         Hunt<[email-masked]
>                                         <mailto:[email-masked]>>wrote:
>
>                                             My understanding was you
>                                             wanted informal cases not
>                                             IDs. The SCIM cases have
>                                             been posted to the mailing
>                                             list. I believe Marius is
>                                             close on the RISC cases.
>
>                                             Phil
>
>                                             Oracle Corporation,
>                                             Identity Cloud Services
>                                             Architect & Standards
>
>                                             @independentid
>
>                                             www.independentid.com
>                                             <mailto:[email-masked]>
>
>                                                 On May 3, 2017, at
>                                                 3:56 PM, Dick Hardt
>                                                 <[email-masked]
>                                                 <mailto:[email-masked]>>
>                                                 wrote:
>
>                                                 Phil / Marius
>
>                                                 At the Chicago
>                                                 meeting, the two of
>                                                 you agreed to work on
>                                                 a document containing
>                                                 use cases you
>                                                 considered to be
>                                                 relevant for secevent
>                                                 so that the WG could
>                                                 decide which ones were
>                                                 in scope and which
>                                                 ones were out of scope.
>
>                                                 Checking in on the
>                                                 status of the use case
>                                                 document. Would you
>                                                 provide an update when
>                                                 you have a chance?
>
>                                                 /Dick
>
>                                                 <mailto:[email-masked]>
>                                         Subscribe to theHARDTWARE
>                                         <https://urldefense.proofpoint.com/v2/url?u=http-3A__hardtware.com_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=bAI2H661a1QkItfplrd3RIM36dgAhF4WdbWxW8BOy4Q&s=uVstd9R0_1UCdJ6s_rcX7xhYo6fyGuk22APkiwL0vpI&e=>mail
>                                         list to learn about projects I
>                                         am working on!
>
>                                         <mailto:[email-masked]>
>
>                                 Subscribe to theHARDTWARE
>                                 <https://urldefense.proofpoint.com/v2/url?u=http-3A__hardtware.com_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=gwGItrqQynlr86zXGtWnR-LWrcrcTS6Ly1w14yDo0vk&s=vljaqeEQFcDwsi_zNO5R2uecLv2B3VE8QvdEVBRHIGI&e=>mail
>                                 list to learn about projects I am
>                                 working on!
>
>                                 <mailto:[email-masked]>
>             [email-masked] <mailto:[email-masked]>
>     Subscribe to the HARDTWARE <http://hardtware.com/> mail list to
>     learn about projects I am working on!
>