Subject: [Id-event] Bounced Mail - How You Can Help Fix

From: Phil Hunt <[email-masked]>
Date: Sat, 1 Jul 2017 10:09:30 -0700

If you have been getting bounce notification messages from the id-events mailing list or even suspensions notifications, this is what is going on according to Matt Larson:

> Greetings all!
> 
> Welcome to the exciting and interesting world of mailing lists in a DMARC
> environment :)
> 
> Here is what is happening.
> 
> A user with a Microsoft.com <http://microsoft.com/> address sent an email to the mailing list. The
> mailing list processor then forwarded the email to everyone on the list, using
> the sender's email address as the 'from' address.
> 
> Gmail received the email from the IETF mail transport, with a Microsoft.com <http://microsoft.com/>
> from address, and so it checked Microsoft's published DMARC policy, and it
> discovered that the IETF servers are not authorized to send emails for the
> Microsoft.com <http://microsoft.com/> domain. This generated a bounce:
> 
> <[email-masked] <mailto:[email-masked]>>: host gmail-smtp-in.l.google.com <http://gmail-smtp-in.l.google.com/>[173.194.175.27] said:
> 550-5.7.1 Unauthenticated email from microsoft.com <http://microsoft.com/> is not accepted due to
> 550-5.7.1 domain's DMARC policy. Please contact the administrator of 550-5.7.1
> microsoft.com <http://microsoft.com/> domain if this was a legitimate mail. Please visit 550-5.7.1
<<snip>>
> 
> The DMARC mailing list issue has been a topic of active discussion among the
> Technology Management Committee, and there is work in progress toward
> developing a solution. Unfortunately, until this work is completed and a
> solution deployed, mailing list users whose mail transports have strict DMARC
> policies will continue to experience difficulties. Matt
> 

When your email provider is bouncing emails (for any ietf list), you start getting on the list of mis-behaving subscribers and eventually suspended from this list.

I did get a tip from John Bradley that seems to help fix the problem at least for Gmail and Google.com receivers:

> 
> If it is a gmail account.
>  
> Go to settings in the web interface.
>  
> Find “Filters and Blocked Addresses”
> He needs to add filters for both the ietf and OIDF lists.
>  
> Match on “Has the words”  list:"@ietf.org”  or list:"@lists.openid.net”
>  
> For actions I have “Never send to spam” selected 
> I also have categorize as “Forums”  selected to make filtering the mailbox easier.  I can hide the list mail to cut clutter.
>  
> It is not perfect but it works to override the DKIM failure in the spam processing.
>  
> John B.

I went through the list of subscribers and reset anyone who was been suspended for bouncing. I’ve set the number of allowed bounces up from 5 to 20 so at least the suspensions will happen less often.

If you, or your colleague is suspended and can’t get back on, let me know and I can subscribe you manually.

Cheers,

Phil

Oracle Corporation, Identity Cloud Services Architect & Standards
@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

---

From: John Bradley <[email-masked]>
Date: Sat, 1 Jul 2017 13:18:31 -0400

Cool, I don’t know the list started suspending people for bounces.

I just did it to stop posts from Brian Campbell from gong in the spam when Ping turned on DMARC then Microsoft. 

My fix has the small side effect of turning off all spam processing on the filters lists.
Someone could probably come up with a more specific filter but just matching the list seemed to work for me.

John B.

> On Jul 1, 2017, at 1:09 PM, Phil Hunt <[email-masked]> wrote:
> 
> I did get a tip from John Bradley that seems to help fix the problem at least for Gmail and Google.com <http://google.com/> receivers:
> 
>> 
> _______________________________________________
> Id-event mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/id-event