Subject: [Id-event] Verify Event move to control plane draft

From: Marius Scurtescu <[email-masked]>
Date: Wed, 19 Jul 2017 12:42:04 +0200

Hi Phil,

The verification event is defined in the delivery draft while the api to
trigger it is defined in the control plane draft. Since it is not directly
related to delivery we are thinking that it would make sense to move the
definition to the control plane draft next to the corresponding api.

Does that make sense to you?

Both drafts are attached for reference.

Marius

---

From: Dick Hardt <[email-masked]>
Date: Wed, 19 Jul 2017 10:50:51 +0000

+1

On Wed, Jul 19, 2017 at 12:42 PM Marius Scurtescu <[email-masked]>
wrote:

> _______________________________________________
> Id-event mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/id-event
>
-- 
Subscribe to the HARDTWARE <http://hardtware.com/> mail list to learn about
projects I am working on!

---

From: Phil Hunt <[email-masked]>
Date: Wed, 19 Jul 2017 07:57:51 -0600

Yes I think we discussed this on one of the author calls. I recall that we had planned to move it once there was a control plane draft.

As background for others on the list:

In the original distribution draft, verify was transmitter initiated. We had to change to receiver initiated due to the polling profile.  The original draft required the receiver to acknowledge with the parsed confirmation value.  This doesn’t work so well in polling mode. We realized that verify is much simpler overall if we change to receiver initiated.

We now suggest the receiver requests a verify through control plane and gets confirmation back. It’s up to the receiver to raise an alarm (I assume through administrative channels) when a verify is not received when and as expected.  Note:  the receiver and transmitter could also agree to exchange a verify if no new events have occurred in a period of time in order to let operations centres know the delivery system is working.

Phil

Oracle Corporation, Identity Cloud Services Architect & Standards
@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>
> On Jul 19, 2017, at 4:50 AM, Dick Hardt <[email-masked]> wrote:
> 
> +1
> 
> On Wed, Jul 19, 2017 at 12:42 PM Marius Scurtescu <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Phil,
> 
> The verification event is defined in the delivery draft while the api to trigger it is defined in the control plane draft. Since it is not directly related to delivery we are thinking that it would make sense to move the definition to the control plane draft next to the corresponding api.
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/id-event <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=JdllRkPTlIB1AfExZWGfqtmhvVlWDOSz4HGo1ilgTZw&s=YrouF2OfsPag_qQgiWd6jUq3QYWKdY9r2HFDo6BFGcg&e=>
> -- 
> Subscribe to the HARDTWARE <https://urldefense.proofpoint.com/v2/url?u=http-3A__hardtware.com_&d=DwMFaQ&c=RoP1YumCXCgaWHvlZYR8PQcxBKCX5YTpkKY057SbK10&r=JBm5biRrKugCH0FkITSeGJxPEivzjWwlNKe4C_lLIGk&m=JdllRkPTlIB1AfExZWGfqtmhvVlWDOSz4HGo1ilgTZw&s=2FfGhagoi3ZbciSL00ye_4MMsOUQT3wrw-xC7wXnocA&e=> mail list to learn about projects I am working on!