Subject: [Ideas] Diasambugating Identifier and Identity

From: Robert Moskowitz <[email-masked]>
Date: Tue, 28 Mar 2017 11:07:29 -0500

The Identifier/Identity definitions in 
draft-padma-ideas-problem-statement-01.txt is a good start, it fails in 
the appreviations used. (There is NO abbreviation for Identity!)

ID should NOT be the appreviation of Identitfier.  People will default 
to thinking 'Identity' when they see it.  Think about people outside our 
discussion group.

I propose 'IDf' for Identifier.  'ID' is too owned by Identity.

I will be working on proposed wording to improve these definitions.

---

From: Padma Pillay-Esnault <[email-masked]>
Date: Tue, 28 Mar 2017 16:54:21 -0500

Hi Robert

Thanks for our comment.

On Tue, Mar 28, 2017 at 11:07 AM, Robert Moskowitz <[email-masked]
> wrote:

> The Identifier/Identity definitions in draft-padma-ideas-problem-statement-01.txt
> is a good start, it fails in the appreviations used. (There is NO
> abbreviation for Identity!)
>

Yes I see your point.

>
> ID should NOT be the appreviation of Identitfier.  People will default to
> thinking 'Identity' when they see it.  Think about people outside our
> discussion group.
>

I feel in the past they were used  interchangeably depending on protocols
which further muddles the water.
May be we should have IDy and IDr?

> I will be working on proposed wording to improve these definitions.

Great!

Thanks
Padma

>
>
> _______________________________________________
> Ideas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ideas
>

---

From: Hesham ElBakoury <[email-masked]>
Date: Tue, 28 Mar 2017 22:35:11 +0000

We can use ID for identifier, and IDn, or IDT for identity (although sometimes IDT is used for identity theft).

Sent from HUAWEI AnyOffice
From:Padma Pillay-Esnault
To:Robert Moskowitz
Cc:[email-masked],Padma Pillay-Esnault
Date:2017-03-28 14:54:43
Subject:Re: [Ideas] Diasambugating Identifier and Identity

Hi Robert

Thanks for our comment.

On Tue, Mar 28, 2017 at 11:07 AM, Robert Moskowitz <[email-masked]<mailto:[email-masked]>> wrote:
The Identifier/Identity definitions in draft-padma-ideas-problem-statement-01.txt is a good start, it fails in the appreviations used. (There is NO abbreviation for Identity!)

Yes I see your point.

ID should NOT be the appreviation of Identitfier.  People will default to thinking 'Identity' when they see it.  Think about people outside our discussion group.

I feel in the past they were used  interchangeably depending on protocols which further muddles the water.
May be we should have IDy and IDr?

Great!

Thanks
Padma

_______________________________________________
Ideas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ideas

---

From: Alexander Clemm <[email-masked]>
Date: Wed, 29 Mar 2017 02:54:27 +0000

I also think that ID is better used for identifier, not identity.

That said, it seems either way there is potential for confusion, so maybe we just need to bite the bullet and spell it out wherever possible.

In cases where abbreviation cannot be avoided, it may be a good idea to refrain from using "ID" at all (also avoid mixed upper/lower case).  IDT works for Identity, how about IDF for identifier (since there is no F in identity)?

--- Alex

From: Ideas [mailto:[email-masked]] On Behalf Of Hesham ElBakoury
Sent: Tuesday, March 28, 2017 3:35 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Ideas] Diasambugating Identifier and Identity

Hi Robert

Thanks for our comment.

Yes I see your point.

Great!

Thanks
Padma

---

From: Hesham ElBakoury <[email-masked]>
Date: Wed, 29 Mar 2017 02:57:51 +0000

Alex,

I was actually thinking to use IDF for identifier, but in may of the projects I worked on, we used ID for identifier.

Hesham

From: Alexander Clemm
Sent: Tuesday, March 28, 2017 7:54 PM
To: Hesham ElBakoury; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ideas] Diasambugating Identifier and Identity

--- Alex

Hi Robert

Thanks for our comment.

Yes I see your point.

Great!

Thanks
Padma

---

From: <[email-masked]>
Date: Wed, 29 Mar 2017 06:40:04 +0000

E.g. 3GPP does not really distinguish between identity and identifier and use Id for both.

I would prefer to spell them out especially in a work that tries to further distinguish identifiers that are labels and identifiers that are addresses.

Axel

From: Ideas [mailto:[email-masked]] On Behalf Of Hesham ElBakoury
Sent: Wednesday, March 29, 2017 4:58 AM
To: Alexander Clemm; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Ideas] Diasambugating Identifier and Identity

Alex,

Hesham

From: Alexander Clemm
Sent: Tuesday, March 28, 2017 7:54 PM
To: Hesham ElBakoury; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Ideas] Diasambugating Identifier and Identity

--- Alex

From: Ideas [mailto:[email-masked]] On Behalf Of Hesham ElBakoury
Sent: Tuesday, March 28, 2017 3:35 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Ideas] Diasambugating Identifier and Identity

Hi Robert

Thanks for our comment.

Yes I see your point.

Great!

Thanks
Padma

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 29 Mar 2017 09:25:14 -0500

For many, the distinction is of small value or just perhaps confusing to 
them.  RFID is an example of confounding Identifier and Identity.

In Loc/EID work, the distinction is important.  With HIP, it is obvious, 
though it did take us some time to settle on HI and HIT. In '99 in 
draft-moskowitz-hip-arch-00.txt, I called them HI and HIGH, but talking 
about them was challenging.  :)

It was the -02 draft where we adopted HIT.  So I don't expect us, with 
generic naming, to 'get it right' the first time.

The distinction between Identifiers used for 'labels' or the more 
limited 'addresses' is potential constraints on Identifier construction 
rules.  There are other classes of Identifiers other than addresses that 
have constraining construction rules.

This is helping me work out the wording of defining Identifier and 
Identity.  I have talked around this for over 20 years and have written 
it down many times.  But almost always in a specific context.  Here I am 
striving for a general discussion of the two.

On 03/29/2017 01:40 AM, [email-masked] wrote:
> I would prefer to spell them out especially in a work that tries to 
> further distinguish identifiers that are labels and identifiers that 
> are addresses.
>
> Axel
>
> *From:*Ideas [mailto:[email-masked]] *On Behalf Of *Hesham 
> ElBakoury
> *Sent:* Wednesday, March 29, 2017 4:58 AM
> *To:* Alexander Clemm; [email-masked]; [email-masked]
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [Ideas] Diasambugating Identifier and Identity
>
> Alex,
>
> I was actually thinking to use IDF for identifier, but in may of the 
> projects I worked on, we used ID for identifier.
>
> Hesham
>
> *From:*Alexander Clemm
> *Sent:* Tuesday, March 28, 2017 7:54 PM
> *To:* Hesham ElBakoury; [email-masked] 
> <mailto:[email-masked]>; [email-masked] 
> <mailto:[email-masked]>
> *Cc:* [email-masked] <mailto:[email-masked]>; [email-masked] 
> <mailto:[email-masked]>
> *Subject:* RE: [Ideas] Diasambugating Identifier and Identity
>
> That said, it seems either way there is potential for confusion, so 
> maybe we just need to bite the bullet and spell it out wherever possible.
>
> In cases where abbreviation cannot be avoided, it may be a good idea 
> to refrain from using “ID” at all (also avoid mixed upper/lower 
> case).  IDT works for Identity, how about IDF for identifier (since 
> there is no F in identity)?
>
> --- Alex
>
> *From:*Ideas [mailto:[email-masked]] *On Behalf Of *Hesham 
> ElBakoury
> *Sent:* Tuesday, March 28, 2017 3:35 PM
> *To:* [email-masked] <mailto:[email-masked]>; 
> [email-masked] <mailto:[email-masked]>
> *Cc:* [email-masked] <mailto:[email-masked]>; [email-masked] 
> <mailto:[email-masked]>
> *Subject:* Re: [Ideas] Diasambugating Identifier and Identity
>
> We can use ID for identifier, and IDn, or IDT for identity (although 
> sometimes IDT is used for identity theft).
>
> *From:*Padma Pillay-Esnault
>
> *To:*Robert Moskowitz
>
> *Cc:[email-masked],Padma Pillay-Esnault
>
> *Date:*2017-03-28 14:54:43
>
> *Subject:*Re: [Ideas] Diasambugating Identifier and Identity
>
> Hi Robert
>
> Thanks for our comment.
>
> On Tue, Mar 28, 2017 at 11:07 AM, Robert Moskowitz 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     draft-padma-ideas-problem-statement-01.txt is a good start, it
>     fails in the appreviations used. (There is NO abbreviation for
>     Identity!)
>
> Yes I see your point.
>
>
>     ID should NOT be the appreviation of Identitfier. People will
>     default to thinking 'Identity' when they see it.  Think about
>     people outside our discussion group.
>
> I feel in the past they were used  interchangeably depending on 
> protocols which further muddles the water.
>
>     [email-masked] <mailto:[email-masked]>

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 29 Mar 2017 08:38:13 -0700

Why is this so important?

An Identifier identifies an entity. Can’t we move on to bigger fish to fry?

Dino

> On Mar 29, 2017, at 7:25 AM, Robert Moskowitz <[email-masked]> wrote:
> 
> For many, the distinction is of small value or just perhaps confusing to them.  RFID is an example of confounding Identifier and Identity.
> 
> In Loc/EID work, the distinction is important.  With HIP, it is obvious, though it did take us some time to settle on HI and HIT.  In '99 in draft-moskowitz-hip-arch-00.txt, I called them HI and HIGH, but talking about them was challenging.  :)  
> 
> It was the -02 draft where we adopted HIT.  So I don't expect us, with generic naming, to 'get it right' the first time.
> 
> The distinction between Identifiers used for 'labels' or the more limited 'addresses' is potential constraints on Identifier construction rules.  There are other classes of Identifiers other than addresses that have constraining construction rules.
> 
> This is helping me work out the wording of defining Identifier and Identity.  I have talked around this for over 20 years and have written it down many times.  But almost always in a specific context.  Here I am striving for a general discussion of the two.
> 
> 
>> In cases where abbreviation cannot be avoided, it may be a good idea to refrain from using “ID” at all (also avoid mixed upper/lower case).  IDT works for Identity, how about IDF for identifier (since there is no F in identity)?
>>  
>> --- Alex
>>  
>> On Tue, Mar 28, 2017 at 11:07 AM, Robert Moskowitz <[email-masked]> wrote:

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 29 Mar 2017 11:05:09 -0500

> An Identifier identifies an entity. Can’t we move on to bigger fish to fry?

No.  This ties very strongly into the service registry.

For some there is seems to be no distinction between Identifier and 
Identity, but when you get to registration and services, Identity starts 
going into policy decisions.

But as you indirectly indicate, I have some serious writing to do.

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 29 Mar 2017 09:08:32 -0700

> For some there is seems to be no distinction between Identifier and Identity, but when you get to registration and services, Identity starts going into policy decisions.

But an Identifier identifies an entity, so when the entity is registered it is described by an Identifier value. When an identity is described in a policy statement, it is described by an Identifier value.

It is hard to disagree with my statement above because it is such a fundamental and basic definition.

Dino