Subject: [Ideas] some comments on the requirement draft

From: "Liubingyang (Bryan)" <[email-masked]>
Date: Sun, 19 Mar 2017 07:10:18 +0000

Thanks for the authors for the work. I think this doc is very important for specifying the difference between ideas/grids from related works.

I suggest that in the next version, there should be a figure sketching the module structure of GRIDS, including the layers and interfaces between GRIDS-IS, GRIDS-MS, and GRIDS-SS, as well as the external service interfaces. One detail comment is that GRIDS-IS might not be a perfect naming, since it is "id service - id service".

For REQ-MS-40, a companion requirement may be needed for authorization (like REQ-MS-30), which allows authorized client to update the access-control list.

For REQ-IS-10, it is better to explicitly show that length and structure are two independent dimensions.

I think "root-of-trust" is an important element, which need to appear in the next version.

Best
Bingyang

---

From: Alexander Clemm <[email-masked]>
Date: Mon, 20 Mar 2017 17:46:57 +0000

Hello Bingyang,

Thank you for your detailed comments!

Given that this is a requirements document, not an architectural overview of GRIDS, I am not sure this is the right place to put a diagram, but clearly a diagram will be needed somewhere, as you rightfully point out.

Sure, we can discuss the naming.  GRIDS itself is more encompassing than GRIDS-IS and from the definition the distinction should be clear, but I agree that when the acronyms are expanded, the IS term sounds very similar which is something we may want to avoid.

I agree the policy-based authorization aspect deserves further expansion as well as potentially some examples of policies that could be applied.

On IS-10, sure we can mention this - note taken for next revision.

Regarding root-of-trust, we probably need more discussions.  This is still rev -00 so there are likely additional requirements that we need to put.

Best
--- Alex

From: Ideas [mailto:[email-masked]] On Behalf Of Liubingyang (Bryan)
Sent: Sunday, March 19, 2017 12:10 AM
To: [email-masked]
Subject: [Ideas] some comments on the requirement draft

Best
Bingyang