Subject: [Ideas] IDEAS BoF at IETF 99

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Wed, 7 Jun 2017 21:46:10 +0000

Dear IDEAS list:

The IAB/IESG held our BoF Coordination Call today, and it was decided to go forward with an IDEAS BoF at IETF 99.  Congratulations!
There are however some concerns that we need you (proponents/participants/authors) to address at the BoF.  Based on that, we should ideally be able to take some action, which could include chartering a WG(s), deciding that the work belongs in existing WGs, a combination, or even the decision of not doing anything.  From my point of view, the success of the BoF should be measured by whether we have the necessary information to make the correct decision.
In summary, the general concerns are (in no particular order):
- Portions of the existing drafts, and even the proposed Charter, sound like marketing materials.  The IETF, and this process in particular, are not the place to do marketing – we need you then to clean up the existing documentation and simply get to the technical point you’re trying to make.
- It is not completely clear from the current documents exactly what the IETF can/should work on.  We need a gap analysis that clearly and explicitly spells out what is needed and a discussion of why current protocols may not be appropriate (if a new protocol is required, for example).
- A question was brought up about current deployment of existing ID/Loc protocols (lisp, ila, etc.) and whether a common framework is needed (as proposed) or if the community would be better served by a new protocol…or maybe both.  IOW, we would like to see this discussion as part of the problem description and justification for the work.
- What about overlap with other SDOs? Why is the IETF the right place?

We would of course not only want to see these points covered during the BoF, but also documented in the appropriate drafts.  Please keep the ID submission cut-off date in mind (July/3).

Erik Nordmark (cc’d) has stepped up to act as IAB Shepherd.  He will work with you (the proponents/list) with an architectural point of view in mind.  I will continue to be the Responsible AD through the process.
One of the process items we need to work on is the assignment of BoF Chairs.  Ideally, the BoF Chairs are not one of the proponents or authors.  At this point we need someone to drive through the process more than anything else – reminder: being a BoF Chair doesn’t necessarily translate into WG Chair (if one was to be chartered).  If anyone has a suggestion, please send me a private note.
Once we identify BoF Chairs, I will work with them in defining the Agenda.  In general, we want to be able to answer the following questions (we’ll refine them as we go):
- Are the Problem Statement and Use Cases clear?  Is the scope of the problem well defined and understood?
- Does the Gap Analysis reflect the requirements gleaned from the Problem Statement/Use Cases?  Are these the right deliverables?
- Is the Charter text clear and understandable?  Does it reflect the Gap Analysis?  [*]
- Should the IETF do this work?
- Who is willing to contribute (write, review, comment, etc.)?

[*] Note: depending on what the Gap Analysis shows, we might not have a Charter discussion – maybe just a discussion about potential work items (which may belong to existing WGs, for example).  Also, even if a Charter is not discussed at the BoF, formation of a new WG (as needed) is not precluded.

Thanks!
Alvaro.

---

From: Padma Pillay-Esnault <[email-masked]>
Date: Wed, 7 Jun 2017 22:37:46 -0700

Dear Alvaro and Erik

On Wed, Jun 7, 2017 at 2:46 PM, Alvaro Retana (aretana) <[email-masked]>
wrote:

> Dear IDEAS list:
>
>
>
> The IAB/IESG held our BoF Coordination Call today, and it was decided to
> go forward with an IDEAS BoF at IETF 99.  Congratulations!
>
There are however some concerns that we need you
> (proponents/participants/authors) to address at the BoF.  Based on that,
> we should ideally be able to take some action, which could include
> chartering a WG(s), deciding that the work belongs in existing WGs, a
> combination, or even the decision of not doing anything.  From my point of
> view, the success of the BoF should be measured by whether we have the
> necessary information to make the correct decision.
>

<PPE> Noted. Will work towards this goal with everyone.

> - Portions of the existing drafts, and even the proposed Charter, sound
> like marketing materials.  The IETF, and this process in particular, are
> not the place to do marketing – we need you then to clean up the existing
> documentation and simply get to the technical point you’re trying to make.
>
> - It is not completely clear from the current documents exactly what the
> IETF can/should work on.  We need a gap analysis that clearly and
> explicitly spells out what is needed and a discussion of why current
> protocols may not be appropriate (if a new protocol is required, for
> example).
>
> - A question was brought up about current deployment of existing ID/Loc
> protocols (lisp, ila, etc.) and whether a common framework is needed (as
> proposed) or if the community would be better served by a new protocol…or
> maybe both.  IOW, we would like to see this discussion as part of the
> problem description and justification for the work.
>
> We would of course not only want to see these points covered during the
> BoF, but also documented in the appropriate drafts.  Please keep the ID
> submission cut-off date in mind (July/3).
>
>
>
<PPE> Understood. Will work with everyone to address these concerns.

> Erik Nordmark (cc’d) has stepped up to act as IAB Shepherd.  He will work
> with you (the proponents/list) with an architectural point of view in
> mind.  I will continue to be the Responsible AD through the process.
>

<PPE> Looking forward to working with Erik.

> One of the process items we need to work on is the assignment of BoF
> Chairs.  Ideally, the BoF Chairs are not one of the proponents or authors.
> At this point we need someone to drive through the process more than
> anything else – reminder: being a BoF Chair doesn’t necessarily translate
> into WG Chair (if one was to be chartered).  If anyone has a suggestion,
> please send me a private note.
>
> Once we identify BoF Chairs, I will work with them in defining the
> Agenda.  In general, we want to be able to answer the following questions
> (we’ll refine them as we go):
>
> - Does the Gap Analysis reflect the requirements gleaned from the Problem
> Statement/Use Cases?  Are these the right deliverables?
>
> [*] Note: depending on what the Gap Analysis shows, we might not have a
> Charter discussion – maybe just a discussion about potential work items
> (which may belong to existing WGs, for example).  Also, even if a Charter
> is not discussed at the BoF, formation of a new WG (as needed) is not
> precluded.
>

<PPE>
Thanks in advance Alvaro, Erik for your guidance.
Will work with the list and proponents to address the above and prepare for
the BOF.

Regards
Padma

>
>
> Thanks!
>
> Alvaro.
>
> _______________________________________________
> Ideas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ideas
>
>