Subject: Re: [Ideas] IDEAS BoF at IETF 99

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Fri, 28 Jul 2017 16:56:15 +0000

On 6/7/17, 5:46 PM, "Ideas on behalf of Alvaro Retana (aretana)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Dear IDEAS list:

First of all, I want to thank the proponents and everyone who participated in last week’s BOF in Prague.  Special thanks to the BOF Chairs!

> The IAB/IESG held our BoF Coordination Call today, and it was decided
> to go forward with an IDEAS BoF at IETF 99.  Congratulations!
>
> There are however some concerns that we need you (proponents/
> participants/authors) to address at the BoF.  Based on that, we should
> ideally be able to take some action… From my point of view, the success
> of the BoF should be measured by whether we have the necessary
> information to make the correct decision.

The consensus among the Chairs and the IESG/IAB is that the materials presented at the BOF resulted in the feeling that there is something to be done here, but that “something” is not clear.  In part, this impression comes from the wide-ranging discussion – in part from the fact that most of the technical discussions have so far not been held on the list.  To paraphrase one of the participants: “I know what I want, and I kind of know what others want”…

What are the next steps?  I would like to see more discussions and participation on the list, to reflect the interest in the room – some of that is starting to happen already.

I don’t think that this effort would necessarily benefit from the BOF result being “let’s try it again next time”.  Alternatively, I am willing to sponsor a focused WG proposal [*] to define a framework that reflects consensus on what is expected from the mapping system, the questions around identity persistence, privacy, etc.  I note that the BOF proposal [1] included precisely a framework as milestones…

===
Milestones
Dec 2017 Adopt WG draft for the Identity Services framework
May 2018 WGLC for the Identity Services framework
August 2018 Send Identity Services framework draft to the IESG
===

…but the current proposed charter [2] does not reflect that.

If the group has the interest to follow this focused path, please start the discussion around an updated proposed charter.  If we settle on the text quickly, we should be able to take a proposal through the process (long) before the next IETF.  I would hope for an aggressive timeline in completing that piece of work.

Thanks!

Alvaro.

[*] Obviously, the normal approval process would be followed: IESG/IAB/community review, etc.
[1] https://trac.tools.ietf.org/bof/trac/
[2] https://github.com/IETF-IDEAS/Charter-Proposal

---

From: Padma Pillay-Esnault <[email-masked]>
Date: Fri, 28 Jul 2017 11:37:01 -0700

Dear Alvaro and IDEAS

The github was updated to have a separate file with a version of the first
charter for your reference.

Propose that updates to the version2 of charter be done to recapture the
focus of version1 and share it here on the alias.

Thanks
Padma

On Fri, Jul 28, 2017 at 9:56 AM, Alvaro Retana (aretana) <[email-masked]>
wrote:

> On 6/7/17, 5:46 PM, "Ideas on behalf of Alvaro Retana (aretana)" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>
>
> Dear IDEAS list:
>
>
>
> First of all, I want to thank the proponents and everyone who participated
> in last week’s BOF in Prague.  Special thanks to the BOF Chairs!
>
>
>
> The consensus among the Chairs and the IESG/IAB is that the materials
> presented at the BOF resulted in the feeling that there is something to be
> done here, but that “something” is not clear.  In part, this impression
> comes from the wide-ranging discussion – in part from the fact that most of
> the technical discussions have so far not been held on the list.  To
> paraphrase one of the participants: “I know what I want, and I kind of know
> what others want”…
>
>
>
> What are the next steps?  I would like to see more discussions and
> participation on the list, to reflect the interest in the room – some of
> that is starting to happen already.
>
>
>
> I don’t think that this effort would necessarily benefit from the BOF
> result being “let’s try it again next time”.  Alternatively, I am willing
> to sponsor a focused WG proposal [*] to define a framework that reflects
> consensus on what is expected from the mapping system, the questions around
> identity persistence, privacy, etc.  I note that the BOF proposal [1]
> included precisely a framework as milestones…
>
>
>
> ===
>
> Milestones
>
> If the group has the interest to follow this focused path, please start
> the discussion around an updated proposed charter.  If we settle on the
> text quickly, we should be able to take a proposal through the process
> (long) before the next IETF.  I would hope for an aggressive timeline in
> completing that piece of work.
>
>
>
> Thanks!
>
>
>
> Alvaro.
>
>
>
>
>
> _______________________________________________
> Ideas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ideas
>
>

---

From: "Alexander Clemm" <[email-masked]>
Date: Sat, 29 Jul 2017 10:01:58 -0700

Hi Padma, Alvaro,

I looked at the charter version on the github.  Charter-version1.txt does not reflect the latest version that we had discussed in Prague.  The latest version had been pruned down significantly over that, in an effort to try and create sharper focus.  Of course, further work is still required, but many of the earlier items, such as metadata support, endpoint grouping support, DDoS considerations were already removed (but show in Charter-version1.txt).  

Also posted on github is IDEAS-charter.txt; this is probably the version that we should discuss.  But it is not clear and I find it very confusing what is supposed to be the most current version and the one that we should be discussing updates on.  If it is “IDEAS-charter.txt”, I find “Charter-version1.txt” a distraction; can we mark it as historic or such, or remove it, just so we are all on the same page what the current baseline is that we are discussing?  

What is the way forward here – how will we refine the charter; should we make edits on github or have the discussion on text snippets here on the mailer?  Who holds the editor’s pen?

Thanks

--- Alex

From: Ideas [mailto:[email-masked]] On Behalf Of Padma Pillay-Esnault
Sent: Friday, July 28, 2017 11:37 AM
To: Alvaro Retana (aretana) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Ideas] IDEAS BoF at IETF 99

Dear Alvaro and IDEAS

The github was updated to have a separate file with a version of the first charter for your reference.

Propose that updates to the version2 of charter be done to recapture the focus of version1 and share it here on the alias.

Thanks

Padma

On Fri, Jul 28, 2017 at 9:56 AM, Alvaro Retana (aretana) <[email-masked] <mailto:[email-masked]> > wrote:

On 6/7/17, 5:46 PM, "Ideas on behalf of Alvaro Retana (aretana)" <[email-masked] <mailto:[email-masked]>  on behalf of [email-masked] <mailto:[email-masked]> > wrote:

Dear IDEAS list:

===

Milestones

===

Thanks!

Alvaro.

_______________________________________________
Ideas mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/ideas

---

From: Padma Pillay-Esnault <[email-masked]>
Date: Mon, 31 Jul 2017 07:19:18 -0700

Hi Alex

Sent from my iPhone

> On Jul 29, 2017, at 10:01, Alexander Clemm <[email-masked]> wrote:
> 
> Hi Padma, Alvaro,
>  
Alex can mark it but it has to be there.

> What is the way forward here – how will we refine the charter; should we make edits on github or have the discussion on text snippets here on the mailer?  Who holds the editor’s pen?
Edits on got hub fine but suggest we also send on alias. 

Per Alvaro's email the changes should be to reflect delivery of the framework.

Padma
> On Fri, Jul 28, 2017 at 9:56 AM, Alvaro Retana (aretana) <[email-masked]> wrote:
> On 6/7/17, 5:46 PM, "Ideas on behalf of Alvaro Retana (aretana)" <[email-masked] on behalf of [email-masked]> wrote:
>  
> Dear IDEAS list:
>