Subject: [Ideas] Alissa Cooper's Block on charter-ietf-ideas-00-06: (with BLOCK)

From: Alissa Cooper <[email-masked]>
Date: Wed, 11 Oct 2017 07:53:55 -0700

Alissa Cooper has entered the following ballot position for
charter-ietf-ideas-00-06: Block

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-ideas/

----------------------------------------------------------------------
BLOCK:
----------------------------------------------------------------------

I do not think this group is ready to be chartered at this time given the
significant objections from the community.

There seem to be two key problems with the work as proposed:

(1) The work is insufficiently motivated. The claims about the need for the
mapping system and the identity management system envisioned here do not appear
to be backed up by those who have developed and deployed ID/LOC separation
protocols. Nor do there seem to be compelling arguments that the framework that
this proposed WG would produce would be the motivator for further interoperable
deployments.

(2) The work proposed here seems as if it would have a substantial intrinsic
impact on user privacy if widely deployed. In cases like these, I don't believe
it's sufficient to say that the WG will analyze the situation and propose
mitigations; the work proposal itself needs to explain how the design of the
infrastructure envisioned is going to mitigate what seem like obvious attacks
on privacy that the proposed designs open up.

I think further discussions of this work (in private, on the list, at a bar in
Singapore, or at a potential future BoF) would need to resolve both of the
above issues in order to address concerns raised by the community.

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 11 Oct 2017 12:07:46 -0700

This is simply not true. The IETF mailing lists are not finding the reach of interest that exists in the industry.

Dino

---

From: Padma Pillay-Esnault <[email-masked]>
Date: Wed, 11 Oct 2017 12:25:32 -0700

On Wed, Oct 11, 2017 at 12:20 PM, Eric Rescorla <[email-masked]> wrote:

>
>
> On Wed, Oct 11, 2017 at 12:07 PM, Dino Farinacci <[email-masked]>
> wrote:
>
>> This is simply not true. The IETF mailing lists are not finding the reach
>> of interest that exists in the industry
>>
>

>
> Be that as it may, the determination of consensus and justification has to
> be made primarily on what appears on the mailing lists and at meetings.
>

Why are we discounting the interest showed at the BOF?

Padma

> -Ekr

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 11 Oct 2017 12:20:42 -0700

-Ekr

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 11 Oct 2017 12:30:11 -0700

I am reaching out to the SD-WAN community. There has been huge investment from the VC community in overlay startups. They are all using proprietary control-planes. There is no interoperability among them. The IETF should not ignore this market and should help shape it.

This is VXLAN-in-the-data-center market all over again making IETF working group nvo3 irrelevant.

Mapping Databases ARE being deployed under the auspices of SDN-controllers. There are high profile user-groups that endorse the activity. It is not going away. 

IETF needs to lead and not follow.

Dino

> On Oct 11, 2017, at 12:20 PM, Eric Rescorla <[email-masked]> wrote:
> 
> 
> 
> On Wed, Oct 11, 2017 at 12:07 PM, Dino Farinacci <[email-masked]> wrote:
> This is simply not true. The IETF mailing lists are not finding the reach of interest that exists in the industry
> 
> Be that as it may, the determination of consensus and justification has to be made primarily on what appears on the mailing lists and at meetings.
> 
> -Ekr
> 
> 
> Dino
> 
>

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 11 Oct 2017 12:30:21 -0700

On Wed, Oct 11, 2017 at 12:25 PM, Padma Pillay-Esnault <[email-masked]

>>> This is simply not true. The IETF mailing lists are not finding the
>>> reach of interest that exists in the industry
>>>
>>
>
>>
>> Be that as it may, the determination of consensus and justification has
>> to be made primarily on what appears on the mailing lists and at meetings.
>>
>

I'm not, hence "mailing lists and at meetings".

However, based on the minutes, the BOF also seems to fall far short of
consensus:
https://datatracker.ietf.org/meeting/99/materials/minutes-99-ideas/

And of course the sentiment on the IETF list is rather more negative.

-Ekr

---

From: Tom Herbert <[email-masked]>
Date: Wed, 11 Oct 2017 12:42:15 -0700

On Wed, Oct 11, 2017 at 12:30 PM, Dino Farinacci <[email-masked]>
wrote:

> I am reaching out to the SD-WAN community. There has been huge investment
> from the VC community in overlay startups. They are all using proprietary
> control-planes. There is no interoperability among them. The IETF should
> not ignore this market and should help shape it.
>
> Mapping Databases ARE being deployed under the auspices of
> SDN-controllers. There are high profile user-groups that endorse the
> activity. It is not going away.
>
> +1

The need for a common mapping system has already been discussed for for
years in nvo3. With the emergence of identifier-locator protocols, and
particularly their utility to provide seamless mobility at large scale, the
need for a well defined mapping system has become more evident. IMO this is
a problem IETF should work on.

Note that identity, which is what most of this discussion has been about,
is only one aspect of the mapping system for identifier-locator protocols
and network virtualization. There are many other aspects that have not been
mentioned but need attention. I am worried that we might be throwing the
baby out with the bath water as they say...

Tom

> _______________________________________________
> Ideas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ideas
>

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 11 Oct 2017 12:46:29 -0700

> The need for a common mapping system has already been discussed for for years in nvo3. With the emergence of identifier-locator protocols, and particularly their utility to provide seamless mobility at large scale, the need for a well defined mapping system has become more evident. IMO this is a problem IETF should work on.

A public mapping system has been discussed in the LISP WG (and many have been designed to compare tradeoffs) since 2009. And before that in the IRTF Routing RG dating back to 2006.

And there was/is a 30 country, 300 site pilot research network run by vendors/researchers/ISPs dating back to 2007.

Dino

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 11 Oct 2017 15:52:03 -0400

Just before I shut down for the week...

And I am in conversation with VC funding for IIoT that will build their 
own just like this.  Only one will put any effort into privacy because 
there is no leadship.

Dino and I are connected outside the IETF.  These groups come to us to 
talk, then go back and do their own thing to fill the void.  They will 
NOT come to the IETF, but will take what is offered.

Bob

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 11 Oct 2017 15:52:55 -0400

> On Oct 11, 2017, at 3:42 PM, Tom Herbert <[email-masked]> wrote:
> 
> 
> 
> On Wed, Oct 11, 2017 at 12:30 PM, Dino Farinacci <[email-masked] <mailto:[email-masked]>> wrote:
> Note that identity, which is what most of this discussion has been about, is only one aspect of the mapping system for identifier-locator protocols and network virtualization. There are many other aspects that have not been mentioned but need attention. I am worried that we might be throwing the baby out with the bath water as they say…

The immediate question before the IESG is whether to charter a working group with the charter and deliverables as currently proposed. If someone wanted to propose a more limited charter or a different charter that focuses on these unmentioned aspects, we would certainly evaluate it anew.

Alissa

> 
> Tom
>  
> Dino
> 
> 
> > On Oct 11, 2017, at 12:20 PM, Eric Rescorla <[email-masked] <mailto:[email-masked]>> wrote:
> >
> >
> >
> > On Wed, Oct 11, 2017 at 12:07 PM, Dino Farinacci <[email-masked] <mailto:[email-masked]>> wrote:
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ideas <https://www.ietf.org/mailman/listinfo/ideas>
>

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 11 Oct 2017 12:59:47 -0700

> Dino and I are connected outside the IETF.  These groups come to us to talk, then go back and do their own thing to fill the void.  They will NOT come to the IETF, but will take what is offered.

And of course, the typical mantra from them (and I know you all have heard this before):

(1) The IETF is too slow.

(2) The IETF cannot decide.

(3) The IETF has too many options. So we are going to pick one and put our Intellectual Property on top of it (i.e. SD-WAN IPsec doesn’t interoperate).

(4) We can do protocols better and faster than the IETF.

(5) We want to build our own protocols so we look innovative.

(6) We can get strategic interoperability with our business partners.

Dino

---

From: Padma Pillay-Esnault <[email-masked]>
Date: Wed, 11 Oct 2017 13:04:06 -0700

On Wed, Oct 11, 2017 at 12:52 PM, Alissa Cooper <[email-masked]> wrote:

>
>
> The immediate question before the IESG is whether to charter a working
> group with the charter and deliverables as currently proposed. If someone
> wanted to propose a more limited charter or a different charter that
> focuses on these unmentioned aspects, we would certainly evaluate it anew.
>
>
I'll take this task up and work on it.

Padma

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 11 Oct 2017 16:08:04 -0400

> On Oct 11, 2017, at 3:59 PM, Dino Farinacci <[email-masked]> wrote:
> 

I don’t understand how chartering this WG with the proposed charter — to write a framework document — addresses any of these concerns. Furthermore, it isn’t the function of the chartering process to change people’s minds about what they find deficient about the IETF. The function of the chartering process is to scope out and define new pieces of work for which there is support in the IETF community.

“The IETF” amounts to the people who come to the IETF to do the work and review the work. Work doesn’t get chartered unless the people who want it can at least minimally engage, explain why they want it in a way that is compelling to others, and explain how it fits within the scope of the rest of the IETF’s work and the internet architecture.

As I said in my note to Tom, this charter ballot isn’t a death sentence on all mapping system work forever more. It’s a judgment about the charter text and deliverables as they are right now.

Alissa

---

From: Sam Sun <[email-masked]>
Date: Wed, 11 Oct 2017 16:23:36 -0400

My recall from the last BoF meeting is that we got quite a large number 
of hums on the issues reflected in the current charter. I believe there 
are sufficient motivations here.

The disputes on privacy protection and discoverability in the mailing 
list only shows the interests from the community looking for a better 
solution. Having disputes about different approaches, or even question 
whether or not there’s any feasible solution, is exactly why we need to 
form a WG to work on this, IMHO.

Sam

---

From: Sam Sun <[email-masked]>
Date: Wed, 11 Oct 2017 16:38:23 -0400

Sam

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 11 Oct 2017 16:58:12 -0400

> On Oct 11, 2017, at 4:38 PM, Sam Sun <[email-masked]> wrote:
> 
> My recall from the last BoF meeting is that we got quite a large number of hums on the issues reflected in the current charter. I believe there are sufficient motivations here. 
> 
I don’t see this clearly reflected in the minutes or on the list discussion. From the minutes it sounds like there was general interest in the work, but also acknowledgment that folks with deployments are not engaged, and many folks present who hadn’t read the problem statement or felt that the problem was not well defined. From the list discussion, at least for the identity management piece I see only the proponents defending the proposal (but happy to be corrected — I’m looking at this for the first time this week so may have missed some messages).
> 
> The disputes on privacy protection and discoverability in the mailing list only shows the interests from the community looking for a better solution. Having disputes about different approaches, or even question whether or not there’s any feasible solution, is exactly why we need to form a WG to work on this, IMHO.
> 
This seems backwards to me. We don’t typically form working groups in order to determine whether there is work to be done and whether there is any way that work can be designed in alignment with our BCPs and principles about things like privacy. That is what the chartering process is for.

Alissa
>> https://datatracker.ietf.org/doc/charter-ietf-ideas/ <https://datatracker.ietf.org/doc/charter-ietf-ideas/>
>> 
>> 
>>

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 11 Oct 2017 14:15:04 -0700

> On Oct 11, 2017, at 1:08 PM, Alissa Cooper <[email-masked]> wrote:
> 
> 
> I don’t understand how chartering this WG with the proposed charter — to write a framework document — 

Agree. But the work is important and the limited definition of the work MUST be in the charter.

> As I said in my note to Tom, this charter ballot isn’t a death sentence on all mapping system work forever more. It’s a judgment about the charter text and deliverables as they are right now.

Understand. Thanks for being open minded.

Dino

---

From: Sam Sun <[email-masked]>
Date: Wed, 11 Oct 2017 17:36:40 -0400

On 10/11/17 4:58 PM, Alissa Cooper wrote:
>
>> On Oct 11, 2017, at 4:38 PM, Sam Sun <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> My recall from the last BoF meeting is that we got quite a large 
>> number of hums on the issues reflected in the current charter. I 
>> believe there are sufficient motivations here.
>>
> I don’t see this clearly reflected in the minutes or on the list 
> discussion. From the minutes it sounds like there was general interest 
> in the work, but also acknowledgment that folks with deployments are 
> not engaged, and many folks present who hadn’t read the problem 
> statement or felt that the problem was not well defined. From the list 
> discussion, at least for the identity management piece I see only the 
> proponents defending the proposal (but happy to be corrected — I’m 
> looking at this for the first time this week so may have missed some 
> messages).
>>
>>
>> solution. Having disputes about different approaches, or even 
>> question whether or not there’s any feasible solution, is exactly why 
>> we need to form a WG to work on this, IMHO.
>>
> This seems backwards to me. We don’t typically form working groups in 
> order to determine whether there is work to be done and whether there 
> is any way that work can be designed in alignment with our BCPs and 
> principles about things like privacy. That is what the chartering 
> process is for.
>
This is good clarification.

The proposed charter did state the exact works to be done, including 
"security analysis of the complete system". Intrinsic impact on user 
privacy could be covered here. Whether the infrastructure envisioned 
opens up obvious attacks on privacy depends how the system is finally 
defined. With proper access control and protection on data 
confidentiality, it may or may not.

Sam

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 12 Oct 2017 10:29:25 +0100

I agree with Dino on this.

We need to find ways to lead and not follow, even if the technology and 
the consequences are not to our taste. The market will do what makes 
economic sense even if it is not "pure". Pursuit of purity in the face 
of economics leads to irrelevance.

This seems a useful body of work to complement our traditional 
approaches to this problem.

- Stewart

---

From: Alia Atlas <[email-masked]>
Date: Thu, 19 Oct 2017 17:56:48 -0400

Dino,

I hear and understand your frustration and am, frankly, delighted to hear
that you are reaching out to the SD-WAN community.

In making a determination of work to be done, considering the broader
industry and associated eco-systems is critical.  Having sufficient
IETF community interest to do the work is also important - but sometimes
engagement happens after or when a WG is chartered.

As for the usual mantra, a standard pushback is that the IETF is as fast as
the volunteers who are supported to do the work....
Innovation is even more persuasive when it is an IETF RFC :-)

Please let me know if I can help.

Regards,
Alia

On Wed, Oct 11, 2017 at 3:59 PM, Dino Farinacci <[email-masked]> wrote:

> talk, then go back and do their own thing to fill the void.  They will NOT
> come to the IETF, but will take what is offered.
>
> (3) The IETF has too many options. So we are going to pick one and put our
> Intellectual Property on top of it (i.e. SD-WAN IPsec doesn’t interoperate).
>

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 19 Oct 2017 20:58:19 -0400

> As for the usual mantra, a standard pushback is that the IETF is as fast as the volunteers who are supported to do the work....

Okay then, let’s get going with the work. I’ll be at the first IDEAs WG in Singapore. 

I am not alone here. 

The volunteers are just as fast as the IETF supports them. 

Dino

---

From: Sam Sun <[email-masked]>
Date: Fri, 20 Oct 2017 11:18:15 -0400

I second Dino on this.

Sam

---

From: Lan Gao <[email-masked]>
Date: Fri, 20 Oct 2017 23:44:10 +0800

Definitely not alone. The IETF and the Volunteers are codependent. Neither
of us can move forward if the other doesn't support its counterpart.
Hopefully we can make IDEAs into something that benefits us all.

On Fri, Oct 20, 2017 at 8:58 AM, Dino Farinacci <[email-masked]> wrote:

> > As for the usual mantra, a standard pushback is that the IETF is as fast
> as the volunteers who are supported to do the work....
>

-- 
*Lan Gao*
Primary internet Platform Manager | Content Digital Innovation Technology
Phone: (+86)13439899334
Web: www.cdi.cn