Subject: [Ideas] Fwd: New Version Notification for draft-herbert-idlocd-00.txt

From: Tom Herbert <[email-masked]>
Date: Wed, 4 Oct 2017 16:39:19 -0700

Hello,

I've posted a draft to develop a software daemon that could control
various mapping systems and identifier/locator protocols. I hope to
have same code to make public in near future.

Tom

---------- Forwarded message ----------
From:  <[email-masked]>
Date: Wed, Oct 4, 2017 at 4:35 PM
Subject: New Version Notification for draft-herbert-idlocd-00.txt
To: Tom Herbert <[email-masked]>

A new version of I-D, draft-herbert-idlocd-00.txt
has been successfully submitted by Tom Herbert and posted to the
IETF repository.

Name:           draft-herbert-idlocd
Revision:       00
Title:          Identifier-locator control daemon
Document date:  2017-10-04
Group:          Individual Submission
Pages:          11
URL:            https://www.ietf.org/internet-drafts/draft-herbert-idlocd-00.txt
Status:         https://datatracker.ietf.org/doc/draft-herbert-idlocd/
Htmlized:       https://tools.ietf.org/html/draft-herbert-idlocd-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-herbert-idlocd-00

Abstract:
   Identifier-locator protocols rely on a mapping system that is able to
   map identifiers to locators. Such a mapping system is a type of
   key/value store. This draft proposes a design and implementation for
   an Identifier-Locator control daemon (idlocd). The intent is to
   provide an open source implementation that would be a basis for
   experimentation, development, and eventual deployment of identifier-
   locator solutions at large scale.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Uma Chunduri <[email-masked]>
Date: Mon, 9 Oct 2017 17:38:47 +0000

> I've posted a draft to develop a software daemon that could control various mapping systems and identifier/locator protocols.

It seems you are contradicting yourself in couple of e-mails posted in IDEAS.
Not sure where you want to standardize the below "idlocd" mapping system.

>From Page 9:

	>5  Security Considerations

   	>Security is very important in identifier-locator mapping protocols.
   	>Any mapping system must be protected from authorized access that
   	>could lead to forged mapping entries or leak other data. ilocd should
   	>therefore run only with admin privileges and software signing should
   	>be used if idlocd were to allow dynamically loadable modules. Any
   	>access to a mapping system should have appropriate security. For an
   	>application to write into a mapping system its credentials must be
   	>verified 

[Uma]:  This is what is being proposed in IDEAS - credential verification AKA authentication. It doesn't matter if this if the ID is the one used  in data plane directly (EID) or ephemeral one. 
                  The moment you authenticate (credential verification in your language), this can be construed is tracking the user of the ID,  as it's been discussed now.
                Sure, if this is deployed in a secure and local environment in a DC (for VM mobility), you may not needed.
                But your draft seems more generically applied to all ID/LOC protocols from Section 2 (LISP, ILNP, ILA...)

	>and the network communications for this should be encrypted.

[Uma]: Yes.

--
Uma C.

-----Original Message-----
From: Ideas [mailto:[email-masked]] On Behalf Of Tom Herbert
Sent: Wednesday, October 04, 2017 4:39 PM
To: [email-masked]
Subject: [Ideas] Fwd: New Version Notification for draft-herbert-idlocd-00.txt

Hello,

I've posted a draft to develop a software daemon that could control various mapping systems and identifier/locator protocols. I hope to have same code to make public in near future.

Tom

---------- Forwarded message ----------
From:  <[email-masked]>
Date: Wed, Oct 4, 2017 at 4:35 PM
Subject: New Version Notification for draft-herbert-idlocd-00.txt
To: Tom Herbert <[email-masked]>

A new version of I-D, draft-herbert-idlocd-00.txt has been successfully submitted by Tom Herbert and posted to the IETF repository.

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
Ideas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ideas