Subject: Re: multi-homing and load balancing

From: [email-masked] (Jeremy Hall)
Date: Tue, 15 Feb 2000 13:04:50 -0500 (EST)

In sparse mode, yes it works fine.  In dense mode, a condition can occur
where all traffic is forwarded due to a favourite vendor feature.

_J

In the new year, Kevin C. Almeroth wrote:
> A couple of folks have asked me to clarify my
> picture.  Hating ASCII pictures...  let me explain 
> in words:
> 
>    Classic multi-homed subnet.  Two routers, and
>    one is elected the DR and the other is obviously
>    not.
> 
> My understanding is that all IGMP joins will go to
> the DR who will then send a join into the network.
> This creates forwarding state so ALL multicast traffic
> flows through the DR.  
> 
> This becomes a load balancing issue if you have a
> slightly more complicated picture than what I've
> drawn.  In reality, we have a few Layer 2 switches
> on the multi-homed network and a full-duplex connection.
> So, it becomes an issue that we don't want ALL mcast
> traffic going through the DR.  Sometimes, we'd like
> traffic to go through the non-DR.
> 
> As Tony pointed out the correct behavior seems to be
> for the DR to send the join to the other router and
> let it do the forwarding.  This is exactly what we
> want but wanted to know if anyone had experienced this
> in practice.
> 
> -Kevin
>

---

From: [email-masked] (Kevin C. Almeroth)
Date: Tue, 15 Feb 2000 09:58:37 -0800 (PST)

-Kevin

---

From: Steve Deering <[email-masked]>
Date: Wed, 16 Feb 2000 09:38:47 -0800

>the DR who will then send a join into the network.

Kevin,

IGMP reports (not "joins") go to *all* multicast routers on the subnet,
not just the DR.

Steve