Subject: multi-homing and load balancing

From: [email-masked] (Kevin C. Almeroth)
Date: Mon, 14 Feb 2000 16:58:30 -0800 (PST)

I'm having an interesting configuration problem that I'd like
some advice on.

My network looks like the following:

       ____       ___
       |DR|       |R|
       ----       ---
         !         !
  ------------------------
              !
             ---
             |H|
             ---

This is a straightforward, multi-homed network and the 
designated router, DR, is the left router.

The fundamental question is whether there is any way to get
multicast traffic to flow through the non-DR.

   * My sense is, there is no easy way.  Because IGMP msgs
     go to the DR the DR initiates the join toward
     the RP/source.

Now here is a sneaky hack:

   * If I can assign different addresses to the
     SOURCES.  Set routing so that the ONLY path
     to the source is through the non-DR.  

   * This way, when the DR gets the join, it sends
     the join back over the LAN and to the non-DR
     router who now sends a join toward the source.

Why do I want to do this:  load balancing.  I need
to bring some traffic onto the multi-homed subnet via
both the DR and the non-DR router.

So a re-state of the question:  do I need to do something
as absurd as having all my sources multi-homed in order
to get this to work?  Is there something easier?   If
not, will this actually work?

-Kevin

---

From: Xin Wang <[email-masked]>
Date: Mon, 14 Feb 2000 23:18:59 -0500 (EST)

> My network looks like the following:

My understanding is   
the repsonsibility of the DR is just to draw down the traffic initially,
and it will then forward all the traffic to the LAN. In this case, both
the non-DR and H will receive the traffic.
In some topology, the non-DR may become the Forwarder when it has minimum
cost path to RP/source, if you use PIM.

Xin