Subject: Re: multi-homing and load balancing

From: Tony Ballardie <[email-masked]>
Date: Tue, 15 Feb 2000 09:29:22 -0000

>My network looks like the following:
>
>       ____       ___
>       |DR|       |R|
>       ----       ---
>         !         !
>  ------------------------
>              !
>             ---
>             |H|
>             ---
>
>The fundamental question is whether there is any way to get
>multicast traffic to flow through the non-DR.
>
>   * My sense is, there is no easy way.  Because IGMP msgs
>     go to the DR the DR initiates the join toward
>     the RP/source.

in general... (and not speaking for pim, though I imagine
it would/should do this):
joins should follow the normally routed paths, so for some
join destinations the DR will forward the join off-LAN, and
for others the DR will forward the join to R for forwarding 
off-LAN. For the latter, in CBT the DR doesn't keep fwd
state for the group (even though it originates joins in response
to IGMP), so mcast traffic is only forwarded by the off-LAN
forwarder for the group. 

I don't 'think there currently exist means to go beyond this 
"natural" load balancing in any of the protocols without
hacks.

Tony

---

From: Bill Fenner <[email-masked]>
Date: Tue, 15 Feb 2000 12:33:41 -0800

>My understanding is that all IGMP joins will go to
>the DR who will then send a join into the network.
>This creates forwarding state so ALL multicast traffic
>flows through the DR.  

If the DR's route towards the RP or source points through the other
router, then the Join will go that way.   The way you painted the original
picture, I thought maybe the DR was one of the exit routers and that's
why the other one wasn't being used.  If you have 2 exit routers which
each only have routes pointing out, using either one as a DR will not
allow load balancing.  Try making the "downstream" router the DR.

>This becomes a load balancing issue if you have a
>slightly more complicated picture than what I've
>drawn.  In reality, we have a few Layer 2 switches
>on the multi-homed network and a full-duplex connection.
>So, it becomes an issue that we don't want ALL mcast
>traffic going through the DR.  Sometimes, we'd like
>traffic to go through the non-DR.

Note that unless you have PIM-snooping switches, the multicast
traffic on the lan will go to the DR anyway, since the switches
know that the DR is a multicast router.

  Bill