Subject: Question on MBGP.

From: Chirayu Shah <[email-masked]>
Date: Mon, 07 Feb 2000 16:03:55 -0500

Hi,
	I had a MBGP-deployment question. It seems that for receivers
in a PIM domain which is a part of an AS to be able to 
receive traffic from sources external to the AS, it is necessary to run 
IMBGP on all the routers in the AS. Is this correct? Is there any
other way in which one can receive MBGP routes on a router within a PIM 
domain without having to run IMBGP on it? I believe it is not
possible to export MBGP routes into OSPF/RIP because it would be difficult
to differentiate between BGP and MBGP routes (assuming that
BGP and MBGP topologies are incongruent).

Chirayu Shah
Software Engineer.
Ericsson IP Infrastructure
12120 Plum Orchard Dr
Suite A
Silver Spring, MD 20904.

---

From: [email-masked] (Jeremy Hall)
Date: Mon, 7 Feb 2000 18:22:42 -0500 (EST)

yes, traditionally, we deploy IMBGP just like we deploy IBGP.  We do NOT
under ANY circumstances mix the multicast nlri with unicast nlri in a
routing protocol.  Such a mix would cause DESASTEROUS consequences.

Also, deploy MSDP between the domains on EMBGP boundaries.

_J