Subject: Re: Multicast MIB

From: Thomas Marshall Eubanks <[email-masked]>
Date: Mon, 31 Jan 2000 23:08:43 -0500

Hello;

Dave Thaler wrote:

> The IESG feedback on the Multicast MIB was that we need IANA
> guidelines on how to assign new values for unicast and multicast
> routing protocols.  Page 5 of RFC 2434 provides several possibilities,
> including (see RFC for description):
>    Private Use
>    Hierarchical allocation
>    First Come First Served
>    Expert Review
>    Specification Required
>    IESG Approval
>    IETF Consensus
>    Standards Action
>
> Based on reviewing various existing IANA-maintained MIBs
> and what they require, in my opinion, the "designated expert"
> would work here, as might requiring RFCs.
>
> So to steal language from existing RFCs, here are two
> strawmen (pick one, or suggest alternative):
>
> Alternative A (either "published documentation" or Expert):
> > Any and all requests for additional values require
> > proper and readily available documentation.  Possible forms
> > of documentation include, but are not limited to, RFCs.
> > Other requests may also be accepted under the advice of a
> > "designated expert".  (Contact the IANA for the contact information
> > of the current expert.)"
>
> Alternative B (always Expert):
> > Any additions or changes to the contents of this MIB
> > module require Designated Expert Review as defined in
> > the Guidelines for Writing IANA Considerations Section
> > document.  The Designated Expert will be selected by
> > the IESG Area Director of the Routing Area.
>
> Preferences?
>
> -Dave

Why not require "proper and readily available documentation" as well as
expert review ?
Isn't this a good thing to require in any case ? In that case you could
say

Any additions or changes to the contents of this MIB
module requires both proper and readily available documentation
and Designated Expert Review (as defined in
the Guidelines for Writing IANA Considerations Section
document). The Designated Expert will be selected by
the IESG Area Director of the Routing Area.
The existence of proper documentation will be certified by the Designated
Expert.

(That way, any appropriate documentation could be submitted, as long as
it would satisfy the
DE.)

--

Regards

Marshall Eubanks

T.M. Eubanks
CTO
Multicast Technologies, LLC
P.O. Box 99
Clifton, Virginia 20124
Phone : 703-803-8141
Fax     : 703-222-3250
e-mail : [email-masked]

---

From: Bill Fenner <[email-masked]>
Date: Wed, 2 Feb 2000 12:10:50 -0800

>expert review ?  Isn't this a good thing to require in any case ?

Well, the other option is to trust the IANA to know when an expert should
be called in.  This has the advantage of speeding up assignments that
the IANA feels that it can handle itself.

> "designated expert".  (Contact the IANA for the contact information

Do any other WG members have an opinion?  Otherwise, as rough as it may
be I think we have a rough consensus on option A.

  Bill