Subject: DVMRP doubt

From: [email-masked]
Date: Mon, 24 Apr 2000 11:14:36 +0530

Hi all,
 I have a question regarding DVMRP v3 as explained in draft-ietf-idmr-dvmrp-v3(September 
1999).

 Prune messages are sent to prune the multicast tree and graft messages to add the 
branches.I donot understand the need for prune timers. Why do we need to maintain prune 
timers and join back the branches which have already been pruned after the timer expires, 
There is a specific graft messages to join back the branches. 

Regards,
Vijay

Enter your default signature here
Sent by Indya Messaging Service

---

From: Steve Deering <[email-masked]>
Date: Mon, 24 Apr 2000 16:23:51 -0700

>There is a specific graft messages to join back the branches. 

Vijay,

Prune messages create state in the routers, to remember which branches
are pruned off the delivery tree for a given (source, group) pair.  If
there were no prune timers, that state would last forever, even though
the traffic from the source had long since terminated.  Thus, the
prune timers are used for garbage collection of the state created by
prune messages.

Steve