Subject: About Join Latency

From: chung <[email-masked]>
Date: Sat, 29 Apr 2000 14:02:35 +0800

Dear all,
    
    I'm now doing a research on the multicast routing protocol. After I do some testing, I find some unexpected result. I perform the test with PIM-SM and IGMPv2. One of the test is to use a Linux router (Routing Program: "pimd-2.1.0-alpha26" authored by Pavlin Ivanov Radoslavov and University of Southern California), the other is to use a Cisco 7500 router. The test done on a controlled LAN, with fixed transmission rate and packet size.
    
    For Linux router, I find that the Join Latency is vary from 1 sec to 9 sec
    For Cisco router, I find that the Join Latency is vary from 0.05sec to 1 sec

I wounder why the Join latency will vary with all other condition unchange!!
Could anyone tell me what is the cause of it!! 
Look for your kindly reply!!

Thanks a lot!!
K.C. Chan

---

From: Zachary Amsden <[email-masked]>
Date: Sat, 29 Apr 2000 13:59:02 -0700

>     I'm now doing a research on the multicast routing protocol. After I > do some testing, I find some unexpected result. I perform the test with > PIM-SM and IGMPv2. One of the test is to use a Linux router (Routing > Program: "pimd-2.1.0-alpha26" authored by Pavlin Ivanov Radoslavov and > University of Southern California), the other is to use a Cisco 7500 > router. The test done on a controlled LAN, with fixed transmission rate > and packet size.
>     For Linux router, I find that the Join Latency is vary from 1 sec to > 9 sec
>     For Cisco router, I find that the Join Latency is vary from 0.05sec > to 1 sec
> 
> I wounder why the Join latency will vary with all other condition > unchange!!

While, on the Linux router, multicast misses most of the kernel fast paths, 
and you need to copy the packet to userspace.  I would imagine on the Cisco, 
this is all done very close to hardware.

In any case, that wouldn't account for the huge difference you are seeing, 
that is most likely a problem with the pimd program.  Perhaps it uses large 
timeouts, or is loosing time doing a DNS lookup.

-- 
Zachary Amsden  [email-masked]  3-6919  31-2-510  Core Protocols