Subject: IGMP packets and Multicast Dgrams

From: [email-masked]
Date: Wed, 24 May 2000 11:36:01 +0530

Hi all,
 
I have a question regarding handling multicast datagrams and IGMP packets in TCP/IP stack 
which uses DVMRP in the routers.

All DVMRP messages come with protocol type(in IP header) as IGMP. Only after looking at 
the message type code IP layer can switch the message to DVMRP or IGMP. Can this 
decision be taken at the IP layer or can all IGMP type packets be given to either IGMP or 
DVMRP and then decide based on the message type? Also, on core routers where IGMP is 
not running should this decision be taken differently ,ie, to always give IGMP type packets to 
DVMRP. 

The IGMP rfc says that IGMP should enable multicast addresses in the link layer. If IGMP is 
not running as in core routers who is responsible for enabling multicasting in the interfaces. 

In a leaf router where DVMRP and IGMP may be present if a multicast datagram is received 
should IP layer make a copy and send to both IGMP and DVMRP or else how will it be done.

Regards,
Vijay

Enter your default signature here
Sent by Indya Messaging Service

---

From: Sundeep Singatwaria <[email-masked]>
Date: Wed, 24 May 2000 11:31:23 -0700

>not running should this decision be taken differently ,ie, to always give
IGMP type packets to 

I guess good software engineering practise require to have a single code
base which can be used at
different places.

>not running as in core routers who is responsible for enabling
multicasting in the interfaces. 

Multicast protocols like DVMRP, PIM
>should IP layer make a copy and send to both IGMP and DVMRP or else how
will it be done.

I don't see a need to make copy of packets.