Subject: DVMRP Forwarding

From: [email-masked]
Date: Mon, 19 Jun 2000 10:30:45 +0530

Hi all,
 I have a question regarding multicast forwarding in DVMRPv3.

The draft seems to suggest that the forwarding cache should be created on a per (S,G) 
basis.So after a (S1,G1) entry is created and a multicast delivery tree is bulit from the source 
S1 for the group G1 if a new source S2(with a diff netmask) comes-up for the same group G1 
then will the multicast packets from it be flooded all the way and then a new delivery tree built 
OR when the multicast packet reaches a router where a forwarding cache entry exists for the 
group(S1,G1) will the packet be forwarded only on the downstream interfaces as for S1,G1.ie, 
the same downstream interfaces for the previous source S1. If this is the case then the 
forwarding cache should be maintained on a per Group basis in addition to the (S,G) view 
given to it.

Thanks in advance

Regards,
Vijay

Enter your default signature here
Sent by Indya Messaging Service

---

From: Tom Pusateri <[email-masked]>
Date: Mon, 19 Jun 2000 06:46:46 -0700

The use of a forwarding cache is optional. While the spec should
have been written to empahasize this more, most everyone is going
to use a forwarding cache for the performance improvement. The spec
also shouldn't dictate that an (S,G) cache be used. You are free
to be creative here and come up with the best approach. Of course,
since each S may have a different upstream interface, having only
G in your cache won't work.

The simplest cache design would be to use Group and Source host
but it would also be possible to use Group and Source network to
reduce the number of entries in your cache, however, this is a bit
trickier to maintain.

Tom

---

From: Steve Deering <[email-masked]>
Date: Mon, 19 Jun 2000 08:04:05 -0700

At 6:46 AM -0700 6/19/00, Tom Pusateri wrote:
>Of course, since each S may have a different upstream interface, having
>only G in your cache won't work.

Note also that different S's can have different outgoing interfaces even
when G is the same and the incoming interface is the same (which is
something that many people have trouble believing).  That's another
reason why Vijay's proposal to use an [S1,G] cache entry (or just a [G]
cache entry) to forward [S2,G] packets won't work.

Steve