Subject: IGMP V1 - V2 Compatibility

From: Balasubramanian Mandakolathur B <[email-masked]>
Date: Mon, 07 Aug 2000 15:43:24 +0530

Hi all,

We have a issue regarding IGMP V1 - V2 Compatibility .

If we run IGMP V2 (System A) in the router and if we receive a IGMP V1
query from a router whose IP address less than the (A) should the
V2 router do a Querier election and go to NON-QUERIER mode ??

The RFC states that the V2 router should log a warning if it receives
a V1 query...

Kindly clarify.

Regards
bala

---

From: Bill Fenner <[email-masked]>
Date: Mon, 7 Aug 2000 05:59:17 -0700

>V2 router do a Querier election and go to NON-QUERIER mode ??

Yes.

>The RFC states that the V2 router should log a warning if it receives

There's no automatic Querier configuration; if you get a V1 Query
and you're not configured for V1 then there's a misconfiguration.
The warning is to make the administrator aware of the misconfiguration.
Logging the warning is in addition to doing the election.

  Bill