Subject: [Idna-update] Fwd: Last Call: <draft-freytag-lager-variant-rules-05.txt> (Variant Rules) to Informational RFC

From: "Paul Hoffman" <[email-masked]>
Date: Mon, 17 Apr 2017 10:23:25 -0700

Forwarded message:

> From: The IESG <[email-masked]>
> To: IETF-Announce <[email-masked]>
> Cc: [email-masked], 
> [email-masked], [email-masked]
> Subject: Last Call: <draft-freytag-lager-variant-rules-05.txt> 
> (Variant Rules) to Informational RFC
> Date: Mon, 17 Apr 2017 09:17:58 -0700
>
> The IESG has received a request from an individual submitter to 
> consider
> the following document:
> - 'Variant Rules'
>   <draft-freytag-lager-variant-rules-05.txt> as Informational RFC
>
> Some comments were raised in IETF LC about how this document relates
> to RFC 7940. The document was updated to clarify that.
> This is a Second IETF LC to make IETF community aware of changes
> to this draft.
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2017-05-15. Exceptionally, comments may 
> be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
>
> Abstract
>
>    Rules for validating identifier labels and alternate 
> representations
>    of those labels (variants) are known as "Label Generation Rulesets"
>    (LGRs); they are used for the implementation of identifier systems
>    such as Internationalized Domain Names (IDNs).  This document
>    describes ways of designing Label Generation Rulesets (LGRs) that
>    support variant labels.  In designing LGRs, it is important to 
> ensure
>    that the label generation rules are consistent and well-behaved in
>    the presence of variants.  The design decisions can then be 
> expressed
>    using the XML representation of LGRs that is defined in RFC7940.
>
>
> The file can be obtained via
> https://datatracker.ietf.org/doc/draft-freytag-lager-variant-rules/
>
> IESG discussion can be tracked via
> https://datatracker.ietf.org/doc/draft-freytag-lager-variant-rules/ballot/
>
>
> No IPR declarations have been submitted directly on this I-D.

---

From: Vint Cerf <[email-masked]>
Date: Tue, 18 Apr 2017 10:04:09 -0400

if this is published, I hope it is made clear that this is not a standards
recommendation endorsed by the IDNA working group.

v

On Mon, Apr 17, 2017 at 1:23 PM, Paul Hoffman <[email-masked]> wrote:

>> Cc: [email-masked], [email-masked],
>> [email-masked]
>> Subject: Last Call: <draft-freytag-lager-variant-rules-05.txt> (Variant
>> Rules) to Informational RFC
>> The IESG has received a request from an individual submitter to consider
>> the following document:
>> - 'Variant Rules'
>> [email-masked] mailing lists by 2017-05-15. Exceptionally, comments may be
>>    Rules for validating identifier labels and alternate representations
>>    support variant labels.  In designing LGRs, it is important to ensure
>>    the presence of variants.  The design decisions can then be expressed
> _______________________________________________
> IDNA-UPDATE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idna-update
>

-- 
New postal address:
Google
1875 Explorer Street, 10th Floor
Reston, VA 20190

---

From: "Paul Hoffman" <[email-masked]>
Date: Tue, 18 Apr 2017 09:38:29 -0700

> recommendation endorsed by the IDNA working group.

It says "Informational" right at the top of the document, and that's the 
best we can do for the RFC Series.

There is no IDNA Working Group any more, so there is no way to say that 
it was not endorsed by this WG. The document is, however, intending to 
be an IETF consensus document.

--Paul Hoffman

---

From: Martin J. Dürst <[email-masked]>
Date: Wed, 19 Apr 2017 16:20:57 +0900

> be an IETF consensus document.

Sorry to bring this up, but
"there is no way to say that it was not endorsed by this WG"
seems weird to me.

Because the WG doesn't exist anymore, I think it's correct to say that
"there is no way to say that it was endorsed by this WG"
or
"there is no need to say that it was not endorsed by this WG",
or so.

The result is the same, anyway: The document isn't endorsed by any WG.
(and there's no need to say that explicitly)

Regards,   Martin.